Abstract

This document helps you understand and use HP Integrity Virtual Server Manager.

The audience for this document includes system administrators and others responsible for maintaining an Integrity VSP and its virtual machines (VMs) or virtual partitions (vPars). You must be familiar with the Integrity VM product and HP-UX system administration using either HP SMH or HP Systems Insight Manager.
Acknowledgments

AMD is a trademark of Advanced Micro Devices, Inc.

Intel® is a trademark of Intel Corporation in the United States and other countries.

Java is a registered trademark of Oracle Corporation and/or its affiliates.

Microsoft®, Windows®, and Windows® XP are U.S. registered trademarks of Microsoft Corporation.

Warranty

HP will replace defective delivery media for a period of 90 days from the date of purchase. This warranty applies to all Insight Management products.
# Contents

1 Introduction ..............................................................................................7  
   HP Integrity VM ....................................................................................7  
   HP Integrity Virtual Server Manager ....................................................7  
   Integrity Virtual Server Manager tasks ................................................11  

2 Installing Integrity Virtual Server Manager .............................................13  
   System and software requirements .......................................................13  
   Installing Integrity Virtual Server Manager on HP Systems Insight Manager ...........................................................................14  
   Installing Integrity Virtual Server Manager on HP SMH.........................14  
   Licensing requirements .........................................................................15  
   Setting security credentials ...................................................................15  
   Setting WBEM credentials in HP Systems Insight Manager ....................16  
   Setting WBEM credentials in HP SMH .................................................16  
   Trusted certificates ...............................................................................18  
   Discovering data when setting new WBEM credentials .........................19  

3 Accessing and Navigating Integrity Virtual Server Manager ....................21  
   Accessing Integrity Virtual Server Manager from Matrix Operating Environment for HP-UX .................................................................21  
   Accessing Integrity Virtual Server Manager from HP SMH ....................23  
   Accessing Integrity Virtual Server Manager help ...................................24  
   Navigating Integrity Virtual Server Manager .........................................24  
   Returning to the HP SMH Homepage ....................................................26  

4 Using Integrity Virtual Server Manager views and tabs ..........................27  
   VSP view .............................................................................................27  
   VSP General tab ..................................................................................28  
   Quick reference ...................................................................................29  
   Screen details .....................................................................................30  
   VSP Virtual Servers tab .......................................................................31  
   Quick reference ...................................................................................31  
   Screen details .....................................................................................32  
   VSP Virtual Switches tab .....................................................................33  
   Quick reference ...................................................................................33  
   Screen details .....................................................................................34  
   VSP Network tab ................................................................................34  
   Quick reference ...................................................................................35  
   Network devices ................................................................................35  
   Screen details .....................................................................................36  
   VSP Storage tab ................................................................................37  
   Quick reference ...................................................................................42  
   Storage devices ..................................................................................42  
   Screen details .....................................................................................43  
   VSP Console tab ................................................................................49  
   Quick reference ...................................................................................49  
   VSP GUID Resources tab ....................................................................49  
   Quick reference ...................................................................................50  
   Creating WWN ranges .........................................................................50  
   Modifying WWN ranges ......................................................................51  
   Deleting the WWN ranges ...................................................................51
Contents 5

Creating virtual switches................................................................. 102
Starting, stopping, and deleting virtual switches................................. 105
Deleting network or storage devices..................................................... 105
Opening iLO console............................................................................ 106
Opening virtual iLO remote console....................................................... 107
Deleting virtual iLO remote console....................................................... 108
Deleting DIOs..................................................................................... 108
Adding DIOs...................................................................................... 109
Replacing DIO H/W path.................................................................... 109
Replacing DIO MAC address............................................................... 110

Working with vPars............................................................................. 111
Creating vPars................................................................................... 111
Modifying vPars................................................................................ 113
Booting vPars..................................................................................... 114
Stopping vPars.................................................................................. 115
Resetting vPars................................................................................. 115
Creating virtual switches.................................................................... 116
Starting, stopping, and deleting virtual switches................................. 116
Deleting network or storage devices..................................................... 117
Deleting vPars................................................................................... 117
Opening iLO console........................................................................... 117
Opening virtual iLO remote console...................................................... 117
Deleting virtual iLO remote console...................................................... 117
Adding DIOs..................................................................................... 117
Replacing DIO H/W path................................................................... 118
Replacing DIO MAC address............................................................... 118
Deleting DIOs................................................................................... 118

7 Collecting and viewing utilization data............................................. 119
Enabling collection of utilization data................................................... 119
Viewing utilization data..................................................................... 120
Creating a historical utilization data report............................................ 124

8 Viewing logs and version information............................................. 125
Viewing VSP, VM, or vPar logs............................................................ 125
Viewing the VSP log.......................................................................... 125
Viewing the VM or vPar log................................................................. 126
Viewing Integrity Virtual Server Manager, Integrity VM, and WBEM Provider versions.................................................. 126

9 Support and other resources............................................................ 129
Information to collect before contacting HP......................................... 129
How to contact HP............................................................................. 129
Security bulletin and alert policy for non-HP owned software components................................................................. 129
Subscription service.......................................................................... 129
Registering for software technical support and update service.............. 129
How to use your software technical support and update service............ 130
HP authorized resellers..................................................................... 130
New and changed information in this edition..................................... 130
Related information.......................................................................... 130
Documents...................................................................................... 130
Websites........................................................................................ 131
Typographic conventions.................................................................. 131
1 Introduction

This document helps you understand and use HP Integrity Virtual Server Manager.

The audience for this document includes system administrators and others responsible for maintaining an Integrity VM and resources. You must be familiar with the HP Integrity VM (Integrity VM) product and HP-UX system administration using either HP SMH or HP Systems Insight Manager.

This chapter provides an overview of HP Integrity Virtual Server Manager and the product that it manages, HP Integrity Virtual Machines (Integrity VM). This chapter also lists the basic management tasks you can perform using Integrity Virtual Server Manager.

HP Integrity VM

HP Integrity Virtual Machines (Integrity VM) is a soft partitioning and virtualization technology that enables you to create multiple software-controlled Itanium-based VMs or vPars within a single HP Integrity server, Integrity blade, or nPartition. The Integrity server or nPartition acts as a VSP for the VMs or vPars (VMs or vPars are also called guests). The VSP is a platform manager. It manages hardware resources such as memory, CPU allocation, and I/O devices, and shares them among multiple VMs or vPars. The VSP runs a version of the HP-UX operating system and can be managed using standard HP-UX management tools. HP Integrity VM 4.0 and later runs on HP-UX 11i v3 only. Version 3.5 runs on HP-UX 11i v2 only.

The VMs or vPars share a single set of physical hardware resources, yet each VM or vPar is a complete environment in itself and runs its own instance of an operating system (called a guest OS). For a vPar, CPU and memory are not shared with other vPars. As with a real machine, the VM or vPar contains:

- At least one processor core, also referred to as a CPU
- Memory
- Disks
- Networking cards
- A keyboard
- A console
- Other components of a computer

All these elements are virtual (for vPar, CPU and Memory are not virtual), meaning that they are at least partially emulated in software rather than fully implemented in hardware; however, to the guest OS they appear as if they are real, physical components.

A guest OS cannot access memory allocated to another guest OS. One VM or vPar is not affected by software events on another VM or vPar, such as faults or planned software downtimes. Integrity VM optimizes the utilization of hardware resources, quickly allocating resources such as processor cores, memory, or I/O bandwidth to the VMs or vPars as needed. Any software that runs on supported versions of HP-UX can run in an Integrity VM virtual machine or virtual partition. No recompiling, recertification, or changes are required for applications to run in a guest OS. Applications run in the guest OS as they do on any operating system.

The operating systems supported on guests vary from version to version of HP Integrity VM. For information about supported VM or vPar operating systems, see the version of the HP-UX vPars and Integrity VM Administrator Guide manual that corresponds to the version of HP Integrity VM being used.

HP Integrity Virtual Server Manager

HP Integrity Virtual Server Manager is the GUI that you can use from your browser to manage Integrity VM resources. Integrity Virtual Server Manager allows you to create, configure, and
manage VMs or vPars, and to monitor and evaluate data and resources at the level of the Virtual Server Platform (VSP). You can view all of a VSP’s VMs or vPars and their assigned resources, and you can view all resources assigned to a specific virtual partition (machine) or virtual switch. For example, Integrity Virtual Server Manager provides graphical views of virtual-to-physical network and storage devices so that you can view I/O data, including resource utilization information. Integrity Virtual Server Manager obtains information about Integrity VM resources through Web-Based Enterprise Management (WBEM) providers installed on the VSP and on VMs or vPars (guest operating systems).

NOTE: The Integrity Virtual Server Manager GUI is available when you install HP Integrity Virtual Machines (Integrity VM) 6.1 and later. On Integrity VM v4.3 and earlier, the GUI is named Virtual Machines Manager (VM Manager). Depending on the Integrity VM version installed, Virtual Server Manager can be used to manage VMs or vPars or both. If the version installed is v4.3PK2 and earlier, you cannot manage vPars. If version 6.0 is installed, VMs cannot be managed. Table 1 lists the Integrity VM versions and the features supported in Integrity Virtual Server Manager for the corresponding Integrity VM versions.

Table 1 Integrity VM versions and Integrity Virtual Server Manager functionality

<table>
<thead>
<tr>
<th>Version of Integrity VM or vPar installed</th>
<th>Integrity Virtual Server Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrity VM v4.2</td>
<td>Functions as VM Manager 4.1</td>
</tr>
<tr>
<td>Integrity VM v4.2.5</td>
<td></td>
</tr>
<tr>
<td>Integrity VM v4.3</td>
<td></td>
</tr>
<tr>
<td>Integrity VM v4.3PK1</td>
<td></td>
</tr>
<tr>
<td>Integrity VM v4.3PK2</td>
<td>Manages 4.3 service pack features in addition to the features of Virtual Machines Manager 4.1.</td>
</tr>
<tr>
<td>vPars v6.0</td>
<td>Supports HP Virtual Partitions 6.0. Manages vPars on the version of HP-UX on which the Virtual Server Manager is installed.</td>
</tr>
<tr>
<td>HP-UX vPars and Integrity VM 6.1</td>
<td>Integrity Virtual Server Manager 6.1 manages virtual machines and virtual partitions.</td>
</tr>
<tr>
<td>HP-UX vPars and Integrity VM 6.2</td>
<td>Virtual machines and virtual partitions coexist.</td>
</tr>
</tbody>
</table>

Integrity Virtual Server Manager is available as a standalone product (the VMMGR bundle) that is installed on a VSP and accessed through the HP System Management Homepage (HP SMH), or as a component provided with HP Matrix Operating Environment for HP-UX (the VSEMgmt bundle), the latter which is installed with HP Systems Insight Manager on a central management server (CMS). As a component of HP Matrix Operating Environment for HP-UX, Integrity Virtual Server Manager seamlessly integrates with other Matrix Operating Environment components.

You can access Integrity Virtual Server Manager from a browser, using any of the two web-based software components (depending on the bundle installed):

- **HP System Management Homepage (HP SMH)**
  Integrity Virtual Server Manager is installed separately on any given VSP to manage that Integrity VSP and its VMs or vPars. You access Integrity Virtual Server Manager from a browser that can connect over the network to that VSP. Figure 1 shows how Integrity Virtual Server Manager is configured and used with HP SMH. This configuration is supported on HP-UX 11i v3 and 11i v2.
Figure 1 Integrity Virtual Server Manager with HP SMH

HP Matrix Operating Environment for HP-UX

Integrity Virtual Server Manager is installed as part of Matrix Operating Environment for HP-UX that runs under HP Systems Insight Manager on a server reserved for use as a central management server (CMS). The CMS can run on HP-UX or Windows platforms. HP Systems Insight Manager serves as the central point of administration for complete resource-lifecycle management for multi-OS environments. You access Integrity Virtual Server Manager from a browser that can connect over the network to the CMS. The CMS allows you to manage multiple Integrity VMs (VSPs and each of their VMs or vPars) that are discovered by HP Systems Insight Manager. Figure 2 shows how Integrity Virtual Server Manager is configured and used with HP Matrix Operating Environment (Matrix OE) and HP Systems Insight Manager.
In this environment, you can use Integrity Virtual Server Manager in seamless integration with other Matrix Operating Environment for HP-UX components. These interlinking components enhance the functionality and flexibility of your virtual server environment. For example:

- HP Matrix OE visualization provides a framework for visualizing your Virtual Server Environment. All of the systems and workloads that you are authorized to view are displayed in a graphical view. The hierarchical relationships between systems and their current utilization metrics can be seen in a single screen. Using HP Matrix OE visualization, you can manage a pool of multiple-OS, dynamically sizable virtual servers. You use HP Matrix OE visualization to access Integrity Virtual Server Manager for viewing and modifying VSP or virtual partition (machine) components.

- HP Global Workload Manager (gWLM) is a multiple-system, multiple-OS workload manager that serves as an intelligent policy engine in Matrix Operating Environment for...
HP-UX. It simplifies the deployment of automated workload management policies across multiple servers, and provides centralized monitoring and reporting and improved server utilization to assist in meeting your service level objectives. Using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, you can create, view, and modify gWLM policies for VMs or vPars.

- HP Capacity Advisor is capacity analysis and planning software that allows you to optimize the workloads across Matrix Operating Environment for HP-UX for the highest utilization of server resources. From Integrity Virtual Server Manager, you can cause Capacity Advisor to collect and display historical data for a VSP or selected VMs or vPars. Certain Integrity Virtual Server Manager views include utilization meters (bar graphs) that display current utilization data for a resource; you can click the meter to view a screen that provides more detailed historical data. (These meters are visible when using Integrity Virtual Server Manager with HP SMH, but you cannot click them to obtain a Capacity Advisor report.) For more information about using Integrity Virtual Server Manager to collect and view utilization data, see Chapter 7 (page 119). For more information about accessing Capacity Advisor through Integrity Virtual Server Manager, see “Using the Tools menu” (page 75) and “Using the View menu” (page 80).

Other Matrix Operating Environment for HP-UX components include:

- Application Discovery
- HP Instant Capacity Manager
- Partition Manager
- WBEM providers (which include the VM Provider and the Utilization Provider, as described in “System and software requirements” (page 13) and other agents.

For more information about Matrix OE concepts and terminology, including a complete list of the components of Matrix Operating Environment for HP-UX, see the HP Matrix Operating Environment 7.2 Getting Started Guide.

Information about HP SMH is available at the following HP SMH website:
http://www.hp.com/go/smh

Information about HP Systems Insight Manager is available at the following HP Systems Insight Manager website:
http://www.hp.com/go/insightmanagement/sim/

Integrity Virtual Server Manager tasks

Use Integrity Virtual Server Manager to create and manage VMs or vPars. To take full advantage of Integrity Virtual Server Manager, you can perform the following tasks:

- Create, configure, and control VMs or vPars and their resources, such as virtual switches (vswitches), virtual network devices, and virtual storage devices (Chapter 6 (page 83))
- Monitor VSP and VM or vPar operation (Chapter 4 (page 27))
- Modify VM or vPar configurations (Section (page 113))
- Migrate VMs from VSP to VSP (“Migrating VMs” (page 94))
- Collect and view utilization data for VSP, VMs or vPars, and their resources (Chapter 7 (page 119))
- Respond to status reports, error messages, and problems concerning VMs or vPars (Appendix A (page 135))
2 Installing Integrity Virtual Server Manager

This chapter discusses how to install Integrity Virtual Server Manager on your system or on the systems you will manage, including setup and software requirements, licensing requirements, and how to set WBEM security credentials.

System and software requirements

System requirements for the VSP, VMs, and vPars are described in the HP-UX vPars and Integrity VM Administrator Guide manual. In addition, see the HP-UX vPars and Integrity VM Release Notes, which are available on the product media. The most up-to-date release notes are available at the following location (click on the HP Matrix Operating Environment for HP-UX tab):

http://www.hp.com/go/matrixoe/docs

NOTE: Operating system support for VSP and guests varies from release to release of HP Integrity VM. For information about operating systems supported by a particular release and about installing supported operating systems on VMs or vPars, see the HP-UX vPars and Integrity VM Administrator Guide manual.

With use of Integrity Virtual Server Manager in the Matrix OE environment, any managed node must have WBEM and the appropriate WBEM credentials to support the visualization and configuration features of HP Matrix OE visualization and the collection of utilization data by HP Capacity Advisor. Without WBEM, only Global Workload Manager (gWLM) is functional. Managed nodes are systems that the user has instructed HP Systems Insight Manager to manage. For Matrix OE, all VMs or vPars and their VSP are managed nodes. Systems become managed nodes through the Systems Insight Manager “discovery” mechanism. Nodes can be discovered by Systems Insight Manager in various ways, including automated discovery or manual addition of the node. For example, you can configure and initiate node discovery, and perform numerous other setup tasks, by using the Insight managed system setup wizard. For more information, see the Insight managed system setup wizard getting started guide, available at the following location:

http://www.hp.com/go/matrixoe/docs

To use Integrity Virtual Server Manager and all its features, install the required WBEM provider components on the VSP and on the VM or vPar.

In the Matrix OE environment, to install such components on guests, use the Insight managed system setup wizard. The wizard allows you to choose whether to install the VM Provider. The wizard also checks the selected VMs or vPars for the appropriate versions of Utilization Provider software and installs the software as needed on supported platforms. (On a VSP, you must install the appropriate providers manually, using the VSP command line.) For more information, see the Insight managed system setup wizard getting started guide and the HP Integrity VM documentation available from the HP Technical Documentation website (for the HP Integrity VM documentation, click on the HP Matrix Operating Environment for HP-UX tab):

http://www.hp.com/go/matrixoe/docs

In the HP SMH environment, install the required provider components on the VM or vPar. These provider components are located in /opt/hpvm/guest-images on the VSP. Subdirectories contain the guest management software for each type of guest operating system, including both HP-UX versions 11i v2 and v3, Windows, and Linux. Each subdirectory includes software provided by HP Integrity VM that should be installed on the guest, including the latest VM Provider software.

For more information about installing software components on the VSP and guests, see the HP-UX vPars and Integrity VM Administrator Guide manual and the HP-UX vPars and Integrity VM Release Notes.

The WBEM provider components are the VM Provider and the Utilization Provider:
• The VM Provider provides VSP and guest configuration data. This information is delivered using WBEM. To use Integrity Virtual Server Manager to view configuration data, install the VM Provider (VMProvider bundle) that is provided with Integrity VM. Install the VM Provider on the VSP and on each VM or vPar when you install the HP Integrity VM product. If you upgrade Integrity VM, be sure to keep the VM Provider up to date, too. If the VM Provider version does not match the Integrity VM version, the Integrity Virtual Server Manager might not work as expected.

As for guests, the VM provider is required to view guest configuration data. The VM Provider and Integrity VM versions need not match. A guest’s VM Provider can be an earlier version than that of the Integrity VM running on the VSP. However, HP recommends upgrading the guests to the latest version of VM Provider available, even if the latest available provider version is greater than the version of the Integrity VM currently installed on the VSP. When the VSP Integrity VM is upgraded, you are not required to upgrade the VM Provider on each of the guests, but HP recommends upgrading the VM Providers on the guests to at least match the version of the Integrity VM on the VSP.

To install the VM Provider on the VSP and guests, install the appropriate provider software from the operating system media or the Integrity VM guest management software kit.

• The Utilization Provider gathers utilization statistics for CPU, memory, disk, and LAN. This information is delivered using WBEM and gathers data using a daemon (/usr/sbin/utild). You must install the Utilization Provider on the VSP and on each VM or vPar.

Installing Integrity Virtual Server Manager on HP Systems Insight Manager

On HP Systems Insight Manager, system requirements for installing Integrity Virtual Server Manager are the same as requirements for installing Matrix Operating Environment for HP-UX. You must have a license for at least one other component of Matrix Operating Environment for HP-UX, such as HP Matrix OE visualization. You cannot access the functionality in Integrity Virtual Server Manager unless you have a license for, and have installed Integrity VM on, at least one system to be managed through your licensed Matrix Operating Environment for HP-UX components.

For information about system requirements and installation instructions, see the HP Matrix Operating Environment 7.2 Integrity CMS Installation and Configuration Guide and the Insight managed system setup wizard getting started guide. This and other similar documentation is available from the HP Technical Documentation website:

http://www.hp.com/go/matrixoe/docs

NOTE: Do not install the VMMGR bundle (the bundle containing the Integrity Virtual Server Manager HP SMH plug-in) from the software depot onto the HP Systems Insight Manager CMS. For centralized Integrity VM management capabilities, install the VSEMgmt bundle (containing the Integrity Virtual Server Manager for HP Systems Insight Manager) from the software bundle.

Installing Integrity Virtual Server Manager on HP SMH

On HP SMH, Integrity Virtual Server Manager must be installed separately on a VSP.

Integrity Virtual Server Manager 6.2 requires JDK 6.1 for installation. Ensure that you have installed JDK 6.1 before installing Integrity Virtual Server Manager 6.2.

Download the Integrity Virtual Server Manager software depot from the following location:

After downloading the depot, install the software. As a privileged user, execute the following command, where path-to-depot-file is the full path specification to the depot file:

```
# swinstall -x mount_all_filesystems=false -s path-to-depot-file VMMGR
```

To determine the version of Integrity Virtual Server Manager currently installed, enter the following command:
Licensing requirements

The licensing requirements for Integrity Virtual Server Manager on HP SMH include the following:

On HP SMH, Integrity Virtual Server Manager is installed separately on a VSP. You must have a license for Integrity VM and have Integrity VM installed on that VSP. A separate license for Integrity Virtual Server Manager is not required.

For information about licensing, see the readme file in the /opt/vmmgr/src directory (HP SMH).

You must purchase licenses for any software you run in a VM or vPar, including the HP-UX operating system and any HP or third-party layered software. You can purchase the licenses for HP software under the HP Virtualization Licensing program. For more information, contact your HP representative.

- On HP Systems Insight Manager, Integrity Virtual Server Manager is included with Matrix Operating Environment for HP-UX and is installed when Matrix OE is installed. To make Integrity Virtual Server Manager operational, you must have a valid license installed for at least one component of Matrix Operating Environment for HP-UX (for example, HP Matrix OE visualization) and one license installed for Integrity VM on at least one VSP. You cannot access the functionality in Integrity Virtual Server Manager unless you have a license for Integrity VM and have Integrity VM installed on at least one system to be managed through your licensed Matrix Operating Environment for HP-UX components.

Setting security credentials

To display the full range of data about each VM or vPar in Integrity Virtual Server Manager, you must have WBEM-recognized credentials for each VM or vPar. A user name and password are required to collect resource utilization and other data, such as the status of the installed operating system. This data is available only from a WBEM provider on the VSP or VM (vPar). The WBEM providers are the tools used to gather data about the VM or vPar and the VSP. The user interface uses this information to show various kinds of system status.

You can set credentials by specifying a default user name and password combination for any or all VMs or vPars. You can also override the default user name or password on a case-by-case basis.

NOTE:

- For a given VM or vPar, if no user name or password is specified, the default is used.
- If a password is specified but a user name is not, the default user name is used with the password override. This allows a system administrator to use the same user name but different passwords for each VM or vPar.

When running Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, Systems Insight Manager is responsible for managing the credentials needed for using WBEM providers on the VSP and on VMs or vPars. When running Integrity Virtual Server Manager under HP SMH, HP SMH manages credentials and access for the VSP on which HP SMH is running; credentials for each VM or vPar are managed by Integrity Virtual Server Manager.

The method for setting WBEM credentials depends on whether you are using HP Systems Insight Manager or HP SMH.
Setting WBEM credentials in HP Systems Insight Manager

Any VMs or vPars that are not managed nodes do not have any credentials available, and Integrity Virtual Server Manager cannot contact them. These machines are displayed, but some of the information that can be gathered from the managed nodes is not displayed for non-managed nodes.

You can set credentials in HP Systems Insight Manager for a global configuration across multiple systems by selecting Options → Protocol Settings → Global Protocol Settings...; for a single managed node, set credentials by selecting Options → Protocol Settings → System Protocol Settings.... Integrity Virtual Server Manager requires that the proper WBEM credentials (a valid user name and password) be set in those option pages. Without WBEM, the HP Matrix OE visualization and HP Capacity Advisor functionality will not be available; only Global Workload Manager (gWLM) is functional.

With HP Systems Insight Manager, you can set the credentials when you first launch HP Systems Insight Manager after installation by using the HP Systems Insight Manager First Time Wizard. For information about setting credentials, see the HP Matrix Operating Environment 7.2 Integrity CMS Installation and Configuration Guide.

Setting WBEM credentials in HP SMH

You must set WBEM credentials for VMs or vPars in HP SMH. This allows Integrity Virtual Server Manager to collect utilization data and operating system information on the VM or vPar. Stored credentials are specific to the user logged in to HP SMH. Two users who are logged in with different user names do not share credentials.

When you log into SMH without having already set the WBEM credentials and saving them in the file system, the Set WBEM Credentials for VM or vPar page is displayed. When you create a new VM or vPar, you must add credentials for that VM or vPar by selecting Modify → WBEM Credentials... from the Integrity Virtual Server Manager menu bar, which displays the same page. Figure 3 shows an example of the Set WBEM Credentials for VM or vPar page.

**Figure 3 HP SMH: Set WBEM Credentials page**

On this page, you can set one user name and password combination for all VMs or vPars (For vPars and Integrity VM 6.2, VMs and vPars cannot work at same VSP), or you can set them individually for one or more VMs or vPars. If you set the credentials for some but not all of the...
individual systems, Integrity Virtual Server Manager does not collect utilization data and operating
system information for the excluded systems.
You can also save the user name and password entries in obscured format in the file system. This
allows you to use the same setting each time you enter Integrity Virtual Server Manager through
HP SMH. To save these entries, select the Save user name and password settings in the file system
check box, and then click OK. This information is obfuscated before being stored.
If you do not want to provide this security information for the current session, click Cancel. Integrity
Virtual Server Manager continues without collecting this data. If you do not want to
be prompted for it on each entry into Integrity Virtual Server Manager, make sure all entries on
the page are blank, select the check box to save the credentials to file, and click OK. Empty
credentials are stored, and this prevents the WBEM credentials page from being displayed on
subsequent entries into Integrity Virtual Server Manager.
If you require the additional security provided by certificate validation, you can turn on SSL certificate
validation by checking the Require trusted certificates check box. If this box is checked, you must
store the valid certificates for the VMs or vPars in a keystore on the VSP to indicate that connections
to those VMs or vPars are trusted; otherwise, some information is not displayed by Integrity Virtual
Server Manager. For example, if a certificate is missing, utilization meters are labeled No Data.
For more information about trusted certificates and how to store them in a keystore on the VSP,
see “Trusted certificates” (page 18).
You can use the basic features of the HP SMH version of Integrity Virtual Server Manager without
exposing user credentials or configuration data on the local network. In this case, you see a subset
of the potential information that the Integrity Virtual Server Manager can display. To have all data
displayed, the following steps are required.

**NOTE:** Displaying all the information about the VMs or vPars’ configuration exposes the credentials
of a connecting user.

1. Create a nonlogin, nonprivileged account on each VM or vPar to which Integrity Virtual Server
Manager might connect and whose credentials can be intercepted on the network. Although
these credentials are restricted to nonlogin capabilities, they can also be used to gain access
to other data or actions available using WBEM and other nonlogin services, including those
from additional providers that are registered on the system.

2. **Optional, for additional security:** If local policy is to avoid exposure of any account credentials
on your network, or if you do not want to expose the VM or vPar configuration data, then
configure an SSH or IPSec tunnel from the VSP system to each VM or vPar for port 5989 (HP
WBEM Services).

The following types of information require credentials for each VM or vPar for which information
is to be gathered:

- **Operating System:** If the required credentials are not set for a VM or vPar, Integrity Virtual
Server Manager cannot contact the machine. Integrity Virtual Server Manager displays the
expected operating system (if the operating system was set during configuration of the VM or
vPar, or if the guest operating system on the VM or vPar has been booted). If the credentials
are set and the VM or vPar is running with the proper provider, Integrity Virtual Server Manager
displays the operating system and version number.

- **Utilization:** If the required credentials are not set for a VM or vPar, the utilization meters for
VM-specific or vPar-specific items are dimmed. (Meters specific to a VM or vPar are located
on such Integrity Virtual Server Manager pages as the VSP Virtual Servers tab, the VMs or
vPars Properties Network and VMs or vPars Properties Storage tabs, and the VMs or vPars
Properties General tab. For more information about these tabs, see Chapter 4 (page 27).) Meters
for the VSP and VSP resources are still available if the VSP’s WBEM Utilization Provider
is running.

The data is a 5-minute average that is calculated and updated on 5-minute boundaries.
When a utilization meter is dimmed, a label next to the meter indicates the probable cause. These labels and status indicators are described in “Utilization meter status/error information” (page 137).

Virtual LAN interface I/O utilization on the VM or vPar Properties Network tab: For a VM or vPar with invalid credentials, either the No Perm. or No Data label appears next to the meter. The page still displays whatever information is available from the VSP, such as the status and the bus, device, and function numbers for a virtual LAN interface. For a VM or vPar with valid credentials, Integrity Virtual Server Manager displays I/O utilization data for each virtual LAN interface and for VM or vPar aggregated LAN interfaces.

Virtual storage device I/O utilization on the VM or vPar Properties Storage tab: For a VM or vPar with invalid credentials, either the No Perm. or No Data label appears next to the meter. The page still displays whatever information is available from the VSP, such as the virtual device type and the bus, device, and target numbers for the virtual storage device. For a VM or vPar with valid credentials, Integrity Virtual Server Manager displays I/O utilization data for each virtual storage device and for VM or vPar aggregated storage interfaces.

- Virtual LAN (VLAN) interface name and status on the Network tab: This status is displayed for a VM or vPar with valid credentials, but invalid credentials will return an unknown LAN status and utilization. It might display whatever information is available, for example, the bus, dev, or the fcn number for the VLAN interface.

To change the WBEM credentials settings for VMs or vPars, return to the Set WBEM Credentials for VMs or vPars page by selecting Modify → WBEM Credentials.... You do not need to select a VM or vPar before setting credentials.

1. IMPORTANT: After you enter the data, save it by clicking OK. Otherwise, the data is cleared when the session ends.

Trusted certificates

If you require the additional security provided by certificate validation you can turn on SSL certificate validation by selecting the Require trusted certificates check box on the Integrity Virtual Server Manager Set WBEM Credentials for VMs or vPars page. With this setting turned on, the client Certificate Trust Store must include the server certificates from the VMs or vPars; otherwise, Integrity Virtual Server Manager cannot obtain certain information from the VMs or vPars. If your environment does not require the additional security provided by certificate validation, you can leave certificate validation turned off.

To enable SSL certificate validation in Integrity Virtual Server Manager, you must export the server certificates from the WBEM services providers on the VMs or vPars, and import those certificates into the keystore on the VSP where Integrity Virtual Server Manager is running. This keystore is shared between Partition (machine) Manager and Integrity Virtual Server Manager. Certificates in this keystore are trusted by both Partition (Machine) Manager and Integrity Virtual Server Manager.

To get the certificate file from the WBEM services provider, follow these steps:
1. Locate the WBEM services provider certificate file (`cert.pem`) on the VM or vPar to which you want to connect. To find the correct file, open the WBEM services Provider configuration file, which can be found in the following locations:
   - For Windows:
     `%PEGASUS_HOME%\cimserver_current.conf`
   - For HP-UX:
     `$PEGASUS_HOME/cimserver_current.conf`
     (The default value for PEGASUS_HOME on HP-UX is `/var/opt/wbem`.)

   The location of the server certificate file is configured by the `sslCertificateFilePath` setting. If this value is not set in the configuration file, the default values are as follows:
   - For Windows:
     `%PEGASUS_HOME%\server.pem`
   - For HP-UX:
     `/etc/opt/hp/sslshare/cert.pem`

2. Copy the certificate file (`cert.pem` or `server.pem`) to the VSP where Integrity Virtual Server Manager is running.

   **NOTE:** Copy the certificate file to a temporary directory (not to the `sslshare` directory) on the VSP. Do not overwrite the existing `cert.pem` or `server.pem` file in the `sslshare` directory on the VSP.

3. To import the certificate file, enter the following command on the VSP:

   ```bash
   JAVA_HOME/bin/keytool -import -alias server_hostname \
   -file cert.pem \
   -keystore /etc/opt/hp/sslshare/parmgr.keystore
   ```

**Discovering data when setting new WBEM credentials**

When you set new WBEM credentials from the Integrity Virtual Server Manager Modify menu and click OK, the page to which you return is updated using the new credentials. However, especially when Integrity Virtual Server Manager must retrieve data from a large number of VMs or vPars, some of the data might not yet be updated when the page displays in full (instead, the old data is still displayed). With the exception of data displayed by utilization meters, the new data (such as the VM or vPar guest OS version) is not seen until the page refreshes again. The utilization meters update immediately after Integrity Virtual Server Manager retrieves the utilization data; refreshing the page is not required for updating that data.
3 Accessing and Navigating Integrity Virtual Server Manager

You access Integrity Virtual Server Manager through a web browser. This chapter explains how to access Integrity Virtual Server Manager from HP SMH and HP SIM. This chapter also explains how to access Integrity Virtual Server Manager help. Information about possible access failures and the messages that might be seen is included in Appendix A (page 135).

Accessing Integrity Virtual Server Manager from Matrix Operating Environment for HP-UX

To use all the functions in Integrity Virtual Server Manager (view all screens and perform all menu actions), you must have Matrix OE All Tools authorization. To access Integrity Virtual Server Manager from Matrix OE:

1. From the Systems Insight Manager/Matrix OE Home page, select Tools→HP Matrix OE visualization..., as shown in Figure 4.

Figure 4 HP Matrix Operating Environment: accessing HP Matrix OE visualization

This displays the HP Matrix OE visualization Visualization tab, as shown in Figure 5.
2. The first time you start HP Matrix OE visualization, the **Visualization** tab appears with the default **Physical and Virtual** perspective, which shows all physical and virtual nodes in graphical compartments. When you start HP Matrix OE visualization any time after, the software checks whether you had previously set a default view by modifying user preferences (modify user preferences by selecting **Configure→User Preferences...** from the HP Matrix OE visualization menu bar). If you set a collection such as VSPs, HP Matrix OE visualization displays the collection for all VSPs and VMs or vPars.

The **Perspective** menu allows you to choose a view comprised solely of VSPs and VMs or vPars (both HP Integrity VM and VMware ESX, if both products are present among the resources). Select **Virtual Machine** from the drop-down menu, as shown in Figure 6.

Figure 6 Selecting VM or vPar perspective
3. On the HP Matrix OE visualization **Visualization** tab, select the VSP or VM (vPar) that you want to manage. For example, in the Integrity VM representation shown in Figure 7 (a closeup from the screen shown in Figure 6 (page 22)), you can select VSP system *chili3* by clicking the monitor icon beneath the VSP name. (If you hover your cursor over the icon, a pop-up pane displays explanatory text.) Selecting a VSP monitor icon displays the Integrity Virtual Server Manager **VSP Virtual Servers** tab.

   Alternatively, you can select one of the VMs or vPars running on VSP *chili3* by clicking the similar but smaller icon beneath a VM or vPar name (such as the monitor icon for *chili3a* in Figure 7). Selecting a VM or vPar monitor icon, displays the **VM or vPar Properties General** tab.

   The basic Integrity Virtual Server Manager views are described in Chapter 4 (page 27).

   ![Figure 7 Select VSP](image)

### Accessing Integrity Virtual Server Manager from HP SMH

To use all the functions in Integrity Virtual Server Manager (view all screens and perform all menu actions), you must log in to HP SMH with Administrator privileges. To access Integrity Virtual Server Manager from HP SMH:

1. On the SMH **Home** page, click **Tools**.

   **NOTE:** SMH GUI sessions stop after the session timeout period elapses without any user activity (by default, the session timeout period is 15 minutes). With HP SMH Version 2.2.7 December 2007 and later, you can prevent a session from timing out by selecting the **Session never expires** check box in the upper right corner of the page. Even if the box is checked, the SMH server might shut itself down to conserve system resources if there is a period of inactivity from all users (by default, this timeout period is 30 minutes). All of the Integrity Virtual Server Manager Version 4.1.1 views and dialogs periodically issue short keepalive messages to the server to prevent SMH from shutting itself down during your session. For more information about SMH session management, see the `smhstartconfig(1)` and `hpsmh(1)` manpages.

2. On the SMH **Tools** page, select **Integrity Virtual Server Manager** from the **Integrity Virtual Server Management** menu box. In the SMH **Tools** page shown in Figure 8, the **Integrity Virtual Server Manager** menu box appears in the left of the page. (Its location varies, depending on the management tools that are available.) This example shows the SMH list view. The SMH icon view displays icons instead of menu boxes. Look for the Integrity Virtual Server Manager icon (). To switch from one type of view to another, click one of the associated icons in the SMH header (to the right of the Management Processor information).
NOTE: When you access Integrity Virtual Server Manager for the first time from HP SMH, you might encounter an End User License Agreement (EULA). You must accept this agreement to continue using the Integrity Virtual Server Manager product.

Figure 8 HP SMH: accessing Integrity Virtual Server Manager

If you have already saved WBEM credentials for each VM or vPar, selecting Integrity Virtual Server Manager displays the VSP Virtual Servers tab.

If you have not set and saved WBEM credentials for each VM or vPar, the Set WBEM Credentials page is displayed first (instead of the VSP Virtual Servers tab). An example of the Set WBEM Credentials page is shown in Figure 3. Enter the appropriate information and click OK, or click Cancel to skip this step and advance to the Integrity Virtual Server Manager VSP Virtual Servers tab. For more information about setting WBEM credentials, see “Setting security credentials” (page 15).

Accessing Integrity Virtual Server Manager help

To access help information for any Integrity Virtual Server Manager page, click the question mark icon located in the upper right corner of the Integrity Virtual Server Manager page.

Navigating Integrity Virtual Server Manager

Integrity Virtual Server Manager provides numerous navigation aids, as shown in Figure 9, which is an example of a Integrity Virtual Server Manager view from within the SMH.
NOTE: The Integrity Virtual Server Manager navigation aids available in a particular view vary according to the view. The view in Figure 9 shows most of the navigation aids that Integrity Virtual Server Manager provides. Missing from this view are navigation buttons such as Previous and Next, visible in some of the Create Virtual Machines or Virtual Partitions wizard pages (discussed in “Creating VMs” (page 83) or “Creating vPars” (page 111)). Certain Integrity Virtual Server Manager pages (such as the Start Virtual Machine or Start Virtual Partition page) include OK and Cancel buttons, which complete or cancel an action, returning you to the Integrity Virtual Server Manager view from which you initiated the action.

Figure 9 Integrity Virtual Server Manager navigation features

1. Click a tab to change to another view. All Integrity Virtual Server Manager tabs are described in Chapter 4 (page 27).
2. Click a menu in the menu bar beneath the tab title. This displays additional information about the actions you can perform. The Integrity Virtual Server Manager menu bar is described in Chapter 5 (page 75).
3. Click the top of a column of a table (on or near the title of the column) to change which column is driving the sort order of the table. Click the arrow in the selected column to toggle between ascending and descending order. Not all columns can drive the sort order. Hover your cursor over a column heading to determine whether the column is selectable for sorting; the cursor (pointer) changes according to the current pointer scheme configured for your operating system (for example, when you hover over a selectable column, your cursor might change from an arrow to a hand).

In tables that are sortable, one column has a darker grey background in the column heading and an ascending or descending arrow in the same area. The dark grey color indicates that the column is driving the sort order for all rows of data in the table. The arrow indicates whether the column has been sorted in ascending or descending order. Criteria for the order may be numeric or alphabetical. In Figure 9, the column that drives the sorting order is the VM or vPar Name column, and the column is sorted in ascending order.

4. Click a check box next to an object that you want to act on, then select the action from one of the Integrity Virtual Server Manager menus. To perform an action on all the objects listed, select the box at the top of the check box column (in the header row at the top of the table).
5. Click a link to an object (the object’s name forms the link) to move to a view of that object. For example, click the VM name link shown in Figure 9 to access the VM Properties page for that VM.
6. These icons indicate the status of the VM or vPar hardware (HW) and its guest operating system (OS). The icons in the HW column indicate whether the VM or vPar is started (up) or stopped (down). For example, the icon indicates a VM or vPar is up; the icon indicates it is down. The same icons in the OS column indicate whether the operating system is running.
The icon in the OS column indicates that the VM is in a suspended state. In this particular view (the VSP Virtual Servers tab), if a VM is migrating, an icon indicates the direction of migration. In the last row of the table, the icon indicates the VM is migrating to another VSP. For more information about migration status icons, see “VSP Virtual Servers tab” (page 31). The meanings of these and other status icons are summarized in “Status indicators” (page 137).

Using Integrity Virtual Server Manager with Matrix Operating Environment, you can click a utilization meter to view a snapshot of Capacity Advisor historical data; this feature is not provided when using Integrity Virtual Server Manager from HP SMH. For information about using Integrity Virtual Server Manager to collect and view utilization data, see Chapter 7 (page 119).

NOTE: Avoid using your browser’s Back and Forward buttons in Integrity Virtual Server Manager. When you use these buttons, Integrity Virtual Server Manager cannot identify that you have changed to a different view. This can cause problems, including incorrect display of objects selected in the current view. Instead, use the links and navigation buttons provided by Integrity Virtual Server Manager.

If you navigate from one Integrity Virtual Server Manager view to another (for example, from VSP view to VM or vPar Properties view), click the Go back link in the new view (and on any subsequent tabs you navigate to in that same view) to return to the previous Integrity Virtual Server Manager view. For example, if you navigate from the VSP view to the VM or vPar Properties view or to the Vswitch Properties view, clicking the Go back link returns you to the VSP view. If you navigate from the VM or vPar Properties view to the VSP view or to the Vswitch Properties view, clicking the Go back link returns you to the VM or vPar Properties view.

Using Integrity Virtual Server Manager from Matrix Operating Environment, if the Integrity Virtual Server Manager view was accessed directly from HP Matrix OE visualization, clicking the Go back link returns you to HP Matrix OE visualization (as indicated in Figure 9); clicking the Go back link on any tab that you navigate to in the same view also returns you to the HP Matrix OE visualization. For more information about returning to HP Matrix OE visualization from Integrity Virtual Server Manager (or, if you are using HP SMH, about returning to the HP SMH Homepage), see “Returning to the HP SMH Homepage” (page 26).

Returning to the HP SMH Homepage

With HP Matrix Operating Environment, to access HP Matrix OE visualization from a Integrity Virtual Server Manager view in which the Go back link currently directs you to another Integrity Virtual Server Manager view, you can do one of the following:

- From the HP Matrix Operating Environment menu bar (top menu bar), select Tools→HP Matrix OE visualization... Alternatively, select the All VSE Resources link in the left-hand navigation pane (System and Event Collections→Systems→Shared→Systems by Type→All VSE Resources). To access the top menu bar or left-hand navigation pane, your Integrity Virtual Server Manager view must not be maximized (using the Maximize link in the top right corner). If your view is maximized, return to the view that includes the top menu bar by clicking Restore Size in the top right corner of the maximized Integrity Virtual Server Manager view.

- Continue using the Go back link until you return to the Integrity Virtual Server Manager view that you accessed originally from the HP Matrix OE visualization, at which point you can click the Go back to HP Matrix OE visualization link.

Click Home from the HP SMH menu bar to return to the HP SMH Homepage if you are using Integrity Virtual Server Manager from HP SMH.

NOTE: Avoid using your browser’s Back and Forward buttons in Integrity Virtual Server Manager. Instead, use the links and navigation buttons provided by Integrity Virtual Server Manager, as described in this section and “Navigating Integrity Virtual Server Manager” (page 24).
4 Using Integrity Virtual Server Manager views and tabs

Integrity Virtual Server Manager provides three basic views, each with several tabs, as described in the following sections.

You can print any of the VSP or vPar or VM tabs by clicking View Printer-friendly beneath the Integrity Virtual Server Manager menu bar, on the left side of the page. This redisplays the tab in a format suitable for printing. To print the tab, click Print. To switch back, click View Normal.

You can update the data on certain pages by clicking Refresh Data beneath the Integrity Virtual Server Manager menu bar, on the right side of the page. In general, Integrity Virtual Server Manager tabbed views are refreshed automatically every five minutes. An indicator on these visualization pages notifies you when the data was last refreshed. Integrity Virtual Server Manager screens that display configuration data are updated instantaneously when you use Integrity Virtual Server Manager to change the related configuration parameters. However, when changes to the VM or vPar I/O configuration are made using tools other than Integrity Virtual Server Manager (such as adding or removing I/O devices by using the VSP command line), the updated configuration data is not shown until the screen is refreshed. Some dialog screens, such as the Create Virtual Machine or Create Virtual Partition wizard Add Storage Device and the Modify → Add Storage Device to VM or vPar... screens, include a Refresh Data link that you can use to manually refresh data.

NOTE: The figures in this chapter and in the remainder of the manual display views seen from HP Matrix Operating Environment. Views in HP SMH might differ slightly. Differences are noted. In addition, the examples display maximized window views to give more focus to the Integrity Virtual Server Manager window (eliminating the Matrix Operating Environment system status pane available on the left of the page and the Systems Insight Manager/HP Matrix Operating Environment header and menu bar on the top of the page). Select the maximized view by clicking Maximize in the top right corner of the page. To return to the original view, click Restore Size in the top right corner of the maximized page. The maximize feature is not provided by HP SMH but is not needed; HP SMH provides a full-window Integrity Virtual Server Manager view.

VSP view

You can access the Integrity Virtual Server Manager VSP view directly from SMH or from other Integrity Virtual Server Manager views that include a link to the VSP, such as the VM or vPar Properties General tab. Figure 10 shows a typical VSP view in Integrity Virtual Server Manager. Tabs available from the VSP view are described in the text that follows. Subsequent sections describe each tab in more detail.
The “VSP General tab” (page 28) displays information about the VSP system. The “VSP Virtual Servers tab” (page 31) displays information about the state of VMs or vPars in the VSP system. The “VSP Virtual Switches tab” (page 33) shows information about the virtual switches on the VSP. The “VSP Network tab” (page 34) shows all mappings from virtual network interface cards in the VMs or vPars to the physical network interface cards in the VSP system. The “VSP Storage tab” (page 42) shows all mappings from the virtual storage devices in the VMs or vPars to the physical storage devices in the VSP system. The “VSP Console tab” (page 49) displays the screen through which you can open a iLO console terminal or a virtual iLO remote console terminal based on your privileges. The “VSP GUID Resources tab” (page 49) displays the screen through which you can create, modify, or delete World Wide Number (WWN) ranges. The “DIO Pool tab” (page 51) displays the screen through which you can create or modify the properties of DIO owned by the host or HPVM.

VSP General tab

The VSP General tab displays information about the overall state and configuration of the VSP system.
Quick reference

Figure 11 VSP General tab

1. Displays this window in a format suitable for printing.
2. Describes resources in the VSP system.
3. Describes the status of VMs or vPars in the VSP system and identifies external managers. If the VSP VMs or vPars are being managed by gWLM or HP Serviceguide, the External Managers field displays gWLM or Serviceguide. If the vPars are managed by gWLM, the field provides a hyperlink that enables you to access gWLM.
4. Summarizes resource utilization for the VSP system.
   For more information about using Integrity Virtual Server Manager to collect and view utilization data, see Chapter 7 (page 119).
5. Summarizes version information of virtual server manager.
Screen details

VSP Information

- **VSP name:** The hostname of the VSP system (as well as the nPartition name and link to Partition Manager for this nPartition, if the VSP system is contained within an nPartition).
- Resource inventory.
  - **Physical CPU Core Count:** The number of processors.
  - **Physical CPU Core Speed:** The speed of processors.
  - **Physical Memory:** The amount of memory.
  - **Online Migration:** Indicates whether the VSP is enabled and licensed to support online migration of VMs. The second column in the following table shows what the status field displays, based on the state of the VSP listed in the first column:

<table>
<thead>
<tr>
<th>VSP state for online migration</th>
<th>Online migration status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disabled</td>
<td>Host disabled</td>
</tr>
<tr>
<td>Enabled and licensed</td>
<td>Host licensed</td>
</tr>
<tr>
<td>Enabled and unlicensed</td>
<td>Host not licensed</td>
</tr>
</tbody>
</table>

The licensing is included with a bundle that must be installed on the VSP. For more information about enabling and licensing the VSP, see the *HP-UX vPars and Integrity VM Administrator Guide* manual.

VM and vPar Information

- **Number of defined VMs or vPars:** The number of defined VMs or vPars.
- **Number of active VMs or vPars:** The number of VMs or vPars currently booted, and the number of VM or vPar packages running on the local VSP (local) as well as the number that are hosted remotely using HP Serviceguard.
- **External Managers:** Indicates if the VMs or vPars are being managed by gWLM or HP Serviceguard. With Matrix Operating Environment, if VMs or vPars are managed by gWLM, the field provides a hyperlink to gWLM. Under HP SMH, if VMs are being managed by gWLM, the field identifies the Central Management Server (CMS) on which gWLM is running and provides a hyperlink to the Systems Insight Manager/Matrix Operating Environment login screen (you cannot modify gWLM policies from HP SMH). In either case (using Integrity Virtual Server Manager with HP Matrix Operating Environment or HP SMH), if the VMs or vPars are not being managed by gWLM or HP Serviceguard, this field displays *(none)*.

VSP Resource Utilization

The utilization data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot be displayed, the utilization meter (bar graph) is dimmed and a label indicates the probable cause. For a description of meter labels, see “Utilization meter status/error information” (page 137).

Using Integrity Virtual Server Manager with Matrix Operating Environment, you can click a meter to view a snapshot of Capacity Advisor historical data. This feature is not provided when using Integrity Virtual Server Manager from HP SMH.
- **VSP CPU Utilization**: An aggregate showing how busy the VSP is with respect to the processes and VMs or vPars that are executing on it.

- **Physical Memory currently in use**: A started VM or vPar requires the total amount of memory defined for that VM or vPar. If the memory is set to be reserved, the stopped vPar also requires the total amount of memory defined for it.

- **Physical Network I/O**: An aggregate of all network I/O that is occurring on the VSP as a result of both VSP and guest access to network devices. Because this is an aggregate, one or more network devices might be very busy, while others might be idle. For information about specific devices, see the **VSP Network** tab.

- **Physical Disk I/O**: An aggregate of the storage I/O that is occurring on the VSP as a result of both VSP and guest access to storage devices. Because this is an aggregate, one or more storage devices might be very busy, while others might be idle. For more information about each device, see the **VSP Storage** tab.

**VSP Virtual Servers** tab

The **VSP Virtual Servers** tab displays information about the state of VMs or vPars in the VSP system.

Quick reference

**Figure 12 VSP Virtual Servers tab**

1. Displays this window in a format suitable for printing.
2. Allows you to perform an action on the VM or vPar. Select the box for a specific VM or vPar, then select an action from one of the menus available on the Integrity Virtual Server Manager menu bar. To perform an action on all the VMs or vPars, select the box in the header row.
3. Displays information about the VM or vPar by taking you to the **VM or vPar Properties General** tab.
4. Indicates the hardware status of the VM or vPar.
5. Indicates whether the OS is running.
6. Utilization meters (bar graphs) display utilization data. Other meters display data about VM or vPar CPU utilization, disk I/O, network I/O, and CPU utilization. (In Figure 12, the VM or vPar information table is only partially visible; some utilization meters are not visible. To see all the utilization meters in the full-width view, see Figure 13.)

If the data cannot be displayed, the meter is dimmed and a label indicates the probable cause. For a description of meter labels, see “Utilization meter status/error information” (page 137)
In Integrity Virtual Server Manager on Matrix Operating Environment, you can click a meter to view a snapshot of Capacity Advisor historical data. Virtual Server Manager is on SMH and does not provide an option to generate a Capacity Advisor report.

Figure 13 shows an example of the full-width view of the VM or vPar information table displayed by the VSP Virtual Servers tab. (To see the entire table, you might have to scroll horizontally or maximize your window.)

Figure 13 Full-width view of virtual servers information table

<table>
<thead>
<tr>
<th>Name (FQDN)</th>
<th>Type</th>
<th>HW</th>
<th>OS</th>
<th>Operating System</th>
<th>CPU Utilization</th>
<th>Memory Utilization</th>
<th>Disk I/O</th>
<th>Network I/O</th>
<th>CPU Count</th>
<th>CPU Utilization</th>
</tr>
</thead>
<tbody>
<tr>
<td>vms1 (2)</td>
<td>VM</td>
<td>Down</td>
<td>HPUX</td>
<td></td>
<td>No Data</td>
<td>No Data</td>
<td>No Data</td>
<td>No Data</td>
<td>1</td>
<td>10%</td>
</tr>
<tr>
<td>vms2 (2)</td>
<td>vPar</td>
<td>Down</td>
<td>HPUX</td>
<td></td>
<td>No Data</td>
<td>No Data</td>
<td>No Data</td>
<td>No Data</td>
<td>1</td>
<td>No Data</td>
</tr>
</tbody>
</table>

Screen details

- **Name (FQDN):** Displays the VM or vPar name and, in parentheses, a fully qualified network name for the VM or vPar (if available). If the VM or vPar is configured as a Serviceguard package, the package icon appears next to the VM or vPar name. If the VM or vPar Serviceguard package is being managed by another VSP, the HW field indicates so. If errors occur during an attempt to migrate the VM, the Migration Alerts icon appears next to the VM name; more information about the errors is available from the VM or vPar Properties General tab.

- **HW:** Displays an icon that indicates the state (for example, up/down) of the VM or vPar. You can hover your cursor over the icon for a more detailed description.

If the state of the VM or vPar becomes Not Runnable, it is indicated with the following status icon: . This means that the VM or vPar cannot be modified or started.

If the VM has successfully migrated to another VSP, the state of the VM becomes Not Runnable, indicated with the following status icon: . This means that the VM cannot be modified or started. If you never intend to migrate the VM back to this VSP, you can remove the VM configuration by using the Integrity Virtual Server Manager Delete → Virtual Machine... menu item.

If the VM or vPar is an HP Serviceguard package managed by another VSP, this field also displays the following icon: . Flyover text shows the state of the hardware (On) and the name of the VSP currently managing the VM or vPar.

For more information on the meanings of status icons, see “Status indicators” (page 137).

- **OS:** Displays an icon that indicates whether the operating system is active on the VM or vPar. You can hover your cursor over the icon for a more detailed description. The icon indicates the operating system is running. The icon indicates the operating system is not running. The icon in the OS column indicates that the VM is in a suspended state.

If the VM is currently migrating, an icon indicates the direction of migration:

- : Migrating to another VSP. Flyover text indicates the VM is migrating and provides the name of the target VSP.

- : Migrating to this VSP from another VSP. Flyover text indicates the VM is migrating from another VSP.

If the VM is waiting in queue to migrate (when several VMs are selected to migrate, only one migrates at a time; the rest wait in queue), an hourglass icon indicates so. To view changes in migration status, click Refresh Data.
NOTE: Although only one VM migrates at a time, you might see indication of two machines migrating simultaneously to another VSP. The first migration has actually completed but Integrity Virtual Server Manager has not yet received notification from the VM Provider.

For more information on the meanings of status icons, see “Status indicators” (page 137)

- **Operating System**: Displays the operating system type and version information for the VM or vPar.
- **CPU Utilization**: Displays how much of the virtual CPU assigned to the VM or vPar is currently being used.

NOTE: This and other utilization meters in this table display utilization data, if available. The utilization information is a 5-minute average that is calculated and updated on 5-minute boundaries. If the utilization cannot be displayed, the utilization meter is dimmed and a label indicates the probable cause. For a description of meter labels, see “Utilization meter status/error information” (page 137).

Using Integrity Virtual Server Manager with Matrix Operating Environment, you can click a utilization meter to view a snapshot of Capacity Advisor historical data; this feature is not provided when using Integrity Virtual Server Manager from HP SMH. For an example utilization history screen and information about collecting and viewing utilization data, see Chapter 7 (page 119).

- **Memory Utilization**: Displays how much of the memory assigned to the VM or vPar is currently being used.
- **Disk I/O**: Displays storage I/O throughput measured for this VM or vPar.
- **Network I/O**: Displays network I/O throughput measured for this VM or vPar.
- **CPU Count**: Displays the number of CPUs in the VM or vPar.
- **CPU Entitlement**: Displays the percentage of CPU power guaranteed to the VM or vPar. This field is not displayed if the VM or vPar is being managed by gWLM.
- **VSP CPU Utilization**: Displays how many of the VSP’s physical CPU resources are being consumed by this VM or vPar. This meter is not displayed if the VM or vPar is a Serviceguard package running on another VSP.

**VSP Virtual Switches** tab

The **VSP Virtual Switches** tab displays information about the virtual switches (vswitches) on the VSP system.

Quick reference

**Figure 14 VSP Virtual Switches tab**
1 Displays this window in a format suitable for printing.
2 Allows you to perform an action on the virtual switches. Select the box for a vswitch, then select a command from the menu to perform an action on the vswitch. To perform an action on all the virtual switches, select the box in the header row.
3 Displays information about the virtual switch by taking you to the Vswitch Properties General tab.
4 Indicates whether the physical backing device supports Accelerated Virtual Input/Output (AVIO).

Screen details

- **Virtual Switch Name**: lists the names of the virtual switches.
- **Status**: shows whether the virtual switch is up (operational) or down (inoperational).
- **Type**: shows whether the corresponding virtual switch is a shared or dedicated vswitch.
- **Supports AVIO**: shows whether the corresponding backing device supports Accelerated Virtual Input/Output (AVIO). AVIO is supported on HP Integrity VM Version 3.5 or later. For each VM or vPar containing an AVIO device, the VSP OS and the guest OS must support AVIO. With HP Integrity VM, AVIO requires a virtual switch that has a physical network device as the backing device (local virtual switches such as localnet are not supported). In addition, the physical NIC that backs the virtual switch must have an AVIO-compatible driver. For more information about AVIO requirements, see the HP Integrity VM documentation at the following website (click on the HP Matrix Operating Environment for HP-UX tab):
- **Used by**: shows the VMs or vPars that are using the virtual switch. Position your cursor over the information icon to view a list of the VMs or vPars that are connected to the virtual switch.

**VSP Network tab**

The VSP Network tab shows the mapping from virtual network interfaces in the VMs or vPars to the physical network interface cards (also called adapters) in the VSP system.
Displays this window in a format suitable for printing.

2 Displays detailed information about the VM or vPar by taking you to the VM or vPar Properties General tab.

3 Allows you to perform an action on the VM or vPar or I/O device. Select the box, then select an action from one of the menus available on the Integrity Virtual Server Manager menu bar.

4 Limits the display to only those network devices associated with the selected object (in this instance, the devices associated with VM or vPar) and the objects directly connected to it. All other devices are not displayed. To return to the original view, click the Show All link visible beneath the Virtual Server Manager menu bar on the focused page.

5 Indicates by color coding that matching components are related.

6 Utilization meters (bar graphs) provide data as a 5-minute average that is calculated and updated on 5-minute boundaries. If data cannot be displayed, the meter is dimmed and a label indicates the probable cause. For a description of meter labels, see “Utilization meter status/error information” (page 137).

Utilization history links are not provided when using Virtual Server Manager through HP SMH.

Network devices

Integrity Virtual Server Manager displays icons to represent certain network devices. You can hover your cursor over the icon to see text describing the representation. Table 3 describes these icons.
### Table 3 Network device icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Physical or virtual network card</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Virtual switch</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Virtual LAN (VLAN)</td>
</tr>
</tbody>
</table>

A question mark within the device icon, such as ![Icon](image), indicates that the type of device cannot be determined. The device type cannot be determined, for example, when the device has been removed from the VSP but not from the VM or vPar.

**Screen details**

**Network tab column layout**

*Figure 16* depicts the column layout for the **VSP Network** tab.

### Figure 16 Network tab column layout

<table>
<thead>
<tr>
<th>Virtual Network Interfaces</th>
<th>Virtual Switches</th>
<th>Physical Network Interfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Virtual Network Interfaces" /></td>
<td><img src="image" alt="Virtual Switches" /></td>
<td><img src="image" alt="Physical Network Interfaces" /></td>
</tr>
</tbody>
</table>

The **VSP Network** tab consists of three columns with the following titles. The contents of each column are described in the subsections that follow.

**Virtual Network Interfaces column contents**

This column displays the virtual network interfaces in the VMs or vPars. The virtual network interfaces are grouped by VM or vPar. Each major box grouping in the column represents a VM or vPar.
Referring to Figure 17, note the following:

- The icons next to the name of the VM or vPar and next to the network interface devices show the status of the system or interface. A question mark (?) means no information is available.
- Clicking the name of the VM or vPar (for example, vpar001) displays general information about the VM or vPar.
- Clicking the box near the VM or vPar name allows you to perform operations on the VM or vPar by using one of the menus available from the Integrity Virtual Server Manager menu bar. Clicking the box next to the device label allows you to perform operations on the device (for example, removing the device).
- The bar graphs indicate network throughput, if available.
- If the VM or vPar is running and can be contacted by using WBEM, the network interfaces are shown (for example, vs1); otherwise, a portion of the hardware path (bus, device, and function) is shown.
- If the virtual network interface is defined to use Accelerated Virtual Input/Output (AVIO), the label AVIO appears with the network interface designation, such as AVIO LAN or AVIO lan0 (the latter for a specific guest network interface designation). If the virtual network interface is not defined to use AVIO, the network interface designation does not include the AVIO label.
- The Focus link limits the display to a specific VM or vPar or interface and the objects connected to it. All other devices are not displayed. If you use this link to focus on only a specific VM or vPar or interface, you can return to see all the VMs or vPars or network interfaces by using the Show All link visible on the focus page.

Virtual Switches column contents
This column displays details about each virtual switch. Each major box grouping represents a virtual switch.
Referring to Figure 18, note the following:

- The icon next to the name of the virtual switch shows whether the virtual switch is operational.
- Clicking the box near the virtual switch name allows you to perform operations on the virtual switch by using one of the menus available from the Integrity Virtual Server Manager menu bar.
- Clicking the virtual switch name displays general information about the virtual switch.
- The icon and label below the virtual switch name indicates whether the corresponding virtual switch is shared or dedicated.
- If the physical network interface that backs the virtual switch can support AVIO, the label Supports AVIO appears next to the Focus link. The Focus link shows only that specific virtual switch and anything connected to it. If use this link to focus on a specific virtual switch, you can return to displaying all the virtual switches by using the Show All link visible on the focus page.

A virtual LAN (VLAN) is depicted as shown in Figure 19:
If a virtual switch has VLANs configured on it, each VLAN appears as a separate box within the virtual switch box. The virtual NICs from the VMs or vPars are connected to the appropriate VLAN box by a color-coded line. The switch port used by the virtual NIC is listed in its box. The VLAN boxes list the switch ports that are using that VLAN ID.

For ports on the switch that are not associated with a VLAN, the virtual switch contains a box labeled No VLAN. Virtual NICs can be connected to the No VLAN box.
Physical Network Interfaces column contents

Each box in the Physical Network Interfaces column represents one of the following:

- A physical network interface card in the VSP

  **Figure 20 Physical network interface card**

- An APA. When multiple physical network interface devices are aggregated using the Auto Port Aggregation (APA) software package, they are displayed as network devices inside an APA box.

  **Figure 21 APA**

The icon next to the hardware path of the physical interface device shows whether the device is operational.
The label next to the hardware path shows the description for the physical interface device.
The bar graph indicates network throughput, if available.

If the physical interface can support AVIO, the label Supports AVIO appears next to the **Focus** link.
The **Focus** link limits the display to the selected physical interface and anything connected to it. If you use this link to focus on a specific physical interface, you can return to displaying all the physical interfaces by using the **Show All** link visible on the focus page.
Colors

The connections are color coded to help you identify interconnected elements.

**NOTE:** The actual colors shown do not imply any specific meaning. The colors are provided to help you understand the connections from virtual to physical devices.

Focus links

Clicking one of these links simplifies the display by showing only the item that was selected and the elements that are directly attached to it.

- Focusing on a VM or vPar shows the network interfaces on the VM or vPar, the virtual switches that they are connected to, and the physical network interface devices connected to the virtual switches.
- Focusing on a LAN in a VM or vPar shows only the devices and VMs or vPars connected to the LAN.
- Focusing on a virtual network shows all of the virtual switches and all of the network interface devices connected to it.
- Focusing on a virtual switch shows only the devices and VMs or vPars connected to the vswitch.
- Focusing on a physical network interface device shows the virtual switches connected to the physical interface device and all the virtual network interfaces connected to them.
- Focusing on an APA shows the shared virtual switches connected to it, and all the virtual network interfaces connected to them.
- In a focused view, the presence of additional devices or connections are shown either as an ellipsis, or as a solid line becoming a dotted line.
- To view all the virtual network interfaces again, click the **Show All** link.

Dotted lines

The vertical dotted line indicates the boundary between the virtual and physical devices.

Bar graphs

The bar graphs are utilization meters that indicate the current IO throughput of a device or interface device. When using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, some bar graphs are selectable and bring up a view of the historical data related to the graph.
Status icons
These indicate whether an item is operational. Position the cursor over the icon to view a textual description. For more information about status icons, see “Status indicators” (page 137).

VSP Storage tab
The VSP Storage tab shows the mappings from the virtual storage devices in the VMs or vPars to the physical storage devices in the VSP system.

Quick reference
Figure 22 VSP Storage tab

1. Displays this window in a format suitable for printing.
2. With the **Show physical VSP bus adapters** check box selected (as in this example), the view includes the complete storage bus structure, VSP bus adapters, and multipath storage configurations. This view may take longer to render and can be more challenging for discerning the associations between VMs or vPars and devices, especially when many multipath storage devices exist on the VSP. By default (the check box being unselected), the view is simpler, showing only the specific storage devices that are being used as backing devices. For a multipath device, the simple view shows only the device special file (DSF) path, as specified when the virtual storage device was created. In contrast, the complex view displays all DSF versions of the same device, including the persistent DSF. The complex view is identical to the view displayed by the VSP Storage tab in earlier versions of Virtual Server Manager.

When you navigate to another Integrity Virtual Server Manager view and return to this view again, the **Show physical VSP bus adapters** check box retains its state. In other words, if the box is checked when you navigate away from the VSP Storage tab, it remains checked when
you navigate back (you continue to see the complex view on return). If the box is unchecked, it remains unchecked when you return (you continue to see the simple view). The check box state on the VSP Storage tab does not affect the state of the same check box on the VM or vPar Properties Storage tab. For example, selecting the check box on the VSP Storage tab does not automatically affect the check box and view of the VM or vPar Properties Storage tab.

3 Allows you to perform an action on the VM or vPar or I/O device. Select the box, then select an action from one of the menus available on the Integrity Virtual Server Manager menu bar.

4 Clicking the Focus link limits the display to only those storage devices associated with the selected object (in this instance, the devices associated with VMs, vm1pq01s01 and vm2pq02) and the objects directly connected to it. All other devices are not displayed. To return to the original view, click the Show All link visible beneath the Integrity Virtual Server Manager menu bar on the focused view.

The Show physical VSP bus adapters check box is disabled (dimmed) in the focussed view; you cannot change the Show physical host bus adapters state until you return to the original (unfocussed) view. The simplicity or complexity of the focussed view with respect to host bus adapters and so forth is determined by the check box selection at the time that you selected the focus link.

5 Displays detailed information about the VM or vPar by taking you to the VM or vPar Properties General tab.

6 The utilization meter (bar graph) displays storage I/O throughput data, if available. The data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot be displayed, the meter is dimmed (as in the meter underneath this one) and a label indicates the probable cause. For a description of meter labels, see “Utilization meter status/error information” (page 137). To view utilization history, click the appropriate meter. These meters link to HP Capacity Advisor, which provides the utilization statistics. For more information about using Integrity Virtual Server Manager to collect and view utilization data, see Chapter 7 (page 119).

Using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, you can click a meter to view a snapshot of Capacity Advisor historical data for storage I/O; this feature is not provided when using Integrity Virtual Server Manager from HP SMH.

7 The orange horizontal line indicates by color coding that matching components are related. This particular line links the virtual storage component to its corresponding physical storage component. The orange vertical line to the right of the screen also indicates by color coding that matching components are related. This line links two representations of the storage device, one with the agile address and the other with the legacy address. The line indicates that they are two different representations of the same physical device. Multiple representations are displayed only if the Show physical host bus adapters check box is selected.

### Storage devices

Various types of devices are supported on VMs or vPars. Integrity Virtual Server Manager represents each type of device with an icon. You can hover your cursor over the icon to see text describing the representation. Table 4 describes these icons.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Disk Icon" /></td>
<td>Disk</td>
</tr>
<tr>
<td><img src="image2" alt="DVD Icon" /></td>
<td>DVD</td>
</tr>
<tr>
<td><img src="image3" alt="Tape Icon" /></td>
<td>Tape</td>
</tr>
</tbody>
</table>
### Table 4 Network device icons (continued)

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🍀</td>
<td>Burner</td>
</tr>
<tr>
<td>🎁</td>
<td>Changer</td>
</tr>
<tr>
<td>📄</td>
<td>File</td>
</tr>
<tr>
<td>🔥</td>
<td>Directory (folder)</td>
</tr>
<tr>
<td>🏕️</td>
<td>Storage adapter</td>
</tr>
</tbody>
</table>

A question mark within the device icon, such as 🎁❓, indicates that the type of device cannot be determined. The device type cannot be determined, for example, when the device has been removed from the VSP but not from the VM or vPar.

Virtual device type:
- The virtual device type and subset of the hardware path are shown with each virtual device. This also indicates how the device is being used in the VM or vPar.

Backing device:
The storage that backs a virtual device does not necessarily need to be the same type as the virtual device itself; for example, a file can be the backing storage for virtual disks or virtual DVDs. A file can be selected as a backing device for one of two purposes:
- The file is intended to represent the capacity of a virtual storage device. This storage space is treated like a disk drive and can be used the way a disk drive is used (for example, by a storage manager, or a raw device).
- The file is intended to represent a DVD or CD. In these cases, the file is an .ISO image of the actual media.

A directory can be a backing device for a virtual DVD. A directory backing device is equivalent to a physical DVD drive that is empty (the DVD was ejected or has not been inserted). The list of files in the backing directory are ISO files, each representing a physical DVD that can be inserted and used as the backing device.

If you eject a file-backed virtual DVD, the storage device is then backed by the directory in which the ISO file was located. If you insert (select) an ISO file for a directory-backed DVD, the DVD becomes a file-backed virtual DVD. For information about loading and ejecting a virtual DVD by command from the VM or vPar virtual console, see the **HP-UX vPars and Integrity VM Administrator Guide** manual.

**NOTE:** If you use Integrity Virtual Server Manager to manage a VSP running Integrity VM Version 3.5 or earlier, Integrity Virtual Server Manager does not fully support virtual device special files located in /hpap (introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for virtual storage. If a virtual storage device using an /hpap device special file already exists on a VM or vPar managed by Integrity Virtual Server Manager, Integrity Virtual Server Manager displays it on the VSP Storage and VM or vPar Properties Storage tabs as an unknown device (using the question mark icon, 🎁). Integrity Virtual Server Manager displays the correct device special file name (for example, /hpap/rdsk/hpap1) but the box representing this device is not connected to the boxes that represent the physical storage devices associated with that virtual device special file. In general, Integrity Virtual Server Manager correctly displays only those device special files located in /dev.
Screen details

Storage tab column layout

Figure 23 depicts the column layout for the VSP Storage tab.

Figure 23 Storage tab column layout

The VSP Storage tab consists of three columns with the following titles. The contents of each column are described in the subsections that follow.

Virtual Storage column contents

As shown in Figure 24, this column displays the virtual storage devices in the VMs or vPars. The virtual storage devices are grouped by VM or vPar. Each major box grouping in the column represents a VM or vPar.

Figure 24 Virtual Storage column

Referring to Figure 24, note the following:

- The icon next to the name of the VM or vPar shows operational status of the VM or vPar. A question mark (?) means no information is available.
- Clicking the name of the VM or vPar (for example, vse02v4) displays general information about the VM or vPar.
- Clicking the box next to the VM or vPar allows you to perform operations on the VM or vPar by using one of the menus available from the Integrity Virtual Server Manager menu bar. Clicking the box near the device name allows you to perform operations on that device (such as removing the device).
- The meters (bar graphs) indicate I/O throughput, if available.
- If the virtual storage device is defined to use Accelerated Virtual Input/Output (AVIO), the label AVIO identifies the device interface type; for example, AVIO Disk. If the virtual storage device is defined to use emulated SCSI, the label SCSI identifies the device interface type; for example, SCSI Disk.
- The Focus link limits the display to a specific VM or vPar or device and anything connected to it. All other objects are not displayed. If you use this link to focus on only a specific VM or
Logical Storage column contents
This column displays information about logical storage devices, including the files and logical volumes that reside on physical storage devices. Each box represents a logical storage device, as in Figure 25.

Figure 25 Logical storage device

Referring to Figure 25, note the following:
- The Focus link limits the display to only that specific storage device and the objects connected to it. All other devices are not displayed. If you use this link to focus on a specific storage device, you can return to displaying all the storage devices by using the Show All link visible on the focus page.

Physical Storage column contents
This column displays the physical storage media, such as disk, DVD, DVD writers, tape devices and tape changers, as well as their corresponding physical storage devices through which the media is accessed. Each box in the column represents a physical storage device or interface card in the VSP. Two examples follow: Figure 26 shows what might be seen on an HP Integrity VM Version 3.5 VSP, while Figure 27 shows what might be seen on an HP Integrity VM Version 4.0 or later VSP. The former lists the device special file (legacy addressing) for the storage device, as defined in HP-UX 11i v2 and all earlier versions of HP-UX. The latter lists in addition the device’s new persistent device special file (agile addressing), available with HP-UX 11i v3. The orange line in this second example links the two representations of the storage device.

Figure 26 Physical storage detail from HP Integrity VM Version 3.5 VSP

The following items describe physical storage details in Figure 26:
- The first line at the top includes the hardware path for the adapter (also referred to as the VSP bus adapter or HBA).
- The line below the hardware path (here, beginning with SCSI) describes the adapter.
- The first line in the gray box describes the storage device.
- The next line in the gray box (/dev/rdsk/c5t8d0) displays the device file path (device special file) for the storage device, using the legacy addressing scheme.
- The bar graph is an I/O utilization meter that registers throughput. In this example, the meter is grayed out, indicating that the data is not available.
- Clicking a Focus link limits the display to the selected device and those objects connected to it. All other devices are not shown. If you use this link to focus on a specific adapter or device, you can return to the original view displaying all the storage interface cards and devices by using the Show All link visible on the focus page.
The following items describe physical storage details in Figure 27:

- The box on the top is the storage device representation with the persistent device special file (agile addressing). The first line describes the storage device (HP 300 GST33000007LC). The next line below that (/dev/rdsk/disk3) displays the persistent device special file (DSF) path for the storage device. The path is persistent with respect to changes in the access path or host bus adapter, and can use multiple paths through a single device file name. This enables Integrity Virtual Server Manager to display a single DSF for each device instead of displaying a separate DSF for each path to a device with multiple paths (as done when devices are displayed using the legacy addressing scheme).

- The second, larger box shows the adapter information, where the first line displays the hardware address (0/1/1/0), and the next line describes the adapter (SCSI Ultra320). The gray box within this larger box is the storage device representation of the HP 300 GST33000007LC, but with the legacy DSF path (/dev/rdsk/c2t1d0). The orange line on the right of the two boxes links the two representations of the storage device (one with the agile address and the other with the legacy address), indicating that they are two different representations of the same physical device.

- The utilization meter (bar graph) is an I/O utilization meter that registers throughput. In this example, the meter is grayed out, indicating that the data is not available.

- Clicking a Focus link displays information about the specific physical storage adapter or device and anything connected to it. If you use this link to focus on a specific adapter or device, you can return to the original view displaying all the storage interface cards and devices by using the Show All link visible on the focus page.
Colors

The connections are color coded to help identify interconnected elements.

**NOTE:** The actual colors shown do not imply any specific meaning. The colors are provided to help you understand the connections from virtual to physical devices.

Focus links

Clicking a **Focus** link simplifies the display by showing only the item that was clicked and the elements that are directly attached to it:

- Focusing on a VM or vPar shows the virtual storage interfaces in the VM or vPar and all the logical storage devices, physical interface cards, and devices that back them.
- Focusing on a virtual storage interface is like focusing on a VM or vPar, except that only the selected virtual storage interface and its connections are shown; all others are hidden.
- Focusing on a logical storage device shows all of the virtual storage devices and all of the physical storage interface cards and devices connected to it.
- Focusing on a physical storage interface card shows only the physical devices attached to the card, the logical storage devices connected to the physical device, and the virtual storage devices connected to those logical storage devices.
- Focusing on a physical storage device shows only the logical and virtual devices using that physical storage. This might reduce the number of devices shown, depending on how many virtual devices and VMs or vPars are connected to the physical storage device.
- In a focused view, the presence of additional devices or connections is shown by either an ellipsis, or a solid line becoming a dotted line.
- To view all the storage devices again, use the **Show All** link.

Dotted lines

The black vertical dotted line indicates the boundary between the virtual and physical devices. A colored vertical dotted line indicates devices are present but not associated with the indicated VM or vPar. For example, a three-dotted vertical line inside a box indicates that other storage devices are attached to the host bus adapter but are not used by the VM or vPar (in other words, other VMs or vPars are using those devices).
Bar graphs
The bar graphs are utilization meters that indicate the current I/O throughput of a device or interface card. When running the Integrity Integrity Virtual Server Manager with Matrix Operating Environment, some bar graphs are selectable and display a view of the historical data related to the graph.

Status icons
These indicate whether an item is operational. You can hover the cursor over the icon to view a textual description. For more information about status icons, see “Status indicators” (page 137).

VSP Console tab
The VSP Console tab allows you to open a iLO console terminal or a virtual iLO remote console terminal based on your privileges.

Quick reference

Figure 28 VSP Console tab

1. The Virtual iLO Remote Console column provides information about the IP address and Net mask.
2. The iLO Console column provides information about the IP address.

VSP GUID Resources tab
The HP-UX GUID (globally unique identifier) Manager (GUIDMgr) is integrated with the Virtual Server Manager to manage server database. GUIDMgr is a client-server based product that allocates and manages unique World-Wide Names (WWNs) for N_Port ID Virtualization (NPIV) Host Bus Adapters (HBAs). The VSP GUID Resources tab provided in the Virtual Server Manager GUI allows you to access GUIDMgr to create, modify, or delete WWN ranges. For more information on GUIDMgr, see the HP-UX GUID Manager Administrator Guide.
Quick reference

Figure 29 GUID Resources tab

1. Select **Hidden node WWN ranges** to hide the node WWN values and to display the port WWN values only. If you delete a port WWN range, the corresponding node range is also deleted.
2. Select a WWN range to modify or delete.
3. The name of the node or port WWN range.
4. Select a port WWN range and click **Modify**. This allows you to modify the WWN ranges. For more information, see “Modifying WWN ranges” (page 51).
5. Select a node or port WWN range and click **Delete** to delete the range. For more information, see “Deleting the WWN ranges” (page 51).
6. Click **Create** to create a new unique WWN range for the node or port. For more information, see “Creating WWN ranges” (page 50).

Creating WWN ranges

The **Create** option in the **GUID Resources** tab allows you to create a new unique WWN range for the node or port.

To create a unique WWN range for a port:

1. Click **Create** under the **Create a new range owned by HPVM** heading to create a new WWN range. The **Input the start and end address** screen is displayed, as shown in Figure 30.

Figure 30 Create WWN range

2. Enter the **Start Address** and **End Address** in the respective fields under **Input the start and end address**.
3. Click **OK** to create the WWN range for a port. The corresponding WWN range for a node is created automatically.
Modifying WWN ranges

The **Modify** option in the **GUID Resources** tab allows you to modify the unique WWN range for the node or port.

To modify the unique WWN range for a port:

1. Select the port WWN range that you want to modify from the WWN ranges table and click **Modify**. The **Start Address** and **End Address** fields are displayed, as shown in Figure 31.

![Figure 31 Modify WWN ranges](image)

2. Update the **Start Address** and **End Address** fields to specify the new WWN range.
3. Click **OK** to update the WWN range for the selected port.

Deleting the WWN ranges

The **Delete** option in the **GUID Resources** tab allows you to delete the unique WWN range for the node or port.

To delete a WWN range for a port:

1. Select the port WWN range that you want to delete and click **Delete**. A message prompts you to confirm whether the range can be deleted, as displayed in Figure 32.

![Figure 32 Delete WWN ranges](image)

2. Select **Yes** to delete the selected range.

**DIO Pool** tab

Direct Input Output (DIO) is an I/O architecture designed to provide a VM or a vPar with near native I/O functionality, manageability, and performance by giving a VM or a vPar direct access to Host PCI Express (PCIe) functions, which may be physical or virtual. DIO is an additional I/O option and not a replacement for any current or planned HPVM I/O options. Figure 33 (page 52) shows the **DIO Pool** tab.
The **SHOW DIO Table Option** lists the options to view the DIOs in the host or HPVM. When you select an option, its corresponding table is displayed. The following options are listed:

- **Show All DIO Resources** displays both the host DIO tables and the HPVM DIO table.
- **Show Host DIO Resources** displays only the host DIO table. There are two host DIO tables, one with IP and Vswitch and the other without IP and Vswitch.
- **Show HPVM DIO Resources** displays only the HPVM DIO table.

**Host DIO tables.** One lists DIOs with IP and as PNIC for Vswitch. For more information about the parameters, see “Column descriptions” (page 54).

**HPVM DIO table** include parameters for the Integrity VM (vPar) DIO. For more information about the parameters, see “Column descriptions” (page 54)

**Host DIO table**

When you select the **Show HOST DIO Resources** option, the host DIO tables are displayed. There are two host DIO tables, one for DIOs with IP or as PNIC for Vswitch. The other one contains the left DIOs.

In the first table, the host DIO with IP or Vswitch has no check box. These host DIOs cannot be used to perform normal DIO operations, such as “Change Owner” or “Change Restricted Status”. This is because they are used by the host as sitelan or as PNIC for Vswitch. The second table lists DIOs without IP or Vswitch. This table has a check box. You can use the DIOs in this table for normal DIO operations.

The host DIO table lists the details of the DIOs owned by the host. The following DIO details are displayed:

- **H/W path**
- **LAN interface**
- **Status**
- **Assignment level**
- **Driver type**
- **A brief description of the DIO**
- **Whether the DIO is restricted**
- **Whether the DIO has IP and is used as PNIC for Vswitch**
The default setting is, the **Change Restricted Status** and **Change Owner** buttons are disabled. To enable them, you must select one or more DIOs. Figure 34 (page 53) shows the **Host DIO table**.

**Figure 34 Show HOST DIO Resources**

You must select a DIO check box in the host DIO table to enable **Change Restricted Status** and **Change Owner**.

Click **Change Restricted Status** to change the restricted status of the DIO owned by host. For more information, see “Changing the restricted status of host DIOs” (page 57).

Click **Change Owner** to change the owner of the DIO to HPVM. For more information, see “Changing the owner of host DIOs to HPVM” (page 56).

**HPVM DIO table**

When you select **Show HPVM DIO Resources**, the HPVM DIO table is displayed.

The HPVM DIO table lists the details of the DIOs owned by HPVM. The DIO details include the H/W path, assignment level, driver type, a brief description of the DIO, label of the DIO, and also whether the DIO is used by a guest VM or vPar. By default, the **Change Label** and **Change Owner** buttons are disabled. To enable them, you must select one or more DIOs in the table by selecting the check boxes. “HPVM DIO table” (page 53) shows the **hpvm DIO**.
You must the DIO check box in the HPVM DIO table to enable **Change Label** and **Change Owner**. Click **Change Label** to change the label of the DIO. For more information, see “Changing the labels of HPVM DIOs” (page 59).
Click **Change Owner** to change the owner of the DIO to host. For more information, see “Changing the owner of HPVM DIOs to host” (page 59).

Column descriptions

Table 5 describes the parameters listed for host DIO resources and Table 6 describes the parameters listed for HPVM DIO resources.

**Table 5 Show host DIO resources**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>H/W Path</td>
<td>Indicates the functions of a device. For example, a function H/W path 0/0/0/3/0/0/0 indicates function 0, which is the last number of the H/W path. Therefore, 0/0/0/3/0/0/[0–N] are all functions of the same device 0/0/0/0/0/0.</td>
</tr>
<tr>
<td>LAN Interface</td>
<td>Indicates the LAN ID through which the host VM or vPar is connected to the network.</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates the status (Up or Down) of the LAN interface. The status is Up if the interface is operational, and Down if it is not operational.</td>
</tr>
</tbody>
</table>
**Table 5 Show host DIO resources (continued)**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignment Level</td>
<td>Indicates whether the operation of the DIO is at a function level or device level. In Function Level Assignment (FLA), each function is shared among several VMs or vPars. In Device Level Assignment (DLA), an entire device is assigned to the same guest OS. In the DIO pool, all functions of DIOs with device-level assignment are placed together. If a command is issued to one function in the device, all other functions also perform the same operation. For example, 0/0/0/4/0/0/0 and 0/0/0/4/0/0/1 are device-level functions and belong to the device, 0/0/0/4/0/0. They are placed in a single cell in the DIO pool. If you select them from the host or the HPVM table, the command preview field displays only the first function, 0/0/0/4/0/0/0.</td>
</tr>
<tr>
<td>Driver Type</td>
<td>Indicates the type of DIO driver. The driver used must be compatible with DIO. For example, HPUX 11i v3 1112/1203 iexgbe guest driver with DIO support.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays a description of the DIO network adapter. For example, the name of the adapter is provided, AM225-60001 HP Integrity PCIe 2-port 10GbE-SR Fabric Adapter.</td>
</tr>
<tr>
<td>Restricted</td>
<td>Indicates whether the DIO is restricted or not. If the DIO is restricted, you cannot change the owner of the DIO from host to HPVM.</td>
</tr>
<tr>
<td>IP</td>
<td>Indicates the IP address of the LAN interface of the DIO.</td>
</tr>
<tr>
<td>Vswitch</td>
<td>Indicates the name of the Vswitch associated with the DIO.</td>
</tr>
</tbody>
</table>

**Table 6 Show HPVM DIO resources**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>H/W Path</td>
<td>The H/W Path indicates the functions of a device. For example, a function H/W path 0/0/0/3/0/0/0 indicates function 0, which is the last number of the H/W path. Therefore, 0/0/0/3/0/0/0/[0–N] are all functions of the same device 0/0/0/3/0/0/0.</td>
</tr>
<tr>
<td>Assignment Level</td>
<td>Indicates whether the operation of the DIO is at a function level or device level. In Function Level Assignment (FLA), each function is shared among several guest VMs or vPars. In Device Level Assignment (DLA), an entire device is assigned to the same guest OS. In the DIO pool, all functions of DIOs with device-level assignment are placed together. If a command is issued to one function in the device, all other functions also perform the same operation. For example, 0/0/0/4/0/0/0 and 0/0/0/4/0/0/1 are device-level functions and belong to the device, 0/0/0/4/0/0. They are placed in a single cell in the DIO pool. If you select them from the host or HPVM table, the command preview field displays only the first function, 0/0/0/4/0/0/0.</td>
</tr>
<tr>
<td>Driver Type</td>
<td>Indicates the type of DIO driver. The driver used must be compatible with DIO. For example, HPUX 11i v3 1112/1203 iexgbe guest driver with DIO support.</td>
</tr>
</tbody>
</table>
Table 6 Show HPVM DIO resources *(continued)*

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Displays a description of the DIO network adaptor. For example, the name of the adaptor is provided, AM225-60001 HP Integrity PCIe 2-port 10GbESR Fabric Adapter.</td>
</tr>
<tr>
<td>Label</td>
<td>Indicates the label of the DIO. HPVM DIOs of a DLA group have the same label.</td>
</tr>
<tr>
<td>Used by Guest</td>
<td>Indicates the VMs or vPars that are configured to use this DIO.</td>
</tr>
</tbody>
</table>

Changing the owner of host DIOs to HPVM

You can change the owner of a DIO from host to HPVM. If the DIO status is restricted, you cannot change the ownership.

Figure 36 Change owner of host DIOs to HPVM page

![Change owner of the selected DIOs to HPVM](image-url)
To change the owner of DIOs:

1. Select Show HOST DIO Resources in the DIO Pool tab. The host DIO table appears.
2. Select the check boxes of preferred DIOs. This enables the Change Owner button.
3. Click Change Owner button to open the Change owner of the selected DIOs to HPVM page.

   **NOTE:** If the status of the DIO is restricted, you cannot change the ownership of the DIO. To change the ownership, first you must change the restricted status, and then proceed to change the owner.

4. If you do not want to set a new label for the DIO, do not select the check box: Assign new labels for the selected DIOs. To change the owner and also set a label for the selected DIOs, select the Assign new labels for the selected DIOs check box. By default, this check box is selected.

   If you select the check box, the DIO table is displayed. You can enter the New Label for the DIO in this table.

5. Click OK to change the owner of the DIO and set the new label.

**Changing the restricted status of host DIOs**

You can change the restricted status of a DIO owned by host. If the DIO status is restricted, you cannot change the owner of that DIO to HPVM.
Figure 38 Change restricted status of a DIO

To change the restricted status:

1. Select Show HOST DIO Resources in the DIO Pool tab. The host DIO table appears.
2. Select the check boxes of preferred DIOs to change the restricted status. This enables the Change Restricted Status button.
3. Click Change Restricted Status button to open the Set restricted status for the selected host DIOs page.

   Restricted and Unrestricted options are displayed. By default, the current status is Restricted.
4. Select the Unrestricted option, and then click OK.

Figure 39 Change unrestricted status of a DIO page
Changing the owner of HPVM DIOs to host

You can change the owner of DIOs from HPVM to host.

**Figure 40 Change owner of HPVM DIOs to host**

To change the owner of DIOs:
1. Select **Show HPVM DIO Resources** in the **DIO Pool** tab. The HPVM DIO table appears.
2. Select the check boxes of preferred DIOs to change the owner. This enables the **Change Owner** button.
3. Click **Change Owner** to open the **Change owner of the selected DIOs to HOST** page. This page displays a note indicating that the owner of the selected DIOs will be changed from HPVM to the host.
4. Click **OK** to change the ownership to host.

Changing the labels of HPVM DIOs

You can set a new label or delete the existing label of HPVM DIOs.

**Figure 41 Set label of HPVM DIO**
To set or delete the label of DIOs:
1. Select Show HPVM DIO Resources. The HPVM table appears.
2. Select the check boxes of preferred DIOs to change the labels. This enables the Change Label button.
3. Click Change Label to open the Change labels for the selected DIOs page. This page displays the following options:
   Depending on the option you select, the page displays the data.
4. Select one of the two options.
   If you select Delete, the labels of the selected DIOs are deleted.
   If you select set, the DIO table is displayed, and you can enter new labels in the New Label field to set new label for the DIO. You can modify labels of more than one DIO at the same time.
5. Click OK. The DIO label is deleted or set depending on the option selected.

**VM or vPar Properties view**

You can access the VM or vPar Properties view from any other Integrity Virtual Server Manager views that include a link to a VM or vPar, such as the VSP General tab, the VSP Virtual Servers tab, or any Network or Storage tab. You can also access the VM or vPar Properties view by selecting View→VM or vPar Properties... (a VM or vPar must be selected in the current view). Figure 43 shows a portion of a typical VM or vPar Properties view. Tabs available from the view are described in the text that follows. Subsequent sections describe each tab in more detail.
1 The “VM or vPar properties general tab” (page 61) displays information about the general state of the VM or vPar.

2 The “VM or vPar Properties Network tab” (page 67) displays information about the network devices for the VM or vPar.

3 The “VM or vPar Properties Storage tab” (page 69) displays information about the storage devices for the VM or vPar.

**VM or vPar properties general tab**

The Virtual Server Manager Properties General tab shows the state and configuration details of a specific VM or vPar. If the VSP has HP-UX for Integrity Virtual Server Manager version 3.0 or later installed, which supports dynamic memory, dynamic memory parameters are shown.
Quick reference

Figure 44 VM Properties General tab

1. VM Name: spu-e07
2. VM Network Identity: 7
3. VSSPex
4. VM Description: (none)
5. Virtual Hardware Status: On
6. Operating System: Windows
7. DS Status: In Drive
8. VM Architecture: (none)
9. Guest Skip Timeout: Default
10. Online Migration Enabled: Yes

VM CPU Information:
- Number of Cores: 2
- CPU Entitlement: 100%
- CPU Entitlement Caps: 100%

VM Memory Information:
- Memory Required to Start VM: 2 GB
- Initial Target for Memory Size After Boot: 2 GB
- Minimum Memory Size: 512 MB
- VM is Allowed to Control Memory Size: Yes
- APIC is enabled: No

External Manager Information:
- Split M Policy: (none)
- ServiceGuard Package: (none)

VM Activation Information:
- VMware License:
- VMware Entitlement:

VM Performance Information:
- Authorized Administrators: (none)
- Authorized Administrators Groups: (none)
- Authorized Operations: (none)
- Authorized Operator Groups: (none)
Figure 45 vPar Properties General tab

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Displays this window in a format suitable for printing.</td>
</tr>
<tr>
<td>2</td>
<td>Lists VM or vPar identification, status, and general configuration details. To update status information, click <strong>Refresh Data</strong>. If supported by the version of Integrity Virtual Server Manager running on the VSP, the Graceful Stop Timeout is displayed, as in this screen example. The timeout value is set by using the <code>hpvmmodify</code> command at the VSP command line. This section of the screen includes configuration and status information about online migration. If the VM has migrated to another VSP, the <strong>Virtual Hardware Status</strong> field displays the icon indicating the VM is Not Runnable ( ), and Integrity Virtual Server Manager displays additional fields that indicate the agent or activity that caused the Not Runnable status and the reason for the status change. If the VM is currently migrating or waiting to migrate, an icon in the <strong>OS Status</strong> field indicates the status or direction of the migration. (You can manage the VM at the target VSP once the migration process finishes.) If the VM is migrating to another VSP, Integrity Virtual Server Manager displays an <strong>Online Migration Phases</strong> section following this section that reports the status of each phase of the migration. For more information about VM migration and how to start migration of a VM, see “Migrating VMs” (page 94). If an error occurs during the attempt to migrate a VM, Integrity Virtual Server Manager displays an <strong>Alerts</strong> section that reports the error details.</td>
</tr>
<tr>
<td>3</td>
<td>Lists information about CPUs.</td>
</tr>
<tr>
<td>4</td>
<td>Lists information about VM or vPar memory. If the guest operating system supports dynamic memory, the information about dynamic memory parameters is displayed.</td>
</tr>
<tr>
<td>5</td>
<td>Lists information about external management tools or software.</td>
</tr>
<tr>
<td>6</td>
<td>Lists utilization information. Using Integrity Virtual Server Manager with Matrix Operating Environment, you can click a meter to view a snapshot of Capacity Advisor historical data for</td>
</tr>
</tbody>
</table>
virtual CPUs, memory, disk I/O, or network I/O; this feature is not provided when using Integrity Virtual Server Manager from HP SMH.

Lists authorization information.

Screen details

VM or vPar Configuration Information

- **VM or vPar Name**: The VM or vPar name. If the VM or vPar is configured as a Serviceguard package, the package icon appears next to the VM or vPar name. (If the Virtual Server Manager is being managed by another VSP, the **HW** field indicates so.)

- **VM or vPar Network Identity**: The VSP name of the operating system (OS) running on the VM or vPar. The VSP name is discovered by communicating with the VM or vPar, or if the VM or vPar is not active, the VSP name stored in the VM or vPar configuration is used. The VM or vPar must have booted an OS at least once for a VSP name to be stored in the VM or vPar configuration. If the VSP name is not known, a question mark (?) is displayed.

- **VSP(s)**: The name of the VSP on which this VM or vPar is configured. This is a hyperlink to the VSP view. If the VSP is an nPartition, the label “(contained in nPartition)” is displayed and “nPartition” is a hyperlink to Partition Manager for that nPartition. If the VM or vPar is managed by HP Serviceguard and is hosted on multiple VSPs, all of the VSPs are listed here.

- **VM or vPar Description**: The description of the VM or vPar, if the description is available.

- **Virtual Hardware Status**: This indicates the status of the virtual hardware of a VM or vPar. For a description of the status, position the cursor over the icon.

If the VM has migrated to another VSP, the hardware status of the VM is indicated as **Not Runnable** (Not Runnable). The Virtual Server Manager Configuration Information section includes two additional lines of information explaining the cause of the Not Runnable status, as described below.

If the VM or vPar is an HP Serviceguard package that is managed by another VSP, this field also displays a status icon that indicates so. Flyover text shows the status of the hardware (On) and the name of the VSP currently managing the VM or vPar (Serviceguard guest package).

- **Operating System**: Indicates the last OS type to be booted on this VM or vPar. If the VM or vPar has never been booted, this field contains the value that was supplied when the VM or vPar was created.

- **OS Status**: Indicates the OS status for a VM or vPar, such as Up, Down, Initializing (indicating that the VM or vPar has just been started and is being initialized — the OS is not yet active), or In EFI (indicating that the VM or vPar is in the firmware interface and an OS has not yet been booted). If the VM is migrating, an icon indicates the direction of migration (indicates migration to another VSP; indicates migration from another VSP). If the VM is waiting to migrate (when multiple VMs are selected to migrate, only one is migrated at a time), an hourglass icon indicates so; to view changes in migration status, click **Refresh Data**. For a description of the status, position the cursor over the icon.

- **Boot Attribute**: Indicates the hardware startup attribute for a VM or vPar, which determines its startup behavior (that is, whether the VM or vPar is started automatically when the VM or vPar boots or whether it must be manually started). To use Integrity Virtual Server Manager to modify this attribute, click **Modify → Hardware Auto Start**.

- **Graceful Stop Timeout**: If supported by the version of Integrity Virtual Server Manager running on the VSP, this specifies the amount of time HP Integrity Virtual Server Manager waits for
I/O activity to complete before stopping a VM or vPar. The timeout value is set at the VSP command line by using the `hpvmmodify` command.

- **Online Migration Enabled:** Indicates whether the VM is enabled for online migration or whether the VSP is not licensed to support online migration. The VSP administrator can enable a VM by using the `hpvmmodify` command at the VSP. vPar does not support migration. The following table shows in the third column what the status field displays, based on the state of the VSP and VM listed in the first and second column, respectively:

  **Table 7 Online migration status**

<table>
<thead>
<tr>
<th>VSP state</th>
<th>VM state</th>
<th>Online migration status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disabled</td>
<td>Enabled or disabled</td>
<td>Host disabled</td>
</tr>
<tr>
<td>Unlicensed</td>
<td>Enabled or disabled</td>
<td>Host not licensed</td>
</tr>
<tr>
<td>Enabled and licensed</td>
<td>Enabled</td>
<td>VM enabled</td>
</tr>
<tr>
<td>Enabled and licensed</td>
<td>Disabled</td>
<td>VM disabled</td>
</tr>
</tbody>
</table>

- **Not Runnable Set By:** Displayed when the VM has migrated to another VSP, indicates the activity or agent that caused the VM hardware status to be Not Runnable. For example, Migrate indicates the Not Runnable state was initiated by migration (`hpvmmigrate`); Admin indicates the VM was marked Not Runnable by the `hpvmmodify` command.

- **Not Runnable Reason:** Displayed when the VM has migrated to another VSP, indicates the reason the VM hardware status is Not Runnable. For example, the guest has migrated to another VSP.

### Online Migration Phases

The **VM Properties General** tab displays the Online Migration Phases section when online migration is in progress. An example is shown in **Figure 46**.

**NOTE:** If you access the **VM Properties General** tab immediately after initiating a migration, the Online Migration Phases section might not be displayed. To view this data, click **Refresh Data**.

**Figure 46 Online migration phases**

<table>
<thead>
<tr>
<th>Online Migration Phases:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Init Phase:</td>
<td>100%</td>
</tr>
<tr>
<td>Copy Phase:</td>
<td>34%</td>
</tr>
<tr>
<td>I/O Quiesce Phase:</td>
<td>0%</td>
</tr>
<tr>
<td>Frozen Phase:</td>
<td>0%</td>
</tr>
</tbody>
</table>

Each of the following fields display the phase’s percentage of completion:

- **Init Phase:** The initialization phase when the source and target VSPs establish connections, perform various checks, starts the target guest, and so forth.

- **Copy Phase:** Tracks writes to guest memory and copies all of guest memory from the source to the target VSP.

- **I/O Quiesce Phase:** Completes outstanding I/O and queues new I/O requests for the target guest.

- **Frozen Phase:** Stops the virtual CPUs and copies modified memory and guest state to the target guest.
Alerts

The **VM Properties General** tab displays the Alerts section only when an error occurs during an attempt to migrate one or more VMs to another VSP. An example is shown in **Figure 47**.

**Figure 47 Migration alerts**

- **Error**: Displays errors pertaining to migration of VMs.

You can clear the alerts information by clicking the trash button (Trash) on the right. This also clears the Migration Alerts icon (Warning) next to the VM name on the **VSP Virtual Servers** tab.

For more information about migration and how to start the migration of a VM, see “Migrating VMs” (page 94).

VM or vPar CPU Information

- **CPU Count**: The number of virtual CPUs in the VM or vPar. To use Virtual Server Manager to modify the CPU count, click **Modify → VM or vPar CPU Count**.

VM or vPar Memory Information

To use Virtual Server Manager to modify the following parameters, click **Modify → Memory**.

- **Memory Required to Start VM or vPar**: The amount of memory needed for the VM or vPar to boot.
- **Initial Target for Memory Size After Boot**: The value to which Integrity Virtual Server Manager tries to change the VM or vPar memory immediately after it boots.
- **Minimum Memory Size**: The lowest value to which the VM or vPar can attempt to decrease its memory while the OS is running.
- **Maximum Memory Size**: The highest value to which the VM or vPar can attempt to increase its memory while the OS is running.
- **Base Memory Size**: The memory size value that you specify for a vPar. The base memory that you specify is the kernel memory.
- **Float Memory Size**: The memory size value that you specify for a vPar. Float memory is an optional value.

**NOTE**: **Base Memory Size** and **Float Memory Size** fields are displayed only for vPars.

- **VM or vPar is Allowed to Control Memory Size**: Indicates whether the Allow dynamic control of memory size from the VM or vPar is in effect. This control allows applications running Virtual Server Manager (for example, gWLM) to dynamically change the memory on the VM or vPar.
- **AMR is enabled**: Indicates whether automatic memory reallocation (AMR) for a VM or vPar is enabled or not. You can enable AMR only on Virtual Server Manager on which dynamic memory control is enabled.
External Manager Information

- **gWLM Policy**: If the VSP is being managed by gWLM and a policy has been assigned to the VM or vPar, the External Manager gWLM field displays the name of the gWLM policy. If the VSP is not managed by gWLM or if a policy has not been assigned to the VM or vPar, the gWLM field displays (none). Using Virtual Server Manager with Matrix OE, if the VM or vPar is managed by gWLM, the gWLM policy name is a hyperlink to gWLM. Under HP SMH, if VMs or vPars are being managed by gWLM, the gWLM policy name is text only (you cannot modify gWLM policies from HP SMH). In either case (using Virtual Server Manager with Matrix OE or HP SMH), if the VM or vPar is not being managed by gWLM, this field displays (none).

- **Serviceguard Package**: If the VM or vPar is being managed by HP Serviceguard, the VM or vPar package name is listed here. If the VM or vPar is not being managed by HP Serviceguard, this field displays (none).

VM or vPar Utilization Information

- **VM or vPar Utilization Information**: Displays resource utilization statistics for a VM or vPar. The utilization information is a 5-minute average that is calculated and updated on 5-minute boundaries. If the utilization cannot be displayed, the utilization meter (bar graph) is dimmed and a label indicates the probable cause. For a description of meter labels, see the Error messages and troubleshooting topic. When Integrity Virtual Server Manager runs on Matrix Operating Environment, the utilization meters link to HP Capacity Advisor, which records and displays utilization data. Click a meter to view the VM or vPar utilization history for virtual CPUs, memory, disk I/O, or network I/O; this feature is not provided when using Virtual Server Manager from HP SMH. For an example utilization history screen and more information about collecting and viewing utilization data, see the Collecting and viewing utilization data topic.

VM or vPar Authorization Information

- **Authorized Administrators, Authorized Administrative Groups, Authorized Operators, Authorized Operator Groups**: These fields indicate which users and groups have administrator or operator authority.

**VM or vPar Properties Network tab**

The Virtual Server Manager Properties Network tab works the same way as the VSP Network tab. The difference between the two tabs is that the VM or vPar Properties Network tab shows only the devices related to a single VM or vPar, whereas the VSP Network tab shows all the devices (for the VSP and all VMs or vPars) in the Integrity Virtual Server Manager environment.
**Quick reference**

**Figure 48 VM or vPar Properties Network tab**

1. Goes back to the previous view, in this case the Integrity Virtual Server Manager VSP view. When you access the Virtual Server Manager Properties view from another Integrity Virtual Server Manager view (such as the VSP view), the link returns you to that previous view. If you had accessed the Virtual Server Manager Properties view directly from Matrix OE visualization, the link returns you to Matrix OE visualization. In HP SMH, when you first access this page from HP SMH, the link is not provided. The link appears whenever you move from one Integrity Virtual Server Manager view to another (such as from VSP view to Virtual Server Manager Properties view, in which case the Go back to Integrity Virtual Server Manager: Manage Host link appears on the Virtual Server Manager Properties view).

2. Displays this window in a format suitable for printing.

3. The utilization meter (bar graph) displays network I/O throughput data, if available. The data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot be displayed, the meter is dimmed as in this example, and a label indicates the possible cause. For a description of meter labels, see the Error messages and troubleshooting topic. Using Virtual Server Manager with Matrix Operating Environment, you can click a meter to view a snapshot of Capacity Advisor historical data for network I/O; this feature is not provided when using Virtual Server Manager from HP SMH. For an example utilization history screen and more information about collecting and viewing utilization data, see the Collecting and viewing utilization data topic.

4. Displays the type of network interface such as emulated LAN (displayed as “LAN”) or Accelerated Virtual Input/Output LAN (displayed as “AVIO LAN,” as in this instance).

5. Allows you to perform an action on the I/O device. Select the box, then select an action from the appropriate menu available on the Integrity Virtual Server Manager menu bar.

6. Limits the display to only those network devices associated with the selected object (in this instance, the device associated with port 1) and the objects directly connected to it. To return to the original view, click the Show All link visible beneath the Integrity Virtual Server Manager menu bar on the focused page.

7. Color coding indicates that matching components are related.

**Screen details**

For more information about using and interpreting the items displayed in the Network tab, see “Screen details” (page 36).
VM or vPar Properties Storage tab

The VM or vPar Properties Storage tab works similarly to the VSP Storage tab. The difference between the two tabs is that the VM or vPar Properties Storage tab shows only the devices related to a single VM or vPar, whereas the VSP Storage tab shows all the devices (for the VSP and all VMs or vPars) in the Integrity Virtual Server Manager environment.

Quick reference

Figure 49 VM or vPar Properties Storage tab

1. Goes back to the previous view, in this case the VSP view. If you accessed the Virtual Server Manager Properties view from Matrix OE visualization, the link returns you to Matrix OE visualization. In HP SMH, when you first access this page from SMH, the link is not provided. The link appears whenever you move from one Integrity Virtual Server Manager view to another (such as from VSP view to Virtual Server Manager Properties view, in which case the Go back to Integrity Virtual Server Manager: Manage VSP link appears on the Virtual Server Manager Properties view).

2. Displays this window in a format suitable for printing.

3. With the Show physical host bus adapters check box selected (as in this example), the view includes the complete storage bus structure, host bus adapters, and multipath storage configurations. This view may take longer to render and can be more challenging for discerning the associations between VMs or vPars and devices, especially when many multipath storage devices exist on the VSP. By default (the check box being unselected), the view is simpler, showing only the specific storage devices that are being used as backing devices. For a multipath device, the simple view shows only the device special file (DSF) path, as specified when the virtual storage device was created. In contrast, the complex view displays all DSF versions of the same device, including (on an HP-UX 11i v3 VSP) the persistent DSF. The complex view is identical to the view displayed by the VM or vPar Properties tab in earlier versions of Virtual Server Manager.

When you navigate to another Integrity Virtual Server Manager view and return to this view again, the Show physical VSP bus adapters check box retains its state. In other words, if the box is checked when you navigate away from the VM or vPar Properties Storage tab, it remains checked when you navigate back (you continue to see the complex view on return). If the box is unchecked, it remains unchecked when you return (you continue to see the simple view).

The check box state on the VM or vPar Properties Storage tab does not affect the state of the same check box on the VSP Storage tab. For example, selecting the check box on the VM or vPar Properties Storage tab does not automatically affect the check box and view of the VSP Storage tab.
The utilization meter (bar graph) displays I/O throughput data, if available. The data is a 5-minute average that is calculated and updated on 5-minute boundaries. If the data cannot be displayed, the meter is dimmed (as in the meter below this one) and a label indicates the probable cause. For a description of meter labels, see the Error messages and troubleshooting topic. Using Virtual Server Manager with Matrix Operating Environment, you can click a meter to view a snapshot of Capacity Advisor historical data for storage I/O; this feature is not provided when using Virtual Server Manager from HP SMH. For an example utilization history screen and more information about collecting and viewing utilization data, see the Collect and view utilization data topic.

Allows you to perform an action on the I/O device. Select the box, then select an action from the appropriate menu available on the Virtual Server Manager menu bar.

Clicking the Focus link limits the display to only the storage devices associated with the object (in this instance, the devices associated with the indicated AVIO disk) and the objects directly connected to it. All other devices are not shown. To return to the original view, click the Show All link visible beneath the Virtual Server Manager menu bar on the focused view.

The Show physical VSP bus adapters check box is disabled (dimmed) in the focus view; you cannot change the Show physical VSP bus adapters state until you return to the original (unfocused) view. The simplicity or complexity of the focused view with respect to VSP bus adapters and so forth is determined by the check box selection at the time that you selected the focus link.

Color coding indicates that matching components are related.

Screen details

For more information about using and interpreting the items displayed in the VM or vPar Properties Storage tab, see “Screen details” (page 45).

Virtual Switch (Vswitch) Properties view

You can access the Vswitch Properties view from any Integrity Virtual Server Manager views that include a link to a virtual switch, such as the VSP Virtual Switches tab, the VSP Network tab, or the VM or vPar Properties Network tab. You can also access the Vswitch Properties view by selecting View→Virtual Switch Properties... (a virtual switch must be selected in the current view).

Figure 50 shows a typical Vswitch Properties view. Tabs available from the view are described in the text that follows. Subsequent sections describe each tab in more detail.
Figure 50 Vswitch Properties view: General view

1. The "Vswitch Properties General tab" (page 71) displays information about the general state of the virtual switch.

2. The "Vswitch Properties Network tab" (page 72) displays network details about the virtual switch.

Vswitch Properties General tab

The Vswitch Properties General tab shows the status, configuration properties, and port assignments of a virtual switch.

Quick reference

Figure 51 Vswitch Properties General tab
Goes back to the previous view, in this case the Integrity Virtual Server Manager VSP view. When you access the Vswitch Properties view from another Integrity Virtual Server Manager view (such as the VSP view), the link returns you to that previous Integrity Virtual Server Manager view.

Displays this window in a format suitable for printing.

Displays virtual switch configuration information.

Screen details

Table 8 Data displayed by the Vswitch Properties General tab

<table>
<thead>
<tr>
<th>Data</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vswitch Name</td>
<td>Name of the virtual switch</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the virtual switch:</td>
</tr>
<tr>
<td></td>
<td>• Up (operational)</td>
</tr>
<tr>
<td></td>
<td>• Down (inoperational)</td>
</tr>
<tr>
<td></td>
<td>• Link down (the physical network interface used by the vswitch is not running)</td>
</tr>
<tr>
<td>Type</td>
<td>The type of virtual switch:</td>
</tr>
<tr>
<td></td>
<td>• shared vswitch: can be used by more than one VM or vPar that includes a virtual network device (virtual NIC) backed by the switch</td>
</tr>
<tr>
<td></td>
<td>• dedicated vswitch: can be used by only one started VM or vPar at a time</td>
</tr>
<tr>
<td>Backing LAN</td>
<td>The LAN interface on the host through which the network traffic flows</td>
</tr>
<tr>
<td>Supports AVIO</td>
<td>Indicates whether the backing LAN interface supports Accelerated Virtual Input/Output. AVIO is supported on HP Integrity VM Version 3.5 or later. For each VM or vPar containing an AVIO device, the VSP OS and the guest OS must support AVIO. With HP Integrity Virtual Server Manager, AVIO requires a virtual switch that has a physical network device as the backing device (local virtual switches such as localnet are not supported). In addition, the physical NIC that backs the virtual switch must have an AVIO-compatible driver. For more information about AVIO requirements, see the HP Integrity Virtual Server Manager documentation at the following website (click on the <strong>HP Matrix Operating Environment for HP-UX</strong> tab): <a href="http://www.hp.com/go/matrixoe/docs">http://www.hp.com/go/matrixoe/docs</a></td>
</tr>
<tr>
<td>Actively used by</td>
<td>The set of active VMs or vPars that are configured to use this vswitch, are currently started, and therefore, are using the vswitch</td>
</tr>
<tr>
<td>Configured, but not actively used by</td>
<td>The set of inactive VMs or vPars with at least one virtual network interface card in the VM or vPar configured to use the vswitch as a backing device</td>
</tr>
<tr>
<td>Vswitch Port Assignments</td>
<td>If the VSP is running HP Integrity VM Version 2.0 or greater, a table of the VLAN (virtual LAN) port assignments, if any. (A VLAN defines the logical connectivity defined by a LAN.) This table lists the following information:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port</td>
<td>Port IDs for the vswitch</td>
</tr>
<tr>
<td>VLAN ID</td>
<td>If a VLAN ID has been specified for this port, it is displayed here; otherwise, this column displays (none)</td>
</tr>
<tr>
<td>Assigned to</td>
<td>List of VMs or vPars that are assigned to this vswitch port</td>
</tr>
</tbody>
</table>

**Vswitch Properties Network** tab

The **Vswitch Properties Network** tab shows the network details about a vswitch, including the VMs or vPars that use the virtual switch.
**Quick reference**

**Figure 52 Vswitch Properties Network tab**

1. Goes back to the previous view, in this case the VM Properties view. When you access the Vswitch Properties view from another Integrity Virtual Server Manager view (such as the VM Properties view), the link returns you to that previous Integrity Virtual Server Manager view.

2. Displays this window in a format suitable for printing.

3. Displays information about the VM or vPar by taking you to the **VM or vPar Properties General tab**.

4. Allows you to perform an action on the VM or vPar or I/O device. Select the box, then select an action from one of the menus available on the Integrity Virtual Server Manager menu bar.

5. Clicking the **Focus** link limits the display to only those network devices associated with the selected object (in this instance, the devices associated with the indicated LAN) and the objects directly connected to it. All other devices are not displayed. To return to the original view, click the **Show All** link visible beneath the Integrity Virtual Server Manager menu bar on the focused page.

6. Color coding indicates that matching components are related.

**Screen details**

For detailed information about what is displayed in the **Vswitch Properties Network** tab, see the description of the **VSP Network** tab, “Screen details” (page 36).
5 Using Integrity Virtual Server Manager menus

Integrity Virtual Server Manager views provide a menu bar beneath the tabs row, as shown in Figure 53. The menus enable you to perform a variety of actions. Not all actions (menu options) are available from every screen view. Actions are enabled or disabled based on the state of the system, the view you are in, and the objects in that view that are currently selected. Actions that are disabled are dimmed and unselectable. To display text that explains how to enable a disabled action, place the cursor over the visible but dimmed, menu item.

Figure 53 Integrity Virtual Server Manager menus

The menus are described in each of the following sections:

- “Using the Tools menu” (page 75)
- “Using the Create menu” (page 77)
- “Using the Modify menu” (page 78)
- “Using the Delete menu” (page 79)
- “Using the View menu” (page 80)

NOTE: The menus for VM and vPars are enabled based on the Integrity VM version installed.

Using the Tools menu

The Integrity Virtual Server Manager Tools menu allows you to perform actions on a selected VM or vPar or virtual switch. The options that might be available when you select the Tools menu are shown in Figure 54. In this example, the Start Virtual Switch... and Stop Virtual Switch... options are disabled. These options are enabled when you are in the Vsswitch Properties view or a view with one or more virtual switches selected, such as the VSP Virtual Switches tab. The VM or vPar operations (start, stop, restart, migrate) are enabled when you are in a VM Properties view or in a view that allows selection of VMs or vPars, such as the VSP Virtual Servers tab. From tabs that list and allow selection of multiple VMs or vPars or multiple virtual switches, you can perform an action on multiple selected machines or partitions or switches.
Table 9 describes the Tools menu options and where to obtain more information in this manual. More detailed information is provided by the Integrity Virtual Server Manager help.

Table 9 Integrity Virtual Server Manager Tools menu options

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
<th>More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools → Start VM...</td>
<td>This menu is enabled only for VMs.</td>
<td>“Starting VMs” (page 90).</td>
</tr>
<tr>
<td>Tools → Stop Virtual Machine...</td>
<td>This menu is enabled only for VMs.</td>
<td>“Stopping VMs” (page 91).</td>
</tr>
<tr>
<td>Tools → Restart Virtual Machine</td>
<td>This menu is enabled only for VMs.</td>
<td>“Restarting VMs” (page 93).</td>
</tr>
<tr>
<td>Tools → Suspend Virtual Machine</td>
<td>This menu is enabled only for VMs.</td>
<td>“Suspending VMs” (page 99).</td>
</tr>
<tr>
<td>Tools → Resume Virtual Machine</td>
<td>This menu is enabled only for VMs.</td>
<td>“Resuming VMs” (page 100).</td>
</tr>
<tr>
<td>Tools → Boot Virtual Partition</td>
<td>Boots a vPar starting up the hardware for the vPar, taking it from an Off state (powered off) to an On state (powered on).</td>
<td>“Booting vPars” (page 114)</td>
</tr>
<tr>
<td>Tools → Stop Virtual Partition</td>
<td>Stops a vPar, taking it from an On state (powered on) to an Off state (powered off).</td>
<td>“Stopping vPars” (page 115)</td>
</tr>
<tr>
<td>Tools → Reset Virtual Partition</td>
<td>Restarts an already started vPar, taking it first to an Off state (powered off) and then to an On state (powered on). Starts a stopped vPar.</td>
<td>“Resetting vPars” (page 115)</td>
</tr>
</tbody>
</table>
### Table 9 Integrity Virtual Server Manager Tools menu options (continued)

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
<th>More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools → Start Virtual Switch...</td>
<td>Starts a virtual switch, taking it from a Down state (powered off) to an Up state (powered on).</td>
<td>“Starting, stopping, and deleting virtual switches” (page 105)</td>
</tr>
<tr>
<td>Tools → Stop Virtual Switch...</td>
<td>Stops a virtual switch, taking it from an Up state (powered on) to a Down state (powered off).</td>
<td>“Starting, stopping, and deleting virtual switches” (page 105)</td>
</tr>
<tr>
<td>Tools → Migrate Virtual Machine...</td>
<td>This menu is enabled only for VMs.</td>
<td>“Migrating VMs” (page 94).</td>
</tr>
<tr>
<td>Tools → VM Move Suspend...</td>
<td>This menu is enabled only for VMs.</td>
<td>“Moving suspend files” (page 101).</td>
</tr>
<tr>
<td>Tools → Open iLO Console...</td>
<td>This menu is enabled for VMs and vPars.</td>
<td>“Opening iLO console” (page 106).</td>
</tr>
<tr>
<td>Tools → Open Virtual iLO Remote Console...</td>
<td>This menu is enabled for VMs and vPars.</td>
<td>“Opening iLO console” (page 106).</td>
</tr>
</tbody>
</table>

### Using the Create menu

The **Create** menu allows you to create a VM or vPar or virtual switch. Figure 55 shows the choices when you select the **Create** menu.

**Figure 55 Integrity Virtual Server Manager Create menu**

![Create menu](image)

Table 10 describes the **Create** menu options and where to obtain more information in this manual. More detailed information is provided by the Integrity Virtual Server Manager help.
### Table 10 Integrity Virtual Server Manager Create menu options

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
<th>More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create → Virtual Machine...</td>
<td>This menu is enabled only for VMs. Starts the Create Virtual Machine wizard, which guides you through the procedure of creating a VM. Each step presents a dialog that asks you to specify required information.</td>
<td>“Creating VMs” (page 83)</td>
</tr>
<tr>
<td>Create → Virtual Partition...</td>
<td>Starts the Create Virtual Partition wizard, which guides you through the procedure of creating a vPar. Each step presents a dialog that asks you to specify required information.</td>
<td>“Creating vPars” (page 111)</td>
</tr>
<tr>
<td>Create → Virtual Switch...</td>
<td>Creates a new virtual network switch (vswitch) on the VSP. The vswitch is used by the VMs or vPars to connect to the network: one or more VMs or vPars connect to the vswitch, and the vswitch is connected to a VSP’s physical network device.</td>
<td>“Creating virtual switches” (page 102)</td>
</tr>
</tbody>
</table>

### Using the Modify menu

The Integrity Virtual Server Manager Modify menu allows you to perform actions on a selected VM or vPar. The options displayed when you select the Modify menu using Integrity Virtual Server Manager from HP Matrix Operating Environment are shown in Figure 56. The options are available only when you are in a VM or vPar Properties view or in a view in which you have selected a VM or vPar, such as on the VSP Virtual Servers tab. You can only modify one VM or vPar at a time.

If the VM or vPar being modified is an HP Serviceguard package, you must make the same modifications to the VM or vPar on the other VSPs in the cluster.

**NOTE:** When you use Integrity Virtual Server Manager from HP SMH, this menu includes an additional option that allows you to modify WBEM credentials. This option can be available from any Integrity Virtual Server Manager view.

![Figure 56 Integrity Virtual Server Manager Modify menu](image)

Table 11 describes the Modify menu options. More information about the various modification options is provided in “Modifying vPars” (page 113). More detailed information is provided by the Integrity Virtual Server Manager help and the HP-UX vPars and Integrity VM Administrator Guide manual.
Table 11 Integrity Virtual Server Manager Modify menu options

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify → CPU Count...</td>
<td>Modifies the number of virtual CPUs allotted to a VM or a vPar that has been configured for symmetric multiprocessing. The changed value takes effect when the VM or vPar is restarted.</td>
</tr>
<tr>
<td>Modify → Memory...</td>
<td>Modifies the amount of virtual memory (entitlement) to allocate to the VM or vPar. Allows you to set dynamic memory parameters if dynamic memory is supported on the VM or vPar OS. The changes take effect when the VM or vPar is restarted. Supports online memory operations on active vPars.</td>
</tr>
<tr>
<td>Modify → VLAN Settings...</td>
<td>Modifies the LAN assignments of virtual switch ports connected to the VM or vPar.</td>
</tr>
<tr>
<td>Modify → Add/Modify Virtual iLO Remote Console...</td>
<td>Modifies the IP address and the Netmask of the virtual iLO remote console of a VM or vPar guest.</td>
</tr>
<tr>
<td>Modify → Add Storage Device ...</td>
<td>Adds a virtual storage device to a VM or vPar, where the virtual storage device is backed by physical storage and connected to a virtual storage adapter on the VSP.</td>
</tr>
<tr>
<td>Modify → Add Network Device...</td>
<td>Adds a network device to a VM or vPar, where the network device is associated with a virtual switch. Allows you to create a new virtual switch.</td>
</tr>
<tr>
<td>Modify → CPU Entitlement for VM...</td>
<td>This menu is enabled only for VMs.</td>
</tr>
<tr>
<td>Modify → Hardware Auto Start for VM...</td>
<td>This menu is enabled only for VMs.</td>
</tr>
<tr>
<td>Modify → Add DIO...</td>
<td>Adds DIO to VM or vPar.</td>
</tr>
<tr>
<td>Modify → Replace DIO H/W Path...</td>
<td>Replaces the h/w path of a DIO owned by a VM or a vPar.</td>
</tr>
<tr>
<td>Modify → Replace DIO MAC Address...</td>
<td>Replaces the MAC address of DIOs owned by a VM or a vPar.</td>
</tr>
<tr>
<td>Modify → WBEM Credentials...</td>
<td>Sets and changes WBEM credentials for VMs or vPars. For information, see “Setting WBEM credentials in HP SMH” (page 16). This menu is available only when using Integrity Virtual Server Manager with HP SMH.</td>
</tr>
</tbody>
</table>

Using the **Delete** menu

The **Delete** menu allows you to delete one or more VMs or vPars, virtual switches, or I/O devices. Figure 57 shows the choices that might be available when you select the **Delete** menu. The choices are enabled according to the view and tab. In Figure 57, the **Virtual Machine**... option is enabled and the **Virtual Switch**... and **I/O Device**... options are disabled. The **Virtual Machine**... option is enabled at the VM Properties view or any VSP or Vswitch Properties tab where you have selected one or more VMs (such as the **VSP Virtual Servers** tab, as shown in Figure 57). The **Virtual Switch**... option is enabled at the Vswitch Properties view or any VSP or VM Properties tab where one or more virtual switches are selected. The **I/O Device**... option is enabled at any **Network** or **Storage** tab where one or more I/O devices are selected.

From tabs that list and allow selection of multiple VMs or vPars, virtual switches, or I/O devices, you can simultaneously delete all selected objects.
Table 12 describes the **Delete** menu options and where to obtain more information in this manual. More detailed information is provided by the Integrity Virtual Server Manager help.

### Table 12 Integrity Virtual Server Manager Delete menu options

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
<th>More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete → Virtual Machine.......</td>
<td>This menu is enabled only for VMs.</td>
<td>“Deleting VMs” (page 94)</td>
</tr>
<tr>
<td>Delete → Virtual Partition...</td>
<td>Deletes all configuration files for the vPar and frees resources assigned to the vPar.</td>
<td>“Deleting vPars” (page 117)</td>
</tr>
<tr>
<td>Delete → Virtual Switch...</td>
<td>Removes all configuration information for a virtual switch.</td>
<td>“Starting, stopping, and deleting virtual switches” (page 105)</td>
</tr>
<tr>
<td>Delete → I/O Device...</td>
<td>Removes all configuration information for an I/O device.</td>
<td>“Deleting network or storage devices” (page 105)</td>
</tr>
<tr>
<td>Delete → DIO...</td>
<td>Deletes the DIOs of a VM or a vPar.</td>
<td>“Deleting DIOs” (page 108)</td>
</tr>
<tr>
<td>Delete → Virtual iLO Remote Console</td>
<td>This menu is enabled for VMs or vPars.</td>
<td>“Deleting virtual iLO remote console” (page 108)</td>
</tr>
</tbody>
</table>

### Using the View menu

The **View** menu allows you to display a variety of information. Figure 58 shows the choices that might be available when you select the **View** menu.
NOTE: The Capacity Advisor Data item is displayed only when you use Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX; it is not displayed when using Integrity Virtual Server Manager through HP SMH. The accessibility of the other menu items depends on the current view and selections. For example, to access the VM or vPar log from the VSP Virtual Servers tab, a VM or vPar must be selected, as shown in Figure 58.

Figure 58 Integrity Virtual Server Manager View menu

<table>
<thead>
<tr>
<th>Tools</th>
<th>Integrity Virtual Server Management</th>
<th>Integrity Virtual Server Manager</th>
</tr>
</thead>
<tbody>
<tr>
<td>VSP hpvmus5.6cup.hp.com</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>General</th>
<th>Virtual Servers</th>
<th>Virtual Switches</th>
<th>Network</th>
<th>Storage</th>
<th>Console</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools</td>
<td>Create</td>
<td>Modify</td>
<td>Delete</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name (FQDN)</td>
<td>Type</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>vm001</td>
<td>VM</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>vpar0002</td>
<td>vPar</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 13 Integrity Virtual Server Manager View menu options

<table>
<thead>
<tr>
<th>Menu Selection</th>
<th>Action Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>View→Virtual Server Properties...</td>
<td>Displays the VM or vPar Properties General tab. For more information about this view, see “VM or vPar Properties view” (page 60).</td>
</tr>
<tr>
<td>View→Virtual Switch Properties...</td>
<td>Displays the Vswitch Properties General tab. For more information about this view, see “Virtual Switch (Vswitch) Properties view” (page 70).</td>
</tr>
<tr>
<td>View→Integrity Virtual Server Manager Version Information...</td>
<td>Displays the version numbers of Integrity Virtual Server Manager, Integrity VM, and the providers on the VSP and each VM or vPar. For more information, see “Viewing Integrity Virtual Server Manager, Integrity VM, and WBEM Provider versions” (page 126).</td>
</tr>
<tr>
<td>View→VSP log...</td>
<td>Displays the events logged by Integrity VM pertaining to the VSP and all its guests. To use this feature with Integrity Virtual Server Manager running under HP SMH, you must be logged into HP SMH with either Operator or Administrator privileges. For more information, see “Viewing the VSP log” (page 125).</td>
</tr>
<tr>
<td>View→VM or vPar log...</td>
<td>Displays the events logged by Integrity VM pertaining to a VM or a vPar. To use this feature with Integrity Virtual Server Manager running under HP SMH, you must be logged into HP SMH with either Operator or Administrator privileges. For more information, see “Viewing the VM or vPar log” (page 126).</td>
</tr>
</tbody>
</table>
6 Working with VMs or vPars

This chapter describes tasks you can perform to create and manage VMs or vPars and their resources.

NOTE: Integrity Virtual Server Manager version 6.1 supports only one type of guest. If the first guest created on Virtual Server Manager is a vPar, then only vPar guests can be created on that VSP. If the first guest created is a VM, then only VMs can be created on that VSP. But, with Integrity Virtual Server Manager version 6.2, VMs and vPars coexist on the same host.

Working with VMs

Planning VMs

To achieve your goals using VMs, plan the configuration of each VM by assessing its requirements for resources on the HP Integrity system on which it will run. For information about how to assess your system’s resources as well as the VMs you will run on the system, and how to map your VM requirements to the system’s resources, see the HP-UX vPars and Integrity VM Administrator Guide manual, located on the HP Technical Documentation website (click on the HP Matrix Operating Environment for HP-UX tab):

http://www.hp.com/go/matrixoe/docs

For information about AVIO performance tuning, see the latest Integrity VM white papers available from this website.

Creating VMs

To create a VM, Integrity Virtual Server Manager uses the Create Virtual Machine wizard to guide you through the process. Each step presents a dialog that allows you to specify the required information. At any time you can get help, return to previous steps, or exit the wizard. By creating a new VM, you assign attributes and resources to it. This creates an association among the virtual devices known to the VM and the physical devices managed by the VSP.

Where possible, reasonable default values are provided for each dialog. However, the default values are not necessarily optimal. You must determine what values are optimal based on the unique requirements of your machine (such as the applications you plan to run and the performance you expect).

To access the Create Virtual Machine wizard, select Create → Virtual Machine... from the Integrity Virtual Server Manager menu bar. The Create Virtual Machine wizard leads you through several screens in the following order. For more information about any screen, see the corresponding Integrity Virtual Server Manager help topic.

1. Specify VM Identity
   - Specify the VM name, an optional description, the intended guest operating system, and the VM hardware startup value (autoboot).

2. Specify Processor Entitlements
   - The processor entitlement sets the guaranteed amount of processing power for each virtual CPU in a VM. The processor entitlement is the default entitlement (10%), a percentage of physical processor power, or a specific, fixed processor speed. If supported by the version of Integrity VM running on the VSP, you can specify an entitlement cap and the minimum and maximum number of vCPUs to be allotted to the VM. An entitlement cap is the maximum amount of computing power allotted to a VM for each vCPU.
3. Specify Memory
Specify the amount of memory for the VM. If the VSP has Integrity VM 3.0 or later installed and the OS type you chose in step 1 supports dynamic memory (for example, specifying HP-UX as the intended guest OS, with Integrity VM 3.0 or later installed on the VSP), the memory screen allows you to set dynamic memory parameters.

**NOTE:** An up-to-date version of the WBEM Utilization Provider (UP) must be installed on the VM or vPar to enable HP Capacity Advisor and the memory utilization meters in Integrity Virtual Server Manager and Integrity VM to reflect the dynamic change in memory. For information about verifying and installing software on VM or vPar, see “System and software requirements” (page 13) and the HP-UX vPars and Integrity VM documentation.

**NOTE:** VSP might not be able to start the VM if there are insufficient resources to create the VM. Verifying the memory resources in the third step is to ensure that there are sufficient resources to create the VM. In the final step, if there are insufficient resources and you still want to create the VM, you can select the Create VM even if resources are insufficient, missing or unavailable check box.

4. Specify Network Devices
To add a virtual network device, click Add Network Device... on the first network device screen. This brings up the Add Network Device screen. First, select the type of virtual network interface card. The default is an emulated LAN device. You can select Accelerated Virtual Input/Output (AVIO) device type if AVIO is supported by the version of Integrity VM (Version 3.5 or later) on the VSP and by the intended guest OS. For Windows and Linux guests, support for AVIO virtual network devices requires that compatible Windows and Linux drivers be installed on the guest and additional patches be installed on the Integrity VM Version 3.5 or later. The OpenVMS guest OS supports only the AVIO interface.

For HP-UX, HP recommends that you install the latest AVIO components for both the VSP and the guest; however, updating both guest and host components at the same time is not mandatory. Updating both components ensures that you always receive the latest bug fixes for a complete solution. Always check the following software depot website for the latest version of AVIO software (search for “HPVM AVIO”):

http://software.hp.com

The guest AVIO drivers are included in the VMGuestSW bundle available from the software depot website. Search for the bundle and make sure you install the latest version.

For more information, see the HP Integrity Virtual Machines documentation available at www.hp.com/go/hpux-hpvm-docs.

After you select the virtual network interface type, select the virtual switch from the list provided or create a virtual switch. To provide network access for the VM, a virtual switch is necessary.

**NOTE:** Integrity Virtual Server Manager does not automatically update its display of I/O while the Create Virtual Machine wizard is being used. If the network or storage I/O configuration on the VSP changes while the Create Virtual Machine wizard is in use, update the configuration changes displayed by the wizard by clicking the Refresh Data link.

5. Specify DIOs
This is step five of the Create Virtual Machine wizard. In this step, you define DIOs for the VM. If you want to modify a DIO, you must first delete it and then add the device again with the correct specifications.

You can add HPVM DIOs to a VM to provide near native I/O functionality, manageability, and performance by giving a VM direct access to Host PCI Express (PCIe) functions, which can be physical or virtual.

To add DIOs:
1. Select the preferred DIOs from the HPVM DIO table. These DIOs do not have an IP address and are not associated with a Vswitch.
2. If you want to enter the Bus, Device, and MAC parameters for the selected DIOs, select Specify virtual address parameters (advanced). If you do not want to enter the parameters, leave the check box blank.
3. Click Add to List to add the selected DIOs to the VM. The Specify DIOs page appears, where the selected DIOs are listed.
4. Click Next to move to the next screen of the wizard.
Table 14 describes the information which the device selection table displays.

Table 14 DIO selection table: column descriptions

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>H/W Path</td>
<td>The H/W Path indicates the functions of a device. For example, a function H/W path 0/0/0/3/0/0/0 indicates function 0, which is the last number of the H/W path. Therefore, 0/0/0/3/0/0/[0–N] are all functions of the same device 0/0/0/3/0/0.</td>
</tr>
<tr>
<td>Assignment Level</td>
<td>Indicates whether the operation of the DIO is at a function level or device level. In Function Level Assignment (FLA), each function is shared among several VMs or vPars. In Device Level Assignment (DLA), an entire device is assigned to the same guest OS. In the DIO pool, all functions of DIOs with device-level assignment are placed together. If a command is issued to one function in the device, all other functions also perform the same operation. For example, 0/0/0/4/0/0/0 and 0/0/0/4/0/0/1 are device-level functions and belong to the device, 0/0/0/4/0/0. They are placed in a single cell in the DIO pool. If you select them from the host or HPVM table, the command preview field displays only the first function, 0/0/0/4/0/0/0.</td>
</tr>
<tr>
<td>Driver Type</td>
<td>Indicates the type of DIO driver. The driver used must be compatible with DIO. For example, HPUX 11i v3 11i/2/1203 iexgbe guest driver with DIO support.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays a description of the DIO network adaptor. For example, AM225-60001 HP Integrity PCIe 2-port 10GbESR Fabric Adapter.</td>
</tr>
<tr>
<td>Label</td>
<td>Indicates the label of the DIO.</td>
</tr>
<tr>
<td>Used by Guest</td>
<td>Indicates the VMs or vPars configured to use this DIO.</td>
</tr>
</tbody>
</table>

6. Each virtual storage device is backed by physical storage in the VSP system. A physical storage device can be a disk device, a logical volume, a DVD or CD, a DVD writer (burner), a tape device, a tape changer, an existing file (a file or directory being used as the backing storage device for a virtual storage device of an already-existing VM on the VSP), or a new file that Integrity Virtual Server Manager allows you to create as a backing storage device for a virtual disk (Virtual FileDisk). When you add a DVD writer, tape device, or changer, they are added as attached devices. You can add attached devices only if they are using an emulated SCSI adapter. You cannot use Integrity Virtual Server Manager to add an attached AVIO device; to add such a device to a VM, use the hpvmdevmgmt command at the VSP. To add a virtual storage device, click Add Storage Device... on the first storage device screen. This brings up the Add Storage Device screen. First, select the type of virtual storage adapter. The default is an emulated SCSI adapter. You can select Accelerated Virtual Input/Output (AVIO) adapter type if AVIO is supported by the version of Integrity VM (Version 3.5 or later) on the VSP and by the intended guest OS (HP-UX 11i v3 only).
If the VSP is running HP-UX 11i v3, the **Add Storage Device** screen gives you the choice of listing storage devices by their agile address (the default) or by their legacy address. HP recommends using agile device addressing when configuring storage devices. This provides benefits especially for multipath devices. With legacy addressing, the screen lists one entry for each path to a storage device that has multiple paths. With agile addressing, the screen lists only one entry for each multipath storage device. To change the addressing scheme for viewing, select the appropriate addressing scheme. If the VSP runs an earlier version of HP-UX, you are not given a choice: the table lists devices by the legacy addressing scheme only. For more information about agile addressing, see the **VSP Storage** tab help topic.

For more information on AVIO devices and on agile addressing, see the HP-UX vPars and Integrity VM documentation.

After you select the virtual storage adapter type, select the physical backing device from the list of devices provided in the device selection table (such as disk, DVD, tape, LVM volume, files).

**NOTE:** The list can include file and directory backing devices that have not been associated with a particular VM, or that were associated with VMs that have been removed or from which the associated virtual devices have been removed. You can make these devices available to Integrity Virtual Server Manager by adding them to the Integrity VM device database. One advantage is that this allows you to populate the Integrity VM device database with entries for OS installation DVD images that might be used when creating and provisioning several VMs. When you use Integrity Virtual Server Manager to add a virtual DVD to a VM, the image file shows up in the list of storage backing devices to choose from, saving you from having to type the name of the image file or to browse for it.

At the VSP command line, add a file as a guest device (gdev) to the device management database by specifying the `hpvmdevmgmt` command with the `USAGE` attribute value as either `USAGE=DISK` or `USAGE=DVD`. As a result, the Integrity Virtual Server Manager screen includes the file in the list of backing devices you can choose from. The file is listed as a backing device for either a virtual disk or a virtual DVD, depending on the value of the `USAGE` attribute. For example, if you add file `/images/myos.iso` to the device management database, specifying `USAGE=DVD`, then `/images/myos.iso` will appear in the Integrity Virtual Server Manager list of backing devices as a possible backing device for a virtual DVD. If you add a file to the database without specifying the `USAGE` attribute, the file is not included in the list of possible backing devices.

If you add a directory to the database, it is included in the list as a possible backing device for a virtual DVD. Do not specify the `USAGE` attribute for a directory; the attribute is not needed for a directory.

To ensure that a device database entry is preserved in the VSP device management database for future selection, even when the associated virtual device is removed from the VM, or even when all VMs using the entry as a backing device are deleted from the VSP, you can enter the `hpvmdevmgmt` command with the `PRESERVE` attribute specified as `PRESERVE=YES`.

When you use the `hpvmdevmgmt` command to create a file as a backing device for a disk, specify the size (`-S`) and `-A` attributes to ensure that the file is included in the list of possible backing devices. Specifying these two attributes automatically sets `USAGE=DISK` and `PRESERVE=YES`.

When you use Integrity Virtual Server Manager to create a file as a backing device for a disk, the `PRESERVE` attribute is set as `PRESERVE=YES`. 
NOTE: If you use Integrity Virtual Server Manager to manage a VSP running Integrity VM Version 3.5 or earlier, Integrity Virtual Server Manager does not fully support virtual device special files located in /hgap (introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for virtual storage. When you use Integrity Virtual Server Manager to add a storage device on a VM, Integrity Virtual Server Manager does not display device files in /hgap as possible backing devices to choose from.

To add a virtual storage device that uses a virtual device special file in /hgap to a new VM on a VSP running Integrity VM Version 3.5 or earlier, use the Integrity VM hpvmcreate command. For more information about these commands, see the HP-UX vPars and Integrity VM Administrator Guide manual.

7. Summary
Review the identity and resources specified for the new VM and preview the command that will be used to create it. This summary step allows you to review all information before the new VM is created.

At this step, you can still cancel (exit the Create VM wizard) or return to modify previous steps in the wizard. When you click Finish, the wizard executes the hpvmcreate commands displayed in the Command Preview area:

- If the Create VM even if resources are insufficient, missing or unavailable check box is not selected, the wizard executes the first of two commands (hpvmcreate -s) to check for resource availability and other issues without actually creating the VM. This command reports any errors or warnings at the top of the page. If warnings or errors are detected, the VM will not be created. Upon analyzing any reported warnings, you can choose to create the VM anyway by selecting the check box and clicking Finish again.

- If no serious problems are detected by the first command, the wizard then executes the second command (hpvmcreate -F), which creates the VM.

- If the Create VM even if resources are insufficient, missing or unavailable check box is selected, the wizard does not check for resource warnings. It simply runs the hpvmcreate -F to create the VM even if potential resource issues exist (but not if a fatal error is detected). For example, if this check box is selected, you can create a VM that uses a physical disk that some other running VM is already using. As another example, you can create a VM for which you incorrectly specified a storage device file. You can correct these kinds of problems after the VM is created and before it is started. For information about problem solving, see “Troubleshooting VM or vPar problems” (page 138).

8. Specify VLAN IDs
If the VSP supports vswitch VLANs (virtual LANs), and virtual NICs (vNICs) are specified for the new VM, then you can assign VLAN IDs to the newly created VM. You can assign a VLAN ID to the vswitch port connected to each virtual NIC in the VM. By default, VLANs are not specified (VLAN ID is “none”). When you click OK on this page, any modifications to the VLAN IDs are updated, after which the Create Virtual Machine wizard Next Steps page is displayed.

9. Next Steps
After creating the new VM, Integrity Virtual Server Manager presents you with the next steps you can take to manage and use the new VM. The steps presented depend on the environment in which you created the VM. For example, when VM scheduling on a VSP is managed by Global Workload Manager (gWLM), the Next Steps page advises you to associate the VM with a gWLM policy and add the VM to a Shared Resource Domain (SRD). You cannot start the VM until you complete that action.

If the new VM includes AVIO devices (AVIO support is provided on HP Integrity VM Version 3.5 or later), you are advised to make sure the appropriate OS that supports AVIO is installed.
on the VSP and the VM. If the intended OS on the VM does not support AVIO, you are warned of this. In addition, HP strongly recommends that AVIO components (such as drivers and libraries) on the VM and VSP be updated to the latest release of the OS. If the VM OS is Windows or Linux, install additional AVIO-compatible drivers on the VM; the Windows and Linux AVIO drivers include instructions for installing the drivers on VMs. For more information about AVIO requirements, see the HP-UX vPars and Integrity VM Administrator Guide manual.

Other steps you can take include starting the virtual hardware for the VM, accessing the VM console, adding additional software (provider components) needed to support management of the VM, getting information about the VM, and tuning the performance of the VM.

NOTE: Any devices added using the Create Virtual Machine wizard are not functional on the VM until the new VM is started. Certain devices are not seen in a Integrity Virtual Server Manager Storage tab until the VM is started.

You can configure the VM’s Extensible Firmware Interface (EFI) to boot the guest OS automatically when the VM is started (powered on). Configure EFI when the VM has been started and before booting the OS. You can interact with EFI through the virtual Management Processor (vMP) for the VM. The vMP provides access to the console for the VM. To interact with vMP, use the hpvmconsole command. For more information, see the HP-UX vPars and Integrity VM Administrator Guide manual.

If you are using Integrity Virtual Server Manager from HP SMH, click OK to finish. Integrity Virtual Server Manager displays the page from which you initiated the Create Virtual Machine wizard.

If you are using Integrity Virtual Server Manager from HP Matrix Operating Environment, click Apply gWLM Policy. To skip this step and add the new VM to the SRD later, click Apply Later (you must click either button). When you click Apply Later, Integrity Virtual Server Manager displays the page from which you initiated the Create Virtual Machine wizard. When you are ready to add the VM to the SRD, select the VM from the appropriate screen (for example, from the VSP Virtual Servers tab) and then select Policy → Apply gWLM Policy ... from the Integrity Virtual Server Manager Policy Menu help topic.

NOTE: After creating a VM using Integrity Virtual Server Manager, if you return immediately to HP Matrix OE visualization, the machine might not yet appear in HP Matrix OE visualization. This means Systems Insight Manager/HP Matrix Operating Environment has not yet completed identifying the new VM. However, it appears when the identification process completes (usually within a minute or two).

Modifying VMs

To modify a VM, select one of the following items from the Integrity Virtual Server Manager Modify menu. For more information about any item, see the corresponding Integrity Virtual Server Manager help topic.

NOTE: You cannot modify a VM that is currently migrating online. You must wait until migration completes. You cannot modify a VM that has migrated to another VSP (the target): the VM (on the source VSP) is in the Not Runnable state.

- **Virtual Machine vCPU Entitlement** to modify the processor entitlement of a selected VM. If supported by the version of Integrity VM running on the VSP, you can modify the entitlement cap. An entitlement cap is the maximum amount of computing power allotted to a VM for each vCPU.
NOTE: If the VM is being managed by gWLM, you cannot modify the vCPU entitlement. When you access the **Virtual Machine vCPU Entitlement** page, the following error message is displayed, where *virtual-machine-name* is the name of the VM:

The processor entitlement for VM *virtual-machine-name* cannot be modified because it is being managed by gWLM. To adjust the processor entitlement for this VM, use gWLM to change the policy associated with this VM.

To create or modify the gWLM policy for this VM, use the **Policy** menu (available when using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX).

- **Virtual Machine Memory** to modify the amount of memory for a selected VM. If the VSP has Integrity VM 3.0 or later installed and the OS type for the VM supports dynamic memory, the dynamic memory parameters are shown, and you can modify them. Changes to memory take effect when the VM is restarted.

**NOTE:** An up-to-date version of the WBEM Utilization Provider (UP) must be installed on the VM to enable HP Capacity Advisor and the memory utilization meters in Integrity Virtual Server Manager and Integrity VM to reflect the dynamic change in memory. For information about verifying and installing software on VMs, see “System and software requirements” (page 13) and the HP Integrity Virtual Machines documentation.

- **Virtual Machine vCPU Count** to modify the number of virtual CPUs for a selected VM or CPUs for a selected vPar. If supported by the version of Integrity VM running on the VSP, you can modify the minimum and maximum number of vCPUs to be allotted to the VM or CPUs to the vPar. Changes take effect when the VM or vPar is restarted.

- **Virtual Machine VLAN Settings** to modify the VLAN associated with the VM or vPar.

- **Add/Modify Virtual iLO Remote Console** to modify the IP Address and Net mask details of virtual iLO remote console of a VM or vPar. If the VM or vPar does not have a virtual iLO associated with it, you can create the virtual iLO remote console from the **Add/Modify Virtual iLO Remote Console** screen.

- **Hardware Auto Start for VM** to specify whether the VM should start automatically when Integrity VM is started or whether the VM will be started manually.

- **Add DIO** to add DIOs to a guest VM or vPar.

- **Replace DIO H/W path** to replace the h/w path of a DIO owned by a guest VM or vPar.

- **Replace DIO MAC address** to replace the MAC address of DIOs owned by a guest VM or vPar.

- **WBEM Credentials** to set and change WBEM credentials for VMs or vPars.

- **Add Storage Devices** to add storage devices for VMs or vPars.
NOTE: The list of possible backing devices for the storage device you want to add can include file and directory backing devices that have not been associated with a particular VM or vPar, or that were associated with VMs or vPars that have been removed or from which the associated virtual devices have been removed.

You can create a file as a backing storage device for a virtual disk. You can add DVD burners, tape devices, and changers if they are emulated SCSI adapters; they are added as attached devices. You cannot use Integrity Virtual Server Manager to add an attached AVIO device; to add such a device to a VM or vPar, use the `hpvmdevmgmt` command at the VSP. For more information, see the Modify → Add Storage Device ... help topic.

NOTE: If you use Integrity Virtual Server Manager to manage a VSP running Integrity VM Version 3.5 or earlier, Integrity Virtual Server Manager does not fully support virtual device special files located in `/hpap` (introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for virtual storage. When you use Integrity Virtual Server Manager to add a storage device on a VM, Integrity Virtual Server Manager does not display device files in `/hpap` as possible backing devices to choose from. If a virtual storage device using an `/hpap` device special file already exists on a VM managed by Integrity Virtual Server Manager, Integrity Virtual Server Manager displays it on the VSP Storage and VM Properties Storage tabs as an unknown device (using the question mark icon, `?`). Integrity Virtual Server Manager displays the correct device special file name (for example, `/hpap/rdsk/hpap1`) but the box representing this device is not connected to the boxes that represent the physical storage devices associated with that virtual device special file. In general, Integrity Virtual Server Manager correctly displays only those device special files located in `/dev`.

To add a virtual storage device that uses a virtual device special file in `/hpap` to an existing VM on a VSP running Integrity VM Version 3.5 or earlier, use the Integrity VM `hpvmmodify` command. For more information about these commands, see the HP-UX vPars and Integrity VM Administrator Guide manual.

- **Add Network Device** to add network devices and vswitches for VMs.

NOTE: Any network or storage devices that you add are not functional on the VM until the VM or vPar is started or restarted. When you add an I/O device to a started VM, it might not appear on the Network or Storage tab until the VM is stopped or restarted. For a started vPar, network or storage cannot be modified. If you add an I/O device to a stopped VM or vPar, the tab displays the device immediately.

NOTE: If the VM being modified is an HP Serviceguard package, you must make the same modifications to the VM on the other VSPs in the cluster.

### Starting VMs

Starting a VM starts the virtual hardware for the VM. The VM enters an On state (powered on). The Start and Restart functions are similar except the Start function does not stop and restart a VM that is already started (it leaves the started machine as is), while the Restart function does. Use Restart instead of Start when you have several VMs that you want newly started, some which are already started and some currently stopped. The Restart function takes care of all the VMs (in contrast, the Start function does not restart the already started machines). If you do not want the already started machines stopped and restarted (you just want the stopped machines started), use the Start function instead. For information about restarting VMs, see “Restarting VMs” (page 93).

NOTE: You cannot start a VM that is currently migrating online. You must wait until migration completes. If the selected VM has migrated to another VSP (the target), the VM (on the source VSP) is in the Not Runnable state: you cannot start a VM in this state.

To start one or more selected VMs, perform the following steps.
1. From the **VSP General** tab, select the **VSP Virtual Servers** tab (or any tab that allows you to select one or more VMs).
2. Select one or more VMs to start by clicking the appropriate check boxes.
   Alternatively, you can access the VM Properties view, in which case no selection is necessary; the VM being viewed is implicitly selected.
3. Select **Tools → Start Virtual Machine...** from the Integrity Virtual Server Manager menu bar. A page similar to that shown in Figure 59 is displayed.

![Start Virtual Machine page](image)

4. In the example shown in Figure 59, one VM will be started. The **Note** column indicates that one of the selected VM is already started. The **Command Preview** area shows the commands that Integrity VM will perform to start the VM.
   Click **OK** to start the VM.

When a VM is started, it is in the **on** state (powered on). You can then perform the functions you want.

**NOTE:** Depending on the settings in the VM’s Extensible Firmware Interface (EFI), starting a VM might not boot the operating system. For more information, see “Creating VMs” (page 83).

Once a VM is started, the resources assigned to the VM are allocated for its use. The VSP ensures that the resources required by the VM are available in the current VSP system environment. If the VM cannot be started, Integrity Virtual Server Manager displays messages indicating which resources cannot currently be provided.

For information about possible reasons that a VM might not start, see “Troubleshooting VM or vPar problems” (page 138).

**Stopping VMs**

To stop one or more VMs, perform the following steps. This action allows you to stop the virtual hardware for a VM. When stopped, a VM enters an **Off** state (powered off) and the VM is halted. Once a VM is stopped, the resources assigned to it no longer are allocated and are now available for use by other VMs.
NOTE: If the OS is running on a VM that you want stopped, HP recommends that you shut down the OS before stopping the VM. This ensures that all applications are shut down cleanly.

You cannot stop a VM that is currently migrating online. You must wait until migration completes. If the selected VM has migrated to another VSP (the target), the VM (on the source VSP) is in the Not Runnable state: attempts to stop the VM will fail.

1. From the VSP view, select the VSP Virtual Servers tab (or any tab that allows you to select one or more VMs).
2. Select one or more VMs to stop by clicking the appropriate check boxes.
   Alternatively, you can access the VM Properties view, in which case no selection is necessary; the VM being viewed is implicitly selected.
3. Select Tools→Stop Virtual Machine... from the Integrity Virtual Server Manager menu bar. This displays a page similar to that shown in Figure 60.

   **Figure 60 Stop Virtual Machine page**

4. In the screen example shown in Figure 60, one of the selected VMs is going to be stopped (vm001), while one is already stopped (vm002). The OS is running on one of the VMs and you have to shut down the OS on that machine before stopping it.
   The **How to Stop** options allow you to control how a VM is stopped:
   - **Graceful.** This is the default. With a graceful stop, the VM notifies the guest OS of an impending shutdown. This advance notice gives the OS an opportunity to perform cleanup operations before its VM is powered off. A graceful stop typically takes 30 to 60 seconds, but can take as long as 5 minutes because Integrity VM waits for the OS to complete its cleanup operations.
   - **Forced.** A forced stop is the equivalent of a power failure and gives no warning to the guest OS. Because the guest OS receives no advance notice of the power off operation, the OS has no opportunity to perform a crash dump or perform any system cleanup tasks.

   If you want to set a forced stop for the machines, click the Forced option; otherwise, skip to the next step.

5. The **Command Preview** area shows the commands that Integrity VM will perform to stop the VMs.
   Click **OK** to perform the action.
Restarting VMs

When you choose to restart one or more VMs, Integrity Virtual Server Manager stops a VM that is already started, and then restarts it; if a machine is stopped, Integrity Virtual Server Manager starts it. Once a VM starts, the resources assigned to the VM are allocated for its use.

The Restart and Start functions are similar except the Restart function first stops a VM that is already started, while the Start function does not (it leaves the started VM as is). Use Restart instead of Start when you have several VMs that you want newly started, some which are already started and some currently stopped. The Restart function takes care of all the VMs (in contrast, the Start function does not restart the already started machines). However, if you do not want the already started machines stopped (you just want the stopped machines started), use the Start function instead. For information about the start function, see “Starting VMs” (page 90).

**NOTE:** If the OS is running on a VM that you want stopped, HP recommends that you shut down the OS before stopping the VM. This ensures that all applications are shut down cleanly.

You cannot start a VM that is currently migrating online. You must wait until migration completes. If the selected VM has migrated to another VSP (the target), the VM (on the source VSP) is in the Not Runnable state: you cannot start a VM in this state.

To restart one or more VMs, perform the following steps:

1. From the VSP General tab, select the VSP Virtual Servers tab (or any tab that allows you to select one or more VMs).
2. Select the VMs to restart by clicking the appropriate check boxes.
   Alternatively, you can access the VM Properties view, in which case no selection is necessary; the VM being viewed is implicitly selected.
3. Select Tools → Restart Virtual Machine... from the Integrity Virtual Server Manager menu bar. This displays a page similar to that shown in Figure 61.

**Figure 61 Restart Virtual Machine page**

4. In the screen example shown in Figure 61, one VM (vm001) will be stopped (gracefully) and restarted. A message indicates that this machine have an active operating system that should be shut down prior to stopping the VM. The How to Stop options allow you to control whether the VMs are stopped gracefully (the default) or forcefully. For a description of each stop option, see “Stopping VMs” (page 91).
   If you want to set a forced stop for the machines, click the Forced option; otherwise, skip to the next step. If all machines are already stopped, skip to the next step (the How to Stop options are irrelevant).
   As noted, if the OS is running on a VM that is already started, shut down the OS before initiating the restart in the next step.
5. The **Command Preview** area shows the commands that Integrity VM will perform to restart the VMs.
   
   Click **OK** to perform the action.

For information about possible reasons that a VM might not start, see “Troubleshooting VM or vPar problems” (page 138).

### Deleting VMs

To delete a VM, select **Delete→Virtual Machine...** from the Integrity Virtual Server Manager menu bar. The **Virtual Machine...** menu option is enabled in the VM Properties view or when one or more VMs are selected in any of the tabs that list VMs, such as in the **VSP Virtual Servers** tab. From tabs that list and allow selection of multiple VMs, you can simultaneously delete multiple VMs that are selected.

**NOTE:** Before deleting a VM, you must first stop the VM (put it in the **Off** state). For instructions, see the section **“Stopping VMs” (page 91).**

Deleting a VM removes the configuration definition for a VM and frees any resources assigned to the VM, making the resources available to be assigned to other VMs. Deleting a VM does not delete files and data residing on the virtual storage or backing storage that was assigned to the VM.

By default, vswitch VLAN port assignments are removed when the VM is deleted. If any of the ports are connected to other VMs that are not being removed, those port assignments are not removed. Clearing the **Remove VLAN Assignment** check box causes vswitch VLAN port assignments to remain after the VM is deleted.

**NOTE:** You cannot delete a VM that is currently migrating online. You must wait until migration completes.

**NOTE:** Using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, if you create a VM and then delete it before the new VM has been identified by Systems Insight Manager, the VM might appear in HP Matrix OE visualization as though it had not been deleted. The appearance of the VM in HP Matrix OE visualization depends on when the deletion occurred during the Systems Insight Manager identification process. In addition, if you decide to delete the VM soon after creating it, wait a few minutes before doing so. If the deleted VM does appear in HP Matrix OE visualization, delete it from the Systems Insight Manager All System view. (From the Systems Insight Manager **Systems and Event Collections** list in the navigation area on the left, select **All Systems**.) For more information, see the **HP Matrix Operating Environment Logical Server Management User Guide**.

This is not an issue when using Integrity Virtual Server Manager from HP SMH.

### Migrating VMs

#### Overview

This topic presents an overview of VM migration and of the Migrate VM wizard that allows you to set up and initiate migration of VMs from your Integrity Virtual Server Manager's VSP (the migration source) to another VSP (the migration target).

The wizard allows you to perform either online or offline migration:

- **Online migration** migrates a VM that is running, moving the guest OS and applications without disrupting service. All guest I/O connections to network and storage devices remain active throughout the migration, and the guest OS and its applications continue operating without requiring a reboot or application restart.
- **Offline migration** migrates the configuration of a VM that is not running.
Some of the most common reasons for migrating VMs online include the need to:

- Vacate the source VSP system for maintenance purposes without disrupting services
- Perform a rolling upgrade of a VSP, moving its running guests to another VSP, upgrading the VSP, then moving the guests back
- Populate a new VSP with one or more VMs already configured and tested on the source
- Move VMs to take advantage of a particular resource or feature on the target VSP, without losing application availability
- Balance VSP workloads
- Optimize physical resource utilization

Online migration of VMs enables a higher level of workload-to-resource alignment, flexibility, and agility.

Reasons for migrating a VM offline include the need to:

- Move a stopped VM’s configuration information
- Save VSP resources while migrating VMs (for example, memory and CPUs are not consumed during offline migration)
- Copy local storage, logical volumes, or file-backed storage to the target VSP (such storage cannot be migrated online)
- Migrate a VM between VSP that might have different processor types, making online migration impossible

The Migrate Virtual Machine wizard is started by selecting **Tools → Migrate Virtual Machine...** from the Integrity Virtual Server Manager menu bar. The menu item is enabled from the VM Properties view, from which you can migrate the one viewed VM, or from a tab on which one or more VMs are selected, such as the **VSP Virtual Servers** tab, from which you can migrate multiple VMs at the same time. For more information about starting the wizard, see “Starting the Migrate Virtual Machine wizard” (page 97).

The Migrate Virtual Machine wizard guides you through a two-step procedure. The screen for the first step prompts you to specify the target VSP. The screen for the second step allows you to preview the HP Integrity Virtual Machine commands that will be invoked to initiate the migration and allows you to initiate the migration.

Using the Migrate Virtual Machine wizard, you can migrate VMs from the VSP you are currently using with Integrity Virtual Server Manager to another VSP; you cannot use the wizard to migrate VMs from another VSP to the current Integrity Virtual Server Manager VSP.

While a VM is being migrated to another VSP, you cannot stop, start, restart, modify, or delete that VM. You can continue using Integrity Virtual Server Manager for other purposes.

**NOTE:** If the VM is configured as a Serviceguard package, the wizard allows you to migrate the VM online or offline. However, you cannot migrate a VM that is configured as a Serviceguard cluster node.

When migrating a VM that is configured as a Serviceguard package, Serviceguard protection is suspended temporarily during the migration.

Capacity Advisor cannot collect utilization information for a VM that is being migrated.

For more information about Serviceguard and Capacity Advisor requirements and recommendations pertaining to VM migration, see “Planning requirements and recommendations” (page 95).

**Planning requirements and recommendations**

Successful migration of a VM requires that the source and target hosts be configured appropriately. If they are configured properly before migration of a VM, the migration task completes more
quickly. Configuration requirements for online migration are more elaborate than for offline migration.

Some of the basic migration requirements include the following; for complete details, see the *HP-UX vPars and Integrity VM Administrator Guide* manual:

- For online migration, the source and target VSPs must be running HP Integrity VM Version 4.1 or later.
- The source and target VSPs must conform to the operating system requirements, and both must be able to provide the allocated resources to the VM being migrated.
- The target VSP must be accessible from the source VSP.
- Resources used by the VM must be configured symmetrically on both the source and target VSP.
- You can migrate guests that use both the virtual I/O (VIO) and the accelerated virtual I/O (AVIO) drivers for storage and network. Only whole disk SAN storage and ejected file-backed DVDs can be migrated while the VM is online. File and logical volume backing storage are not supported for online migration of VMs.
- Online migration requires that both the source and target VSP be licensed and enabled for such migration. The licensing is included with a bundle that must be installed on each VSP; for more information, see the *HP-UX vPars and Integrity VM Administrator Guide* manual.
- Online VM migration requires that the VM be enabled for online migration (the VSP administrator can enable a VM by using the `hpvmmodify -x online_migration=enabled` command).

**Serviceguard requirements and recommendations**

For online migration of a VM configured as a Serviceguard package, package switching for the migrating VM guest package is disabled before migration begins and then re-enabled immediately after the migration finishes. Therefore, the VM software is not protected by Serviceguard during the migration process. If a failure occurs during migration, you must manually re-enable package failover after the migration completes and restart the VM by running it on one of the Serviceguard cluster nodes.

If temporary loss of failover protection is not tolerable, disable online migration for the VM. For example, to disable the VM named sgnode, run the `hpvmmodify` command on the VSP as follows:

```
hpvmmodify -P sgnode -x online_migration=disabled
```

Do not attempt online migration of a VM configured as a Serviceguard cluster node. If a Serviceguard node is migrated while online, it might lose connection to other cluster members and be automatically removed from the cluster. Disable online migration for all VMs configured as Serviceguard cluster nodes.

**NOTE:** Integrity Virtual Server Manager detects whether a VM is configured as a Serviceguard package; the **VSP Virtual Servers** and **VM Properties General tab** tabs display the package icon (❑) next to the VM name.

For more information about managing VMs with Serviceguard support, see the *HP-UX vPars and Integrity VM Administrator Guide* manual.

**Capacity Advisor requirements and recommendations**

If Capacity Advisor is used on the VM, collect utilization information before you migrate the VM. The Capacity Advisor cannot continue to collect utilization information for the VM during the migration.
Migration status and error notification

The migration status of a VM — including the direction of migration, percentage completion per phase (for online migration only), and error messages — is displayed on the VM Properties General tab. The VSP Virtual Servers tab also indicates migration status (use this tab to monitor the migration of multiple VMs). For more information, see “VM or vPar properties general tab” (page 61) and “VSP Virtual Servers tab” (page 31).

If errors occur during an attempt to migrate a VM online, the VSP Virtual Servers tab (for the source VSP) displays the Migration Error icon (⚠️) next to the name of the affected VM. Information about the migration-related errors is on the VM Properties General tab. For more information about status icons, see “Status indicators” (page 137).

Various conditions can cause an online migration to abort: insufficient resources on the target host, busy source or target hosts, a slow private network connection, an excessively busy guest (VM operating system and applications), and so on. When a migration aborts, the guest continues to run, unaffected, on the source VSP. Therefore, these are not serious errors. You can attempt the online migration again when the blocking conditions improve.

After a VM successfully migrates to another VSP, it is placed in the Not Runnable state on the source VSP. A VM in this state cannot be modified or started. If you never intend to migrate the VM back to the source VSP, you can remove the VM configuration by using the Integrity Virtual Server Manager Delete → Virtual Machine... menu item.

The state of the VM is displayed by the HW column on the VSP Virtual Servers tab. The Not Runnable state is indicated by the following status icon: 🌴. The VM Properties General tab also displays the state of the VM (in the Virtual Hardware Status field).

Adjusting online migration phase timeout values

To protect the guest’s workload, the online migration software limits the amount of time spent in each phase of the migration. If necessary, the VSP administrator can carefully adjust migration time outs for each phase by using the hpvmmmodify -x command, as documented in the HP-UX vPars and Integrity VM Administrator Guide manual.

Starting the Migrate Virtual Machine wizard

To migrate one or more VMs, follow these steps:

1. If you want to migrate a single VM, access any VM Properties view, and skip to the next step. If you want to migrate several VMs, access the VSP Virtual Servers tab or any tab that allows you to select multiple VMs. Then select the VMs to migrate by clicking the appropriate check boxes.

2. To start the Migrate Virtual Machine wizard, select Tools → Migrate Virtual Machine... from the Integrity Virtual Server Manager menu bar. This displays the first of two Migrate Virtual Machine wizard screens, the Step 1 screen as shown in Figure 62.

NOTE: The Tools → Migrate Virtual Machine... option is enabled from any VM Properties view or from any tab on which one or more VMs are selected.
3. Specify the target VSP name, alias, or IP address. The target must be a valid VSP and must be accessible by the source VSP. If you intend to migrate a VM online, this VSP must be licensed and enabled for online migration.

4. If you want the VM configuration removed from your source VSP after the migration completes, select the check box provided for that purpose. Make this selection if you never intend to migrate the VM back to this VSP. If you might migrate the VM back to this VSP sometime, or if you might want to create a VM on this VSP that is based on the configuration of the VM that you migrated to another VSP, do not check the box.

5. To continue to the Step 2 screen of the Migrate Virtual Machine wizard, click Next. To cancel and return to the Integrity Virtual Server Manager screen from which you initiated the wizard, click Cancel. Figure 63 shows an example of the Step 2 screen.

This screen lists the commands that Integrity Virtual Server Manager will issue to start the migration. The first command will migrate a running VM, so it is listed as an online migration. The second command will migrate a VM that is not running and so is listed as an offline migration. If any VMs cannot be migrated, the screen lists the VM names and the reasons why they cannot be migrated. Reasons that a VM cannot be migrated include:

- It is already migrating
- Online migration only: It is not enabled for online migration
- It is in a Not Runnable state
- Online migration only: The source or target VSP is not licensed and enabled for online migration
- Serviceguard packages only: The package is already running on the target VSP

**NOTE:** If the source or target VSP is not enabled and licensed for online migration, or the VM is not enabled for online migration, you can migrate the VM offline. Stop the VM and then retry migrating it.
6. Inspect the commands. If they suit your needs and you want to go ahead with the migration, click Finish. If you want to tailor the commands to be used for migrating the selected VMs, you can enter the desired commands manually on the VSP. If you want to start over — perhaps to specify a different target VSP or to change your selection regarding whether to remove the VM configuration after it is migrated to the other VSP — click Previous to return to the Step 1 screen of the wizard.

If you do not want to perform the migration, click Cancel. When you click Cancel or Finish, Integrity Virtual Server Manager returns you to the screen from which you initiated the Migrate VM wizard.

While a VM is being migrated to another VSP, you cannot stop, start, restart, modify, or delete that VM. You can continue using Integrity Virtual Server Manager for other purposes. While the current migration is in progress, if you start the Migrate Virtual Machine wizard again to migrate another VM, Integrity Virtual Server Manager queues the newly-selected migration until after the current migration completes.

To determine the status of the migration, use the VSP Virtual Servers tab (especially if multiple VMs are being migrated) or the VM Properties General tab.

Suspending VMs

You can suspend a VM instead of shutting down the VM. Only the OS status of a VM in an Up state can be suspended. The hpvmsuspend command suspends a VM. A VM that is suspended does not use CPU or memory resources.

To suspend a VM:
1. Select a VM in an On state.

The Suspend Virtual Machine screen is displayed, as shown in Figure 64.
3. The **Command Preview** area shows the commands that Integrity VM performs to suspend the VM.
   Click **OK**. The VM is suspended and the **Virtual Servers** tab is displayed. You can view the status as **Sp** in the OS column against the selected VM, as shown in Figure 65.

### Figure 65 Suspend status

![Figure 65 Suspend status](image)

**Resuming VMs**

A VM can be resumed only if it is in a suspended (SP) state. Resuming a VM saves time as it does not involve the actual shutdown and reboot of the OS.

A VM is resumed by the `hpvmresume` command. The `hyvmresume` command checks whether the VM and its resources defined in the configuration file can be allocated. If it cannot be allocated, the VM is not resumed. Only superusers can execute the `hpvmresume` command.

A VM cannot be resumed under the following conditions:

- VM is not in a suspended state.
- The server has fewer CPUs than the VM requires.
- The server has insufficient free memory.
- The server has insufficient CPU resources.
- The server has insufficient swap resources.
- Another VM is using a specified nonshared backing device.
- The server is using a specified backing device.
- A specified backing device does not exist.
- A specified vswitch is not available.
- The vswitch must be created using the `hpvmnet` command before the guests using it can be resumed.
- The specified MAC address is in use.
- The specified guest is a distributed guest.

To resume a VM:
1. Select a VM in a suspended state.
2. Select **Tools** → **Resume Virtual Machine**. The **Resume Virtual Machine** screen is displayed, as shown in Figure 66.

**Figure 66 Virtual Machine Resume page**

![Resume Virtual Machine screen](image)

3. The **Command Preview** area shows the commands that Integrity VM performs to resume the VM.
   
   Click **OK**. The VM is resumed and the **Virtual Servers** tab is displayed. The status turns On in the OS column against the selected VM.

### Moving suspend files

When a VM is suspended, the suspend files are saved at a default location: `/var/opt/hpvm/guests`. Suspend files can be very large, up to the size of guest memory for each suspended guest. HP recommends moving the files to another directory.

The `hpvmmove_suspend` command can be used to change the directory, where suspend files are stored and to move all existing suspend files to a new directory. If there is insufficient space in `/var` to accommodate the suspend files, `hpvmmove_suspend` command can be used to move them to a larger disk.

To move suspend files:
1. Select **Tools VM Move Suspend**. The screen to specify the new directory is displayed, as shown in Figure 67.

**Figure 67 Virtual Machine move suspend**

![Virtual Machine move suspend](image)

2. To change the default directly, select the **Specified directory** option and click **Browse**. The screen listing all the directories is displayed, as shown in Figure 68.

**Figure 68 Virtual machine browse directory**

![Virtual machine browse directory](image)

3. Select a directory and click **Select**. The screen goes back to the VM Move Suspend page.

4. The **Command Preview** field displays the specified directory location. Click **OK** to move the suspended files to the specified directory.

Creating virtual switches

**Create Virtual Switch** menu is applicable for both VMs and vPars. To provide network access for VMs or vPars, you must create virtual network switches (vswitches) for them. This section describes how to create a new vswitch on the VSP. The vswitch is used by a VM or vPar to connect to the network: one or more VMs or vPars connect to the vswitch and the vswitch is connected to a VSP’s physical network device.
To create a vswitch, select **Create → Virtual Switch** from the Integrity Virtual Server Manager menu. This displays a page similar to that shown in Figure 69.

**Figure 69 Create Virtual Switch page**

The table on the screen shown in Figure 69 displays the following information:

- **LAN interface**: Shows the physical LAN interface to which a vswitch can be attached. The “(none)” entry indicates that the vswitch is local, meaning that it is not connected to a LAN interface. Communication over such a vswitch does not go out on the physical network and is useful only for communicating between VMs or vPars.

- **Used by**: Shows all of the vswitches already configured to use the corresponding LAN interface. A LAN interface can be used by only one vswitch at a time. You can configure multiple vswitches that use the same LAN card, but only one of these switches can be active at one time. In the row for creating a local vswitch ["(none)" entry], the Used by column lists all existing local vswitches. All local vswitches can be active simultaneously. A new local vswitch can be started regardless of the number of existing active local vswitches.

- **Hardware path**: Shows the hardware path associated with the LAN interface.

- **Supports AVIO**: Shows whether the physical backing device supports Accelerated Virtual Input/Output (AVIO). For each VM or vPar containing an AVIO device, the VSP OS and the guest OS must support AVIO. In addition, HP strongly recommends that AVIO components (such as drivers and libraries) on the VM or vPar and VSP be updated to the latest release of the OS. If the VM or vPar OS is Windows or Linux, install additional AVIO-compatible drivers on the VSP and VM or vPar.

For HP-UX, HP recommends that you install the latest AVIO components for both the VSP and the guest; however, updating both guest and VSP components at the same time is not mandatory. Updating both components ensures that you always receive the latest bug fixes for a complete solution. Always check the following software depot website for the latest version of AVIO software (search for “HPVM AVIO”):

http://software.hp.com

Guest AVIO drivers are included in the **VMGuestSW** bundle available from the software depot website. Make sure you install the latest version of that bundle.
With HP Integrity VM, AVIO requires a vswitch that has a physical network device as the backing device (local vswitches such as localnet are not supported). In addition, the physical NIC that backs the virtual switch must have an AVIO-compatible driver.

For more information about AVIO requirements, see the HP Integrity Virtual Machines documentation available at http://www.hp.com/go/hpux-hpvm-docs.

Create the virtual switch by performing the following steps:

1. **(Required) Enter a virtual switch name.**
   - The name must be 8 characters or fewer.
   - The allowable characters are A-Z, a-z, 0-9, dash (-), underscore (_), and period (.).
   - The name cannot begin with a dash and cannot remain blank.

2. **Specify the virtual switch type (whether it is to be dedicated or shareable).** The default is shareable.

   **NOTE:** The terms "shareable" and "dedicated" refer to how the switch is assigned to the VMs.
   - A dedicated vswitch can be used by only one started VM at a time and is dedicated to providing network throughput to that VM. More than one VM can have the same dedicated switch as a resource, but only one is allowed to start.
   - A shareable vswitch can be used at any given time by all the associated VMs that contain the virtual network device (NIC) backed by a shareable vswitch.

   **NOTE:** All VMs with virtual NICs backed by a shareable vswitch are not required to be running. If you have a stopped VM that uses the shareable vswitch, you can always start the VM (unless other problems prevent it from starting).

3. **(Required) From the table, select the VSP’s physical network device that will be the physical backing of the vswitch.**
   - Any physical network cards (adapters) configured on the VSP
   - Any APA (Automatic Port Aggregation) configured on the VSP
   - None

   The display shows the APA name in one column and the individual devices or cards in the next column; however, the letters "APA" do not appear in either column. In HP-UX, any LAN port with port number 900 or greater is an APA (for example, lan900 or lan901).

4. **Specify whether or not to start the vswitch after it is created.** The default is to start the vswitch.

   Clicking **OK** does the following:
   - Creates the new vswitch, using the **hpvmnet** command.
   - If you chose to make the vswitch dedicated, configures the vswitch as a dedicated vswitch, using the **hpvmdevmgmt** command.
   - If you chose to have the switch started, starts the vswitch, using the **hpvmnet** command.

   A preview of these commands is shown in the Command Preview area. After you click **OK**, any errors that occur with the execution of these commands is displayed on a separate error page that
lists each command and whether the command succeeded, failed, or was not attempted. Clicking OK on the error page returns you to the Create Vswitch page.

Starting, stopping, and deleting virtual switches

To start or stop a virtual switch, select Tools→Start Virtual Switch… or Tools→Stop Virtual Switch… from the Integrity Virtual Server Manager menu bar. To delete a virtual switch, select Delete→Virtual Switch…. Access these menu options from a view that allows you to select one or more virtual switches, such as the VSP Virtual Switches tab. In this way, you can act on several multiple switches simultaneously, if selected. (You can also access the menu options from the Vswitch Properties view, in which case the action is performed on a single virtual switch: the one being viewed.)

To start a vswitch, select Tools→Start Virtual Switch…. Once a vswitch is started, the VMs that are connected to it can use it for network connectivity. Before you start a vswitch, it must be stopped.

To stop a vswitch, select Tools→Stop Virtual Switch…. The selected vswitch must currently be started. Once a vswitch is stopped, the VMs connected to it can no longer use it for network connectivity.

To remove all configuration information for a vswitch, select Delete→Virtual Switch…. Before you remove a vswitch, you must first stop it.

**NOTE:** For information about creating and managing vswitches, see the HP-UX vPars and Integrity VM Administrator Guide available at [http://www.hp.com/go/hpux-hpvm-docs](http://www.hp.com/go/hpux-hpvm-docs).

Deleting network or storage devices

**Delete Network or Storage Device** menu is applicable to both VMs and vPars. To delete a network or storage device from a VM or vPar, select one or more I/O devices from a Network or Storage tab, and then select Delete→I/O Device… from the Integrity Virtual Server Manager menu bar. You can select I/O devices from any of the following tabs: VSP Storage, VM or vPar Properties Storage, VSP Network, VM or vPar Properties Network, Vswitch Properties Network.

Selecting Delete→I/O Device… displays a page that allows you to remove the selected I/O devices. When you delete a device from a VM or vPar, it is disassociated from that VM or vPar, allowing the device to be used by another VM or vPar on the VSP. Deleted devices remain active on a VM or vPar that is running; the devices are removed once you restart the VM or vPar.

Storage devices that you can delete include virtual disks and DVDs as well as attached tapes, burners, and changers. Deleting a storage device does not affect data on that device (files or data are not removed from the device).
NOTE: You cannot remove a device that is currently being used by the guest OS or if I/O is outstanding.

If a VM or vPar is running the Windows operating system, Integrity Virtual Server Manager indicates that it will not remove the VM or vPar's devices. The operating system must be shut down first.

If a VM or vPar is running HP-UX, devices selected for removal might not be removed until you restart the VM or vPar. To confirm that the device has been removed from the VM or vPar, view the appropriate Network or Storage tab.

NOTE: If the VM or vPar is powered on, preliminary actions might be required to remove an AVIO storage device. If the VM or vPar is powered off, no preliminary actions are required to remove the AVIO storage device (or any other selected storage device). To remove an AVIO storage device from a VM or vPar that is powered on, note the following:

- If the VM or vPar is powered on and running at EFI, to remove the device, first stop the VM or vPar. To stop the VM or vPar, use the Integrity Virtual Server Manager Tools→Stop VM or vPar... menu option. Once the VM or vPar has stopped, delete the device using the Delete→I/O Device... menu option.

- If the VM or vPar is powered on and running HP-UX 11i v3, you must remove all instances of the device from the guest OS. To do so, follow these steps:
  1. Obtain the device’s hardware target path (tgtpath class) or lun path (lunpath class), using the ioscan command at the guest in either of the following ways:
     
     ioscan -kfNC tgtpath
     
     or
     
     ioscan -kfNC lunpath
  
  2. Remove the device by using the rmsf command at the guest, specifying the obtained hardware path:
     
     rmsf -H tgtpath
     
     or
     
     rmsf -H lunpath

     Once the device has been completely removed from the guest OS, then you can delete the storage device by using the Integrity Virtual Server Manager Delete→I/O Device... menu option.

NOTE: HP Integrity VM maintains a device database that includes entries for all devices and their associations. If deleting a device causes removal of the last association of that device with any other VM or vPar on the VSP, HP Integrity VM removes that device from its device database unless it is marked for preservation. To preserve an entry, use the Integrity VM hpvmdevmgmt command, specifying PRESERVE=YES; or, when creating a file as a backing device, specify the -S and -A attributes with that command.

When you use Integrity Virtual Server Manager to create a file as a backing device for a disk, the PRESERVE attribute is set as PRESERVE=YES.

Opening iLO console

The virtual console is a terminal from which you can manage all the VMs or vPars within VSP. To start the virtual console terminal of a VM or a vPar:

1. Click the Virtual Servers tab.
   
   The VMs or vPars are listed in this tab.

2. Select one or more VMs or vPars by selecting the check box against each required VM or vPar.
3. Select **Tools**→**Open iLO Console** or **Open Virtual iLO Remote Console** from the Virtual Servers menu bar. The **iLO Console** screen is displayed.

**Figure 70 iLO console**

![iLO Console Screen]

The **Main menu** is listed:

- **CO**: Console
- **CM**: Command Menu
- **CL**: Console Log
- **SL**: Show Event Logs
- **VM**: Virtual Machine Menu
- **HE**: Main Help Menu
- **X**: Exit Connection

**Opening virtual iLO remote console**

The remote console is a terminal to manage a VM or vPar. This feature allows you to access the guest directly. You do not have to run the `hpvmconsole` command to search for the host machine and guest name. An IP address is assigned to each VM or vPar. You can use this unique IP address and the host login credentials to directly access the guest without running any additional commands. You can use the remote console when you want to access a specific VM or vPar. The login credentials are the same as the credentials that are configured during the OS installation on the VM or vPar.

You can configure the parameters for the virtual iLO remote console from the **Modify** menu. To add a virtual iLO console or to modify the parameters of an existing virtual iLO console, select **Modify**→**Add/Modify Virtual iLO Remote Console**... to open the **Add/Modify Virtual iLO Remote Console** page. For more information, see the Add/Modify Virtual iLO Remote Console help topic.

**NOTE:** You can also configure remote console using the `hpvm` commands on the VMMgr CLI.
Deleting virtual iLO remote console

The **Delete** option in the **Console** tab allows you to delete the current IP address and Netmask of the virtual iLO remote console for the selected VM or vPar.

To delete the virtual iLO remote console settings of a VM or a vPar:

1. Click **Delete** against the VM or vPar for which you want to delete the virtual iLO remote console details. The **Delete virtual iLO remote console** screen is displayed.

   ![Figure 71 Delete virtual iLO remote console](image)

2. Click **OK** to delete the settings for the virtual iLO remote console.

Deleting DIOs

You can delete the DIOs of a VM or vPar.

![Figure 72 Delete DIOs page](image)

To delete the DIOs of a guest:

1. Select a guest from the **Virtual Servers** tab.
2. Click **Delete** → **Delete DIO**... The **Delete DIOs**... page is displayed.

   The **Delete DIO**... menu is enabled only after you select a guest. If more than one guest is selected, the menu items are not enabled.

3. Click **Command Preview** to preview the commands that are executed to delete the selected DIOs. To add parameters, bus, device, and MAC addresses of the DIO in commands, select the **Specify virtual address parameters in command preview (advanced)** check box. By default, the box is not selected.

4. Click **OK** to execute the commands and delete the selected DIOs.
Adding DIOs

You can add DIOs to a VM or vPar.

Figure 73 Add DIOs to VM or vPar page

To add DIOs:

1. Select a guest from the Virtual Servers tab.
2. Click Modify → Add DIO. The Add DIOs to (VM or vPar) page is displayed.
   The Add DIO menu is enabled only after you select a guest. If more than one guest is selected, the menu items are not enabled.
3. Select DIOs from the HPVM DIO table. To specify the PCI bus number, PCI device number, and MAC address, select the Specify virtual address parameters (advanced) check box.
   When you select the check box, fields to enter BUS, Device, and MAC address are displayed. If you do not enter any value in the fields, the default values are applied.
   **NOTE:** PCI bus number must be from 0 through 7.
   PCI device number must be from 0 through 7.
   MAC address format must be 0x000000000000. It must begin with 0x followed by 12 hexadecimal characters.
   **NOTE:** PCI bus and PCI device number must exist together. If one number is entered without the other, the following error message is displayed when you click Command Preview.
   The DIO with backing DIO function x/x/x/x/x/x/x has a missing adapter value (bus a, device (default)). Enter both of the adapter arguments (bus, device) or remove both of them.
   The Command Preview field also displays a note that there are errors in the input.
   MAC address can exist separately without the PCI bus and device numbers.
4. Click OK to add the DIO to the guest.

Replacing DIO H/W path

You can replace the h/w path of a DIO owned by a VM or vPar.
To replace the DIO h/w path:

1. Select a guest from the Virtual Servers tab.
2. Select Modify → Replace DIO H/W Path... After you select a guest, the Replace DIO H/W Path... menu is enabled. If you select more than one guest, the menu items are not enabled.
3. The Modify DIO H/W Path... page is displayed.
   Two tables are displayed, one is the guest DIO table and the other is the HPVM DIO table.
4. Select a DIO from the guest DIO table, and then select another DIO from the HPVM DIO table to replace the selected DIO in the guest DIO table.
5. To view the MAC address parameters in the Command Preview field, select the Specify MAC address parameters in command preview (advanced) check box.
6. Click OK to replace the DIO h/w path.

Replacing DIO MAC address

You can replace the MAC address of DIOs owned by a VM or vPar.

To replace the DIO MAC address:

1. Select a guest from the Virtual Servers tab.
2. Click **Modify → Replace DIO MAC Address**.... The **Modify DIO MAC address** page is displayed. The **Replace DIO MAC Address**... menu is enabled only after you select a guest. If you select more than one guest, the menu items are not enabled.

3. Select DIOs in the guest DIO table.

4. Click **Modify MAC Address & Command Preview**, and then enter the new MAC address in the new table that is displayed.

   **NOTE:** To view errors if any, related to the data that is entered, click **Modify MAC Address & Command Preview**.

5. Click **OK** to save the modified DIO MAC address.

**Working with vPars**

**Creating vPars**

To create a vPar, Virtual Server Manager uses the Create Virtual Partition wizard to guide you through the process. Each steps presents a dialog that allows you to specify the required information. At any time you can get help, return to previous steps, or exit the wizard. By creating a new vPar, you assign attributes and resources to it. This creates an association among the virtual devices known to vPar and the physical devices managed by the vPar VSP.

To access the Create Virtual Partition wizard, select **Create → Virtual Partition** from the vPars menu bar. The Create Virtual Partition wizard leads you through several screens in the following order.

1. **Specify vPar Identity**
   - Specify the vPar name and an optional description.

2. **Specify Processor Count**
   - Specify the number of CPUs.

3. **Specify Memory**
   - Specify the amount of base and float memory (optional) designated for the vPar.

4. **Specify Network Devices**
   - To add a virtual network device, click **Add Network Device**... on the first network device screen. This displays the **Add Network Device** screen. First, select the type of virtual network interface card. The default card type is AVIO LAN (the choices depend on the version of the HP-UX installed on the VSP). AVIO LAN supports newly attached devices on HP-UX 11i v2 and HP-UX 11i v3 vPars.

   After you select the virtual network interface type, select the virtual switch from the list provided or create a virtual switch. To provide network access for the vPar, a virtual switch is necessary.

   Select the **Specify virtual network interface card parameters (advanced)** check box to manually specify virtual network interface card parameters. This is an advanced option. By default, virtual interface card parameters are numbered automatically during vPar creation, but they can be specified manually when this option is selected. HP recommends accepting the automatically numbered parameters that Virtual Server Manager provides. When manually specifying virtual network interface card parameters, valid bus numbers are 0 to 6, and valid device numbers are 0 to 7. You must either specify values for both numbers or leave both blank.

5. **Specify DIOs**
   - You can add DIOs to a vPar to provide near native I/O functionality, manageability, and performance by giving a vPar direct access to Host PCI Express (PCIe) functions, which may be physical or virtual.
To add DIOs:
1. Click **Add DIO...** The **Add a DIO to vPar...** screen is displayed.
2. Select the preferred DIOs from the HPVM DIO table. These DIOs do not have an IP address and are not associated with a Vsswitch.
3. If you want to enter the Bus, Device, and MAC parameters for the selected DIOs, select **Specify virtual address parameters (advanced)**. If you want to use the default parameters, leave the check box blank.
4. Click **Add to List** to add the selected DIOs to the vPar. The **Specify DIOs** page is displayed, where the selected DIOs are listed.
5. Click **Next** to move to the next screen of the wizard.

To delete a DIO, select the DIO from the list in the wizard view, and then click **Delete**.

**NOTE:** If you want to modify a DIO, you must first delete it and then add the device again with the correct specifications.

Table 15 (page 112) describes the information which the device selection table displays.

### Table 15 DIO selection table: column descriptions

<table>
<thead>
<tr>
<th><strong>Parameter name</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>H/W Path</td>
<td>The H/W Path indicates the functions of a device. For example, a function H/W path 0/0/0/3/0/0/0 indicates function 0, which is the last number of the H/W path. Therefore, 0/0/0/3/0/0/[0–N] are all functions of the same device 0/0/0/3/0/0.</td>
</tr>
<tr>
<td>Assignment Level</td>
<td>Indicates whether the operation of the DIO is at a function level or device level. In Function Level Assignment (FLA), each function is shared among several VMs or vPars. In Device Level Assignment (DLA), an entire device is assigned to the same guest OS. In the DIO pool, all functions of DIOs with device-level assignment are placed together. If a command is issued to one function in the device, all other functions also perform the same operation. For example, 0/0/0/4/0/0/0 and 0/0/0/4/0/0/1 are device-level functions and belong to the device, 0/0/0/4/0/0. They are placed in a single cell in the DIO pool. If you select them from the host or HPVM table, the command preview field displays only the first function, 0/0/0/4/0/0/0.</td>
</tr>
<tr>
<td>Driver Type</td>
<td>Indicates the type of DIO driver. The driver used must be compatible with DIO. For example, HPUX 11i v3 1112/1203 iexgbe guest driver with DIO support.</td>
</tr>
<tr>
<td>Description</td>
<td>Displays a description of the DIO network adaptor. For example, AM225-60001 HP Integrity PCIe 2-port 10GbE-SR Fabric Adapter.</td>
</tr>
<tr>
<td>Label</td>
<td>Indicates the label of the DIO.</td>
</tr>
<tr>
<td>Used by Guest</td>
<td>Indicates the VMs or vPars configured to use this DIO.</td>
</tr>
</tbody>
</table>

6. Specify storage device

You specify virtual adapter cards for the vPar. The virtual storage adapter cards are associated with the virtual storage devices that are backed by physical storage. A physical storage device can be a disk, DVD, tape, and Media Changer. NPIV is a Fibre Channel facility allowing multiple N_Port IDs to share a single N_Port. To add a virtual storage device, click **Add Storage Device...**. This displays the **Add Storage Device** screen. First, select the type of virtual storage adapter. The default adapter type is AVIO storage. AVIO storage supports new attached
devices on HP-UX 11i v2 and HP-UX 11i v3 vPars. The attached devices configured using AVIO (avio_stor adapter), have the following benefits over attached devices configured with VIO (scsi adapter):

1. Allow sharing of tapes, changers, and burners among multiple vPars and VSPs
2. Support of USB 2.0 DVD burners
3. Improved performance

If the VSP is running HP-UX 11i v3, the Add Storage Device screen gives you the choice of listing storage devices by their agile address (the default) or by their legacy address. HP recommends using agile device addressing when configuring storage devices. This provides benefits especially for multipath devices. With legacy addressing, the screen lists one entry for each path to a storage device that has multiple paths. With agile addressing, the screen lists only one entry for each multipath storage device. To change the addressing scheme for viewing, select the appropriate addressing scheme.

After you select the virtual storage adapter type, select the physical backing device from the list of devices provided in the device selection table.

**NOTE:** Any devices added using the Create Virtual Partition wizard are not functional on the vPar until the new vPar is started. Certain devices are not seen in a Virtual Server Manager Storage tab until the vPar is started.

7. Summary

Review the identity and resources specified for the new vPar and preview the command that will be used to create the new vPar. This summary step allows you to review all the information before the new vPar is created.

At this step, you can still cancel (exit the Create Virtual Partition wizard) or return to modify previous steps in the wizard. When you click Finish, the wizard executes the vparcreate commands displayed in the Command Preview area.

### Modifying vPars

To modify a vPar, select one of the following items from the Virtual Server Manager Modify menu. For more information about any item, see the corresponding Virtual Server Manager help topic.

**NOTE:** You can modify only one vPar at a time.

- **Base Memory Size** and **Float Memory Size** to modify the memory configurations for a selected vPar.
- **vPar CPU Count** to modify the virtual CPU count for a selected vPar.
- **vPar LAN Settings** to modify VLAN assignments of virtual switch ports connected to the target vPar.
- **Add/Modify Virtual iLO Remote Console** to modify the IP Address and Net mask details of virtual iLO remote console of a vPar. If the vPar does not have a virtual iLO associated with it, you can create the virtual iLO remote console from the Add/Modify Virtual iLO Remote Console screen. For more information, see the Add/Modify Virtual iLO Remote Console help topic.
- **Add Storage Device to vPar** to add a virtual storage device to selected vPar, where the virtual storage device is backed by physical storage and connected to a virtual storage adapter on the VSP.
- **Add Network Device to vPar** to add network devices and vswitches for vPars.
NOTE: Any storage devices that you add are not functional on the vPar until the vPar is started or restarted. When you add a storage device to a started vPar, it might not appear on a Storage tab until the vPar is stopped or restarted. If you add the device to a stopped vPar, the tab displays the device immediately.

- **Add DIO** to add DIOs to a VM or vPar. For more information, see “Adding DIOs” (page 109).
- **Replace DIO H/W path** to replace the h/w path of a DIO owned by a guest, VM or vPar. For more information, see “Replacing DIO H/W path” (page 109).
- **Replace DIO MAC address** to replace the MAC address of DIOs owned by a guest, VM or vPar. For more information, see “Replacing DIO MAC address” (page 110).
- **WBEM Credentials** to set or change WBEM credentials for vPars.

NOTE: This menu is available only when using Virtual Server Manager with HP SMH.

### Booting vPars

Booting a vPar starts the hardware for the vPar. The vPar enters an On state (or is powered on). The Boot and Reset functions are similar except in the following scenario:

The Boot function does not stop and restart a vPar that is already started. It leaves the boot up machine as it is. Whereas, the Reset function stops and restarts the already running vPar.

HP recommends that you use the Reset function instead of the Boot function when you have several vPars that you want to start newly, of which some of them are already started and some of them are currently stopped. The Reset function takes into account all the vPars whether they are already started or not.

If you want the stopped vPars started, you can use the Start function.

You can select multiple vPars and apply the required action.

To boot one or more vPars:

1. Click the Virtual Servers tab.
   
   The vPars are listed in this tab.
2. Select one or more vPars by selecting the check box against each required vPars.
3. Select Tools → Boot virtual partition... from the vPars menu bar.
   
   The Boot virtual partition screen is displayed.

*Figure 76 Boot Virtual Partition*
The Real Command area displays the vPar commands that are executed to boot the vPars.

4. Click **OK** to boot the selected vPars.

**Stopping vPars**

To stop one or more vPars:

1. Click the **Virtual Servers** tab.
   The vPars are listed in this tab.
2. Select one or more vPars by selecting the check box against the vPar.
3. Select **Tools**→**Stop Virtual Partition** from the vPars menu bar.
   The **Stop Virtual Partition** screen is displayed.

**Figure 77 Stop Virtual Partition**

The **General Preview** area shows the vPars that are going to be stopped. The **Real Command** area displays the commands that the vPar Manager will execute to stop the vPars.

4. Select the **How to Stop** option to set the method to stop the vPar. The following options are available:
   - **Graceful stop**: The graceful stop or the `-g` command shuts down the vPar gracefully. The `-g` option does not allow the automatic reboot of the vPar. The vPar must be manually restarted using the `vparboot` command.
   - **Power-off**: The power-off or the `-d` option is equivalent to the PC-off command in the management processor of the specified vPar. The `-d` option does not allow the automatic reboot of the vPar.
     This option abruptly shuts down the vPar operating system without saving the operating system crash dump.

5. Click **OK** to stop the selected vPars.

**Resetting vPars**

When you reset vPars, vPar Manager resets the selected vPar irrespective of whether the vPar is already booted or stopped. The **Reset** and **Boot** functions are similar except that the **Reset** function...
reboots a vPar that is already booted, while the **Boot** function does not (it leaves the booted vPar as it is).

You can use the **Reset** function instead of the **Boot** function when you have several vPars that you want newly booted, some of which are already booted and some currently stopped. The **Reset** function resets all the vPars. However, if you do not want the already booted partitions rebooted, in other words, you just want the stopped partitions booted, use the **Boot** function instead.

To reset one or more vPars:

1. Click the **Virtual Servers** tab.
   
The vPars are listed in this tab.

2. Select one or more vPars by selecting the check box against each required vPar.

3. Select **Tools**→**Reset Virtual Partition** from the vPars menu bar.
   
The **Reset Virtual Partition** screen is displayed.

   **Figure 78 Reset vPars**

   ![Reset vPars](image)

   The **General Preview** area shows the vPars that are going to be reset. The **Real Command** area displays the commands that the vPar Manager will execute to reset the selected vPars.

4. Select the **How to reset** option to set the reset method. The following reset options are available:
   
   - **TOC reset**: The Transfer of Control (TOC) reset using the `-t` option does a soft reset of the selected vPar. The `-t` option is the default operation of the `vparreset` command. For a proper shutdown of the vPar, use the `-h` option.
   
   - **Hard reset**: The hard reset or the `-h` option performs a hard reset of the selected vPar. The `-h` option is equivalent to the `RS` command in the management processor.

5. Click **OK** to reset the selected vPars.

**Creating virtual switches**

Create virtual switches menu is applicable for VMs and vPars. For more information about creating virtual switches, see “Creating virtual switches” (page 102).

**Starting, stopping, and deleting virtual switches**

For details about starting, stopping, and deleting virtual switches, see “Starting, stopping, and deleting virtual switches” (page 105).
Deleting network or storage devices

For details about deleting network or storage devices for vPars, see “Deleting network or storage devices” (page 105).

Deleting vPars

Deleting a vPar removes all configuration files for the vPar and frees up any resources assigned to it, thereby the available resources can be assigned to other vPars. Deleting a vPar does not delete files and data residing on the virtual storage or backing storage that is assigned to the vPar.

**NOTE:** Before you remove a vPar, you must stop the vPar or put to Off state (powered off).

By default, vswitch VLAN port assignments are removed when the vPar is deleted. If any of the ports are connected to other vPars that are not removed, those port assignments are not removed. Clearing the **Remove VLAN Assignment** check box causes vswitch VLAN port assignments to remain after the vPar is deleted.

To remove one or more vPars:

1. Select one or more vPars from the **Virtual Servers** tab.
2. Select **Delete** → **Delete Virtual Partition**. The **Delete Virtual Partition** screen is displayed.

   ![](image)

   **Figure 79 Delete virtual partition**

3. Click **OK** to delete the selected vPars.

Opening iLO console

For details about opening iLO console, see “Opening iLO console” (page 106).

Opening virtual iLO remote console

For details about opening virtual iLO remote console, see “Opening virtual iLO remote console” (page 107).

Deleting virtual iLO remote console

For details about deleting virtual iLO remote console, see “Deleting virtual iLO remote console” (page 108).

Adding DIOs

For details about the adding DIOs, see “Adding DIOs” (page 109).
Replacing DIO H/W path
   For details about replacing H/W paths, see “Replacing DIO H/W path” (page 109).

Replacing DIO MAC address
   For details about replacing DIO MAC addresses, see “Replacing DIO MAC address” (page 110).

Deleting DIOs
   For details about deleting DIOs, see “Deleting DIOs” (page 108).
7 Collecting and viewing utilization data

Certain Integrity Virtual Server Manager views include utilization meters (bar graphs) that display current utilization data for a resource. For example, the **VSP Virtual Servers** tab includes several utilization meters for each vPar and VM listed, as shown in Figure 80. Using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, you can click a meter to view a more detailed historical data report provided by HP Capacity Advisor. These meters are visible when using Integrity Virtual Server Manager with HP SMH, but you cannot click them to obtain a Capacity Advisor report.

**Figure 80 Utilization meters displayed by the VSP Virtual Servers tab**

Using Integrity Virtual Server Manager with HP Matrix Operating Environment, you can cause Capacity Advisor to collect and display historical utilization data for a VSP or selected VMs /vPars.

**Enabling collection of utilization data**

Utilization meters display utilization data retrieved by the WBEM Utilization Provider. WBEM providers are included with Matrix Operating Environment for HP-UX and must be installed on the VSP and each VM or vPar. For more information, see “System and software requirements” (page 13). Using Integrity Virtual Server Manager through HP SMH, viewing utilization meter data specific to VMs or vPars requires certain WBEM credentials to be set. If such credentials are not set, the meters are dimmed. For more information, see “Setting WBEM credentials in HP SMH” (page 16). Meters for the VSP and VSP resources are still available if the VSP’s WBEM Utilization Provider is running.

Using Integrity Virtual Server Manager with Matrix Operating Environment, you can enable collection of utilization data from systems licensed for HP Capacity Advisor. Select the **Tools→Collect Capacity Advisor Data** menu item from the Integrity Virtual Server Manager menu bar. This menu item is not available when using Integrity Virtual Server Manager through HP SMH.

Data is collected by WBEM Utilization Provider software on the licensed systems and stored on the Central Management Server. Data collection is done on individual systems. Results from stdout and stderr are saved to the Systems Insight Manager/Matrix Operating Environment Tasks Results log. Capacity Advisor uses the collected data to calculate the utilization of CPU and memory on targeted systems. You can collect data for:
- All systems licensed to use Capacity Advisor
- Specific selected systems licensed to use Capacity Advisor

To view the collected data, use the **View→Capacity Advisor Data...** menu item, as described in “Viewing utilization data” (page 120).

For information on Capacity Advisor, including prerequisites for using Capacity Advisor features, see the **HP Capacity Advisor User Guide**.
Viewing utilization data

Integrity Virtual Server Manager provides the following options for viewing utilization data. These assume the prerequisites discussed in “Enabling collection of utilization data” (page 119) have been met.

- Utilization meters provided by Integrity Virtual Server Manager tabs. Table 16 lists the meters provided by Integrity Virtual Server Manager tabs. Utilization meters display current utilization data for the associated resource. The utilization information is a 5-minute average that is calculated and updated on 5-minute boundaries. If the utilization cannot be displayed, the utilization meter is dimmed. A label next to the meter indicates the probable cause. For information about these labels, see “Utilization meter status/error information” (page 137).

CPU and memory utilization are expressed as a percentage. Network and storage meters display I/O data in terms of throughput (for example, megabytes per second). Storage meters are labeled as “Disk I/O” but provide utilization data for any supported devices (DVDs and tape devices as well as disks). If a network or storage I/O meter is in a device box on a Network or Storage tab, the data is specific to the device, whether it is a virtual device in a VM or a vPar or a physical device on the VSP; if the meter is in a vPar box, the data is an aggregate, registering the total throughput for all virtual devices on the vPar.

Table 16 Utilization meters available on Integrity Virtual Server Manager tabs

<table>
<thead>
<tr>
<th>Integrity Virtual Server Manager Tab</th>
<th>Utilization Metrics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>CPU (%) Memory (%)</td>
</tr>
<tr>
<td>VSP General</td>
<td>VSP only VSP only</td>
</tr>
<tr>
<td>VSP Virtual Servers</td>
<td>VSP CPU utilization per VM Per VM only</td>
</tr>
<tr>
<td>VSP Network</td>
<td>VSP (Physical Network Interfaces column) VM (Virtual Network Interfaces column)</td>
</tr>
<tr>
<td>VSP Storage</td>
<td>VSP (Physical Storage column) VM (Virtual Storage column)</td>
</tr>
<tr>
<td>VM or vPar Properties General</td>
<td>VM or vPar only VM or vPar only</td>
</tr>
<tr>
<td>VM or vPar Properties Network</td>
<td>VSP (Physical Network Interfaces column) VM or vPar (Virtual Network Interfaces column)</td>
</tr>
</tbody>
</table>
Table 16 Utilization meters available on Integrity Virtual Server Manager tabs (continued)

<table>
<thead>
<tr>
<th>Integrity Virtual Server Manager Tab</th>
<th>Utilization Metrics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>CPU (%)</td>
</tr>
<tr>
<td>VM or vPar Properties</td>
<td></td>
</tr>
<tr>
<td>Storage</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Memory (%)</td>
</tr>
<tr>
<td>Vswitch Properties</td>
<td></td>
</tr>
<tr>
<td>Network</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Network I/O (throughput)</td>
</tr>
<tr>
<td>VSP (Physical Storage column)</td>
<td></td>
</tr>
<tr>
<td>VM or vPar (Virtual Storage column)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Storage I/O (throughput)</td>
</tr>
<tr>
<td>VSP (Physical Network Interfaces column)</td>
<td></td>
</tr>
<tr>
<td>VM or vPar (Virtual Network Interfaces column)</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE:** Data reported by certain Integrity Virtual Server Manager CPU utilization meters might vary from the data collected by Capacity Advisor as displayed in the Profile Viewer and historical utilization reports. The data from Integrity Virtual Server Manager meters is reliable for most purposes. For capacity planning, refer to the data collected by the Capacity Advisor Profile Viewer and historical utilization reports. For more information about how Capacity Advisor data might vary from Integrity Virtual Server Manager data, see “Data Handling” in Chapter 3 of the *HP Capacity Advisor 7.2 User Guide*.

Another source of discrepancy is the difference in the way Capacity Advisor and Integrity Virtual Server Manager present CPU data. Capacity Advisor Profile Viewer and historical utilization reports present CPU data in absolute terms (specifying the number of physical cores used) while Integrity Virtual Server Manager presents CPU data in terms of percentages (specifying the percentage of available CPU resources being used). For example, the Integrity Virtual Server Manager “VSP CPU Utilization” meter displayed on the VSP Virtual Servers and VM or vPar Properties General tabs displays the percentage of the total VSP physical CPU capacity used by the VM or vPar in question. Capacity Advisor tabulates similar data but presents it in different terms. For example, on a VSP that has 16 physical cores, if a VM has 4 CPUs each currently using 50% of a physical core, CapAd would report that the VM is consuming 2 VSP cores. The Integrity Virtual Server Manager “VSP CPU utilization” meter would report that the VM is consuming 12.5% of the VSP’s CPU capacity.

- Using Integrity Virtual Server Manager with HP Matrix Operating Environment:
  - You can click a utilization meter to view a more detailed historical data report provided by HP Capacity Advisor.
  - You can use the Integrity Virtual Server Manager View→Capacity Advisor Data... menu item to view a snapshot of recent utilization data collected by HP Capacity Advisor. First, you must enable collection of data by using the Tools→Collect Capacity Advisor Data menu item, as described in “Enabling collection of utilization data” (page 119). (If you use the Integrity Virtual Server Manager View→Capacity Advisor Data... menu item without having enabled data collection, no data is displayed; however, the screen includes a link to the Collect Capacity Advisor Data facility so that you can begin collecting data to view.)

Figure 81 (page 122) shows the upper half of the screen showing data collected for a VSP, while Figure 82 (page 123) shows the lower half of the screen.
Figure 81 View Capacity Advisor data screen: upper half

**CPU Utilization for tornado.aa.bb.com**

Observed: Forecasted Data: Wed, 8/19/2009 12:35 AM EDT - Wed, 8/26/2009 12:00 AM EDT

This graph shows the observed CPU utilization in terms of the number of CPU cores used for each five minute sample over the specified time interval. In this graph, each CPU is equivalent to a Core. The observed data represents actual utilization provider measurements for the "tornado.fc.hp.com" system.
The data collection view is provided by the Capacity Advisor Profile Viewer. The Profile Viewer displays historical utilization data along with additional information you provide. The Profile Viewer also enables you to examine different time intervals and different categories of data. In the Capacity Advisor graphs, you can view utilization data for both CPUs and memory. You can also view network and disk bandwidth utilization (throughput) for whole OS profiles. For more information about the Capacity Advisor Profile Viewer, see the HP Capacity Advisor 7.2 User Guide or the Capacity Advisor Profile Viewer Screen help topic.

When you click the **View → Capacity Advisor Data...** menu item without any VMs or vPars selected on the current tab, the screen shows utilization data pertaining to the VSP.

The data provided by the **View → Capacity Advisor Data...** menu item is similar to what is provided by clicking on a utilization meter. However, clicking on a meter presets certain parameters, such as what type of utilization metric to display and for which system (VSP or a particular vPar, for example). Nevertheless, you can change parameters once the screen comes up.

- You can use the **Tools → Capacity Advisor Historic Report** menu item to create a comprehensive report that collects and analyzes data over specified time periods from specified sources, as described in “Creating a historical utilization data report” (page 124). The report can be browsed and saved.
Creating a historical utilization data report

To use HP Capacity Advisor to create a historical utilization report that includes data for the target workloads, systems, complexes, or scenarios you specify, select the **Tools → Capacity Advisor Historic Report** menu item from the Integrity Virtual Server Manager menu bar. This menu item is available only when you use Integrity Virtual Server Manager with Matrix Operating Environment; it is not available when using Integrity Virtual Server Manager through HP SMH. Before creating a report, you must have collected data on the systems of interest (see “Enabling collection of utilization data” (page 119)).

HP Capacity Advisor reports provide information about utilization and allocation data that have been collected and analyzed. This facility gives you the flexibility of analyzing and showing data collected over specified time periods. A wizard allows you to set a variety of parameters to determine the time periods and systems for data collection and analysis. The report can be browsed (the screen is presented in a new browser window) and saved. In contrast, the **View → Capacity Advisor Data...** menu item gives a snapshot of utilization that’s more limited to the current, most recent time period.

Capacity Advisor collects data for the following resources or targets: systems, workloads, complexes, and scenarios. For these targets, Capacity Advisor provides utilization information in the following reports:

- System Utilization Report
- Workload Utilization Report
- Complex Utilization Report
- Scenario Utilization Report
8 Viewing logs and version information

Viewing VSP, VM, or vPar logs

You can view the events logged by Integrity VM or vPar for the VSP by selecting View→VSP log... from the Integrity Virtual Server Manager menu bar. This gives a display similar to that created by the `hpvmstatus -eM` command (used at the Integrity VM CLI), except Integrity Virtual Server Manager limits the display to the most recent 1000 log lines. The VSP event log records all changes to configurations of the VSP and to VMs or vPars on the VSP, including information about commands issued and error messages.

You can view the events logged by Integrity VM pertaining to a selected VM or vPar by selecting View→Log for VM or vPar... from the Integrity Virtual Server Manager menu bar (if you are in a VSP or Vswitch Properties view, a VM or a vPar must be selected). This gives the same display that the `hpvmstatus -eM -P vm-name` command would give when used at the Integrity VM CLI (where `vm-name` is the name of the VM or the vPar). The event log records all changes to configurations of the VM or vPar and information about commands issued and error messages.

**NOTE:** With Integrity Virtual Server Manager running under HP SMH, to view the Integrity VM logs using either of these View menu items, you must be logged into HP SMH with either Operator or Administrator privileges. For more information, see the HP SMH documentation, available from the following website (click the Support and Documents link):

http://www.hp.com/go/smh

Some reasons that you might want to view either log include the following:

- To confirm a change that you made to a running VM or vPar. This is especially useful when the Integrity Virtual Server Manager does not immediately display the changed data, such as modification of memory or the number of virtual CPUs for a running VM or vPar. In such circumstances, Integrity Virtual Server Manager does not display the new data until the VM or vPar is shut down or restarted.

- To review an error message that resulted from an Integrity VM command run by Integrity Virtual Server Manager, or to view the actual command line that was run. Integrity Virtual Server Manager displays, or allows you to view this information, at the time of the action. This view allows you to review the information at a later time without having to access a log manually from the VSP.

- To view commands, logged information, and error messages obtained directly from the Integrity VM CLI and that might not have been recorded by Integrity Virtual Server Manager.

- To view other information logged on the VSP, such as the status of the VM or the vPar subsystem startup sequence (this information includes whether the VM or vPar starts automatically when the Integrity VSP starts or remains in the Off state until manually started).

Viewing the VSP log

To view the VSP log:
1. Select **View**→**VSP Log** in the **Virtual Servers** tab. The log for VSP is displayed.

![Figure 83 View VSP log](image)

2. Click **OK** to return to the previous screen.

Viewing the VM or vPar log

To view the VM or vPar log:

1. Select **View**→**VM or vPar Log** in the **Virtual Servers** tab. The log for VM or vPar is displayed.

![Figure 84 View vPar log](image)

2. Click **OK** to return to the previous screen.

Viewing Integrity Virtual Server Manager, Integrity VM, and WBEM Provider versions

You can view the version numbers of Integrity Virtual Server Manager, Integrity VM, and WBEM providers by selecting **View**→**Integrity Virtual Server Manager Version Information** from the Integrity 126 Viewing logs and version information
Virtual Server Manager menu bar. The resulting screen reports the current versions of Integrity VM, of Integrity Virtual Server Manager, and of the providers on both the VSP and each VM or vPar. Figure 85 shows an example of a screen. If “No Permission” is displayed where a VM’s WBEM provider version or a vPar’s WBEM provider version should be, the WBEM credentials (user name and password) have not been set for that vPar. For more information on setting WBEM credentials, see “Setting security credentials” (page 15).

Figure 85 Integrity Virtual Server Manager Version Information screen
9 Support and other resources

Information to collect before contacting HP

Be sure to have the following information available before you contact HP:

• Software product name
• Hardware product model number
• Operating system type and version
• Applicable error message
• Third-party hardware or software
• Technical support registration number (if applicable)

How to contact HP

Use the following methods to contact HP technical support:

• In the United States, see the Customer Service / Contact HP United States website for contact options:
• In the United States, call 1-800-HP-INVENT (1-800-474-6836) to contact HP by telephone. This service is available 24 hours a day, 7 days a week. For continuous quality improvement, conversations might be recorded or monitored.
• In other locations, see the Contact HP Worldwide website for contact options:

Security bulletin and alert policy for non-HP owned software components

Open source software (such as OpenSSL) or third-party software (such as Java) are sometimes included in HP products. HP discloses that the non-HP owned software components listed in the Insight Management end user license agreement (EULA) are included with Insight Management. The EULA is included with the Insight Management Installer on Insight Management DVD #1. HP addresses security bulletins for the software components listed in the EULA with the same level of support afforded HP products. HP is committed to reducing security defects and helping you mitigate the risks associated with security defects when they do occur.

When a security defect is found, HP has a well defined process that culminates with the publication of a security bulletin. The security bulletin provides you with a high level description of the problem and explains how to mitigate the security defect.

Subscription service

HP recommends that you register your product at the Subscriber’s Choice for Business website:
After registering, you will receive email notification of product enhancements, new driver versions, firmware updates, and other product resources.

Registering for software technical support and update service

Insight Management includes one year of 24 x 7 HP Software Technical Support and Update Service. This service provides access to HP technical resources for assistance in resolving software implementation or operations problems.
The service also provides access to software updates and reference manuals in electronic form as they are made available from HP.

With this service, Insight Management customers benefit from expedited problem resolution as well as proactive notification and delivery of software updates. For more information about this service, see the following website:

http://www.hp.com/services/insight

Registration for this service takes place following online redemption of the license certificate.

How to use your software technical support and update

As HP releases updates to software, the latest versions of the software and documentation are made available to you. The Software Updates and Licensing portal gives you access to software, documentation, and license updates for products on your HP software support agreement.

You can access this portal from the HP Support Center:

http://www.hp.com/go/hpsc

After creating your profile and linking your support agreements to your profile, see the Software Updates and Licensing portal at http://www.hp.com/go/hpsoftwareupdatesupport to obtain software, documentation, and license updates.

HP authorized resellers

For the name of the nearest HP authorized reseller, see the following sources:

• In the United States, see the HP U.S. service locator website:
  http://www.hp.com/service_locator

• In other locations, see the Contact HP worldwide website:
  http://www.hp.com/go/assistance

New and changed information in this edition

The VM or vPar properties general tab section is updated with details about base and float memory values for vPars.

Related information

Documents

• HP Matrix Operating Environment 7.2 Getting Started Guide available at:
  http://www.hp.com/go/matrixoe/docs

• HP Integrity Virtual Server Manager 6.2 User Guide available at:
  http://www.hp.com/go/matrixoe/docs

• HP Integrity Virtual Server Manager 6.2 Release Notes available at:
  http://www.hp.com/go/matrixoe/docs

• HP-UX vPars and Integrity VM 6.2 Administrator Guide available at:
  http://www.hp.com/go/hpux-vpars-docs
• HP-UX vPars and Integrity VM 6.2 Release Notes available at:
  http://www.hp.com/go/hpux-vpars-docs

• HP-UX GUID Manager Administrator Guide available at:
  http://www.hp.com/go/hpux-vpars-docs

Websites

• Matrix Operating Environment documentation http://www.hp.com/go/matrixoe/docs
• Matrix Operating Environment for HP-UX: http://www.hp.com/go/matrixoe/integrity
• Matrix Operating Environment: http://www.hp.com/go/matrixoe

Typographic conventions

This document uses the following typographical conventions:

<table>
<thead>
<tr>
<th>Book title</th>
<th>The title of a book. On the web, this can be a hyperlink to the book itself.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>A command name or command phrase, for example ls -a.</td>
</tr>
<tr>
<td>Computer output</td>
<td>Information displayed by the computer.</td>
</tr>
<tr>
<td>Ctrl+x or Ctrl-x</td>
<td>A key sequence that indicates you must hold down the keyboard key labeled Ctrl while you press the letter x.</td>
</tr>
<tr>
<td>ENVIRONMENT VARIABLE</td>
<td>The name of an environment variable, for example, PATH.</td>
</tr>
<tr>
<td>Key</td>
<td>The name of a keyboard key. Return and Enter both refer to the same key.</td>
</tr>
<tr>
<td>Term</td>
<td>A term or phrase that is defined in the body text of the document, not in a glossary.</td>
</tr>
<tr>
<td>User input</td>
<td>Indicates commands and text that you type exactly as shown.</td>
</tr>
<tr>
<td>Replaceable</td>
<td>The name of a placeholder that you replace with an actual value.</td>
</tr>
<tr>
<td>[]</td>
<td>In command syntax statements, these characters enclose optional content.</td>
</tr>
<tr>
<td>{}</td>
<td>In command syntax statements, these characters enclose required content.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td>Indicates that the preceding element can be repeated one or more times.</td>
</tr>
<tr>
<td>WARNING</td>
<td>An alert that calls attention to important information that, if not understood or followed, results in personal injury.</td>
</tr>
<tr>
<td>CAUTION</td>
<td>An alert that calls attention to important information that, if not understood or followed, results in data loss, data corruption, or damage to hardware or software.</td>
</tr>
<tr>
<td>IMPORTANT</td>
<td>An alert that calls attention to essential information.</td>
</tr>
<tr>
<td>NOTE</td>
<td>An alert that contains additional or supplementary information.</td>
</tr>
<tr>
<td>TIP</td>
<td>An alert that provides helpful information.</td>
</tr>
</tbody>
</table>
10 Documentation feedback

HP is committed to providing documentation that meets your needs. To help us improve the documentation, send any errors, suggestions, or comments to Documentation Feedback (docsfeedback@hp.com). Include the document title and part number, version number, or the URL when submitting your feedback.
A Error messages, status indicators, and troubleshooting

This appendix discusses error messages and troubleshooting related to Integrity Virtual Server Manager problems, and describes the status indicators that appear on some Integrity Virtual Server Manager screens and the error and status labels that might appear with utilization meters (bar graphs) displayed on certain Integrity Virtual Server Manager screens.

Error messages

Error messages visible in Integrity Virtual Server Manager are returned primarily from the Integrity VM commands themselves. This section describes how to review such error messages as logged by Integrity VM and includes information about error messages that might be seen when attempting to access Integrity Virtual Server Manager. Other errors or problems are discussed in “Troubleshooting VM or vPar problems” (page 138).

Reviewing error messages

To review an error message that resulted from an Integrity VM command run by Integrity Virtual Server Manager in the past (and so is not currently viewable), you can select View→VSP log... or View→VM or vPar log... The former menu item displays events logged by Integrity VM that pertain to the VSP and all its guests. The latter menu item displays events logged by Integrity VM that pertain to a specific VM or vPar. For more information, see “Viewing VSP, VM, or vPar logs” (page 125).

For more information about error messages related to Integrity VM, see the HP-UX vPars and Integrity VM Administrator Guide manual.

Errors accessing Integrity Virtual Server Manager

Under certain circumstances, errors can occur when attempting to enter Integrity Virtual Server Manager from HP Matrix OE visualization (Matrix Operating Environment for HP-UX) or from the HP System Management Homepage. In those cases, a page titled “Access failure” is displayed with the name of the VSP system and the reason for the failure to enter Integrity Virtual Server Manager. The following list describes the access failure messages that you might receive:

- Incorrect permissions. An error occurred communicating with WBEM: CIM_ERR_ACCESS_DENIED. The following is an example of the error message displayed for a user, hpsmh:
  
  The user 'hpsmh' is not authorized to run 'EnumerateInstances' in the namespace 'root/cimv2/hpvm'.

  CIM_ERR_ACCESS_DENIED (part of the error message mentioned earlier) indicates that a CIM user is not authorized to access the namespace.

  This error occurs when a user with specific credentials uses a WBEM connection to access the VM WBEM services listening at ports 5988 and 5989 without sufficient permissions. For a WBEM user to access the WBEM services, the user must be provided with sufficient permissions.

  This issue does not occur if the CIM configuration parameter enableNamespaceAuthorization is set to FALSE. If the value is set to FALSE, irrespective of whether the users are SIM or SMH users, they can access WBEM services.

  To resolve the issue, first examine the value of the configuration parameter, enableNamespaceAuthorization.

  To examine the configuration parameter settings, run the following command: cimconfig -lp
This command lists all the configuration parameters. Verify whether the enableNamespaceAuthorization parameter is set to TRUE. If it is set to TRUE, follow these steps:

1. To access WBEM Providers from HP Systems Insight Manager, run the following command:
   ```
   # cimauth -a -u <SIMUSER> -n root/cimv2/hpvm -R -W
   # cimconfig -s enableNamespaceAuthorization=true -p
   ```
   where, SIMUSER is the username created for SIM access.

2. To access WBEM Providers from HP SMH, run the following command:
   ```
   # cimauth -a -u <SMHUSER> -n root/cimv2/hpvm -R -W
   # cimconfig -s enableNamespaceAuthorization=true -p
   ```
   where, SMHUSER is the username created for SMH access.

• The user is not authorized to monitor the VSP in Systems Insight Manager/Matrix Operating Environment. Authority to monitor the VSP is required when using Integrity Virtual Server Manager for accessing the VSP or for accessing any hosted VM within the Matrix Operating Environment environment.

To use Integrity Virtual Server Manager, an Systems Insight Manager/Matrix Operating Environment user must have at least Monitor Tools authorization for the VSP system. If a user has authority to manage an individual VM or vPar but is not authorized within Systems Insight Manager/Matrix Operating Environment to monitor the VSP system that contains it, the error message appears when the user selects the Integrity Virtual Server Manager icon in the VM’s or vPar’s system box displayed by the HP Matrix OE visualization Visualization tab. To return to HP Matrix OE visualization, select All VSE Resources in the left-hand navigation pane of Systems Insight Manager/Matrix Operating Environment (System and Event Collections→Systems→Shared→Systems by Type→All VSE Resources).

• The VSP is not known to Systems Insight Manager/Matrix Operating Environment. The VSP must be known to use Integrity Virtual Server Manager for the VSP or for any VSPed by it.

It is possible that a VM or a vPar might be discovered by Systems Insight Manager while the containing VSP has not yet been discovered. To use Integrity Virtual Server Manager, both the VM or vPar and the containing VSP must be discovered by Systems Insight Manager. This error message appears when you select a VM or vPar link in the VM or vPar system box displayed in HP Matrix OE visualization before Systems Insight Manager has discovered the VM’s or vPar’s VSP. To return to HP Matrix OE visualization, select the All VSE Resources link in the left-hand navigation bar of Systems Insight Manager (System and Event Collections→Systems→Shared→Systems by Type→All VSE Resources).

• The user is not authorized to use Integrity Virtual Server Manager on this VSP.

With HP SMH, Integrity Virtual Server Manager is configured by default to permit read-only access to HP SMH users with User-level privileges, and read-write access to HP SMH users with Operator-level and Administrator-level privileges. However, it is possible to reconfigure these permissions to deny all Integrity Virtual Server Manager access to User-level and Operator-level users. In this case, these users can log into HP SMH, but they are denied access to Integrity Virtual Server Manager. To return to the SMH Homepage, select Home in the top navigation link.

With Matrix Operating Environment for HP-UX, users need VSE All Tools authorization to view all Integrity Virtual Server Manager screens and perform all Integrity Virtual Server Manager menu actions.

If other messages are displayed on an Access failure page, contact your HP Technical Support Representative for further assistance.
Status indicators

In several actions and views, the status of a component is represented by an icon next to the component name or label. For example, the icon next to the name of a VM or a vPar shows whether the VM or vPar is up or down. A question mark (?) means no information is available. Table 17 explains the meaning of each status icon.

Table 17 Status icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Indication</th>
<th>Possible meanings in more detail</th>
</tr>
</thead>
<tbody>
<tr>
<td>![on_up_normal_icon]</td>
<td>On/Up/Normal</td>
<td>The VM or vPar is started or starting; devices are powered on and active; the operating system is up or in the last part of the boot sequence; no fault was detected.</td>
</tr>
<tr>
<td>![off_down_disabled_icon]</td>
<td>Off/Down/Disabled</td>
<td>The VM or vPar has stopped or is stopping; the devices are powered off, or powered on but inactive; the operating system is down, shutting down, or in the first part of the boot sequence. For a VM that has migrated to another VSP (the target), this icon indicates the VM is no longer runnable on the source VSP, meaning that you cannot start or modify it. After the migration has finished, you can delete the VM from the source VSP.</td>
</tr>
<tr>
<td>![suspend_icon]</td>
<td>Suspended</td>
<td>The VM is in a suspended state.</td>
</tr>
<tr>
<td>![serviceguard_package_icon]</td>
<td>Serviceguard package</td>
<td>The VM or vPar is configured as a Serviceguard package; flyover text indicates the VM or vPar is a Serviceguard package.</td>
</tr>
<tr>
<td>![managed_by_another_vsp_icon]</td>
<td>Managed by another VSP</td>
<td>The VM or vPar is a Serviceguard package that is running on another VSP; flyover text indicates hardware status (On) and the name of the VSP.</td>
</tr>
<tr>
<td>![unknown_icon]</td>
<td>Unknown</td>
<td>The Integrity Virtual Server Manager cannot read information about VMs or vPars or devices, or cannot obtain this information from the remote WBEM services provider. This does not necessarily indicate an error condition. For example, some information (such as memory configuration) cannot be obtained if the VM or vPar is powered off or has not completed a restart.</td>
</tr>
<tr>
<td>![critical_icon]</td>
<td>Critical</td>
<td>A critical problem with the VM or vPar or device configuration has been detected.</td>
</tr>
<tr>
<td>![major_icon]</td>
<td>Major</td>
<td>The VM or vPar is experiencing major performance problems.</td>
</tr>
<tr>
<td>![migrating_to_another_vsp_icon]</td>
<td>Migrating to another VSP</td>
<td>The VM is currently migrating from this VSP (source) to another VSP (target).</td>
</tr>
<tr>
<td>![migrating_from_another_vsp_icon]</td>
<td>Migrating from another VSP</td>
<td>The VM is currently migrating from another VSP (source) to this VSP (target).</td>
</tr>
<tr>
<td>![waiting_for_migration_icon]</td>
<td>Waiting for migration</td>
<td>The VM is in queue, waiting to migrate. When multiple VMs are selected to migrate, only one is migrated at a time.</td>
</tr>
<tr>
<td>![migration_error_icon]</td>
<td>Migration error</td>
<td>An error was detected during the latest attempt to migrate one or more VMs to another VSP.</td>
</tr>
</tbody>
</table>

Utilization meter status/error information

When a utilization meter visible on one of the Integrity Virtual Server Manager tabs is dimmed (rather than displaying a utilization value), a label indicates the probable cause. The following list describes the labels or status indicators:
• **No Comm.** indicates that Integrity Virtual Server Manager is unable to communicate with the WBEM provider running on a VM or vPar. Hover the cursor over the meter to display an exception error message identifying the problem.

A common reason for the **No Comm.** label to be displayed is a problem with trusted certificates. For example, if trusted certificates are required (the **Require trusted certificates** check box was selected on the **Set WBEM Credentials for VM or vPar** page) but the keystore on the VSP does not trust the certificate from the VM or vPar, then the certificate is not in the keystore, has expired, did not match the VM or vPar name, or is otherwise invalid. For information about trusted certificates, see “Trusted certificates” (page 18).

If the WBEM provider is unresponsive, you might need to restart it.

• **No Data** indicates one of the following:
  - Data is being collected, but it can take up to 10 minutes to display utilization data.
  - The VM or vPar is not started, not booted, or cannot be contacted by the system on which Integrity Virtual Server Manager is running.
  - The VSP has no WBEM credentials for collecting the data from the VM or vPar. Normally, this is only seen for invalid or missing WBEM credentials for a Windows VM guest. See the discussion of the **No Perm** label. For more information about WBEM credentials, see “Setting security credentials” (page 15).

For more information about problems displaying data (data is out of date, incomplete, or missing), see “Troubleshooting VM or vPar problems” (page 138).

• **No Perm.** indicates that the VSP lacks or has invalid WBEM credentials for collecting the data from the VM or vPar.

• **Timed Out** indicates that Integrity Virtual Server Manager attempted to retrieve utilization data but received no response from the WBEM provider on the VM or vPar because of one of the following situations:
  - The WBEM provider for the data is not running, is not installed, or is disabled on the VM or vPar.
  - Network problems are preventing a timely response.

For more information about collecting and viewing utilization data, see Chapter 7 (page 119).

**Troubleshooting VM or vPar problems**

This section discusses problems that might occur when using Integrity Virtual Server Manager to create, start, or modify a VM or a vPar or to display VM or vPar data. Also included are ways for resolving these problems.

• **Utilization data for OpenVMS guests is not displayed**
  The utilization data for OpenVMS guests may not be visible after the first installation of the OpenVMS operating system or after rebooting the OpenVMS guests. This is because, by default, the TCP/IP and WBEM Provider services do not start automatically after rebooting the OpenVMS guest machine.
  The TCP/IP, the WBEM Services, and the Utilization Provider products are not installed by default on an OpenVMS guest. Ensure that the TCP/IP, the WBEM services, and the Utilization Provider products are installed, configured, and started on the guest. After rebooting the guest, verify if the TCP/IP and WBEM services have been started. If not, restart TCP/IP and/or WBEM services manually or add the command in the startup script so that they start automatically when the OpenVMS guest reboots. For more information, see the OpenVMS documentation on setting up TCP/IP and WBEM Provider services.

• **Failure creating a VM**
  When using the Create Virtual Machines wizard, a number of warning or error conditions can prevent the VM or vPar from being created. However, if the **Create VM even if resources are not consumed** check box was selected on the **Create Virtual Machines** page, the VM or vPar will be created even if the resources are not consumed.
are insufficient, missing or unavailable check box is selected on the Create Virtual Machines wizard Summary page, you can still have Integrity Virtual Server Manager create the VM. You will have to correct the conditions prior to starting the VM.

- **Failure starting a VM or a vPar**
  The most likely cause for a VM or a vPar failing to start is missing, insufficient, or unavailable resources. Make sure the required resources are made available. For example:
  - Not enough memory on the VSP is available for the VM or vPar
    Make sure that enough memory is available on the VSP to provide the memory you allocated for the new VM or vPar (in addition to providing for the existing VMs or vPars).
  - You specified a device that is already in use by another VM or vPar
    You might have specified a network or storage device that is already in use by another VM or vPar. You need to return to the appropriate Create Wizard page to select a device that is not in use. To determine what devices are already in use, examine the VSP Network or VSP Storage tab.
  - A file specified as a backing device does not exist
    You might have incorrectly specified the name or path of a file to be used as a backing storage device, or you specified a file that does not exist.
  - The VM is currently migrating online or has migrated to another VSP (and is in a Not Runnable state).

- **Failure to modify the VM CPU entitlement**
  If you attempt to modify (by selecting Modify → CPU Entitlement for VM) the CPU entitlement of a VM that is being managed by gWLM, the following error message is displayed, where virtual-machine-name is the name of the VM:
  ```
  The processor entitlement for VM virtual-machine-name cannot be modified because it is being managed by gWLM. To adjust the processor entitlement for this VM, use gWLM to change the policy associated with this VM.
  To create or modify the gWLM policy for this VM, use the Policy menu (available when using Integrity Virtual Server Manager with the Matrix Operating Environment for HP-UX).
  ```

- **Information is out of date, incomplete, or missing**
  In general, Integrity Virtual Server Manager tabbed view screens are refreshed automatically every five minutes. An indicator on these visualization pages notifies you when the data was last refreshed. Integrity Virtual Server Manager screens that display configuration data are updated instantaneously when you use Integrity Virtual Server Manager to change the related configuration parameters.

  **NOTE:** When changes to VM or vPar I/O configuration are made using tools other than Integrity Virtual Server Manager (such as adding or removing I/O devices by using the VSP command line), the updated configuration data is not shown until the screen is refreshed. You can manually refresh a tabbed view screen and certain dialog screens (such as those for adding storage or network devices) by clicking on the Refresh Data link.

  If information about certain VMs or vPars is missing from a Integrity Virtual Server Manager screen (for example, specifics about a port interface), the screen might need refreshing, the VMs or vPars might not yet be started or, if they are started, the VM Provider or certain WBEM components might not be running on those VMs or vPars or on the VSP. WBEM components are required on any VM or vPar for which you want data. If the VM Provider is not running on the VSP, no data will be available on any Integrity Virtual Server Manager tabs; all tabs will display a “No data available” message. To verify that the VM Provider is running, enter the following command on the VM or vPar or VSP:
  ```bash
cimprovider -ls
  ```
The response “HPVMProviderModule OK” indicates the VM Provider is running. Any other response indicates it is not running. For system and software requirements regarding the VM Provider, see “System and software requirements” (page 13). For installation instructions and information about providers that must be installed and running on VMs or vPars, see the HP-UX vPars and Integrity VM Administrator Guide manual.

- **Device special file displayed as unknown device**
  If you use Integrity Virtual Server Manager to manage a VSP running Integrity VM Version 3.5 or earlier, Integrity Virtual Server Manager does not fully support virtual device special files located in /hpap (introduced in HP StorageWorks Secure Path software Version 3.0F SP2) as backing devices for virtual storage. If a virtual storage device using an /hpap device special file already exists on a VM or vPar managed by, Integrity Virtual Server Manager displays it on the VSP Storage and VM Properties Storage tabs as an unknown device (using the question mark icon, 🤔). Integrity Virtual Server Manager displays the correct device special file name (for example, /hpap/rdsk/hpap1) but the box representing this device is not connected to the boxes that represent the physical storage devices associated with that virtual device special file. In general, Integrity Virtual Server Manager correctly displays only those device special files located in /dev.

- **Deleted VM or vPar still appears in HP Matrix OE visualization**
  Using Integrity Virtual Server Manager with Matrix Operating Environment for HP-UX, if you create a VM or vPar and then delete it before the new VM or vPar has been identified by Systems Insight Manager, the VM or vPar might appear in HP Matrix OE visualization as though it had not been deleted. The appearance of the VM or vPar in HP Matrix OE visualization depends on when the deletion occurred during the Systems Insight Manager identification process. This is not an issue when using Integrity Virtual Server Manager from HP SMH. In addition, if you decide to delete the VM or vPar soon after creating it, wait a few minutes before doing so. If the deleted VM or vPar does appear in HP Matrix OE visualization, delete it from the Systems Insight Manager All System view. (From the Systems Insight Manager Systems and Event Collections list in the navigation area on the left, select All Systems.) For more information, see the HP Matrix Operating Environment Getting Started Guide.

- **Created VM or vPar does not appear immediately in HP Matrix OE visualization**
  After creating a VM or vPar using Integrity Virtual Server Manager, if you return immediately to HP Matrix OE visualization, the machine might not yet appear in HP Matrix OE visualization. This means Systems Insight Manager has not yet completed identifying the new VM or vPar. However, it appears when the identification process completes (usually within a minute or two).
Glossary

The following terms are commonly used to discuss Integrity Virtual Server Manager and its integrated components:

**Accelerated Virtual Input/Output (AVIO)**
A program that regularly gathers information or performs some other service without the user's immediate presence. Matrix Operating Environment for HP-UX relies on agents on managed systems to provide in-depth hardware and software information.

**agent**
A program that regularly gathers information or performs some other service without the user's immediate presence. Matrix Operating Environment for HP-UX relies on agents on managed systems to provide in-depth hardware and software information.

**agile addressing**
Supported on Integrity VM running HP-UX 11i v3, a storage device addressing model that addresses a logical unit (referred to as LUN, this is the logical device that refers to the physical storage device) by using the same device special file (DSF) regardless of the location of the LUN. The addressing model uses a worldwide device identifier (WWID) to uniquely identify LUNs. The WWID is a device attribute that is independent of the device[s] location in a SAN or in an adapter/controller access path. With a multipath device, the WWID allows one persistent DSF and one LUN hardware path to represent the device, regardless of the number of legacy hardware paths. Therefore, an agile device address remains the same (is persistent) when changes are made to the access path. Likewise, if additional paths are offered to a given LUN (by adding a new SCSI controller or new SCSI target paths), the DSF is unaffected: no new DSFs need be provided. This model enables Integrity Virtual Server Manager to display one DSF for each multipath device instead of displaying a separate DSF for each path to the device (as done when using the legacy addressing scheme).

**AVA**
Automatic Port Aggregation. A combination of LAN ports that can be accessed through a single interface name. An APA creates link aggregates (often called trunks) that provide a logical grouping of two or more physical ports into a single “fat pipe.” This port arrangement provides more data bandwidth and higher reliability than would otherwise be available.

**AVIO**
Accelerated Virtual Input/Output. An I/O protocol that improves virtual I/O performance for network and storage devices used within the Integrity VM environment. The protocol also enables support for a greater number of virtual I/O devices per guest. For each vPar containing an AVIO device, the VSP OS and the guest OS must support AVIO.

**backing device**
Backings store. The physical device (such as a network adapter, a disk, or a file) on the VSP that is allocated to guests.

**cluster**
Two or more systems configured together to host workloads. Users are unaware that more than one system is hosting the workload.

**core**
The actual data-processing engine within a processor. A single processor might have multiple cores, and a core might support multiple execution threads. A virtual processor core in a VM is also called a vCPU.

**CPU**
Virtual CPU. A single-core virtual processor in a virtual machine or virtual partition. See also core, processor.

**dedicated vswitch**
A vswitch that is dedicated to use by a certain virtual machine or virtual partition. This type of vswitch cannot be shared by multiple vPars running at the same time.

**EFI**
Extensible Firmware Interface. The system firmware user interface that allows boot-related configuration changes and operations on Itanium-based systems. For example, EFI provides ways to specify boot options and list boot devices.

**entitlement**
The amount of a system resource (for example, processor resources) that is guaranteed to a virtual machine. The actual allocation of resources to the VM can be greater or less than its entitlement, depending on the VM's demand for processor resources and the overall system processor load.

**entitlement cap**
The maximum amount of computing power allotted to a virtual machine for each CPU.

**guest**
The vPar running the guest OS and guest applications.

**guest OS**
Guest operating system.
The VSP, which is the controlling operating system that allows multiple vPars (VMs) to be booted on a single server or nPartition.

A system or partition that is running an instance of an operating system.

HP Integrity VM. The HP product that allows you to install and run multiple systems (virtual machines or virtual partitions) on the same physical host system.

The storage device addressing model that uses the device special file (DSF) path as defined in HP-UX 11 i v2 and earlier versions. In contrast to the agile addressing model introduced with HP-UX 11 i v3, the legacy device special file (DSF) is bound to a specific hardware path to a storage device. For this reason, a device with multiple paths is represented by several legacy DSFs. If the physical storage device is reconnected to a host through a different host bus adapter (HBA) or a different target port, the address represented by the DSF is affected, requiring reconfiguration of applications, volume managers, or file systems. Likewise, if additional paths are offered to a given LUN (through the addition of a new SCSI controller or new SCSI target paths), an equal number of additional DSFs are required to address them.

See also agile addressing.

A vswitch created by default when Integrity VM is installed on a VSP. The local network created by this vswitch can be used for communications among guests but not for communication between the VSP and any guest or between any external system and a VM guest.

A system running under HP Systems Insight Manager/HP Matrix Operating Environment. Systems become managed nodes through the Systems Insight Manager discovery mechanism.

See managed node.

Multiserver Environment group. A set of Integrity VM servers can be grouped into an Integrity VM MSE group, as required when a set of Integrity VM servers is also configured as a Serviceguard cluster.

Network interface card. Also called LAN card, LAN adapter, or PPA.

A partition in a cell-based server that consists of one or more cells, and one or more I/O chassis. Each nPartition operates independently of other nPartitions and either runs a single instance of an operating system or is further divided into vPars.

nPartitions can be used as compartments managed by Global Workload Manager (gWLM) as long as several requirements are met. Refer to the gWLM online help for a description of nPartition requirements.

Also referred to as the central processor unit (CPU), a processor is the hardware component in a computer that processes instructions and plugs into a processor socket. A processor can contain more than one core.

See also core.

HP Serviceguard. A product that allows you to create high-availability clusters of HP 9000 or HP Integrity servers. By installing Serviceguard on an HP Integrity VSP system, Serviceguard can manage Integrity VM virtual machines or virtual partitions as Serviceguard packages. A Serviceguard package groups application services (individual HP-UX processes) together and maintains them on multiple nodes in the cluster, making them available for failover. When the VSP system fails, the guests automatically fail over to another node in the Integrity VM multiserver environment (MSE group). By installing Serviceguard on HP Integrity guests, each guest becomes a Serviceguard cluster node. When a virtual machine or virtual partition fails, the guest applications can fail over to another guest configured as a Serviceguard node or to another server or partition.

A vswitch that can be used by more than one active virtual machine or virtual partition.

The WBEM services provider for real-time utilization data from managed systems.

See CPU.

A software entity provided by HP Integrity VM. This technology allows a single server or nPartition to act as a VSP for multiple individual VMs, each running its own instance of an operating system (referred to as a guest OS). VMs are managed systems under Matrix Operating Environment for HP-UX. Other providers of VMs include VMware ESX, VMware ESXi, or Microsoft Hyper-V.
| **virtual machine or virtual partition console** | The user-mode application that provides console emulation for virtual machine or virtual partition. Each instance of the VM or vPar console is one console session for its associated VM or vPar. |
| **virtual network** | A LAN that is shared by the VMs or vPars running on the same VSP or in the same Serviceguard cluster. |
| **virtual partition** | A vPar is a software partition of a hard partition that contains an instance of HP-UX. Though a hard partition can contain multiple vPars, a vPar cannot span a hard partition boundary. |
| **virtual switch** | See vswitch. |
| **VLAN** | Virtual LAN. Defines logical connectivity instead of the physical connectivity defined by a LAN. A VLAN provides a way to partition a LAN logically such that the broadcast domain for a VLAN is limited to the nodes and switches that are members of the VLAN. |
| **VM** | See virtual machine. |
| **VM Provider** | The WBEM services provider for VSP and guest configuration data. The VM Provider allows Integrity Virtual Server Manager to have visibility to VSP and guest resources. For Integrity Virtual Server Manager VSP views, the provider gives information about the VSP and its guests. For Integrity Virtual Server Manager virtual machine or virtual partition views, the provider gives information about a particular VM or vPar and the identity of its VSP. |
| **VSP** | A server running software such as HP Integrity VM, VMware ESX, VMware ESXi, or Microsoft Hyper-V, that provides multiple VMs or vPars, each running its own instance of an operating system. |
| **vswitch** | Virtual switch. Refers to both a dynamically loadable kernel module (DLKM) and a user-mode component implementing a virtual network switch. The virtualized network interface cards (NICs) for guest machines are attached to the virtual switches. By associating the vswitch with a physical working LAN on the VSP, you provide the guest with the capability of communicating outside the localnet. |
| **WBEM** | Web-Based Enterprise Management. A set of web-based information services standards developed by the Distributed Management Task Force, Inc. A WBEM provider offers access to a resource. WBEM clients send requests to providers to get information about, and access to, the registered resources. |
Index

A
Accelerated Virtual Input/Output see AVIO
agile device addressing
Add Storage screen, 86
APA, 104
Automatic Port Aggregation see APA
AVIO
    performance tuning, 83
    support indication, Create Vswitch screen, 103
    support information, 87
AVIO backing device
    support indication, VSP view, 34
    support indication, Vswitch Properties view, 72
AVIO network
    adding, 84
    support indication, VM Properties view, 68
AVIO storage
    adding, 85

B
backing device
    AVIO support indication, 34, 72, 103
    selecting for network, 84
    selecting for storage, 86
    selecting for vswitch, 104

C
Capacity Advisor
    and Integrity Virtual Server Manager, 11
    collecting data for, 119
    displaying collected data, 120, 121
    historical report, 124
    requirements, 13
core, 7
    see also CPU
CPU, 7
    modifying allotment, 79
CPU core resources
    VM Properties view, 62
    VSP view, 29
CPU count
    displaying, 62
CPU entitlement
    displaying, 62
Create Virtual Machine wizard, 83
credentials, WBEM, 15

E
entitlement see CPU entitlement
error messages, 135
event logs
    viewing, 125
    virtual partition, displaying using View menu, 81
    VSP, displaying using View menu, 81
external managers
Virtual Server Manager Properties view, 67
VSP view, 29

F
focus link
    VSP Storage tab, 43
    Vswitch Properties Network tab, 73

G
Global Workload Manager see gWLM
graceful stop timeout
    displaying, 62
guest OS
    specifying for new VM, 83
    starting automatically, 88
gWLM
    and Integrity Virtual Server Manager, 11
gWLM policy
    Virtual Server Manager Properties view (Virtual Server Manager), 67
    VM Properties view, 63
    VSP view, 29
    VSP view (Integrity Virtual Server Manager), 30

H
help
    accessing, 24
historical utilization data report
    creating, 124
HP Matrix OE visualization
    accessing from Integrity Virtual Server Manager, 26
    accessing from Matrix Operating Environment, 21
    accessing Integrity Virtual Server Manager from, 23
    and Integrity Virtual Server Manager, 10
    requirements, 13
HP Matrix Operating Environment
    documentation, 130
HP Matrix Operating Environment for HP-UX
    accessing Integrity Virtual Server Manager from, 21
    and Integrity Virtual Server Manager, 9
HP SIM
    accessing Integrity Virtual Server Manager from, 21
    documentation, 130
    installing Integrity Virtual Server Manager on, 14
    licensing, 15
HP SMH
    accessing from Integrity Virtual Server Manager, 26
    accessing Integrity Virtual Server Manager from, 23
    and Integrity Virtual Server Manager, 8
    documentation, 11
    installing Integrity Virtual Server Manager on, 14
    licensing, 15
HP Systems Insight Manager
    and Integrity Virtual Server Manager, 9
I/O device
adding (network) to new virtual machine, 84
adding (storage) to new virtual machine, 85
adding to existing VM, 89, 90
deleting, 80, 105

Insight Capacity Advisor software see Capacity Advisor

Insight Global Workload Manager see gWLM

Integrity Virtual Server Manager
accessing, 21
Create menu, 77
Delete menu, 79
focus link
VSP Storage tab, 43
Vswitch Properties Network tab, 73
help, 24
installing, 13
Maximize link, 27
menus, 75
Modify menu, 78
navigating, 24
Refresh Data link, 27
Restore Size link, 27
setting up, 13
Show All link
VSP Storage tab, 43
Vswitch Properties Network tab, 73
system requirements, 13
table sorting, 25
tasks, 11
Tools menu, 75
View menu, 80
View normal link, 27
View Printer-friendly link, 27
viewing version of, 14, 81, 126
views and tabs, 27

Integrity VM
event logs, 125
overview, 7
viewing version of, 81, 126

L
legacy device addressing
Add Storage screen, 86
licensing, 15
logs see event logs

M
Maximize link, 27
memory
displaying, 63
modifying, 89
specifying, 84
utilization, 120
VM Properties view, 62
VSP view, 29
Migrate Virtual Machine wizard
overview, 94
step 1 screen, 97
step 2 screen, 98
migration
overview, 94
phase timeouts, 97
planning and recommendations, 95
previewing and invoking commands, 99
specifying VSP, 98
starting, 97
status and error notification, 97
status and errors, 97
support and status, 32, 63, 64
VSP support status, 30

Multiserver Environment group see MSE group

N
network device
adding to existing VM, 90
adding to new VM, 84
deleting, 80, 105
VM Properties view, 67
VSP view, 34
Vswitch Properties view, 72

P
printer-friendly view, 27
providers
enabling use of, 15
utilization meter status and error information, 137
viewing version of, 81, 126

R
Refresh Data link, 27
Reset menu
overview, 115
Restore Size link, 27

S
security certificates, 18
Serviceguard, 64, 137
Virtual Server Manager Properties view (Virtual Server
Manager), 67
VSP View, 32
VSP view (Integrity Virtual Server Manager), 30
Serviceguard packages
and modifying VMs, 90
Serviceguard support
VM Properties view, 63
VSP view, 29
Shared Resource Domain see SRD
Show All link
VSP Storage tab, 43
Vswitch Properties Network tab, 73

SRD
adding new VMs to, 88
SSL certificates, 17, 18
startup attribute see virtual partition startup attribute
Stop menu
overview, 115
storage device
Virtual Servers tab, 31
Virtual Switches tab, 33

vsswitch
- creating, 78, 102
- deleting, 80, 105
- properties of, 70, 81
- starting, 77, 105
- stopping, 77, 105
- viewing properties of, 70, 81
  VSP view, 33

Vswitch Properties
- General tab, 71
- Network tab, 72
- view, 70

W

WBEM
- setting credentials in HP SIM, 16
- setting credentials in HP SMH, 16

WBEM credentials
- modifying, 89

WBEM providers
- enabling use of, 15
- utilization meter status and error information, 137
- viewing version of, 81, 126

wizard
- migrating virtual machines, 94