HP Enterprise Systems Library (ESL) G3 Tape Library

User Guide
Contents

1 Library Overview ................................................................. 15
   Library Features ................................................................. 16
   Density .................................................................................. 16
   Centralized Management ..................................................... 16
   Proactive Availability ............................................................ 16
   Serviceability and Reliability ................................................. 16
   Host Attachment ..................................................................... 17
   Remote Management ............................................................ 17
   Capacity on Demand ............................................................. 17
   Control Module ....................................................................... 17
   Expansion Modules ................................................................. 18
   Library Management Module ................................................ 20
      Management Control Blade (MCB) ........................................ 21
      Robotics Control Unit (RCU) ................................................. 21
      Library Motor Driver (LMD) ................................................. 21
   I/O Management Units ........................................................... 22
      Control Management Blade (CMB) ........................................ 22
      Ethernet Expansion Blade (EEB) ....................................... 22
   Picker (Cartridge Accessor) ..................................................... 22
   Import/Export Stations .......................................................... 22
      Extended I/E Option ............................................................. 23
   Cartridges ............................................................................... 23
   Cartridge Magazines ............................................................. 24
   Support for WORM .............................................................. 27
   Tape Drives ............................................................................ 27
      LTO Drives ........................................................................... 28
   Operator Panel ........................................................................ 28
   Power System ......................................................................... 29
   Using the library demonstration mode .................................... 29
      Starting demo mode .............................................................. 30
      Pausing demo mode ............................................................. 30
      Stopping demo mode ........................................................... 30
   2 Modifying the Library Configuration .................................. 31
      Setup Wizard Prerequisites .................................................. 31
      Accessing the Setup Wizard ................................................ 31
      Entering License Keys .......................................................... 32
      Working With Partitions ....................................................... 34
         Understanding Partition Media Policy Settings .................. 34
            Media Domain ............................................................... 35
            Media Type ..................................................................... 35
            Media ID Checking ......................................................... 35
            Return Media Identifier ................................................ 35
            Returning media identifiers to hosts ................................ 36
      Working with Library Control Paths .................................... 36

HP Enterprise Systems Library (ESL) G3 Tape Library 3
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring the host name using the Setup Wizard.</td>
<td>53</td>
</tr>
<tr>
<td>Specifying the date and time using the Setup Wizard.</td>
<td>53</td>
</tr>
<tr>
<td>Specifying the Date and Time</td>
<td>54</td>
</tr>
<tr>
<td>Filling the library with cartridges (bulk loading).</td>
<td>54</td>
</tr>
<tr>
<td>Setting up the Network Configuration</td>
<td>35</td>
</tr>
<tr>
<td>Changing internal IP network addressing.</td>
<td>36</td>
</tr>
<tr>
<td>Configuring DNS</td>
<td>57</td>
</tr>
<tr>
<td>Setting up Network Security</td>
<td>57</td>
</tr>
<tr>
<td>Setting up Drives</td>
<td>58</td>
</tr>
<tr>
<td>Configuring E-mail</td>
<td>59</td>
</tr>
<tr>
<td>Setting Up or Changing the E-Mail Configuration</td>
<td>59</td>
</tr>
<tr>
<td>Testing the Current E-Mail Configuration</td>
<td>60</td>
</tr>
<tr>
<td>Setting Up E-mail Notifications</td>
<td>60</td>
</tr>
<tr>
<td>Setting Up Media Security Notifications</td>
<td>64</td>
</tr>
<tr>
<td>Setting up Advanced Reporting Options</td>
<td>65</td>
</tr>
<tr>
<td>Saving Report Criteria Templates</td>
<td>66</td>
</tr>
<tr>
<td>Scheduling a New Job</td>
<td>66</td>
</tr>
<tr>
<td>Editing Scheduled Jobs</td>
<td>69</td>
</tr>
<tr>
<td>Deleting Scheduled Jobs</td>
<td>69</td>
</tr>
<tr>
<td>Configuring Drive Cleaning</td>
<td>69</td>
</tr>
<tr>
<td>Assigning Cleaning Magazines and Importing Cleaning Media.</td>
<td>70</td>
</tr>
<tr>
<td>Exporting Cleaning Media</td>
<td>72</td>
</tr>
<tr>
<td>Unassigning a Cleaning Magazine</td>
<td>72</td>
</tr>
<tr>
<td>Registering SNMP Traps</td>
<td>73</td>
</tr>
<tr>
<td>Registering an Application</td>
<td>73</td>
</tr>
<tr>
<td>Removing an Application Trap Registration</td>
<td>73</td>
</tr>
<tr>
<td>Using the Secure Manager Configuration Wizard</td>
<td>74</td>
</tr>
<tr>
<td>Using the Host Configuration Option</td>
<td>74</td>
</tr>
<tr>
<td>Using the Access Group Configuration Option</td>
<td>75</td>
</tr>
<tr>
<td>Using the Host Access Configuration Option</td>
<td>77</td>
</tr>
<tr>
<td>Using LDAP</td>
<td>78</td>
</tr>
<tr>
<td>LDAP Server Guidelines</td>
<td>78</td>
</tr>
<tr>
<td>User and Group Access</td>
<td>78</td>
</tr>
<tr>
<td>OpenLDAP 2.4</td>
<td>78</td>
</tr>
<tr>
<td>Configuring LDAP</td>
<td>79</td>
</tr>
<tr>
<td>Configuring library behavioral settings</td>
<td>82</td>
</tr>
<tr>
<td>Configuring screen saver preferences</td>
<td>82</td>
</tr>
<tr>
<td>About the configuration record</td>
<td>84</td>
</tr>
<tr>
<td>Setting aisle lights</td>
<td>84</td>
</tr>
<tr>
<td>Clear the registered Command View TL management station</td>
<td>85</td>
</tr>
</tbody>
</table>
3 Operating the Library ................................................................. 87
Logging On and Off ....................................................................... 87
Logging On From the OCP ........................................................... 87
Logging Off From the OCP .......................................................... 88
Logging On From the Library Management Console (LMC) Using a Web Browser ......................................... 88
Software Requirements ......................................................... 88
Accessing the LMC Applet ...................................................... 88
Logging Off From the LMC .......................................................... 89
Connecting to Multiple Libraries ................................................ 90
Using the Indicator Panel and Operator Control Panel (OCP) ................................................................. 90
Using the Indicator Panel .............................................................. 91
Accessing the Library Management Console (LMC) ................................................................. 92
Menus ............................................................................................. 94
Toolbar ............................................................................................ 98
Reading the Library Information Panel ........................................ 98
System Status Buttons .............................................................. 100
Viewing Details about Events .................................................. 101
Understanding Location Coordinates ..................................... 102
Cartridge Locations ................................................................. 102
Tape Drive Locations .............................................................. 106
Viewing the Physical Library or a Partition ............................... 107
Using the View Menu ............................................................ 108
Using the Managed Views Region of the LMC display .............. 108
Changing the Library State .......................................................... 108
Taking the Physical Library or a Partition Online or Offline .................. 108
Online and Offline Functionality ............................................. 109
Working With local User Accounts .......................................... 110
Creating Local User Accounts ............................................... 110
Modifying Local User Accounts ............................................. 112
Deleting Local User Accounts ............................................... 113
Viewing Local User Account Permissions ......................... 114
User Privileges and Library/Partition Functions ....................... 114
Shutting Down/Rebooting the Library ...................................... 118
Powering Off the Library ............................................................ 119
Powering On the Library ............................................................. 119
Locking/Unlocking the I/E Station ........................................... 120
Using the Library When Robotics Are Not Ready ................. 120

4 Monitoring the Library ............................................................. 123
Using Library Explorer ............................................................ 123
Understanding the Graphical Display, frame view .................. 126
Accessing Library Operations ............................................... 126
Monitoring System Components .............................................. 126
Monitoring System Status .......................................................... 126
Monitoring Drive Status .............................................................. 128
Monitoring I/E Station Status ..................................................... 129
Monitoring Slots Status ............................................................... 130
Checking slot status ................................................................. 132
Filtering Slots by Location .................................................... 132
Monitoring Media Status ......................................................... 133
Monitoring library configuration .......................................... 134
Working with the media usage report ..................................... 134
Monitoring Sensor Status ........................................................ 135
Accessing the Sensor Status Dialog Box ................................. 135
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displaying Cooling Fan Information</td>
<td>136</td>
</tr>
<tr>
<td>Displaying Power Supply information</td>
<td>136</td>
</tr>
<tr>
<td>Displaying Temperature Information</td>
<td>136</td>
</tr>
<tr>
<td>Displaying Voltage Information</td>
<td>137</td>
</tr>
<tr>
<td>Saving and Restoring Library Configuration</td>
<td>137</td>
</tr>
<tr>
<td>Types of Configuration Image Files</td>
<td>138</td>
</tr>
<tr>
<td>When to Save the Library Configuration</td>
<td>138</td>
</tr>
<tr>
<td>Saving a Remote Restore Image</td>
<td>138</td>
</tr>
<tr>
<td>Saving a Local Rescue Image</td>
<td>139</td>
</tr>
<tr>
<td>Restoring Library Configuration</td>
<td>140</td>
</tr>
<tr>
<td>Rescuing Library Configuration</td>
<td>141</td>
</tr>
<tr>
<td>Reverting Library Configuration</td>
<td>142</td>
</tr>
<tr>
<td>Emailing or Saving the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Emailing the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Saving the Configuration Record</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring user status</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring Partitions Status</td>
<td>145</td>
</tr>
<tr>
<td>Viewing partition status details</td>
<td>146</td>
</tr>
<tr>
<td>Monitoring Key Management</td>
<td>146</td>
</tr>
<tr>
<td>Creating Support Tickets</td>
<td>147</td>
</tr>
<tr>
<td>Emailing, Saving, and Printing Status Information</td>
<td>147</td>
</tr>
<tr>
<td>Cleaning a Drive</td>
<td>153</td>
</tr>
<tr>
<td>Emailing and Saving Support Tickets</td>
<td>152</td>
</tr>
<tr>
<td>Viewing Drive Details</td>
<td>151</td>
</tr>
<tr>
<td>Saving a Report Template</td>
<td>154</td>
</tr>
<tr>
<td>Viewing the Drive Resource Utilization Reports</td>
<td>155</td>
</tr>
<tr>
<td>Teaching the Library (Configuration and Calibration)</td>
<td>158</td>
</tr>
<tr>
<td>Running Configuration Teach</td>
<td>158</td>
</tr>
<tr>
<td>Running Calibration Teach</td>
<td>159</td>
</tr>
<tr>
<td>Working with Verification Tests</td>
<td>160</td>
</tr>
<tr>
<td>Verification Test Descriptions</td>
<td>161</td>
</tr>
<tr>
<td>Installation Verification Test</td>
<td>161</td>
</tr>
<tr>
<td>Partial System Tests</td>
<td>161</td>
</tr>
<tr>
<td>FRU Operational Tests</td>
<td>161</td>
</tr>
<tr>
<td>Custom Library Alignment Tests</td>
<td>162</td>
</tr>
<tr>
<td>Verification Test Functions</td>
<td>162</td>
</tr>
<tr>
<td>Library Alignment Test</td>
<td>162</td>
</tr>
<tr>
<td>Get/Put Test</td>
<td>163</td>
</tr>
<tr>
<td>Accessor Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Picker Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Drive Sled Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Scan Barcode Test</td>
<td>163</td>
</tr>
<tr>
<td>I/E Station Assembly Test</td>
<td>164</td>
</tr>
<tr>
<td>Scanner Fiducial Test</td>
<td>164</td>
</tr>
<tr>
<td>Saving the Configuration Record</td>
<td>144</td>
</tr>
<tr>
<td>Emailing the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Reverting Library Configuration</td>
<td>142</td>
</tr>
<tr>
<td>Restoring Library Configuration</td>
<td>140</td>
</tr>
<tr>
<td>Saving a Remote Restore Image</td>
<td>138</td>
</tr>
<tr>
<td>Saving a Local Rescue Image</td>
<td>139</td>
</tr>
<tr>
<td>Restoring Library Configuration</td>
<td>140</td>
</tr>
<tr>
<td>Rescuing Library Configuration</td>
<td>141</td>
</tr>
<tr>
<td>Reverting Library Configuration</td>
<td>142</td>
</tr>
<tr>
<td>Emailing or Saving the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Emailing the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Saving the Configuration Record</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring user status</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring Partitions Status</td>
<td>145</td>
</tr>
<tr>
<td>Viewing partition status details</td>
<td>146</td>
</tr>
<tr>
<td>Monitoring Key Management</td>
<td>146</td>
</tr>
<tr>
<td>Creating Support Tickets</td>
<td>147</td>
</tr>
<tr>
<td>Emailing, Saving, and Printing Status Information</td>
<td>147</td>
</tr>
<tr>
<td>Cleaning a Drive</td>
<td>153</td>
</tr>
<tr>
<td>Emailing and Saving Support Tickets</td>
<td>152</td>
</tr>
<tr>
<td>Viewing Drive Details</td>
<td>151</td>
</tr>
<tr>
<td>Saving a Report Template</td>
<td>154</td>
</tr>
<tr>
<td>Viewing the Drive Resource Utilization Reports</td>
<td>155</td>
</tr>
<tr>
<td>Teaching the Library (Configuration and Calibration)</td>
<td>158</td>
</tr>
<tr>
<td>Running Configuration Teach</td>
<td>158</td>
</tr>
<tr>
<td>Running Calibration Teach</td>
<td>159</td>
</tr>
<tr>
<td>Working with Verification Tests</td>
<td>160</td>
</tr>
<tr>
<td>Verification Test Descriptions</td>
<td>161</td>
</tr>
<tr>
<td>Installation Verification Test</td>
<td>161</td>
</tr>
<tr>
<td>Partial System Tests</td>
<td>161</td>
</tr>
<tr>
<td>FRU Operational Tests</td>
<td>161</td>
</tr>
<tr>
<td>Custom Library Alignment Tests</td>
<td>162</td>
</tr>
<tr>
<td>Verification Test Functions</td>
<td>162</td>
</tr>
<tr>
<td>Library Alignment Test</td>
<td>162</td>
</tr>
<tr>
<td>Get/Put Test</td>
<td>163</td>
</tr>
<tr>
<td>Accessor Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Picker Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Drive Sled Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Scan Barcode Test</td>
<td>163</td>
</tr>
<tr>
<td>I/E Station Assembly Test</td>
<td>164</td>
</tr>
<tr>
<td>Scanner Fiducial Test</td>
<td>164</td>
</tr>
<tr>
<td>Saving the Configuration Record</td>
<td>144</td>
</tr>
<tr>
<td>Emailing the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Reverting Library Configuration</td>
<td>142</td>
</tr>
<tr>
<td>Restoring Library Configuration</td>
<td>140</td>
</tr>
<tr>
<td>Saving a Remote Restore Image</td>
<td>138</td>
</tr>
<tr>
<td>Saving a Local Rescue Image</td>
<td>139</td>
</tr>
<tr>
<td>Restoring Library Configuration</td>
<td>140</td>
</tr>
<tr>
<td>Rescuing Library Configuration</td>
<td>141</td>
</tr>
<tr>
<td>Reverting Library Configuration</td>
<td>142</td>
</tr>
<tr>
<td>Emailing or Saving the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Emailing the Configuration Record</td>
<td>143</td>
</tr>
<tr>
<td>Saving the Configuration Record</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring user status</td>
<td>144</td>
</tr>
<tr>
<td>Monitoring Partitions Status</td>
<td>145</td>
</tr>
<tr>
<td>Viewing partition status details</td>
<td>146</td>
</tr>
<tr>
<td>Monitoring Key Management</td>
<td>146</td>
</tr>
<tr>
<td>Creating Support Tickets</td>
<td>147</td>
</tr>
<tr>
<td>Emailing, Saving, and Printing Status Information</td>
<td>147</td>
</tr>
<tr>
<td>Cleaning a Drive</td>
<td>153</td>
</tr>
<tr>
<td>Emailing and Saving Support Tickets</td>
<td>152</td>
</tr>
<tr>
<td>Viewing Drive Details</td>
<td>151</td>
</tr>
<tr>
<td>Saving a Report Template</td>
<td>154</td>
</tr>
<tr>
<td>Viewing the Drive Resource Utilization Reports</td>
<td>155</td>
</tr>
<tr>
<td>Teaching the Library (Configuration and Calibration)</td>
<td>158</td>
</tr>
<tr>
<td>Running Configuration Teach</td>
<td>158</td>
</tr>
<tr>
<td>Running Calibration Teach</td>
<td>159</td>
</tr>
<tr>
<td>Working with Verification Tests</td>
<td>160</td>
</tr>
<tr>
<td>Verification Test Descriptions</td>
<td>161</td>
</tr>
<tr>
<td>Installation Verification Test</td>
<td>161</td>
</tr>
<tr>
<td>Partial System Tests</td>
<td>161</td>
</tr>
<tr>
<td>FRU Operational Tests</td>
<td>161</td>
</tr>
<tr>
<td>Custom Library Alignment Tests</td>
<td>162</td>
</tr>
<tr>
<td>Verification Test Functions</td>
<td>162</td>
</tr>
<tr>
<td>Library Alignment Test</td>
<td>162</td>
</tr>
<tr>
<td>Get/Put Test</td>
<td>163</td>
</tr>
<tr>
<td>Accessor Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Picker Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Drive Sled Assembly Test</td>
<td>163</td>
</tr>
<tr>
<td>Scan Barcode Test</td>
<td>163</td>
</tr>
<tr>
<td>I/E Station Assembly Test</td>
<td>164</td>
</tr>
<tr>
<td>Scanner Fiducial Test</td>
<td>164</td>
</tr>
</tbody>
</table>
8 Troubleshooting your Library ................................................................. 211
   Is the access door closed? ................................................................. 211
   Is a cartridge or drive having problems? ......................................... 211
   How Does the Library Report Issues? ........................................... 211
      Understanding Indicators on System Status Buttons .................. 213
      Understanding E-mail Notifications ........................................... 213
   Working with Events ...................................................................... 214
   Event Guidelines ............................................................................ 214
   Displaying Event Lists ................................................................... 216
      Using System Status Buttons to Display Event Lists ................. 216
      Using the Events Command or the Events Button to Display Event Lists ........................................ 218
   Viewing Event Details ................................................................... 219
   Viewing History Event Details ....................................................... 222
   Viewing Event Details Reports ...................................................... 223
   Viewing Repair Pages ..................................................................... 225
   Viewing Tape Alerts ....................................................................... 226
   Creating a Tape Alert History Report ......................................... 226
   Emailing, Saving, and Printing Event Information ......................... 227
   Running Verification Tests to Determine Issue Resolution .......... 228
   Closing Events .............................................................................. 229
      Closing Individual Events ............................................................ 230
      Closing Multiple Events ............................................................. 230
   Generating the Events Report ....................................................... 230
   Specifying Events Report Criteria ............................................... 230
   Printing or Exporting a Report to PDF ........................................ 232
   Exporting a Report to an E-mail or a Text File ............................ 233
   Saving a Report Template ............................................................... 233
   Interpreting LEDs ......................................................................... 233
   Interpreting Blade Status LEDs .................................................... 234
      Actions Based on LED States ..................................................... 236
   Interpreting Drive Status LEDs .................................................... 236
   Interpreting Fibre Port Link LED ................................................... 237
      Drive Sled Fibre Channel Link LED ........................................... 238
   Interpreting MCB Port LEDs ......................................................... 238
      MCB Ethernet Port LEDs .......................................................... 238
      MCB Fibre Channel Port LEDs ................................................. 239
   Interpreting LBX Terminator LEDs .............................................. 240
   Interpreting Power Supply LEDs .................................................. 241
   Accessing Online Help ................................................................... 242

9 Support and other resources .............................................................. 245
   Contacting HP .............................................................................. 245
   HP websites .................................................................................... 245
   Typographic conventions ................................................................. 245
   Rack stability .................................................................................. 246
   HP product documentation survey ............................................. 247

A ESKM Management Solutions ............................................................ 249
   Enabling the ESKM License Key ................................................. 249
   Configuring Encryption Key Management .................................... 249
      Using Select Key Management Type ......................................... 250
   Using Update Key Manager Configuration ................................ 252
   Using Update Key Manager Certificate ...................................... 252
B Frequently Asked Questions ................................................................. 255

C Product Safety Statements ............................................................... 257
    Mechanical Locks ................................................................................ 257
    Power Button on the Library Indicator Panel ......................................... 257

D Regulatory statements ........................................................................... 259
    Federal Communications Commission notice ........................................ 259
    FCC rating label .................................................................................. 259
        Class A equipment ............................................................................ 259
        Class B equipment ............................................................................ 259
    Declaration of Conformity for products marked with the FCC logo, United States only .................................................. 260
    Modification .......................................................................................... 260
    Cables .................................................................................................... 260
    Mercury Statement ................................................................................ 260
    Canadian notice (Avis Canadien) ........................................................... 260
        Class A equipment ............................................................................ 260
        Class B equipment ............................................................................ 260
    European Union notice .......................................................................... 261
    Japanese notices .................................................................................... 261
        Japanese VCCI-A notice .................................................................... 261
        Japanese VCCI-B notice .................................................................... 261
        Japanese power cord statement ....................................................... 262
    Korean notices ....................................................................................... 262
        Class A equipment ............................................................................ 262
        Class B equipment ............................................................................ 262
    Taiwanese notices .................................................................................. 262
        BSMI Class A notice ......................................................................... 262
        Taiwan battery recycle statement .................................................... 263
    Turkish recycling notice ........................................................................ 263
    Laser compliance notices ....................................................................... 264
        English laser notice .......................................................................... 264
        Dutch laser notice ............................................................................. 264
        French laser notice .......................................................................... 265
        German laser notice ......................................................................... 265
        Italian laser notice ........................................................................... 265
        Japanese laser notice ....................................................................... 266
        Spanish laser notice ......................................................................... 266
    Recycling notices .................................................................................. 266
        English recycling notice .................................................................... 266
        Bulgarian recycling notice ............................................................... 267
        Czech recycling notice ...................................................................... 267
        Danish recycling notice .................................................................... 267
        Dutch recycling notice ...................................................................... 267
        Estonian recycling notice .................................................................. 268
        Finnish recycling notice .................................................................... 268
        French recycling notice ..................................................................... 268
        German recycling notice ................................................................... 268
        Greek recycling notice ...................................................................... 269
        Hungarian recycling notice ............................................................... 269

HP Enterprise Systems Library (ESL) G3 Tape Library  
9
### Figures

1. Front view of a control module and expansion module .......................................................... 15
2. Front and back view of the control module ............................................................................ 18
3. Expansion module with location of 24 slot I/E station ............................................................ 19
4. Expansion module with location of 72 slot I/E station ............................................................ 20
5. Library management module boards ..................................................................................... 21
6. Example of LTO cartridge insertion into a magazine ............................................................. 24
7. Magazine and drive locations in the control module (left) and on the control module access door (right) ............................................................................................................. 25
8. Components of the I/O management unit in the library control module .................................... 26
9. Operator Panel ......................................................................................................................... 29
10. Library Indicator Panel and OCP ......................................................................................... 91
11. Viewing the LMC (physical library view shown) ................................................................... 93
12. LMC (partition view) ............................................................................................................ 99
13. System Status Buttons in Good Status .................................................................................. 100
14. Aisle, Module, and Rack Numbering Locations ...................................................................... 102
15. Section, Column, and Row Numbering for Rack 1 - LTO Cartridges ...................................... 103
16. Section, Column, and Row Numbering for Rack 2 - LTO Cartridges ...................................... 104
17. Example Location Coordinates ............................................................................................. 105
18. Coordinates in Media Status dialog box ................................................................................ 106
19. Drive-side Location Coordinates .......................................................................................... 107
20. Verification Tests Dialog Box .................................................................................................. 162
21. Picker Pivot/Reach Graphical Report ....................................................................................... 177
22. Example Test Log Output ....................................................................................................... 179
23. Top and Bottom Air Filters ................................................................................................... 187
24. Write-protect Switch on an LTO Cartridge ............................................................................ 190
25. Applying Barcode Labels to Cartridges ................................................................................ 192
26. Status Indicator ...................................................................................................................... 212
27. Colors of Blade Status LEDs .................................................................................................. 234
28. Rear View of FC Drive Sled (LTO-4 and LTO-5 Drives) .......................................................... 236
29. Locations - Colors of MCB Ethernet Port LEDs .................................................................... 239
30. Locations - Colors MCB FC Port LEDs ................................................................................ 240
31. Locations of LBX Terminator LEDs ..................................................................................... 240
<table>
<thead>
<tr>
<th>Table Number</th>
<th>Table Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Cartridge capacities in library modules</td>
<td>27</td>
</tr>
<tr>
<td>2</td>
<td>LTO drive and cartridge compatibility</td>
<td>28</td>
</tr>
<tr>
<td>3</td>
<td>Sampling of Media Type Identifiers</td>
<td>36</td>
</tr>
<tr>
<td>4</td>
<td>Return Media Identifier Behavior Example</td>
<td>36</td>
</tr>
<tr>
<td>5</td>
<td>IPv4 Network Configuration Information</td>
<td>51</td>
</tr>
<tr>
<td>6</td>
<td>Severity Levels Assigned to Issues</td>
<td>61</td>
</tr>
<tr>
<td>7</td>
<td>Robotics Enabled Indicator</td>
<td>92</td>
</tr>
<tr>
<td>8</td>
<td>Status Indicator</td>
<td>92</td>
</tr>
<tr>
<td>9</td>
<td>Power Indicator</td>
<td>92</td>
</tr>
<tr>
<td>10</td>
<td>Menu Commands: Privileges and Environments</td>
<td>94</td>
</tr>
<tr>
<td>11</td>
<td>Areas on the Library Information Panel</td>
<td>99</td>
</tr>
<tr>
<td>12</td>
<td>Subsystems and their components</td>
<td>101</td>
</tr>
<tr>
<td>13</td>
<td>Drive location coordinates</td>
<td>107</td>
</tr>
<tr>
<td>14</td>
<td>Library Functions Requiring Online or Offline State</td>
<td>109</td>
</tr>
<tr>
<td>15</td>
<td>Remote Client Commands, Privilege Levels, and Views</td>
<td>114</td>
</tr>
<tr>
<td>16</td>
<td>Menu Commands when Robotics are Disabled</td>
<td>121</td>
</tr>
<tr>
<td>17</td>
<td>System Status Dialog Box</td>
<td>127</td>
</tr>
<tr>
<td>18</td>
<td>Status List Items</td>
<td>127</td>
</tr>
<tr>
<td>19</td>
<td>Drive Status Dialog Box</td>
<td>128</td>
</tr>
<tr>
<td>20</td>
<td>I/E Station Status Dialog Box</td>
<td>129</td>
</tr>
<tr>
<td>21</td>
<td>Slots Status Dialog Box</td>
<td>131</td>
</tr>
<tr>
<td>22</td>
<td>Media Status Dialog Box</td>
<td>133</td>
</tr>
<tr>
<td>23</td>
<td>Media Usage Report Dialog Box</td>
<td>134</td>
</tr>
<tr>
<td>24</td>
<td>Cooling Fan Information</td>
<td>136</td>
</tr>
<tr>
<td>25</td>
<td>Power Supply Information</td>
<td>136</td>
</tr>
<tr>
<td>26</td>
<td>Temperature Information on Sensor Status Dialog Box</td>
<td>136</td>
</tr>
<tr>
<td>27</td>
<td>Voltage Information on the Sensor Status Dialog Box</td>
<td>137</td>
</tr>
<tr>
<td>28</td>
<td>User Status Dialog Box</td>
<td>145</td>
</tr>
<tr>
<td>29</td>
<td>Partitions Status Dialog Box</td>
<td>145</td>
</tr>
<tr>
<td>30</td>
<td>Drives Dialog Box</td>
<td>150</td>
</tr>
<tr>
<td>31</td>
<td>Drive Details Dialog Box</td>
<td>151</td>
</tr>
<tr>
<td>32</td>
<td>Test Results</td>
<td>174</td>
</tr>
</tbody>
</table>
1 Library Overview

The ESL G3 automates the retrieval, storage, and control of tape cartridges. Application software on the host can use the library robotics to mount cartridges into tape drives and retrieve them without operator intervention.

The library can be installed on a solid or raised floor. It has a standard 19-inch rack footprint and can be placed in a standard server rack space. Because the library provides access by way of the access and service doors, the library can be placed with either side against a wall or between racks.

Figure 1 shows a front view of the library, consisting of a control module and an expansion module.

Figure 1 Front view of a control module and expansion module

The library is designed for ease of installation, configuration, and field upgrades. The minimum library configuration consists of one control module. You can add up to 11 expansion modules as storage and tape drive requirements change.

NOTE:

Expansion modules in positions nine through twelve are storage-only modules and do not contain I/E stations or drives.
The maximum library configuration can accommodate:

- 1 control module
- 0 to 11 expansion modules
- 102 to 5322 cartridges
- 1 to 96 tape drives

A library Import/Export (I/E) Station configuration can accommodate:

- 1 to 24-port I/E station in the control module and 1 to 7 I/E stations, one in each of the first 7 expansion modules.

Or

- 1 24-port I/E station in the control module and up to 7 72-slot I/E stations, one in each of the first 7 expansion modules.

Library Features

Density

The library provides a storage density of 758 cartridges (LTO) per square meter. Each module, also referred to as a frame, has two storage racks: one on the drive side and another on the door side. A rack consists of up to 10 horizontal sections and three or four columns of magazines, depending on the rack configuration. Each magazine, located at the intersection of a particular section and a particular column, consists of six cartridge slots.

Centralized Management

The Library Management Console (LMC) gives you a single point from which to view all library components, including robotics, drives, storage, I/E stations, and network connectivity. You can use this graphical user interface both locally from the library OCP and remotely from a remote client. The LMC communicates with the LMC server that runs on the library. The LMC uses a simple and intuitive graphical style that is secure and provides library managers with native partitioning ability.

Proactive Availability

The library can alert you about problems before they occur. The library checks the complete data path at user-defined intervals to make sure that it is functioning properly before backups begin. The library also monitors its six major subsystems (drives, power, robotics, cooling, connectivity, and control). You can configure the library to send notifications of problems to one or more e-mail accounts, including HP service personnel. For more information about the library monitoring and reporting capabilities, Chapter 5.

Serviceability and Reliability

The library has extensive serviceability and reliability features. You can hot swap drives, power supplies (in redundant power configurations only), and fans.

Your backup system and data path are idle most of the time. When backups begin, the system is used intensively at maximum bandwidth. The library provides you with notifications and a robust event system that notifies you of any problems it identifies, enabling you to solve them before backups begin. For more information about the library notification system, event system, and other troubleshooting help, see Chapter 8.
Host Attachment

Requests issued from the host application result in cartridge movement in the library. The primary requests issued are for mounting and dismounting cartridges in and out of the tape drives and for importing and exporting cartridges in and out of the library. The library manages the physical location. In addition to requesting cartridge movement in the library, the host application can use the Fibre Channel (FC) command interface to obtain status information, configuration information, and cartridge storage information from the library.

Tape drives are directly attached to host systems or to the SAN. The library robot control path is presented through one or more tape drive ports, depending on Partitioning and Failover configuration. FC drives can be directly attached to host systems or to the SAN. In these configurations, the management control blade (MCB) has one library control port connecting to the controlling host computer.

Remote Management

The library can be managed locally or remotely using the LMC. Locally, the LMC appears on the OCP on the front of the library. Remotely, the LMC is accessed through a client instance of the LMC software on any computer on the network. For more information about access, see Logging On From the Library Management Console (LMC) Using a Web Browser. For more information about the LMC, see Accessing the Library Management Console (LMC).

The LMC provides additional monitoring of a SAN-attached library over the network to a management server by using Simple Network Management Protocol (SNMP). This includes library subsystem health and status information and early fault notification.

The library also supports the Common Information Model (CIM) server based on the Storage Management Initiative Specification (SMI-S) on the MCB. A CIM client can use the CIM server to monitor the SAN-attached library.

Capacity on Demand

ESL G3 tape libraries can be purchased at starting points of 100, 300, 700, 1500, 3000, or 5000 cartridge slots enabled. Adding physical Expansion Modules does not automatically enable new slots. Instead, slots are flexibly enabled for use in groups of approximately 100 through capacity upgrade licenses.

Control Module

All library configurations include the control module, which contains the following components at a minimum (see Figure 2):

- Library management module (LMM)
- I/E station
- Tape drives
- Cartridge storage
- Operator panel

HP Enterprise Systems Library (ESL) G3 Tape Library
• Power system
• I/O Management Unit and Ethernet Expansion Blade (EEB)

Expansion Modules

Expansion modules enable the library to expand by adding space for tape drives, I/E stations, and cartridges. Each expansion module can add several hundred LTO cartridge slots, depending on the number of tape drives installed and whether an I/E station is installed. See Figure 3 and Figure 4. The library maximum configuration includes 11 expansion modules for a total of 12 modules. Expansion modules can only be added to the right of the control module.

**NOTE:**

Expansion modules in positions 9-12 are storage-only modules and do not contain I/E stations or drives.

The expansion modules can accommodate the following components:

• I/O management unit (optional)
• Tape drives (optional)
• I/E station (optional)
• Cartridge storage
• AC power compartment (required only if drives are added)

If an expansion module contains only cartridges, all power is derived from the control module.

Figure 3 Expansion module with location of 24 slot I/E station

1. Drive cluster (optional) location
2. Cartridge magazines location
3. I/E station 24 slot (optional) location
4. Door side
5. Drive side
Figure 4 Expansion module with location of 72 slot I/E station

An I/E station is an expansion module designed for customers who have an increased need to import or export cartridges. An expansion module can have no I/E station, a 24 slot I/E station, or a 72 slot I/E station. The increased capacity is achieved by increasing the overall length of the I/E station and doubling its width.

The 24-slot I/E station has a capacity of 24 LTO cartridges that are located in four removable magazines.

The 72-slot I/E station consists of two side-by-side 36-slot I/E stations that can operate as one 72-slot I/E station or can operate independently. Each 36-slot I/E station provides I/E capacity of 36 LTO cartridges in six removable magazines.

Library Management Module

The library management module (LMM) controls and manages library hardware and software components. It enables both SAN-connected hosts and users who access the library using the operator panel to configure the library, obtain system status information, and perform various library functions. The LMM contains the management control blade (MCB), the robotics control unit (RCU), and the library motor driver (LMD), as shown in Figure 5.
1. Management control blade

2. Robotics control unit

3. Library motor drive

**Figure 5 Library management module boards**

**Management Control Blade (MCB)**

The MCB is the primary point of intelligent management in the library. The MCB stores firmware and configuration data for itself as well as most other intelligent components in the library. It also contains the LMC, which enables local or remote users or hosts to operate, configure, and monitor the library. The MCB collects status information on other components in the library and issues notifications when problems occur.

**Robotics Control Unit (RCU)**

The RCU provides robotics intelligence that controls accessor movements and functions, including picker, pivot, and reach actions. It receives commands from hosts or users by way of the MCB.

**Library Motor Driver (LMD)**

The LMD monitors wiring, fuses, and relays within the library. It regulates power levels and performs other power-related functions, such as disabling robotics when a library door opens.
I/O Management Units

The I/O management unit is an optional component that provides connectivity and data path management to a SAN fabric and the hosts. The I/O management unit performs all tape drive and library host communication functions in a library that is attached to a SAN.

The I/O management unit supports the control management blade (CMB) and the Ethernet Expansion Blade (EEB).

Control Management Blade (CMB)

The CMB performs unit status monitoring, including power and I/O present conditions. The CMB also enables you to update drive firmware without using a firmware update (FUP) tape.

Ethernet Expansion Blade (EEB)

The Ethernet Expansion Blade (EEB) provides the option for Ethernet connectivity to each LTO drive for MCB-to-drive communication purposes only. The EEB is not in the data path. The connection is at T100. This EEB provides a control path to the drive for commands as well as facilitates taking drive logs and downloading drive firmware. Each EEB has 6 Ethernet ports to allow attachment to 6 LTO drives. The EEB provides Ethernet connectivity to the library internal Ethernet and should not be connected to an external Ethernet source.

Picker (Cartridge Accessor)

The picker moves cartridges between storage cells, tape drives, and I/E stations. A picker is used to Get or Put cartridges in a storage cell or a tape drive slot. It moves along an X and Y axis and can pivot 180 degrees. A barcode scanner on the picker assembly identifies cartridges located in storage slots.

Import/Export Stations

I/E stations enable you to import and export cartridges without interrupting normal library operations. The I/E station is installed on the front of the control module and, optionally, any of the first seven expansion modules in larger library configurations. See Figure 1 and Figure 2 to see the location of the I/E station.

Each 24-slot I/E station contains four removable magazines for a total of 24 LTO tape cartridges. Each 72-slot I/E station contains twelve removable magazines for a total of 72 LTO tape cartridges.

NOTE:

The I/E station cannot be configured as a storage location, but it can be part of a logical division of library resources known as partitions. For information about partitions, see Working With Partitions.
**Extended I/E Option**

The number of I/E slots in a library is usually associated with the number of I/E slots in an actual physical I/E station, but this physical slot count could limit how many I/E slots may be available to a host application.

Extended I/E configurations remove such I/E slot count limitations by increasing the I/E slot count for a partition with storage slots that will be reported to a host as I/E slots. Therefore, Extended I/E allows the user to configure their partitions with I/E slots beyond the number of physical I/E slots configured in the library. As a result, the host can export more media than previously allowed.

Keep in mind that as Extended I/E slots are used, less storage slots are available. You will need to initiate move/import operations of tape cartridges into the extended I/E area for host access. Conversely, to move/export tape cartridges from Extended I/E area slots to the emptied physical I/E Station slots, you need to initiate the move/export operation from the user interface for physical access to the library.

**NOTE:**

By default, the Extended I/E feature is disabled and is only available on ESL G3 libraries. Extended I/E can be enabled/disabled from the **Physical Library** dialog box.

To configure a partition with Extended I/E segments, the user must use the Partition Wizard (**Setup > Partition > Configure**). The Extended I/E feature is only available in Expert creation mode or if you are modifying an existing partition. See **Creating Partitions Manually Using Expert Mode**.

Extended I/E must be enabled before using it. When configuring Extended I/E in a partition, ensure you have enough licensed slots (Capacity On Demand — COD) to accommodate the new Extended I/E slots, since Extended I/E slots use the COD licensed slot count.

When you configure Extended I/E slots you must have at least one physical I/E segment configured in the partition. The maximum number of physical and Extended I/E slots per partition is 240.

**Cartridges**

Cartridges are stored in magazines within the library, as shown in **Figure 6**.
Figure 6 Example of LTO cartridge insertion into a magazine

Each cartridge has an operator-attached, machine-readable barcode label on it for identification purposes. The library can dynamically support barcode labels that consist of 6 characters plus a 2-character media identifier.

For more information about tape cartridges, see Tape Drives.
For additional specification information, see Barcode Requirements.

Cartridge Magazines

The cartridge magazine is a storage assembly that installs on the drive side or door side of the control module or expansion module, as shown in Figure 7 and Figure 8. It contains 6 cartridge slots and provides flexibility when adding storage cartridges to a module.
1. Lower drive cluster  
2. Upper drive cluster  
3. Cartridge magazines  
4. Middle X-axis rail  
5. I/E station  
6. I/E station cartridge magazines  
7. Door side  
8. Drive side  
9. Lower drive ports  
10. Drives or cartridge magazines  
11. Upper drive ports

Figure 7 Magazine and drive locations in the control module (left) and on the control module access door (right)
1. Bay 1 (not used)  
2. Bay 2—CMB  
3. Bay 3 (not used)  
4. Bay 4 (not used)  
5. Bay 5 (not used)  
6. Bay 6 (not used)  
7. Bay 7—First ethernet expansion blade (EEB) for drives 1–6  
8. Bay 8—Second EEB for drives 7–12  
9. I/O management unit cooling assembly  

Figure 8 Components of the I/O management unit in the library control module
See Table 1 for cartridge capacities.

Table 1 Cartridge capacities in library modules

<table>
<thead>
<tr>
<th>Type of cartridge</th>
<th>Cartridges per magazine</th>
<th>Magazines per Control Module $^1$</th>
<th>Magazines per Expansion Module $^2$</th>
<th>Control Module Cartridge Capacity $^3$</th>
<th>Expansion Module Cartridge Capacity $^4$</th>
</tr>
</thead>
<tbody>
<tr>
<td>LTO</td>
<td>6</td>
<td>44 min/50 max</td>
<td>32 min/76 max</td>
<td>264 min/300 max</td>
<td>192 min/456 max</td>
</tr>
</tbody>
</table>

$^1$The minimum is based on having 12 drives installed. The maximum is based on having one drive and one I/E station installed.

$^2$The minimum is based on having one drive and one I/E station installed. The maximum is based on having no drives and no I/E station installed.

$^3$The minimum is based on having 12 drives installed. The maximum is based on having one drive and one I/E station installed.

$^4$The minimum is based on having one drive and one I/E station installed. The maximum is based on having no drives and no I/E station installed.

Each magazine has a barcode label that the scanner reads for identification and inventory. An optional, snap-on dust cover is available for the magazines. Magazines with the dust cover have interlocked stacking that enables easier storage of the media when they are removed from the library for external storage.

**Support for WORM**

The ESL G3 library supports WORM (write once, read many) technology in LTO-4 and LTO-5 tape drives. WORM requirements include:

- Cartridges
- Firmware
- WORM-supported LTO-4 tape drives
- WORM-supported LTO-5 tape drives

WORM allows non-erasable data to be written once and provides extra data security by prohibiting accidental data erasure. When the library firmware and WORM-supported LTO-4 or LTO-5 tape drive code are installed on a library with LTO-4 or LTO-5 tape drives, the WORM feature is supported whenever the operator uses WORM cartridges.

**Tape Drives**

Tape drives are enclosed in a universal drive sled. You can hot swap and hot add all supported drives, regardless of type. The library supports HP LTO-4 and LTO-5 FC Multi-mode tape drives.

The control module and expansion modules have upper and lower drive clusters. Each library must have at least one tape drive. Each drive cluster can house up to six tape drives for a total of 12 drives. Additional drives can be added to the first seven expansion modules in the configuration. This enables you to have a total of 96 drives.

**NOTE:**

When you add drives, you lose storage slots.
Drives must be installed in bottom-to-top order in the control module before any are added to the first expansion module. There are two six-drive clusters in each of the first eight modules.

**NOTE:**
The term drive cluster defines a grouping of up to six tape drives below or above the middle X-axis rail.

Figure 7 shows the locations of drives in the control module.

### LTO Drives

LTO drives are supported as shown in Table 2.

**Table 2 LTO drive and cartridge compatibility**

<table>
<thead>
<tr>
<th></th>
<th>LTO-4 Cartridge</th>
<th>LTO-4 WORM</th>
<th>LTO-5 Cartridge</th>
<th>LTO-5 WORM</th>
</tr>
</thead>
<tbody>
<tr>
<td>LTO-4 Drives</td>
<td>Reads/Writes</td>
<td>Write Once, Read Many</td>
<td>Not compatible</td>
<td>Not compatible</td>
</tr>
<tr>
<td>LTO-5 Drives</td>
<td>Reads/Writes</td>
<td>Write Once, Read Many</td>
<td>Reads/Writes</td>
<td>Write Once, Read Many</td>
</tr>
</tbody>
</table>

All LTO cartridges are the same size, which means they use the same magazines in the library. LTO drives can be directly attached to hosts or attached to the SAN.

### Operator Panel

The operator panel is located on the front of the control module and consists of the indicator panel and the OCP (see Figure 9). In the indicator panel, the buttons are for robot control and power, and the indicators provide library status.
Figure 9 Operator Panel

The OCP is the library navigation point and provides access to the LMC. For more information about the OCP and the LMC, see Accessing the Library Management Console (LMC).

Power System

The library supports single and redundant power configurations. The single configuration has a single AC line input and single DC power supply. The redundant configuration has dual AC line input and dual DC power supplies. You can hot swap a power supply if you have a redundant power supply. You can hot add a second power supply.

The power system consists of the following:

- Power supply
- Power distribution unit (PDU)
- AC power cord

A single power switch, located on the access door, turns on and off all power for the control module and attached expansion modules. Each PDU has a second circuit breaker, located in the rear of the module, that controls the module power supply output. The power supply has three LEDs that provide status information. The power system also has four fuses for system protection.

Using the library demonstration mode

By running the library in demonstration (demo) mode, you can demonstrate the ability of the library to move scratch media from an I/E station to a randomly selected storage slot, and then move media from storage slot to open storage slot until you pause or stop the demonstration. Non-demonstration media in the storage racks are not affected by the demonstration. While the demonstration proceeds, graphs on the main LMC display show data transfer and mount statistics using data that the demonstration routine provides. Demo mode is available only from the library OCP.
Starting demo mode

To start the demo mode:

1. Log onto the library from the local OCP as the Service user.
2. Make sure that no applications are accessing the library.
3. If you are not already working from the physical library, from the View menu, click the name of the physical library. Refer to Selecting a Library or Partition if you need more information on viewing the library.
4. Take the library offline.
5. Select Service > Start Demo.
   A Start Demo message appears.
6. Remove any non-demonstration cartridges from the I/E station, and then put one or more demonstration cartridges into the I/E station.

⚠️ CAUTION:
Any cartridges left in the I/E station will be used in the demonstration.

7. Select OK when you are ready to start the demonstration.
   Before the demonstration starts, the library performs an inventory. As the accessor moves cartridges, an intentional delay of two seconds occurs between move media commands. This prevents unnecessary wear on the robotics.

⚠️ CAUTION:
Do not take the library back online while the demo is running.

Pausing demo mode

You can pause the demonstration anytime while it is in progress. To do so:

1. While the demonstration is in process, select Service > Pause Demo.
   The current SCSI command completes before the library returns control to you. For example, if the library is performing an inventory, it could take several minutes before the inventory command completes.
   While the demonstration is paused, you can open an access door, take the library online, or perform any library operation.
2. To continue the demonstration at the point at which you paused it, select Service > Resume Demo.
   The demonstration will start again where it left off.

Stopping demo mode

To stop the demo mode, select Service > Stop Demo.

The current command will complete before the accessor returns the demo cartridges to their original slots in the I/E station.
Before you can manage your library from a remote Library Management Console (LMC) client, you must initially configure the library from the Operator Control Panel (OCP) on the library itself by either running the Setup Wizard command or using individual configuration commands from the Setup menu. For detailed information about initially configuring the library, see the HP Enterprise Storage Library (ESL) G3 Installation and Configuration Guide.

After the initial setup, you can use either the OCP or the LMC to modify your library configuration. The Setup menu includes most of the configuration commands.

**NOTE:**
Only one administrator can be logged on and performing library configuration at any one time. If another administrator attempts to log on, a message appears, warning that only one administrator at a time is permitted on the library. If a service user logs on while an administrator or regular users are logged on already, the library automatically logs off those users.

### Setup Wizard Prerequisites

Before you run the Setup Wizard:

- Note the name and IP address of your network Domain Name Server (DNS) or the IP address, subnet mask, and default gateway for your network segment.
- Verify that your network is attached to the library network connection.
- Delete the default partition. See Deleting Partitions for more information.

### Accessing the Setup Wizard

Before using the Setup Wizard, see Setup Wizard Prerequisites.

To access the setup wizard from the OCP or the LMC:

1. Log on as administrator. The home screen appears.
2. Verify in the System Information section, in the Name field that the physical library is selected. If necessary, select it by one of the following methods:
   - In the Managed Views section of the screen, click on the name of the physical library.
   - From the menu bar, select View, then the name of the library.
3. Click Setup > Setup Wizard to display the About Setup Wizard screen.
4. Use the buttons at the bottom of the wizard dialog box to navigate to the procedures you want to perform. The procedures available from the Setup Wizard are:

- Entering License Keys
- Setting up partitions (see Creating Partitions, Modifying Partitions, and Deleting Partitions)
- Enabling or disabling IPv6 and IPv4 network configuration
- Configuring the host name using the Setup Wizard
- Specifying the date and time using the Setup Wizard

## Entering License Keys

Enable license keys in the following situations:

- During initial installation and configuration of the library (See the HP Enterprise Storage Library (ESL) G3 Installation Guide)
- During a capacity on demand (COD) or feature upgrade.
- When you need to activate additional storage slots in your current COD configuration.
- When enabling certain reporting functionality
- When enabling ESKM (See Enabling the ESKM License Key for specific instructions.)

If you cannot locate the license instructions shipped with the library, you can obtain them by contacting HP Support.

NOTE:
Authorized service personnel are involved in the first two situations. However, any administrator can activate additional storage slots.

To enable licenses:

1. Log on as an administrator.
2. If you are not already working from the physical library, select it from the View menu.
3. From the menu bar, click Setup > Licenses.

NOTE:
To perform this procedure from the Setup Wizard, select Setup > Setup Wizard, then click Next until the Licenses dialog box appears.

Only run the Setup Wizard to perform initial library configuration. Use the appropriate other menu option to modify the configuration.

The Licenses dialog box appears.
This dialog box lists the licensed features for your library, including their status, expiration date, and quantity. The following guidelines apply to Quantity:

- The COD quantity is the number of slots licensed.
- The partition quantity is either 1 or 16. The only possible multiple number of partitions is 16.
- For features that are not licensed by quantity, such as Automated Media Pool, **Quantity** is always set to 1.

4. In the **Enter License Key** text box, type the appropriate license key.

**NOTE:**

You do not need to highlight the feature before you enter a license key.

License keys are not case-sensitive, so if you are using the library OCP, enter the library key from the lowercase keyboard, which gives you access to the dash (-) character.

If you cannot locate the license instructions shipped with the library, you can obtain them by contacting technical support or, if you are an end user, by contacting your sales representative.

5. Click **OK**.

If you have upgraded the library storage capacity, the extra storage slots you just added are not assigned to a partition. You can either create a new partition to include them or manually modify an existing partition to include them by using expert partitioning mode.

**CAUTION:**

Consult your service representative and see the **HP Enterprise Systems Library (ESL) G3 Tape Library Planning Guide** before you reconfigure your partitions.

**NOTE:**

Command View TL version 2.8 or later must be used to enter the TC347A license key for Command View TL software. Command View TL can also be used to launch the LMC, enter additional license keys, and enable TapeAssure.
Working With Partitions

A partition is an abstraction of a single underlying physical library that presents the appearance of multiple, separate libraries for purposes of file management, access by multiple users, or dedication to one or more host applications. For example, you can choose to run one software application in one partition, and a different software application in a second partition.

A Library Managed Partition (LMP) is like any other partition, except that it is not visible to any backup applications or hosts. The LMP allows the library to manage the partition, rather than the backup application managing the partition.

Each partition contains the following components of the physical library:

- **Accesser:** the robotic assembly that moves media within the library. The accessor includes the picker and reach assemblies.
- **I/E station magazine:** a magazine, consisting of slots for cartridges, that enables media to be moved into or removed from the physical library. The type of media determines the number of slots in the magazine. For example, an LTO magazine has six slots.
- **Storage magazine:** a static column location within a section of the physical library rack that holds removable media. For more about location coordinates, see Understanding Location Coordinates.
- **Drive:** the read/write device for removable media.

For more information about the physical components of the library, see the *HP Enterprise Systems Library (ESL) G3 Tape Library Service Guide*.

A partition consists of, at a minimum, one storage magazine and one drive. Neither the storage magazine nor the drive can be shared with another partition. Each partition is specific to a media type (for example, LTO-4, LTO-5). One 24 slot I/E station can be used by up to four partitions. One 72 slot I/E station can be used by up to twelve partitions. The maximum number of I/E station slots per partition is 240. The maximum number of partitions is determined by the lesser of either the number of drives available in the physical library (assuming there are at least as many storage slots), or 16.

---

**NOTE:**
The library is licensed for either one partition or the maximum number of partitions, which is 16. For more information about partition licensing, see *Generating the Events Report*.

Using the Secure Manager feature, multiple hosts can share a single partition, or a partition can be restricted to one exclusive host.

Each host application can have a partition assigned to it. Each application uses its partition as if it were a dedicated physical library.

Understanding Partition Media Policy Settings

The partition **Media Type Checking Policy** and **Return Media Identifier** settings help determine how the library handles differing media types within the same library. Configure media policy settings when you manually create or modify a partition.
Media Domain

The media domain is the family of all cartridge types that can be stored in the same storage slot. Typically, a media domain represents all the generations and brands of a particular tape technology. Linear Tape Open (LTO), for example, has many generations and vendors, but all LTO cartridges are considered to exist in the same media domain.

Media Type

The media type is a particular generation of tape technology. Several media types can exist within one media domain. Using LTO again as an example, within the LTO media domain is the LTO-4 media type, the LTO-5 media type, and so forth. A media type has an identifier, chosen by the tape manufacturer or consortium, that enables users and libraries to distinguish between them. The LTO consortium uses L4 and L5 to identify the LTO-4 and LTO-5 media types in a volume serial number.

Media ID Checking

Media ID checking policy restricts the movement of tape cartridges based on the media ID on the barcode label. This policy also helps you monitor the management of tapes and drives by the host applications. When you create or modify a partition, you can enable or disable the Media Type Checking option. If you choose to enable media type checking, you also can use the Media Checking Policy option to select from two modes of operation: Required or Not Required. With either mode, the library checks whether a cartridge has a valid media ID on the barcode label.

In Required mode, if the library does not find a valid media ID on a cartridge, the library does not allow it to be moved into or within the library. If the library finds a valid media ID, the library allows it to be moved from an I/E station into a partition that contains magazines matching the media domain of the cartridge (for example, LTO), but the library does not allow the cartridge to be moved from storage to a drive that does not have a matching type (for example, an LTO-5 cartridge will not be allowed to move to an LTO-4 drive).

In Not Required mode, if the library does not find a valid media ID on a cartridge, the library allows it to be moved into or within the library as long as the I/E station magazine, storage magazine, or drive matches the media domain of the cartridge. If the library finds a valid media ID, the library does not allow the cartridge to be moved from storage to a drive that does not have a matching type (for example, an LTO-5 cartridge will not be allowed to move to an LTO-4 drive).

Return Media Identifier

For the media policy settings, the library makes assumptions about a media identifier and its position in a media barcode label. To be considered a media identifier, the identifier characters must be correct for the media domain and media type. Also, the identifier, which for some media types can consist of more than one character, must be complete and in the correct location. The correct characters in the wrong position are not viewed as a media type identifier. In a physical library or partition containing mixed media, the media identifier is not required for all cartridges.

Table 3 explains the media type identifiers and assumptions.
Table 3 Sampling of Media Type Identifiers

<table>
<thead>
<tr>
<th>Media Domain</th>
<th>Media Type</th>
<th>Identifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>LTO</td>
<td>LTO-4</td>
<td>“L4” as the last two characters in the barcode</td>
</tr>
<tr>
<td>LTO</td>
<td>LTO-4 WORM</td>
<td>“LU” as the last two characters in the barcode</td>
</tr>
<tr>
<td>LTO</td>
<td>LTO-5</td>
<td>“L5” as the last two characters in the barcode</td>
</tr>
<tr>
<td>LTO</td>
<td>LTO-5 WORM</td>
<td>“LV” as the last two characters in the barcode</td>
</tr>
</tbody>
</table>

With a valid media type identifier present and the Media Type Checking setting enabled, which is the case by default, a host is prevented from executing invalid media moves across differing media types. For example, a host can be prevented from moving LTO-5 media to an LTO-4 drive. If an invalid move is attempted, the library returns an error to the host.

Returning media identifiers to hosts

With the Return Media Identifier setting, you can control if and where a media type identifier appears in the volume serial number that is returned to the host.

Table 4 shows an example of how the return media identifier behaves, depending on the setting you choose: Disabled, Prefix, Suffix, and Pass Through. The bold, underlined portion is the media identifier.

Table 4 Return Media Identifier Behavior Example

<table>
<thead>
<tr>
<th>Setting</th>
<th>Volume Serial Number Returned to Host¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disabled</td>
<td>AB1234</td>
</tr>
<tr>
<td>Prefix</td>
<td>L5AB1234</td>
</tr>
<tr>
<td>Suffix</td>
<td>AB1234L5</td>
</tr>
<tr>
<td>Pass Through</td>
<td>AB1234L5</td>
</tr>
</tbody>
</table>

¹Based on actual LTO-4 barcode: AB1234L5

For more information about configuring the Media Type Checking and Return Media Identifier settings, see Creating Partitions.

Working with Library Control Paths

You must define a control path for each library partition. The control path is used to connect a partition to a host application. The ESL G3 does not automatically assign a control path when you create a partition. When selecting a library control path for a partition, you are selecting which tape drive will present (or proxy) the virtual robot LUN to the SAN and hosts.

Creating Partitions

You can create library partitions in the following ways:

- Creating Partitions with the Setup Wizard
• Creating Partitions Automatically
• Creating Partitions Manually Using Simple Mode
• Creating Partitions Manually Using Expert Mode

The method you should choose depends on the circumstance and the level of control you want in allocating resources to the partition. In **Automatic** mode, the library assigns available system resources to create the number of partitions you specify. Automatic mode is not available if a partition already exists. **Manual** mode enables you to pick specific drives, storage magazines, and magazines within an I/E station to assign to a partition.

If one or more partitions already exist in the library, you must manually create a new partition to allocate drives, storage slots, and I/E station magazines. You have two options to allocate system resources when manually creating a new partition: Simple and Expert modes. In Simple mode, you can specify the quantity of each element you want assigned to the partition. In Expert mode, you can indicate which specific drives, storage magazines, I/E station magazines, or if enabled, extended I/E station magazines to assign to the partition.

**NOTE:**
Make sure that you have adequately planned for the number of partitions that you want to configure.

---

### Creating Partitions with the Setup Wizard

If you are performing an initial configuration of your library, you can use the Setup Wizard to automatically create partitions using the available system resources. See *Creating Partitions Automatically*. Using the Setup Wizard is part of the normal installation procedure for a library.

**NOTE:**
You should run the Setup Wizard only when you initially configure the library.

The Automatic radio button will be disabled if there are partitions already configured. This indicates that the Setup Wizard has already been run and you should create partitions by using **Setup > Partitions**. See *Creating Partitions Manually Using Simple Mode* or *Creating Partitions Manually Using Expert Mode*.

---

### Creating Partitions Automatically

You can use the library Automatic mode to create partitions within limits based on licensing restrictions and available resources. Automatic mode is available only if no partitions currently exist.

To create partitions automatically:

1. Log on as an administrator.
2. Ensure that you are viewing the physical library. From the **View** menu, click the name of the physical library.
3. Select **Setup > Setup Wizard**, then click **Next** until the **Partitions** dialog box appears.
   Alternatively, click **Setup > Partitions > Configure**.
   The **Partitions** dialog box appears.
4. Click **Create**.
   The **Partitions: Choose Creation Mode** dialog box appears.
5. Select **Automatic**, and then click **Next**.

**NOTE:**

**Automatic** is only available if no partitions currently exist. If it is not available, see Creating
Partitions Manually Using Simple Mode or Creating Partitions Manually Using Expert Mode to
create partitions.

The **Partitions: Automatic Creation** dialog box appears.

6. In the **Partitions** column, type the number of partitions you want to create for each media/drive
type.

The maximum number of partitions that you can create is determined by the number of partitions
you are licensed to create and the number of drives available.

7. Click **Create**.

8. Click **Finish**.

The **Partitions** dialog box appears again.

9. If you are in the **Setup Wizard**, click **Next** to continue, or click **Cancel** to exit the **Setup Wizard**.

If you are not in the **Setup Wizard**, click **Close**.

Creating Partitions Manually Using Simple Mode

In Simple mode, you can specify the quantity of each element you want assigned to the partition.

To create partitions manually using simple mode:

1. Log on as an administrator.

2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed
Views region of the LMC, click the name of the physical library.

3. Click **Setup > Partitions > Configure**.

   The **Partitions** dialog box appears, listing partitions that are currently configured within the library.

**NOTE:**

To perform this procedure from the **Setup Wizard**, select **Setup > Setup Wizard**, then click **Next**
until the **Partitions** dialog box appears.

Only run the **Setup Wizard** to perform initial library configuration. Use the appropriate other
menu option to modify the configuration.

4. Click **Create**.

   The **Partitions: Choose Creation Mode** dialog box appears.

5. Select **Simple**, and then click **Next**.

   The **Partitions: Choose Partition Properties** dialog box appears.

6. Configure the following settings:

   • In the **Name** text box, type a name that describes the new partition.
   • From the **Drive Domain** drop-down list, click the appropriate drive domain.

7. To continue, click **Next**.

   The **Partitions: Choose Policy Settings** dialog box appears.
8. Configure the media type checking and media identifier settings:
   • For Media Type Checking, select either Enable or Disable. This setting is enabled by default.
   • From the Media Checking Policy drop-down list, click either Required or Not Required.
   • From the Return Media Identifier drop-down list, click either Suffix, Pass Through, Prefix, or Disabled. Depending on which setting you choose, you can control the use of the media type identifier in the volume serial number that is returned to the host.

   △ CAUTION:
   After a media volume serial number has been reported to a host, changing the Return Media Identifier setting could cause the host to not recognize media within the library.

   For more information about how media policies work, see Understanding Partition Media Policy Settings.

   • For Automatic Drive Cleaning, click either Enable or Disable. This setting is enabled by default. Enabling automatic drive cleaning allows the library to initiate drive cleaning each time a drive requests a cleaning operation. For automatic drive cleaning to function, you must first configure drive cleaning for the library (see Configuring Drive Cleaning).

   ★ NOTE:
   Automatic drive cleaning should be enabled for partitions only if the host application does not support the coordination of drive cleaning. If drive cleaning functionality is enabled on the host application, do not enable automatic drive cleaning for any partitions in the library.

9. To continue, click Next.
   The Partitions: Choose Resource Quantities dialog box appears.

10. Type the number of elements to include in the partition by specifying:
    • Number of drives
    • Number of storage slots
    • Number of I/E slots
    The quantity available for each type of resource indicates resources not yet assigned to existing partitions.

11. To continue, click Next.
    The Partitions - Summary Information dialog box appears.

12. Verify that the parameters you set are correct.

13. To create the partition, click Create.

   ★ NOTE:
   After you click Create, the Cancel button becomes unavailable.

   The Partitions - Completed dialog box appears.

14. Review the information to make sure it is correct.

15. If you want to view the drive information after creating the partition, click Next.

16. Click Finish.
The **Partitions** dialog box lists the partition you just created.

**17.** If you are in the **Setup Wizard**, click **Next** to continue to **IPv6 Configuration**, or click **Cancel** to exit the **Setup Wizard**. If you are not in the **Setup Wizard**, click **Close**.

---

**Creating Partitions Manually Using Expert Mode**

In Expert mode, you can indicate which specific drives, storage magazines, I/E station magazines, or if enabled, extended I/E station magazines to assign to the partition.

To create partitions manually using expert mode:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Setup > Partitions > Configure**.
   The **Partitions** dialog box displays a list of partitions currently configured within the library.

---

**NOTE:**
To perform this procedure from the **Setup Wizard**, select **Setup > Setup Wizard**, then click **Next** until the **Partitions** dialog box appears.

Only run the **Setup Wizard** to perform initial library configuration. Use the appropriate other menu option to modify the configuration.

---

4. Click **Create**.
   The **Partitions: Choose Creation Mode** dialog box appears.
5. Select **Expert**, and then click **Next**.
   The **Partitions: Choose Partition Properties** dialog box appears.
6. Configure the following settings:

---

**NOTE:**

If you are creating a Library Managed (AMP) partition, do the following:

a. Ensure that the AMP license is installed.

b. Name the partition, select the slot magazines to include in the partition, and select the I/E station slots to include in the partition.

c. Go to 7.

If you are not creating an AMP, do the following:

a. In the **Name** text box, type a name to describe the new partition.

b. From the **Drive Domain** drop-down list, click the appropriate drive type.

---

7. To continue, click **Next**.
   The **Partitions: Choose Policy Settings** dialog box appears.

---

**NOTE:**

If you are configuring the AMP, all fields are greyed out and do not allow input. Go to 9.
8. Configure the following settings:
   • For **Media Type Checking**, select either **Enable** or **Disable**. This setting is enabled by default.
   • From the **Media Checking Policy** drop-down list, click either **Required** or **Not Required**.
   • From the **Return Media Identifier** drop-down list, click either **Suffix**, **Pass Through**, **Prefix**, or **Disabled**. Depending on which setting you choose, you can control the use of the media type identifier in the volume serial number that is returned to the host.

   ![CAUTION:](image)
   After a media volume serial number has been reported to a host, changing the **Return Media Identifier** setting could cause the host to not recognize media within the library.

   For more information about how media policies work, see Understanding Partition Media Policy Settings.

   • For **Automatic Drive Cleaning**, click either **Enable** or **Disable**. This setting is enabled by default. Enabling automatic drive cleaning allows the library to initiate drive cleaning each time a drive requests a cleaning operation. For automatic drive cleaning to function, you must first configure drive cleaning for the library. (See Configuring Drive Cleaning.

   ![NOTE:](image)
   Automatic drive cleaning should be enabled for partitions only if the host application does not support the coordination of drive cleaning. If drive cleaning functionality is enabled on the host application, do not enable automatic drive cleaning for any partitions in the library.

9. To continue, click **Next**.
   The **Partitions: Select Drives** dialog box appears.

10. In the left column, select the location of one or more drives.
    Make sure that you select the appropriate module, because the library can have drives in the control module and any of the eleven expansion modules.

11. To assign a drive to the partition, select the appropriate check box. You can identify a drive by its serial number and location coordinates. For more information, see Understanding Location Coordinates.

12. To continue, click **Next**.
    The **Partitions: Select Storage Slots** dialog box appears.
    When you are selecting storage slots to be part of the partition, if you have the AMP license installed you can also add magazine extensions to the partition that can be used to extend the partition for future growth via the AMP partition slots. For each extension you add, the library will report those extensions as inaccessible slots until you assign magazines from the AMP partitions to this partition.

13. In the left column, select the location of one or more I/E station magazines.

14. To assign a storage slot, select the appropriate check box. You can identify a storage slot by its location coordinates. The number of slots available is determined by the drive media type.

15. To continue, click **Next**.
    The **Partitions: Select I/E Slots** dialog box appears.

16. Select the location of one or more I/E station magazine.
a. Make sure that you select the appropriate module because the library can have I/E stations in the control module and expansion modules.

b. To assign an I/E station magazine, select the appropriate check box. You can identify an I/E station magazine by its location coordinates.

17. If Control Path Failover (CPF) license is installed, you are able to select which drive will be the CP drive. Do so now.

18. If Data Path Failover (DPF) license is installed, you are able to select which drive will use DPF. Do so now.

19. To continue, click Next.

NOTE:
Depending on whether Extended I/E is enabled, Select Extended I/E Slots may appear. See the next step. If Extended I/E is not enabled, go to 21.
To enable Extended I/E, go to Setup > Physical Library, and select the feature. For more information about Extended I/E, see Extended I/E Option.

20. In the Partitions: Select Extended I/E Slots dialog box, do the following:
   a. In the left column, select the location of one or more Extended I/E station magazines.
   b. To assign an Extended I/E station magazine, select the appropriate check box. You can identify an I/E station magazine by its location coordinates.

   The Partitions - Summary Information dialog box appears.

21. In the Partitions - Summary Information dialog box, verify that the parameters you set are correct.

22. To create the partition, click Create.

NOTE:
After you click Create, the Cancel button becomes unavailable.

23. Review the information to make sure it is correct.

24. If you want to view the drive information after creating the partition, click Next.

25. Click Finish
   The Partitions dialog box lists the partition you just created.

26. If you are in the Setup Wizard, click Next to continue to IPv6 Configuration, or click Cancel to exit the Setup Wizard. If you are not in the Setup Wizard, click Close.

Modifying Partitions

You can use the Modify process to change the allocation of drives and storage magazines in existing partitions without having to delete the entire partition and then recreate it. You also can use Modify to change partition properties and partition settings.

CAUTION:
Modifying partitions improperly, particularly when deleting partition elements, can disrupt host applications.
Before you modify any partitions, understand the configuration changes you plan to make and the potentially disruptive effects that those changes could have on the host applications. Be careful whenever you add or delete partition elements that include drives, storage magazines, and I/E station magazines.

**NOTE:**
A partition with loaded drives cannot be modified.

For best results, follow these guidelines when adding or deleting partition elements:
- Shut down the host application.
- Update the inventory in the library.
- Reconfigure the library in the application.
- Update the inventory in the application.

**NOTE:**
This procedure includes instructions for downloading new drive firmware images. You can modify partitions from either the library OCP or a remote client. However, if you want to download drive firmware images, you must do so from a remote client.

To modify an existing partition:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Setup > Partitions > Configure**.
   The **Partitions** dialog box appears.
4. Select the partition you want to change, and then click **Modify**.

**NOTE:**
If the physical library is not offline, you receive a message that asks you whether you want to modify the partition, requiring the library to be taken offline. Click **Yes**. No host will be able to access the partition while the library is offline.

**The Partitions: Choose Partition Properties** dialog box appears.

**NOTE:**
For AMP partitions, you can not modify these properties; all options will be disabled.

5. To modify the **Partition Name**, type the appropriate name into the field.
6. Click **Next**.
   The **Partitions: Choose Policy Settings** dialog box appears.
7. From the Partition dialog box, configure the following:
   a. Select the appropriate value from the Media Barcode Label Type Restrictions.
   b. Select the Return Media Identifier.
   c. Enable or disable Automatic Drive Cleaning.

8. Click Next.
   The Partitions: Select Drives dialog box appears.

9. Select the location of one or more drives.
   Make sure that you select the appropriate module because the library can have drives in the control module and in any of the expansion modules.

10. To add a drive to the partition, select the appropriate drive check box. Delete a drive from the partition by clearing the drive check box. Identify a drive by its serial number and location coordinates.

11. To continue, click Next.
    The Partitions: Select Storage Slots dialog box appears.
    When selecting storage slots to be part of the partition, if you have the AMP license installed you can also add magazine extensions to the partition that can be used to extend the partition for future growth via the AMP partition slots. For each extension you add, the library will report those extensions as inaccessible slots until you assign magazines from the AMP partitions to this partition.

12. Select the rack you want to modify.

13. To add an I/E station magazine, select the appropriate check box. Delete an I/E station magazine by clearing its check box. Identify an I/E station magazine by its location coordinates.

14. Click Next.
    The Partitions: Select I/E Slots dialog box appears.

15. Select the location of one or more I/E station magazines.
    Select the appropriate module. The library can have I/E stations in the control module and in expansion modules.

16. To add an I/E station magazine, select the appropriate check box. To delete an I/E station magazine, clear the associated check box. Identify an I/E station magazine by the location coordinates.

17. Click Next.
    The Partitions: Choose Control Path Drive dialog box appears.

18. Select which drive will be the Control Path Drive.

19. Click Next.
    The Partitions: Choose Control Path Failover Drive dialog box appears.

20. Select the drive to assign for Control Path Failover.
21. Click Next.
   The **Partitions: Choose Data Path Failover Drives** dialog box appears.

22. Select which drives to enable Data Path Failover. Data Path Failover drives must be configured in Fabric mode.

23. Click Next.
   The **Partitions: Configure Drive Firmware Autoleveling** dialog box appears. To download a new drive firmware image go to the next step, otherwise go to 25.

24. To download new drive firmware, see Updating Drive Firmware.

25. To enable autoleveling for the partition, perform the following steps:
   a. From the **Drive Type** drop-down list, click the type of drives that you want to list in the table. Listed drive types use the following format: `<vendor>_<product>_<interface>`
      Drives of the specified type within the partition appear in the table.
   b. In the left-most column of the table in the **Selected Drives will be Autoleveled** area, select one or more check boxes that correspond to drives that you want to update with the same drive firmware version.
   c. If necessary, download a new Tape Drive Firmware image, click **Manage Images**, click **Download**, select the firmware image (file type .frm), then click **Open**.
   d. Click the appropriate version in the **Select Autolevel Firmware File** drop-down list.

26. Click Next.
   The **Partitions - Summary Information** dialog box appears.

27. Verify that the parameters you set are correct.

28. If the summary information is correct, click **Modify**.

**NOTE:**
After you click **Modify**, the **Cancel** button becomes unavailable.

The **Partitions - Completed** dialog box appears.

29. Review the information to make sure it is correct.

30. Click **Finish**.
   The **Partitions** dialog box appears again.

31. If you are in the **Setup Wizard**, click **Next** to continue to IPv6 Configuration, or click **Cancel** to exit the **Setup Wizard**. If you are not in the **Setup Wizard**, click **Close**.

---

**Data Path Failover for Partitions**

Data Path Failover allows an alternate path when a preferred path fails. Only drives configured in Fabric mode are eligible for Data Path Failover.

**NOTE:**
Only LTO-5 drives can be used as Data Path Failover drives.
Data Path Failover shows the current status of each drive is shown:

- **Green** — eligible for Data Path Failover.
- **Yellow** — Data Path Failover currently enabled.
- **White** — no changes have been made.
- **Red** — custom mapping has been applied.

To enable Data Path Failover:
1. Log on as an administrator.
2. Click **Setup > Partitions > Data Path Failover**.
   The **Data Path Failover (DPF)** dialog box appears.
3. Under **Data Path Failover Configuration**, select the drive(s) you want to enable Data Path Failover.
4. Click **OK**. Data Path Failover is now enabled.

To disable Data Path Failover:
1. Log on as an administrator.
2. Click **Setup > Partitions > Data Path Failover**.
   The **Data Path Failover (DPF)** dialog box appears.
3. Click **OK**. Data Path Failover is now disabled.

---

Deleting Partitions

⚠️ **CAUTION:**

For the host application to have access to the written data on the partition that you want to delete, you must recreate a partition that includes the same media type, interface, I/E station magazines, and a host at the same LUN.

To delete a partition, perform the following steps:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Setup > Partitions > Configure**.
   The **Partitions** dialog box appears.
4. Click the partition you want to delete.
   **NOTE:** You can delete only one partition at a time.
5. Click **Delete**. To delete the partition click **Yes**.
   **NOTE:** If the physical library is not offline, you receive a message that asks you whether you want to take the library offline and delete the partition. Click **Yes**.
6. The library deletes the selected partition. Repeat the process to delete another partition, or click Close.

Selecting partition and configuration for control path

To select a partition and configure the control path, perform the following steps:

1. Log on as an administrator.
2. From the main console, select Setup > Partitions > Control Path.
   The Secure Manager Partitions dialog box appears.

3. Highlight the partition you want to configure, and click OK.
   The Control Path dialog box appears.

4. Select the drive you want to configure as the control path.
   The primary Control Path Drive you selected is highlighted in yellow, and the Enable Control Path box is selected automatically.

5. Click OK to finish.
NOTE:
If the partition is not offline, you will receive a message stating that the partition must be taken offline prior to performing the operation. Ensure backup applications are not currently using the partition. Click Yes to continue.

Automated Media Pool (AMP)

NOTE:
Magazines can not be assigned if there are no automated media pool partitions configured.

Automated Media Pool (AMP), also referred to as a Library Managed partition in the LMC, enables the creation of a virtual partition that can be dynamically allocated to other, previously-created partitions, all without disrupting host or application operation. AMP magazines are presented to host applications as part of a standard partition, but AMP magazines appear as “inaccessible” until they are assigned to a normal partition.

AMP may be thought of as “thin provisioning” for a tape library. Both a partition license and an AMP license are required to enable AMP on a library.

An AMP example is shown in the following figure:

![Library Partitioning and What the Backup App Sees](image)

In this example, three standard partitions have been created to present to SAN hosts. Partition 4 is a Library Managed (AMP) partition from which slots can be reassigned. As shown in the example, each partition contains 100 physical storage slots. The host application will see each partition as containing a total of 130 storage slots, 30 of which will be tagged as “inaccessible”.

To create an AMP partition:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > Partitions > Configure.
   The Partitions dialog box displays a list of partitions currently configured within the library.
4. Click Create.
   The Partitions - Choose Creation Mode dialog box appears.
5. Select Expert, and then click Next.
   The Partitions - Choose Partition Properties dialog box appears.
6. In the Name box, type a name for the AMP partition.

7. In the Library Type drop-down box, select Library Managed (AMP) and click Next. The Partitions - Choose Policy Settings dialog box appears. All options are grayed out for AMP partitions.

8. Click Next.

   The Partitions – Select Storage Slots dialog box appears.

9. Select the slots that you want to become part of this AMP partition and click Next.

   The Partitions – Summary Information screen appears.

10. Click Create to create the new AMP partition.

To display a color-coded view of your partitions, drives, and media, click Tools > Library Explorer > Partition View.

Assigning slot magazines from an AMP partition to a standard partition will make those slots accessible to host applications that are using the standard partition. You can also reverse the operation and assign magazines from a standard partition to an AMP partition.

To dynamically assign AMP magazines:

1. Log on as an administrator.

2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.

3. Click Setup > Partitions > Automated Media Pool > Assign Magazines.

   The Assign Magazines: Select Partitions dialog box appears.

4. Select the partition that you want to remove magazines from, and select the partition that you want to assign magazines to. Then click OK.

   The final Assign Magazines dialog box appears.

5. Select the magazine segments that you want to assign to the selected partition and click OK to complete the operation.

   Any magazines assigned to a standard partition are now accessible to host applications. Any magazines assigned to an AMP partition are presented as part of standard partitions to host applications but are tagged as “inaccessible” as previously described.

To display a color-coded view of your partitions, drives, and media, click Tools > Library Explorer > Partition View.

Media cannot be moved directly from a standard partition to another standard partition. However, AMP can be used as a staging area to allow for media to be moved between standard partitions. All of this can be performed via the GUI, no physical intervention is needed.

To move (or “assign”) media to or from an AMP partition:

1. Log on as an administrator.

2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.

3. Click Setup > Partitions > Automated Media Pool > Assign Media.

   The Assign Media: Select Partitions dialog box appears.

4. Select the partition that you want to remove media from, and select the partition that you want to assign or move media to. Then click OK.

   The final Assign Media from... dialog box appears.

5. Select the media that you want to move and click OK.

   The media you selected is moved to the specified partition and the dialog box closes.
To display a color-coded view of your partitions, drives, and media, click **Tools > Library Explorer > Partition View**.

### Enabling or disabling IPv6 and IPv4 network configuration

Selecting **Enable IPv6** and clicking **Next** displays the **Configure Hostname** dialog that you use to specify a library name for connecting to the library remotely. See **Setting up IPv6 Network Configuration** for more information about IPv6 network configuration.

Selecting **Disable IPv6** and clicking **Next** displays the **Network Configuration** dialog that you use to specify the IPv4 host and port settings. See **Setting up IPv4 Network Configuration** for more information about IPv4 network configuration.

### Setting up IPv4 Network Configuration

After completing steps 1 through 3 of **Setting up the Network Configuration**, the **IPv4 Network Configuration** dialog box appears.
1. Use Table 5 to assist you in completing the elements on the IPv4 Network Configuration dialog box.

### Table 5 IPv4 Network Configuration Information

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>In the Host Settings area:</strong></td>
<td></td>
</tr>
<tr>
<td><strong>DHCP</strong></td>
<td>If Dynamic Host Configuration Protocol (DHCP) is enabled on your network, select <strong>Enable</strong> to have DHCP automatically configure the library network settings. <strong>Enable</strong> makes the <strong>IP Address</strong>, <strong>Subnet Mask</strong>, and <strong>Default Gateway</strong> text boxes unavailable. Select <strong>Disable</strong> to make the <strong>IP Address</strong>, <strong>Subnet Mask</strong>, and <strong>Default Gateway</strong> text boxes available for you to manually set the library network settings.</td>
</tr>
<tr>
<td><strong>Library Name</strong></td>
<td>The network name that you want to assign to the library.</td>
</tr>
<tr>
<td><strong>IP Address</strong></td>
<td>The IP address of the library. This text box is available only if DHCP is disabled.</td>
</tr>
<tr>
<td><strong>Subnet Mask</strong></td>
<td>The subnet mask. This text box is available only if DHCP is disabled.</td>
</tr>
<tr>
<td><strong>Default Gateway</strong></td>
<td>The IP address of the default gateway for your portion of the Ethernet network. This text box is available only if DHCP is disabled.</td>
</tr>
<tr>
<td><strong>In the Port Settings area:</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Auto Negotiate</strong></td>
<td>Select <strong>Enable</strong> to have the library automatically negotiate port speeds. <strong>Enable</strong> makes the <strong>Speed</strong> options unavailable. Select <strong>Disable</strong> to make the <strong>Speed</strong> options available for you to manually set the port speed.</td>
</tr>
<tr>
<td><strong>Speed</strong></td>
<td>The port speed (10 Mbps or 100 Mbps). Speed options are available only if <strong>Auto Negotiate</strong> is disabled.</td>
</tr>
</tbody>
</table>

The **Cycle** button enables you to cycle the external Ethernet interface without rebooting the library.

2. Make the appropriate network configuration changes, and then click **OK**.
   A message appears that informs you that network connectivity will be lost temporarily, and asks whether you want to proceed.

3. Click **Yes**.

### Setting up IPv6 Network Configuration

After completing steps 1 through 3 of Setting up the Network Configuration, the **Static IP** tab of the IPv6 Network Configuration dialog box appears:
1. Use the Static IP tab to disable or to enable and specify a static IP address. Valid static IP addresses include link local, site local, and global uncast.

2. Click DHCP to display the DHCP tab.

3. As prompted, use the DHCP tab to enable or disable the Dynamic Host Configuration Protocol (DHCP) auto configuration function.

4. Click Hostname to display the Hostname tab.

5. Use the Hostname tab to specify a library name that can be used for remote connections to the library.

6. Click Settings to display the Settings tab.

7. Use the Settings tab to view the current IPv6 configuration settings.

8. After you make the appropriate network configuration changes, click OK.

   A prompt appears informing you that network connectivity will be temporarily lost and asks whether you want to proceed.
9. Click Yes.

**Setting the network configuration using the Setup Wizard**

You can only set up your network configuration from the OCP. If you have already configured the library, do not use the Setup Wizard to reconfigure your settings.

Ensure that your library is attached to the network before you use the Network Configuration command.

To complete the network portion of the Setup Wizard:

1. From the menu bar, click **Setup > Setup Wizard**.
   
   Navigate to the network portion of the setup wizard.

2. If necessary, contact the network administrator to find out if DHCP is enabled on the network, then perform one of the following:
   
   - If Dynamic Host Configuration Protocol (DHCP) is enabled on your network, select **Enable**. DHCP automatically configures the library network settings.
   - If you do not have DHCP enabled on your network, select **Disable** and type the library name, IP address, subnet mask, and the IP address of the default gateway for your network.

3. Under **Port Settings**, choose to enable or disable **Auto Negotiate**.
   
   - If **Auto Negotiate** is enabled, the **Port Speed** defaults to 100.
   - If **Auto Negotiate** is disabled, select a **Port Speed**.

4. Click **OK**.

**Configuring the host name using the Setup Wizard**

**NOTE:**

Only run the **Setup Wizard** to perform initial library configuration. Thereafter, use the procedure **Setting up IPv6 Network Configuration** to reconfigure the host name.

To configure the IPv6 host name:

1. Select **Setup > Setup Wizard**, then click **Next** until the **Configure Hostname** dialog box appears.

2. Type the name that can be used to connect to the library remotely.

3. Click **Next**.

**Specifying the date and time using the Setup Wizard**

If NTP is enabled, you can complete the date and time in the Setup Wizard:

1. To use NTP, in **NTP Setting**, click **Enable**. The default setting is **Disable**.
   
   - If you choose to use NTP, you must provide valid IP addresses that are accessible from the library. You have the option of using one or two IP addresses.
   - If NTP is enabled and you no longer want to use this setting, click **Disable**. If you do not use NTP, you must manually set the date and time.

2. Use the **Date** drop-down lists to select the month, date, and year.

3. Use the **Time** drop-down lists to select the hour, minute, and, whether the time is A.M. or P.M.
4. In the **Time Zone** drop-down list, select the appropriate time zone.
   
The default time zone is **GMT**. The time zone that you select appears only on your library information panel. Regardless of your selection, the system operates on the GMT zone.

5. Click **OK**.

**Specifying the Date and Time**

To set the date and time or use NTP:

You can use the **Date and Time** command to set or reset the system time. If you want to synchronize the library over a network, you can use the Network Time Protocol (**NTP**) setting. The default date and time is Greenwich Mean Time (GMT).

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Setup** > **Date and Time**.
   
The **Date and Time** dialog box appears.

4. In the **NTP Setting** section:
   
   - If you choose to enable NTP, click **Enable**, otherwise continue with the next step to manually set the date and time.
     
   There are no options for the **Date and Time** sections of the dialog box are grayed out.

   - Type valid IP addresses for the **Primary Server** and optionally the **Secondary Server**.

   - If the DNS Server has not been configured in the LMC, type valid numeric IP addresses that are accessible from the library (example 111.11.11.111). You have the option of using one or two IP addresses.

   - If the DNS Server has been configured through the LMC (**Setup** > **DNS Configuration**), type the valid alpha/numeric IP Addresses that are accessible from the library. You have the option of using one or two IP addresses.

   - If NTP is enabled and you no longer want to use this setting, click **Disable**.

5. Use the **Date** drop-down lists to select the month, date, and year.
6. Use the **Time** drop-down lists to select the hour, minute, and whether the time is A.M. or P.M.
7. Use the **Time Zone** drop-down list to select the appropriate time zone.

   ![NOTE:](image)
   
The default time zone is GMT. The time zone that you select appears only on your library information panel. Regardless of your selection, the system operates on the GMT zone.

8. Click **OK**.

**Filling the library with cartridges (bulk loading)**

Before your library is operational, place cartridges into the slots of the magazines lining the interior of your library.

- Make certain the barcode side is facing out of the slot.
• Make certain that the cartridge is completely seated in the slot. Accessor motion can be impeded if the cartridge is not completely seated within the slot.
• You should not be able to see the name of the media type typically printed on the top of the cartridge by the manufacturer.

When your library is operational, use the I/E Station to add additional cartridges. Insert the cartridges in the slots of the I/E Station. Then use Operations > Import to import the cartridges.

If you have physically connected your host to the MCB, you must use FC host to map the partition(s) to that host in order for the library to manage the media in that partition. To do this, click Setup > Device > Access > FC host. Then, map the partition from the internal Device column to the external ID/LUN/Device column.

Setting up the Network Configuration

Make sure that your library is attached to the network before you use the Network Configuration command.

⚠️ CAUTION:
You must fully understand all network issues before you change the network configuration for an already configured library. It is recommended that you consult with your network administrator before changing your network configuration.

⚠️ NOTE:
To set up an IPv6 network connection, make sure that the IPv6 option is enabled on the Physical Library dialog box.

To set up the network configuration:

1. Log on as an administrator.
2. If you are not already working from the physical library, select the physical library from the View menu.
3. From the menu bar, click Setup > Network Configuration > Network Configuration.
4. Depending on whether IPv6 is enabled or disabled and the protocol of the network connection you want to configure:
   • If IPv6 is disabled, the IPv4 Network Configuration dialog box appears. Proceed to Setting up IPv4 Network Configuration.
   • If IPv6 is enabled, but you want to configure an IPv4 connection, click IPv4 Configuration on the Network Configuration submenu to display the IPv4 Network Configuration dialog. Proceed to Setting up IPv4 Network Configuration.
   • If IPv6 is enabled and you want to configure an IPv6 connection, click IPv6 Configuration on the Network Configuration submenu to display the IPv6 Network Configuration dialog. Proceed to Setting up IPv6 Network Configuration.
NOTE:
The Network Configuration submenu only appears if you have enabled IPv6 for the physical library.

After you set up the network configuration, see the following topics:
- Setting up IPv4 Network Configuration
- Setting up IPv6 Network Configuration

Changing internal IP network addressing

You can use the LMC to change the internal IP address of the library and other library security settings, including enabling or disabling network services, enabling or disabling remote access to the library, setting up firewall access for server callbacks to remote clients, and enabling or disabling SNMP or SMI-S access.

The default internal network subnet setting for the ESL G3 library is 10.10.X.X. Attaching the library to a 10.10.X.X external network can cause library and network problems. The Change Internal IP dialog box enables you to change the library internal IP addressing so that conflicts do not occur. This dialog box is accessible only from the library OCP.

- You only need to change the default internal IP setting if your external network is 10.10.X.X.
- Do not set up internal IP addressing to conflict with existing external IP addressing. If you set up the same IP subnet for both the internal and external IP networks (for example, 10.10.X.X), the library will become unusable.
- If you change the internal IP addressing, and then later on a user uses the Network Configuration dialog box (Setup > Network Configuration) to assign to the library a static IP address that conflicts with the internal network, the assignment request will fail and the library will issue an event.
- If you change the internal IP addressing, and then later on a user uses the Network Configuration dialog box (Setup > Network Configuration) to assign to the library a static IP address that conflicts with the internal network, the assignment request will fail and the library will issue an event.
- If you change the internal IP addressing, and if Dynamic Host Configuration Protocol (DHCP) is enabled and DHCP assigns to the library an IP address that conflicts with the internal network, address conflicts could occur between internal library devices and external customer devices and the library will issue an event.

To change the Internal IP Network Addressing:

1. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
2. Click Setup > Network Configuration > Network Configuration.
3. Type the appropriate value into the IP Address field.
4. To change any other settings, type the appropriate values into the corresponding fields and select or clear the appropriate radio boxes.
   A Warning message appears, explaining that you are changing the network configuration from a remote client, and that the connection to the library will be lost until you restart the remote client.
5. If you are sure that you want to make the change, click Yes. If you are unsure about whether the change is appropriate, click No.
6. After the library processes the request successfully, a message appears that asks you whether you want to shut down the library. You must shut down and restart the library.
Configuring DNS

If DHCP is disabled, you can specify primary and secondary Domain Name System (DNS servers). DNS servers provide IP address resolution of fully qualified domain names. DNS settings are optional.

⚠️ CAUTION:

You must fully understand all network issues before you change the network configuration for an already configured library. It is recommended that you consult with your network administrator before changing your network configuration.

To view the DNS server:

1. Log on as an administrator.
2. If you are not already working from the physical library, select the physical library from the View menu.
3. Click Setup > Network Configuration > DNS Configuration.
4. Type the IP addresses of the primary, secondary (optional), and tertiary (optional) DNS servers to be used.
   When you make a change to the current values, the OK button becomes active.
5. Click OK to accept the new values and exit the dialog box.

Setting up Network Security

To set up network security:

1. Log on as an administrator.
2. If you are not already working from the physical library, select the physical library from the View menu.
3. From the menu bar, click Setup > Network Configuration > Network Security Settings.
4. To select services to enable or disable:
   a. Click the Services tab.
      Available services are:
      • Network Interface
      • ICMP
      • SSH
      • SSHv1
      • CLI
      • HTTP
   b. For each of the services listed, select the radio button to enable or disable the service.
   c. Click Apply.
   d. Read the text in the Attention dialog box, then click Yes.
   e. Click OK to exit the Security Configuration dialog box, or select another tab to continue configuration.
5. To configure security settings on the LMC:
a. Click the LMC tab.

b. In the Remote Access section, enable or disable by selecting the appropriate radio button, then select or clear the box to indicate whether or not to Use SSL.

c. In the Callback section, type in the starting and ending port ranges.

d. In the Remove Service Login section, enable or disable the feature by selecting the appropriate radio button.

e. In the Session section, select the appropriate timeout value (in minutes) by using the scrolling buttons next to the timeout field or by typing in the value.

f. Click Apply.

6. To configure the SNMP/SMI-S security settings:
   a. Click the SNMP/SMI-S tab.
   b. In the SMI-S section, enable either SMI-S or Secure SMI-S by selecting the appropriate radio button.
   c. In the SNMP section, enable or disable SNMP encryption by selecting the appropriate radio button, then either select or clear the box to indicate whether to Enable SNMP v1 and v2.

   d. Click Apply.

   e. Read the text in the Attention dialog box, then click Yes.

   f. Click OK to exit the Security Configuration dialog box, or select another tab to continue configuration.

7. Read the text in the Attention dialog box, then click either Yes or No.

Setting up Drives

**NOTE:**

Drives must be offline and unloaded before changing settings.

To setup drive settings, perform the following:

1. Log on as an administrator.

2. From the menu bar, click Setup > Drive Settings.

   The Drive Settings dialog box appears.

3. Select the drive you want to configure.

4. Select the speed of the drive from the Speed drop-down menu.

5. Select the topology of the drive from the Topology drop-down menu.

   If the topology is set to Loop, configure the Loop ID.

**NOTE:**

Drives configured for data path failover must be set to Fabric mode.

6. Click OK.
Configuring E-mail

Before using the Setup Wizard, see Setup Wizard Prerequisites.

The library uses the e-mail settings on the Email Configuration dialog box whenever library e-mail services are used, such as when you use the Send command to e-mail support events or logs and when the library automatically sends e-mail notifications of library problems.

Setting Up or Changing the E-Mail Configuration

To set up or change the e-mail configuration:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > Notifications > SMTP Email Configuration.
   The SMTP Email Configuration dialog box appears.
4. In the SMTP Server text box, type the IPv4 or IPv6 address of the SMTP server (for example, 192.16.96.201).

⚠️ CAUTION:  
You must identify the SMTP server by its server address.

5. If your SMTP server requires authentication of accounts and passwords, select Password in the Authentication field.
   If your SMTP does not require authentication, select None.

💡 NOTE:  
The Account and Password text boxes are not available if None is selected in the Authentication field.
a. In the **Account** text box, type the name of a valid account on the SMTP server (for example, Jay.User).

b. In the **Password** text box, type the password for the account that you specified in the **Account** field.

6. In the **Sender Address** text box, type an e-mail address for the library (for example, eslg3@my-company.com).

   The library uses this address in the **From** field of e-mail messages that it sends out, indicating the originator of the message. If you type, for example, eslg3, the library appends the domain information (for example, @mycompany.com). If you type, for example, eslg3@mycompany.com, the library does not append any additional information.

7. To test the e-mail configuration, type an e-mail address in the **Recipient** box of the **Test Current Configuration** area and click **Test email**.

8. Confirm that the library displays a message indicating that the test completed successfully, and that the library sends a test message to the specified e-mail address.

   The subject of the test message should be **Test email from ESL G3 Series Library**. and the message text should include the library name, version, and serial number, along with the date and time that the message was sent.

9. To finish, click **OK**.

### Testing the Current E-Mail Configuration

To test the current e-mail configuration:

1. Log on as an administrator.

2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.

3. Click **Setup > Notifications > Email Configuration**.

   The **SMTP Email Configuration** dialog box appears.

4. Type an e-mail address in the **Recipient** box of the **Test Current Configuration** area and click **Test email**.

5. Confirm that the library displays a message indicating that the test completed successfully, and that the library sends a test message to the specified e-mail address.

   The subject of the test message should be **Test email from ESL G3 Series Library**. and the message text should include the library name, version, and serial number, along with the date and time that the message was sent.

6. Click **OK** to close the **Email Configuration** dialog box.

### Setting Up E-mail Notifications

Before using the Setup Wizard, see **Setup Wizard Prerequisites**.

Before you set up notifications, you must configure e-mail in the LMC so that the library can send notifications to the recipients. See **Configuring E-mail**.
Table 6 describes the severity levels for which the library can send notifications if e-mail addresses are set up appropriately to receive them.

**Table 6 Severity Levels Assigned to Issues**

<table>
<thead>
<tr>
<th>Severity Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 (Failed)</td>
<td>Indicates that a failure has occurred or a different serious condition exists within a library subsystem that requires immediate corrective action. In most cases, a hardware component is no longer functioning at an acceptable level or has failed. Typical library operations are either impossible or highly unreliable. Examples of failure situations include a FRU that is not functioning, a temperature threshold that has been reached that causes unreliable operations, or a partition that the library has automatically taken offline.</td>
</tr>
<tr>
<td>2 (Degraded)</td>
<td>Indicates that a degraded condition exists within a library subsystem that impacts system performance or redundancy. Typical library operations can continue without immediate corrective action, but an administrator should investigate the condition and correct the problem soon. An example of a degraded situation is a redundant power supply that has failed, or a connectivity problem that has caused host port failover to occur.</td>
</tr>
<tr>
<td>3 (Warning)</td>
<td>Indicates that a condition exists within a library subsystem that has little effect on system operations. Typical library operations can continue without immediate corrective action, but you should investigate the condition and correct the problem when possible. Warnings also can provide helpful information, such as indicating that a door is open. Examples of warning situations include a FRU that is functioning less reliably, or a temperature threshold that has been reached that does not affect reliable operations.</td>
</tr>
</tbody>
</table>

The body text in the e-mail notification provides details about the issue and library conditions at the time of the event. The e-mail notification also includes an attachment, referred to as a repair page, that provide a problem description and corrective actions you or a customer service engineer (CSE) can perform. For more information about e-mail notifications, see Understanding E-mail Notifications.

To set up e-mail recipients for notifications, perform the following steps:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the ManagedViews region of the LMC, click the name of the physical library.
3. Click **Setup > Notifications > System Setup**. The **System Setup Notifications** dialog box appears with the **Contact Information** tab displayed.
4. Enter the contact information you want included in an e-mail notification if an error occurs in the library.

5. Click OK.
   A message is displayed asking you to perform a Save Configuration operation.

6. Click Yes.
   The Save and Restore Library Configuration dialog box appears.

7. Click Save and then save the file to a desired location.
   The configuration is saved.

8. Click Close to close the Save and Restore Library Configuration dialog box.

9. Setup the rules.
   a. Click Setup > Notifications > System Setup.
      The System Setup Notifications dialog box appears with the Contact Information tab displayed. Click the Rules tab.
This dialog box shows all notification recipients that are set up currently in the LMC. The remaining steps in this procedure guide you through setting up new e-mail notification recipients. To delete an existing e-mail address, click the e-mail address in the **Send Email To** column, and then click **Delete**.

10. To set up a new e-mail notification recipient, click **Create**. The **New Email Notification** dialog box appears.

11. In the **Email Address** text box, type the e-mail address that you want to receive notifications.
NOTE:
Do not enter more than one address in the Email Address text box.

12. In the Choose Severity box, click the severity level you want to assign to this e-mail address.

NOTE:
If you are using the remote client LMC, you can assign more than one severity level. While pressing the CTRL key, click the severity levels you want to assign. The OCP on the library enables you to select only one severity level.

13. To accept this notification setup, click OK.
The System Setup Notification dialog box reappears.

14. After you finish setting up all notifications, click OK.

Setting Up Media Security Notifications

After the Media Security Notification is set up and the physical library allows automatic inventory, you are notified when media is moved in or out of your library, either intentionally or unintentionally. Follow the steps below to set media security notification.

To setup media security notifications, perform the following:

1. Logon as administrator.
2. Click Setup > Notifications > Media Security.
The Media Security Notifications dialog box appears.

3. Check which media security option you wish to enable.
4. Click OK.
5. From the main console, select Setup > Library Settings > Library Behavioral Settings.
The Library Behavioral Settings dialog box appears.
6. For **Automatic Inventory**, click **Enable**.
7. Click **OK** to apply the new settings.
8. Once the configuration has been successfully saved, click **OK**.

### Setting up Advanced Reporting Options

Before using the Setup Wizard, see Setup Wizard Prerequisites.

Reports let you see information about your library at a glance, and help you identify trends and changes over time. You can manually generate reports as needed. In addition, if the advanced reporting options feature is licensed for your library, the LMC can automatically generate reports and e-mail them to designated recipients at specified times.

**NOTE:**

The Advanced reporting feature is available via remote access only.

The LMC can automatically generate and e-mail the Events Report.

- Drive Utilization Report
- Events Report

To automatically generate reports, set up one or more scheduled jobs using advanced reporting options. You can specify when and how often the report is generated, what report templates are used, and which e-mail recipients receive the report. You can also edit and delete scheduled jobs.
NOTE:
To automatically send reports to recipients, the library must be configured for sending e-mail. For more information, see Configuring E-mail.

Saving Report Criteria Templates

To schedule a job for a report, that report must have at least one template. A template is a saved set of report criteria that customize the content and appearance of a report.

Before setting up advanced reporting options, use the Report Criteria dialog box to save one or more templates for each report you want to automatically generate.

To save report criteria templates:

1. On the menu bar, click Tools > Reports > Events.
   The Events Reports dialog box appears.

2. Under Specify Report Criteria, click criteria options in the lists to customize the content and appearance of the report.
   For more information about choosing report criteria, see Generating the Events Report, or Viewing the Drive Resource Utilization Reports.

   NOTE:
   To save a template you must customize the Specify Report Criteria information.

3. Under Templates, click Save.
4. Type a name for the template, and then click OK.
   The template appears in the list under Templates.

5. To close the Events Report dialog box, click Cancel.

Scheduling a New Job

To set up a report to be automatically generated, first schedule a new job, and then set job options.

1. On the menu bar, click Tools > Reports > Reporting Options.
   The Reporting Options dialog box appears.
2. Click New.
   The Create New Job dialog box appears with the Calendar tab selected.

3. Specify time and recurrence options:
   • Under Start Date, click the day, month, and year when you want the report to be generated for the first time. (The current date is selected by default.)
   • Under Specify the Hour to Run, click the value that corresponds to the time of day when you want the report to be generated. (The values in the list correspond to a 24-hour clock. For example, 0 is midnight, 10 is 10:00 a.m., and 20 is 8:00 p.m.)
   • (Optional) Select the Recurring Job check box, and then under Frequency click how often you want the report to be generated.

4. Click the Reports tab, and then add one or more reports to the job.
   • To add a report, click a report in the reports list, and then click a template in the templates list. Click Add to add the report to the job. (You can add more than one report to a job.)
   • If you need to remove a report from a job, click the report, and then click Remove.
   • If there are no templates available for the report you choose, you need to save a template for the report before you can schedule a job. For more information on saving a template, see Saving a Report Template.
5. Click the **Recipients** tab, and then add one or more e-mail recipients to the job.
   - To add a recipient, type an e-mail address in the box, and then click **Add**. (You can add more than one recipient to a job.)
   - If you need to remove a recipient from a job, click the recipient, and then click **Remove**.

6. Click **OK**.

   The new job appears in the list of scheduled jobs. The LMC will generate the report at the specified time and send it to the designated e-mail recipients.

**NOTE:**

If a yellow caution icon appears next to a scheduled job on the **Reporting Options** dialog box, it means there is a problem with the job. For example, the date for the job might be in the past. To correct the problem, edit the job to change job options. For more information about editing scheduled jobs, see **Editing Scheduled Jobs**.

7. Click **Close** to close the **Reporting Options** dialog box.
Editing Scheduled Jobs

If you need to make changes to a scheduled job, edit it to change job options. You can change any job options, such as the date, time, report template, or e-mail recipients.

To edit scheduled jobs:
1. On the menu bar, click Tools > Reports > Reporting Options.
   The Reporting Options dialog box appears.
2. Under Scheduled Jobs, click the job you want to change, and then click Edit.
   The Edit Job dialog box appears.
3. Change job options as needed on the Calendar, Reports, and Recipients tabs.
4. Click OK.
5. Click Close to close the Reporting Options dialog box.

NOTE:
If the start date for a scheduled job is in the past, and it is not a recurring job, the report will not be generated. To correct this problem, edit the scheduled job and choose a start date that is in the future.

Deleting Scheduled Jobs

If you no longer need a scheduled job, you can delete it.

To delete scheduled jobs:
1. On the menu bar, click Tools > Reports > Reporting Options.
   The Reporting Options dialog box appears.
2. Under Scheduled Jobs, click the job you want to delete, and then click Delete.
   A dialog box appears asking if you are sure you want to delete the selected job.
3. Click Yes.
   The job is deleted from the list of scheduled jobs.
4. Click Close to close the Reporting Options dialog box.

Configuring Drive Cleaning

When you create or modify a partition, you can specify that tape drives in that partition be automatically cleaned each time the drive requests a cleaning operation.

For automatic drive cleaning to function, you must configure drive cleaning for the library. To configure drive cleaning, first assign cleaning magazines, and then import cleaning media. Designated cleaning media can also be used when manually cleaning drives. (Cleaning magazines and media are not part of any logical partition, and so are not visible to the host application.)

If cleaning magazines are no longer needed, you can unassign them. In addition, you can export expired cleaning media to remove it from the library.
NOTE:
Automatic drive cleaning should be enabled for partitions only if the host application does not support
the coordination of drive cleaning. If drive cleaning functionality is enabled on the host application,
do not enable automatic drive cleaning for any partitions in the library.

For more information about enabling automatic drive cleaning for a partition, see Working With
Partitions. For more information about manually cleaning drives, see Cleaning a Drive.

Assigning Cleaning Magazines and Importing Cleaning Media

To configure the library for drive cleaning, first assign one or more magazines as cleaning magazines,
and then import cleaning media.

NOTE:
At least one magazine must be assigned for cleaning before you can import cleaning media. Also,
only magazines that do not belong to a partition can be assigned for cleaning.

To configure the library for drive cleaning:

1. Insert one or more pieces of cleaning media into the I/E station and close the I/E station door.
   Use a standard barcode label for cleaning media. Barcode numbers do not require a specific
   prefix or suffix.

2. Make sure that you are viewing the physical library. From the View menu or in the Managed
   Views region of the LMC, click the name of the physical library.

3. On the menu bar, click Setup > Library Settings > Drive Cleaning.
   The Drive Cleaning Configuration dialog box appears.
4. Click a magazine slot or a piece of media to select it. Details about the selected slot or media appear under Information, including the type of media, barcode number, location, and the number of times the media has been mounted in a drive.

**NOTE:**
On a remote client LMC, right-click a magazine slot or a piece of cleaning media to see a menu of available options.

5. If the library has more than one module, click the arrow buttons to display the next or previous module.

6. To assign a magazine for cleaning, click any slot in the magazine to select it. Click **Menu**, and then click **Assign magazine for cleaning.**

   The magazine is assigned for cleaning.

7. Repeat this step to assign additional cleaning magazines.

8. To import cleaning media, click the cleaning media in the I/E station to select it, and then do one of the following:
   - To import only the selected piece of media, click **Menu**, and then click **Import <barcode number> as cleaning media.**
• To import all media in the selected I/E station magazine, click **Menu**, and then click **Import all tapes in magazine as cleaning media**.

The cleaning media is moved to an available cleaning magazine and can be used for automatic or manual cleaning.

9. Click **Close** to close the **Drive Cleaning Configuration** dialog box.

Exporting Cleaning Media

Cleaning media can be used a limited number of times. If a piece of media is expired, export it and remove it from the library.

To export cleaning media:

1. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.

2. On the menu bar, click **Setup > Library Settings > Drive Cleaning**.

The **Drive Cleaning Configuration** dialog box appears. If the library has more than one module, click the arrow buttons to display the next or previous module.

To determine if a piece of cleaning media has been used the maximum number of times, click the media to select it, and then check the **Mount Count** value under **Information**.

3. Click the cleaning media in a cleaning magazine to select it, and then do one of the following:
   • To export only the selected piece of media, click **Menu**, and then click **Export cleaning media <barcode number>**.
   • To export all media in the selected magazine, click **Menu**, and then click **Export all cleaning media in magazine**.

The cleaning media is moved to an available I/E station magazine.

4. Click **Close** to close the **Drive Cleaning Configuration** dialog box.

Unassigning a Cleaning Magazine

If a magazine is no longer needed for holding cleaning media, first export all cleaning media from the magazine, and then unassign it.

To unassign a cleaning magazine:

1. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.

2. On the menu bar, click **Setup > Library Settings > Drive Cleaning**.

The **Drive Cleaning Configuration** dialog box appears. If the library has more than one module, click the arrow buttons to display the next or previous module.

3. If the magazine you want to unassign contains cleaning media, export all cleaning media to the I/E station.

   For more information on exporting cleaning media, see **Exporting Cleaning Media**.

4. Click any slot in the cleaning magazine to select it.

5. Click **Menu**, and then click **Unassign magazine for cleaning**.

   The magazine is no longer assigned for cleaning.

6. Click **Close** to close the **Drive Cleaning Configuration** dialog box.
NOTE:
If you try to unassign a cleaning magazine that contains cleaning media, a message appears asking if you are sure you want to continue. If you click Yes, any media in the magazine is not accessible until you add the magazine to a partition or assign it again as a cleaning magazine.

Registering SNMP Traps
Because the library ignores all SNMP SET operations, external management applications cannot register themselves to receive SNMP traps from the library. The Trap Registration dialog box enables you to manually register external applications.
Before using the Setup Wizard, see Setup Wizard Prerequisites.

Registering an Application
To register an application:
1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > Notifications > SNMP Trap Registration.
   The SNMP Trap Registration dialog box appears.
4. In the Host/IP text box, type the IPv4 or IPv6 address or host name of the host client running the external application.
5. In the Port text box, type the number of the User Datagram Protocol (UDP) port that you want to associate with the IP address or host name.
6. In the Community String text box, type the desired community string for the trap that will be sent to the receiver.
7. Click Create.
   The host application IP address or name and UDP port number appear in the table to indicate that the application is registered to receive SNMP traps from the library.

Removing an Application Trap Registration
To remove an application trap registration:
1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > Notifications > SNMP Trap Registration.
   The SNMP Trap Registration dialog box appears.
4. Click the IP address of the application for which you want to remove trap registration to highlight it.
5. Click Delete.
Using the Secure Manager Configuration Wizard

Secure Manager provides an additional level of security that allows you to control access to the tape library by authorizing specific servers to access the library’s drives and robotics. Secure Manager increases backup reliability by blocking disruptive traffic from unauthorized hosts to the library, which is one of the main causes of failed or incomplete backups.

Secure Manager has three modes of operation:

1. Disabled: All hosts have access to all drives and robotics in the library. Switch-based SAN zoning must be used to control access.
2. Enabled, Basic: If a Secure Manager license key is not installed, only Basic mode is offered. In this mode, a single access group can be created. Hosts added to the access group have access to all drives and robotics in the library. Hosts that are not added to the access group cannot access drives or robotics in the library.
3. Enabled, Advanced/Licensed: When a Secure Manager license is purchased (per library) and the license key is installed, many access groups can be created. Different sets of hosts and drives can be added to different access groups, providing the highest level of granularity and access control.

The Secure Manager Configuration Wizard guides you through all access control configuration steps: Host Configuration, Access Group Configuration, and Host Access Configuration.

To enable or disable secure manager, perform the following:

1. Select **Setup > Secure Manager** to display the Secure Manager Configuration Wizard.
2. Click **Next**.
   
   Initially, the only option available is **Enable/Disable Secure Manager**.
3. Click the radio button next to **Enable/Disable Secure Manager**.
4. Select the box beneath the radio button to enable Secure Manager. Clear the box to disable Secure Manager.
5. Click **Finish**.
6. To perform other tasks related to Secure Manager, see the following procedures:
   - Using the Host Configuration Option
   - Using the Access Group Configuration Option
   - Using the Host Access Configuration Option

Using the **Host Configuration** Option

To create new hosts that are not physically connected to the SAN, delete hosts that are not longer physically connected to the SAN, or select the ports hosts will use to access devices, use the **Host Configuration** Option. To do so:

1. Select **Setup > Secure Manager** to display the Secure Manager Configuration Wizard.
2. Click **Next**.
3. Click the radio button to select **Host Configuration**.
4. Click **Next** to display the **Select Hosts Configuration Options** screen.
5. To create a host:
   a. Click the radio button to select **Create Host**.
   b. Click **Next** to display the **Create New Host** dialog box.
   c. Type an appropriate value into the **Name** field.
   d. Select the operating system of the host from the **Type** field pull-down menu.
   e. Type the port number into the **Port** field.
   f. Type the world wide path name into the **WWPN** field.
      The string must be 8 hexadecimal numbers, a colon (:), and 8 hexadecimal numbers (########:########).
   g. Click **Finish** to create the host.
   h. Click **OK** in the **The Host was created successfully** dialog box.

6. To modify an existing host:
   a. Click the radio button to select **Modify Host**.
   b. Click to appropriate box in the **Select** column to select the host to modify.
   c. Click **Next** to access the Modify Existing Host dialog box, which displays current information for the host.
   d. Correct the information in the **Name**, **Type**, **Port**, and **WWPN** fields.
   e. Click **Finish** to save the modifications.
   f. Click **OK** in the **The Host was modified successfully** dialog box.

7. To delete an existing host:
   a. Click the radio button to select **Delete Host**.
   b. Click to appropriate box in the **Select** column to select the host to delete.
   c. Click **Next** to access the Modify Existing Host dialog box, which displays current information for the host.
   d. Click **Finish** to delete the host.
   e. Click **OK** in the **The Host was deleted successfully** dialog box.

8. If necessary, click **Cancel** then **Yes** to exit the dialog box.

**Using the Access Group Configuration Option**

To create or delete access control groups, or to add hosts to groups or remove hosts from groups, use the **Access Group Configuration** option. To do so:

1. Select **Setup > Secure Manager** to display the Secure Manager Configuration Wizard.
2. Click **Next**.
3. Click the radio button to select **Access Group Configuration**.
4. Click **Next** to display the **Welcome to the Host Access Group Configuration Wizard** screen.
5. Click **Next**.
To create a new group:

a. Select the **Create New Host Access Group** radio button.

b. Click **Next** to display the **Select Group Access Name** dialog box.

c. Type the appropriate value into the **Group Name** field.

d. Click **Next**.

e. Select the box in the **Select** column to indicate which host or hosts to include in the group, or select the **Select All Hosts** box to include all of the hosts in the group.

f. Click **Next** to display the **Select the drives for host access** dialog box.

g. Select the box in the **Select** column to indicate which drive or drives on the selected hosts to include in the group.

h. For each drive selected, also select the appropriate box in either the **Port A** or **Port B** columns to indicate which port to use. (The default is **Port A**.)

i. Click **Next** to display the **Select the partitions for host access** dialog box.

j. Select the box or boxes in the **Select** column to indicate which partitions to configure for host access.

k. For each partition selected, also select the appropriate box in either the **Port A** or **Port B** columns to indicate which port to use. (The default is **Port A**.)

l. Click Finish to create the new access group.

m. Click **OK** in the **The Host Access was updated successfully** dialog box.

To change the name of an access group:

a. Select the **Change Access Group name** radio button.

b. Click **Next** to display the **Select Group Access** dialog box.

c. Select the **Expand Tree** box to list all items in the **Access Group Hosts and Devices** section of the dialog box.

d. Select the box corresponding to the Access Group name to change.

e. Click **Next** to display the **Select Group Access Name** dialog box.

f. Type the appropriate value into the **Group Name** field.

g. Click **Finish** to exit the dialog box.

To delete an existing host access group:

a. Select the **Delete Host Access Group** radio button.

b. Click **Next** to display the **Select Group Access** dialog box.

c. Select the **Expand Tree** box to list all items in the **Access Group Hosts and Devices** section of the dialog box.

d. Select the box corresponding to the Access Group to delete.

e. Click **Next** to display the **Warning** dialog box.

f. Click **Yes** to delete the Access Group.

g. Click **OK** in the **The Group Access was deleted successfully** dialog box.
9. To add a host or hosts to a host access group:
   a. Select the **Add Host to Group** radio button.
   b. Click **Next** to display the **Select Group Access** dialog box.
   c. Select the **Expand Tree** box to list all items in the **Access Group Hosts and Devices** section of the dialog box.
   d. Select the box corresponding to the Access Group to modify.
   e. Click **Next** to display the **Select Group Access Hosts to Add** dialog box.
   f. Select the box in the **Select** column to indicate which host or hosts to add to the group, or select the **Select All Hosts** box to add all of the hosts in the group.
   g. Click **Finish** to save the modification.
   h. Click **OK** in the **The Group Access was updated successfully** dialog box.

10. To remove a host from a host access group:
    a. Select the **Remove Host from Group** radio button.
    b. Click **Next** to display the **Select Group Access** dialog box.
    c. Select the **Expand Tree** box to list all items in the **Access Group Hosts and Devices** section of the dialog box.
    d. Select the box corresponding to the Access Group from which to remove the host.
    e. Click **Next** to display the **Select Group Access Hosts to Remove** dialog box.
    f. Select the box in the **Select** column to indicate which host or hosts to remove from the group, or select the **Select All Hosts** box to remove all of the hosts from the group.
    g. Click **Finish** to save the modification.
    h. Click **Yes** in the **Warning** dialog box.
    i. Click **OK** in the **The Group Access was updated successfully** dialog box.

**Using the Host Access Configuration Option**

To add devices to or remove devices from an existing group, or to select which ports the hosts will use to access devices, use the **Host Access Configuration** option. To do so:

1. Select **Setup > Secure Manager** to display the Secure Manager Configuration Wizard.
2. Click **Next**.
3. Click the radio button to select **Host Access Configuration**.
4. Click **Next** to display the **Select the Group to configure** screen.
5. Select the **Expand Tree** box to list all items in the **Access Group Hosts and Devices** section of the dialog box.
6. Select the box corresponding to the Access Group to configure for host access.
7. Click **Next** to display the **Select the drives for host access** dialog box which shows the current settings.
8. Select or clear the box or boxes in the **Select** column to indicate which drive or drives to configure for host access.
9. For each drive selected, also select the appropriate box in either the **Port A** or **Port B** columns to indicate which port to use. (The default is **Port A**.)
10. Click **Next** to display the **Select the partitions for host access** dialog box.

11. Select or clear the box or boxes in the **Select** column to indicate which partitions to configure for host access.

12. For each partition selected, also select the appropriate box in either the **Port A** or **Port B** columns to indicate which port to use. (The default is **Port A**.)

13. Click **Finish** to update host access.

14. Click **OK** in the **The Host Access was updated successfully** dialog box.

### Using LDAP

Before using the Setup Wizard, see **Setup Wizard Prerequisites**.

Lightweight Directory Access Protocol (LDAP) is the industry standard Internet protocol that provides centralized user account management. This library supports the Microsoft® Active Directory® LDAP server and user account information in the schema defined by RFC 2307. User password schemes must be encrypted using UNIX® crypt.

You can configure the Lightweight Directory Access Protocol (LDAP) settings any time after the initial library configuration. Once you enable and configure LDAP, you can view your current LDAP settings using the LDAP menu.

### LDAP Server Guidelines

User account information is centralized and shared by different applications, simplifying user account management tasks. Administrative users can add, delete, and modify only local user account information.

**User and Group Access**

For LDAP accounts with user privileges, access to library partitions is determined by group assignment on the LDAP server. Groups must be created on the LDAP server with names that correspond to the library partition names. Users without administrator privileges must be assigned to these groups on the LDAP server to have access to the corresponding partitions on the library.

LDAP accounts with administrative privileges have access to all partitions and administrative functions and do not need to be assigned to partition-related groups on the LDAP server.

---

**NOTE:**

Usernames and group objects must be in LDAP Distinguished Names formats.

---

### OpenLDAP 2.4

You must install and run OpenLDAP 2.4 or later. The supported Objects in OpenLDAP 2.4 and above are of type **Person** or derived objects, and the group Objects must be of type **GroupOfNames**.

OpenLDAP must be compiled with Overlay Support and requires the installation of **memberOf overlay**. More information can be found in the man pages of OpenLDAP with the **man slapo-memberof** command.
Configuring LDAP

To configure LDAP:

1. Select **Setup > User Configuration > LDAP**.

   The **LDAP Configuration** dialog box appears with the General tab displayed.

2. On the **General** tab, you can enable or disable LDAP functionality:
   - To enable LDAP, select **Enable LDAP**.
   - To disable LDAP, clear the **Enable LDAP** check box.

   **NOTE:**
   If you disable LDAP, single sign-on functionality will not be available on the library.

3. To configure or modify LDAP, use the appropriate tabs and set the following configurations:
   **General** tab:
   - **Server Configuration**:
     - **Primary**: You must provide a primary IP address or DNS name.
     - **Alternate**: An alternate IP address or DNS name is optional.
     - **Secure**: Use this check box to enable the setup options to access a secure LDAP server, which can be done using any port except 389. The default secure port is 636. If you enable this option, you must retrieve the Trusted Root Certificate from the server by clicking **Retrieve TR**.
     - **Port**: Enter the appropriate port in this field. The default port for non secure connections is 389, and it is 636 for secure (SSL) based LDAP connections. The port setting can be changed.
     - **Retrieve TR**: Use this function to retrieve the Trusted Root Certificate from the LDAP server. A dialog box displays basic Trusted Root certificate information, such as subject name, MD5, and SHA 1 hashes. It is recommended that you verify this information independently on the LDAP server.
⚠ CAUTION:
The first time you use Retrieve TR, the process can take 5 to 10 minutes. To connect to a secure LDAP server, you must complete the retrieval process.

• **Search Information:**
The Search Information section allows you to enter on the LDAP server a user name and password for a user who has sufficient privileges to search for user names. The user name is specified in distinguished name format. To use this feature, administrative user rights are not required, but you must have the right to search user names in the LDAP directory.

4. Click the **Access** tab.
   Use this tab to configure LDAP authentication.

   ![Image of LDAP Configuration settings]

   • **Context Information:**
     • **User Context:** This is a path in distinguished name format to the location used to search for the login users. You can search for a user in the context specified and all contexts below it.
     • **Group Context:** This is a path in distinguished name format to the location used to search for the groups to which a user belongs. Only groups which are in the Group context or below are considered for library access.

   • **Library Access Groups:**
     • **User:** This field contains a fully distinguished name of the groups to which all the library non-admin users belong.
     • **Admin:** This field contains a fully distinguished name of the group to which all admin users belong.
NOTE:

Non-admin library users also need to be members of the groups that match the partition names for which they are granted access. These group names do not need to be specifically listed anywhere in the LDAP setup on the library. When user logins are validated during login, their group memberships for partition access are validated automatically.

5. To validate your configuration, click OK or Test.
6. Click the Test tab.

You can use the test functionality to simulate an LDAP login for a specific user and quickly discover what access rights the user has and to what partitions the user has access.

7. To initiate the library authentication process to the LDAP server, click Test after providing the user name and password.
A dialog box appears displaying what level of access the user is assigned, and to which library partitions the user has access.

8. After you have entered the LDAP configurations, click Test to verify the LDAP connection.
A connection with the LDAP server is established, and the library determines whether the LDAP Distinguished Names specified in the Access tab are valid.
A message box appears indicating the success or failure of the LDAP connection.
• If the connection failed, the error message contains information that you can use to resolve the issue. Click OK to return to the LDAP Configuration dialog box.
• If the connection was successful, click OK in the message box and continue.
9. To accept and save the library configuration, click **OK** in the LDAP Configuration dialog box.
10. To validate your configuration, click **OK** or **Test**.

### Configuring library behavioral settings

The Library Behavioral Settings dialog box is used to enable and disable the following features of the library:

- Automatic teach
- Automatic inventory
- Automatic drive unload
- Logical SN addressing
- IPv6
- Extended I/E

To enable or disable these features:

1. Click **Setup > Library Settings > Library Behavioral Settings**.
2. For each feature, select the **Enable** or **Disable** radio button.
3. Click **OK**.

### Configuring screen saver preferences

Use the **Screen Saver** preferences tab to customize the images that display on the LMC screen when the library is not in use. The screen saver starts automatically if the library is idle for a specified amount of time.

**NOTE:**

Screen saver preferences can only be configured remotely, not using the touch panel.

To configure screen saver preferences:

1. From the menu bar, click **Setup > Library Settings > Screen Saver**.
   
   The **Preferences** dialog box appears with the **Screen Saver** tab displayed.
2. Do one of the following:
   - Select **Default** to use the default HP screen saver with standard settings.
   - Select **Custom** to change screen saver settings such as activation, movement, or images.
   - Select **Off** to disable the screen saver. (The current settings are cleared.)
   If you selected **Custom**, go to the next. Otherwise, go to 6.

3. Under **Activation**, enter a value in the **Wait** box to specify how much idle time must pass before the screen saver is activated. The activation wait time can be 1–120 minutes.

4. Under **Movement**, specify the position and the motion of the screen saver image on the screen.
   - Select **Random** to display the screen saver image in a variety of positions.
   - Select **Stationary** to display a static screen saver image that does not move.
   - Select **Linear** to display the screen saver image as a floating image.
   - Enter values in the **horizontal** and **vertical** boxes to specify the movement of the screen saver image in pixels.
   - Enter a value in the **Motion Delay** box to specify the movement speed of the screen saver image.

5. Under **Images**, specify the image files to display for normal functions, warning notices, and failure notices. You must select image files for all three functions.
   - To specify an image file, click **Browse**. Select the image file and then click **Open**. The image file must be in GIF, JPEG, or PNG format, and cannot be larger than 1 MB. In addition, image resolution is limited to 600 x 800 pixels.
   - Click **Preview** to preview an image file.
6. Click **OK** to save the settings and close the **Preferences** dialog box.  
   Or, click **Apply** to save the settings without closing the **Preferences** dialog box.

7. Because you made system configuration changes, you must click **Yes** to save the configuration changes. For more information, see Saving and Restoring Library Configuration.

About the configuration record

**Before using the Setup Wizard, see Setup Wizard Prerequisites.**

The configuration record contains details about the library configuration and can be sent to a specified e-mail address or saved as a `.txt` file.

Information in the configuration record includes:

- Product information: Product name and version, MCB and RCU versions, serial number, and modules/drives/partitions configuration
- License information: License descriptions, quantities, and installation dates
- Partition information: Serial numbers, online/offline statuses, and numbers of slots, drives, and I/E slots
- Network information: Hostname, DHCP status, IP address, and IP, Netmask, and Gateway addresses
- Drive information, for each drive: Location, partition, online/offline status, vendor, model, serial number, logical serial number, firmware version, drive type, and interface type:
  - Fibre Channel (FC) tape drives — World Wide Name (WWN) and loop ID, speed, and connection type

Before you can e-mail the configuration record, the library e-mail account must be configured. For information on configuring the library e-mail account, see Configuring E-mail.

Setting aisle lights

**Before using the Setup Wizard, see Setup Wizard Prerequisites.**

Aisle lights are optional on each module, and are mounted to the roof of each module to illuminate the inside of the library.

To set the duration for aisle lighting:

1. From the main console, select **Setup > Library Settings > Aisle Light Settings**.  
   The **Aisle Light Settings** dialog box appears.

2. Select a duration for the light to illuminate: **30 minutes**, **1 hour**, or **Always Off**.

3. Click **OK**.
NOTE:
Regardless of the selected setting, the aisle lights will turn off automatically during all inventory and teach operations. At the completion of these events the lights are automatically turned back on if they were on prior to these operations.
For the time limited settings, if the lights were on before the operation, the timer starts over when the lights are automatically turned on.
For time limited aisle light settings, user interaction, such as using the touch panel or opening an I/E station or aisle door, causes the timer to reset. The lights will automatically turn on if they are not already on.
The default setting is **Always Off**.

---

**Clear the registered Command View TL management station**

HP Command View for Tape Libraries (TL) software provides management and control of multiple tape libraries through a single pane of glass, while TapeAssure provides comprehensive summaries and detailed information about the status, performance, utilization, and health of all tape drives and tape media. Utilization and performance reporting features allow you to optimize the use of your tape libraries and tape drives.

The first Command View TL management station to add a tape library to its launcher screen is automatically registered to receive TapeAssure events and statistics from that tape library. If you want a different management station to receive TapeAssure events from your library, you must first clear the management station currently registered with the library.

To clear the Command View TL management station currently registered with the library:

1. Select **Tools > Clear Station** to display the **Clear Station** dialog box.
2. Click **OK**.

---

NOTE:
TapeAssure data will no longer be collected for the library until a Command View TL management station registers with the library. See **HP Command View for Tape Libraries User Guide** for information about Command View TL and TapeAssure.

Command View TL version 2.8 or later supports ESL G3 tape libraries. If Command TL and TapeAssure are used with ESL G3, a software license is required per library.
3 Operating the Library

Logging On and Off

You can log on and off locally by using the library Operator Control Panel (OCP). Or you can log on and off remotely by using a web browser to access the LMC applet on a host computer.

Logging On From the OCP

To log on from the OCP:

1. If the ESL G3 Logon dialog box is not already displayed on the library OCP (the screen saver appears) tap the OCP.
   The ESL G3 Logon dialog box appears.

   NOTE:
   On the OCP, the login dialog box includes the AMC keyboard. Use this keyboard to type the appropriate information into the fields.

   2. In the Name text box, type the name of the user or administrator account with which you want to log on. If you want to log on with the default administrator account, type admin.

   NOTE:
   User names and passwords are case-sensitive. Select the Shift key in the AMC keyboard to display uppercase letters and special characters. This enables you to type one uppercase letter or special character before the ESL G3 Logon dialog box returns to displaying lowercase characters. To type more than one uppercase character or special character, select the Caps key. The Caps key toggles between displaying uppercase and lowercase characters.
   Only one administrator at any given time can be logged on to the library.
   If you want to log on using the default administrator account (admin), and you do not remember the password, contact technical support to reset the password.

   3. Position the cursor in the text box below the Name text box by tapping it, and then type the password for the user or administrator account.
NOTE:
If you are logging on to the library for the first time using the default administrator account (admin), type admin. After you log on, the library prompts you to change the default admin password. You must enter and confirm a new password. Passwords that are most secure include a combination of letters, numbers, and non-alphanumeric characters. Passwords must be eight or more characters in length.

4. After you type a user name and password, select OK.

Logging Off From the OCP

To log off from the OCP:
1. Select Operations > Log Off or select the Log Off button on the toolbar.
2. A message appears that asks you whether you are sure that you want to log off. Select Yes. The ESL G3 Logon dialog box appears.

Logging On From the Library Management Console (LMC) Using a Web Browser

The LMC Java applet lets you access all features of the LMC from a host computer using a standard web browser. To use the LMC applet, the host computer must have network access to the library, and you must know the IP address or hostname of the library.

NOTE:
If you do not know the IP address of the library, log on to the library using the Operator Control Panel (OCP), click Setup > Network Configuration, then write down the value that displays in the IP Address field.

Software Requirements

Before logging on from the LMC, make sure that the host computer meets the following software requirements:
• Web Browser – Microsoft Internet Explorer 6.0 or higher, Mozilla Firefox 3.0 or higher
• Java Plug-in – Java Runtime Environment (JRE) version 1.6 update 24 or higher
For information on downloading the Java Plug-in contact: http://www.HP.com/support.

Accessing the LMC Applet

After verifying that the host computer meets the software requirements and has network access to the library, access the LMC and log on.

To access the LMC:
1. On the host computer, use the web browser to access the IP address of the library.

The first time you access the LMC, the LMC applet is downloaded to the host computer. Downloading the applet can take several minutes depending on the speed of the network. Once the applet is downloaded, it is stored on the host computer and does not need to be downloaded again.
2. If a security warning appears asking if you are sure you want to run the applet, click Run or Yes. The ESL G3 Logon dialog box appears.

3. In the Name text box, type the name of the user or administrator account with which you want to log on. If you want to log on with the default administrator account, type admin.

   NOTE:
   - User names and passwords are case-sensitive.
   - Only one administrator at any given time can be logged on to the library.
   - If you want to log on using the default administrator account (admin), and you do not remember the password, contact technical support to reset the password.

4. In the Password text box, type the password for the user or administrator account.

   NOTE:
   If you are logging on to the library for the first time using the default administrator account (admin), type admin. After you log on, the library prompts you to change the default admin password. You must enter and confirm a new password. Passwords that are most secure include a combination of letters, numbers, and non-alphanumeric characters. Passwords must be eight or more characters in length.

5. Click OK.

   NOTE:
   After logging on, do not close the web browser window or use it to navigate to another URL. Doing so will close the LMC applet but might leave the current session active.

Logging Off From the LMC

To log off from the LMC:

1. Select Operations > Log Off or select the Log Off button on the toolbar.
2. A message appears that asks you whether you are sure that you want to log off. Select Yes. The ESL G3 Logon dialog box appears.
3. To close the LMC applet, click Cancel.
Connecting to Multiple Libraries

This feature allows you to log in to multiple libraries, and switch from one library console to another without logging off.

To connect to multiple libraries:

1. From the LMC menu, click **Connection > New**. The **Connect to Library** dialog box appears.

   ![Connect to Library dialog box](image)

2. Type or select the library hostname or the library IP address, and click **OK**. You can use either IPv4 or IPv6 addresses.

   Once you have connected to additional libraries, you can choose any of those libraries from the **Connection** drop-down list.

**NOTE:**

To log off when connected to multiple libraries, first select the library from the **Connection** drop-down list and follow the instructions at **Logging Off From the LMC**. Repeat this process to log off from additional libraries.

Using the Indicator Panel and Operator Control Panel (OCP)

The library provides an indicator panel and an OCP, as shown in **Figure 10**.
The indicator panel includes a **Robotics Enabled** button and indicator, a **Status** indicator, and a **Power** button and indicator. The Library Management Console (LMC) appears on the OCP.

For more information about indicator panel functions, see *Using the Indicator Panel*. For a brief overview of the LMC, see *Accessing the Library Management Console (LMC)*.

### Using the Indicator Panel

The **Robotics Enabled** indicator and the **Power** indicator each include a button. The **Status** indicator is not a button. These indicators do not report the status of communications with a host.

**NOTE:**

The enabled state does not mean that robotics are communicating with the host. It means that the robotics are communicating with the library controller.
Table 7, Table 8, and Table 9 describe the indicators in detail.

### Table 7 Robotics Enabled Indicator

<table>
<thead>
<tr>
<th>Indicator</th>
<th>State and Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Solid on—robotics are enabled and ready to process commands or are actively processing commands from the library controller. No attention required. Do not open the access door. Blinking—a change of robotics state is pending, either from the enabled state to the not enabled state or from the not enabled state to the enabled state. No attention required. Do not open the access door.</td>
</tr>
<tr>
<td>No color</td>
<td>Solid off—either robotics are not ready, the doors might be open, or the library might be powered off. Attention required. The operator should close the doors and press the Robotics Enabled button to return robotics to the enabled state.</td>
</tr>
</tbody>
</table>

### Table 8 Status Indicator

<table>
<thead>
<tr>
<th>Indicator</th>
<th>State and Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Solid on—normal. No attention required.</td>
</tr>
<tr>
<td>Amber</td>
<td>Blinking or solid on—fault. Attention required. Monitor the system status buttons. To determine whether the library has created any events, click Tools &gt; Event Viewer.</td>
</tr>
</tbody>
</table>

### Table 9 Power Indicator

<table>
<thead>
<tr>
<th>Indicator</th>
<th>State and Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Solid on—normal. No attention required.</td>
</tr>
<tr>
<td>No color</td>
<td>Solid off—power off. Attention required. To operate the library, you must turn on the power. Press the Power button.</td>
</tr>
</tbody>
</table>

### Accessing the Library Management Console (LMC)

You can view the LMC from either the library OCP or a remote computer. If you use the OCP, you do not need to install the LMC because it is already installed on the library. To access the LMC using a web browser, see Logging On From the Library Management Console (LMC) Using a Web Browser.

To manage your library from a remote client, first perform the initial network configuration of the library from the OCP. For more information, see Setting up the Network Configuration.

The main LMC display consists of five areas:

- The title bar of the LMC displays the words ESL G3 Library Management Console.
- The menu bar provides access to all menu commands used to manage library functions.
  
  **Menu commands for user types** admin and security **are** Operations, Monitor, Setup, Tools, View, Connection, and Help.

  The additional menu Service is available to user type service. See Menus.
• The tool bar displays icons that represent the most commonly run commands: I/E (view the import/export station slots), IMPORT (load tapes into the library from the import/export station), EXPORT (move tapes from the library into the import/export station), EVENTS (view library events), EXPLORER (finding a tape in the library), and LOG OFF. See Toolbar.

• The library information panel fills most of the main LMC display, presenting operational data from the current library, whether the current library is the physical library or a partition. The operation data is presented in four sections: Managed Views, Slots Utilized, Data Transfer, and Configuration. Of these, only Managed Views is an active section, meaning the user can interact with it. The others only display information. See Reading the Library Information Panel.

• The Overall System Status buttons provide current status information for the six subsystems of the physical library: Drives, Connectivity, Control, Robotics, Power, and Cooling. See System Status Buttons.

See Viewing Details about Events to interpret information provided from clicking the Robotics button in the Overall System Status section.

Figure 11 Viewing the LMC (physical library view shown)
The following seven LMC menus organize commands into logical groupings:

- **Operations** menu consists of commands that enable you to change the library mode of operation (online or offline), import and export cartridges, load and unload drives, move media, lock or unlock the I/E stations, perform an inventory, shut down the system, and log off.

- **Monitor** menu consists of commands that enable you to obtain status information about various aspects of the library, including system, drives, I/E stations, storage slots, media, sensors, the email configuration, users, partitions, and key management information if you are using ESKM.

- **Setup** menu consists of commands that enable you access the Setup Wizard and to set up and configure various aspects of the library from other menu choices, including partitions, secure manager, drive settings, the network configuration, physical library, users, notifications, date and time, licenses, e-mail, and SNMP trap registration. The security manager can enroll the library with ESKM from this menu.

- **Tools** menu consists of commands that enable you to maintain and troubleshoot the library by viewing events, controlling the drives, updating library or drive firmware, generating support events, teaching the library, running verification tests, saving and restoring library configurations, obtaining drive resource utilization reports, locating cartridges in the library via the Library Explorer, defragmenting partitions, using sift/sort, and clearing the station.

- **View** menu enables you to select the library (either the physical library or a partition) that you want currently displayed on the main LMC display. Some LMC menu commands require you to be in either a physical library or partition view to run them.

- **Connection** menu enables you to log on to multiple libraries and switch between consoles for different libraries without logging off.

- **Help** menu provides you with access to Online Help as well as information about the library, such as copyright information, the product version, firmware version, and build information for various library components (LMC server, LMC client, MCB, CMB, and RCU).

- **Service** menu is available only to those logged on with service permissions. This menu enables you to perform manual diagnostics and preventative maintenance, and enables you to debug the console.

If the OCP remains unused after a period of time, the library screen saver appears. The color of the screen saver image reflects the worst status of the library systems as indicated by the system status buttons. For example, if system status buttons show a mix of green (Good), yellow (Warning or Degraded), and red (Failed) states, the color of the screen saver image will be red.

Table 10 summarizes all available commands, including required user privilege levels and required library environments (OCP or remote client). The LMC prompts you to take the library offline or to select either the physical library or a partition if the command you request requires you to change library mode.

**Table 10 Menu Commands: Privileges and Environments**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Privilege Level</th>
<th>Physical Library View</th>
<th>Partition View</th>
<th>OCP</th>
<th>Remote Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Mode</td>
<td>Admin, User</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Import</td>
<td>Admin, User</td>
<td>X^2</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Menu Command</td>
<td>Privilege Level</td>
<td>Physical Library View</td>
<td>Partition View</td>
<td>OCP</td>
<td>Remote Client</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------</td>
<td>-----------------------</td>
<td>----------------</td>
<td>-----</td>
<td>---------------</td>
</tr>
<tr>
<td>Export</td>
<td>Admin, User¹</td>
<td>X²</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Drives</td>
<td>Admin, User¹</td>
<td>X²</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Move Media</td>
<td>Admin, User¹</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>I/E stations</td>
<td>Admin, User¹</td>
<td>X</td>
<td>X</td>
<td>X²,³</td>
<td>X³</td>
</tr>
<tr>
<td>Inventory</td>
<td>Admin, User</td>
<td>X</td>
<td>X</td>
<td>X²,³</td>
<td>X³</td>
</tr>
<tr>
<td>System Shutt.</td>
<td>Admin, User</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Log Off</td>
<td>Admin, User¹</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

On the Monitor menu:

<p>| System       | Admin, User¹    | X                     | X              | X   | X             |
| Drives       | Admin, User¹    | X                     | X              | X   | X             |
| I/E Station  | Admin, User¹    | X                     | X              | X   | X             |
| Slots        | Admin, User¹    | X                     | X              | X   | X             |
| Media        | Admin, User¹    | X                     | X              | X   | X             |
| Sensors      | Admin, User¹    | X                     | X              | X   | X             |
| E-Mail Config. Record | Admin, User¹ | X                     |                | X   | X             |
| Users        | Admin, User¹    | X                     | X              | X   | X             |
| Partitions   | Admin, User¹    | X                     | X              | X   | X             |</p>
<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Privilege Level</th>
<th>Physical Library View</th>
<th>Partition View</th>
<th>OCP</th>
<th>Remote Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key Management (ESKM)</td>
<td>Admin, User¹</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>On the Setup menu:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup Wizard</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Partitions 4</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Secure Manager</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Drive Settings</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Network Configurations</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Network Security Settings</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Library Settings</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>User Configuration</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Notifications</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Date and Time</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Licenses</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Encryption</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>On the Tools menu:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Event Viewer</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Drives ⁴</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Update Firmware</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Support Events</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Library Diagnostics</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Operating the Library
<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Privilege Level</th>
<th>Physical Library View</th>
<th>Partition View</th>
<th>OCP</th>
<th>Remote Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save/Restore 4</td>
<td>Admin</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Reports</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Library Explorer</td>
<td>Admin, User1</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Partitions</td>
<td>Admin</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Defragmentation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sift Sort</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Clear Station</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

On the View menu:

<table>
<thead>
<tr>
<th>[physical library name] (Physical)</th>
<th>Admin, User, Guest2</th>
<th>X</th>
<th>X</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>[partition name] (Partition)</td>
<td>Admin, User, Guest2</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

On the Connection menu:

<table>
<thead>
<tr>
<th>New</th>
<th>Admin, User, Guest</th>
<th>X</th>
<th>X</th>
<th></th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>[library IP address]</td>
<td>Admin, User, Guest</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

On the Help menu:

<table>
<thead>
<tr>
<th>Content</th>
<th>Admin, User</th>
<th>X</th>
<th>X</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Admin, User, Guest</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

On the Help menu:

<table>
<thead>
<tr>
<th>Content</th>
<th>Admin, User, Guest</th>
<th>X</th>
<th>X</th>
<th>X</th>
<th>X</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Admin, User, Guest</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

1 Users can use this command only from partitions to which they have privileges.
2 Partition must be offline.
3 Feature is configurable from the OCP only, but the configuration is viewable from the OCP or remote client.
4 Physical library must be online.
5 Guest cannot obtain more details or perform operations.
Toolbar

The toolbar consists of icons that represent commonly used commands that also are available on the menus.

The I/E button displays a table of the current contents of the Import/Export station. You also can display the table by clicking Monitor > I/E Station. For more information, see Monitoring I/E Station Status.

The Import button launches the import of cartridges if the current library is a partition. You also can request an import operation by clicking Operations > Import.

The Export button launches the export of cartridges if the current library is a partition. You also can request an export operation by clicking Operations > Export.

The Events button displays events that the library created when it detected issues within the subsystems. You also can display events by clicking Tools > Event Viewer. For more information, see Chapter 8.

The Explorer button provides a graphical presentation of all the drives, cartridges, and slots in the library. The Library Explorer can display all library elements according to physical location in any configuration, from one module to eight modules, and one drive up to the maximum number of 96 drives. You also can view the explorer by clicking Tools > Library Explorer. For more information, see Using Library Explorer.

The Log Off button logs off the current user after confirming the logoff request. You also can log off by clicking Operations > Log Off. For more information, see Logging On and Off.

Reading the Library Information Panel

The library information panel, shown in Figure 12, occupies the central portion of the main LMC display. It provides you with a significant amount of dynamically updated status information.
Table 11 Areas on the Library Information Panel

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Information: Name</td>
<td>The name of the current library. This is the library that appears with a check mark beside it in the <strong>View</strong> menu. First, the genre of library appears (physical or partition), then, after a colon, the name of the library appears.</td>
</tr>
<tr>
<td>System Information: IP Address</td>
<td>The IP address of the current library. This is particularly useful when you are connected to more than one library. See Connecting to Multiple Libraries.</td>
</tr>
<tr>
<td>System Information: Contact</td>
<td>The person to contact if you need access to or have questions about the library.</td>
</tr>
<tr>
<td>System Information: Activity</td>
<td>The current activity for the current library.</td>
</tr>
<tr>
<td>System Information: Physical Serial # or Partition Serial #</td>
<td>The serial number of the physical library or partition, depending on which is currently selected.</td>
</tr>
</tbody>
</table>
The current date and user-enabled time. The date that appears reflects user settings, but the system operates according to Greenwich Mean Time (GMT).

Lists the physical library and all partition as [physical library name] (Physical), then [partition name] (Partition). Clicking the library or a partition selects it so that all menu choices and information displayed is specific to the library or partition selected. This is the only interactive section of the Library Information Panel.

This graph shows the percentage of occupied media slots in the library or partition, depending on the current view. The number of used media slots appears beneath the graph (occupied slots/total number of storage slots).

The bar graph contrasts the amount of data read and written for the past 24 hours. The units being reported appear beside the graph.

Configuration summary information is presented textually. Data points reported are:
- Number of tape drives
- Drive types: LTO-4, LTO-5, or MIXED
- Total number of licensed storage slots (appears only in the physical library view)
- Total number of storage slots in the physical library or partition, depending on the current view
- Library type

System Status Buttons

System status buttons are located in the Overall System Status area at the bottom of the LMC. See Figure 13.

![Overall System Status](image)

**Figure 13 System Status Buttons in Good Status**

Each button represents a subsystem. Table 12 lists the library subsystems and some of the components that each subsystem represents. Each field replaceable unit (FRU) in the library belongs to one of the subsystems.
Table 12 Subsystems and their components

<table>
<thead>
<tr>
<th>Subsystem</th>
<th>Components</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drives</td>
<td>Drives and media, such as brick firmware, drive bricks, drive sleds, cartridges, and magazines</td>
</tr>
<tr>
<td>Robotics</td>
<td>Assemblies and processors involved in the movement and handling of library media, such as the IEX board, I/E stations, the pivot and reach assemblies, system barcode labels, doors, filters, the accessor, drive mounts, rails, and carriages</td>
</tr>
<tr>
<td>Connectivity</td>
<td>Host connectivity components, such as I/O management units, and the chassis management blade (CMB)</td>
</tr>
<tr>
<td>Power</td>
<td>Power supplies and related hardware, such as the power distribution unit (PDU), power chassis, and fuses</td>
</tr>
<tr>
<td>Control</td>
<td>Main processor cards and related hardware and software, such as system firmware, the management control blade (MCB), the robotics control unit (RCU), the library motor drive (LMD), and the operator panel</td>
</tr>
<tr>
<td>Cooling</td>
<td>Cooling system components, such as fans for the library management module (LMM) and the I/O management unit</td>
</tr>
</tbody>
</table>

Each button displays a status indicator that reveals a Good, Warning, Degraded, or Failed state as follows:

<table>
<thead>
<tr>
<th>Status Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="green.png" alt="Green Circle" /></td>
<td>Good (green) — the library system is in working order, no problems or issues exist.</td>
</tr>
<tr>
<td><img src="yellow.png" alt="Exclamation Mark" /></td>
<td>Warning or Degraded (yellow) — there is a degraded or failed component within this category that requires action, but the overall category still is functioning.</td>
</tr>
<tr>
<td><img src="red.png" alt="Red Cross" /></td>
<td>Failed (flashing red) — a component in this category has failed.</td>
</tr>
</tbody>
</table>

Click system status buttons to display additional information about the subsystems. The information that appears depends on the status shown on the button:

- **Good** — either a message appears informing you that no events exist for the subsystem, or a list of subsystem events that are in Closed or Verified states appears.
- **Warning, Degraded, or Failed** — a list of open events for the subsystem appears.

Events provide information about issues that the library has detected.

### Viewing Details about Events

Events are error conditions in the library system. The system provides Overall System Status buttons to report details about errors that are discovered.

To see details about reported errors:

1. Wait until the test is completed, or click **Cancel** to close the test dialog box.
2. Click the **Overall System Status** button corresponding to the system for which to view events. Alternatively, click the **Events** button in the toolbar.

**Understanding Location Coordinates**

This section describes the coordinate addressing system that the library uses to indicate the location of cartridges and drives in the library.

You can use the **Library Explorer** feature to view a graphical presentation of all the drives, cartridges, and slots in the library. The **Library Explorer** can display all library elements according to physical location in any configuration, from 1 to 8 cabinets (called modules), and 1 drive up to the maximum number of 96 drives. See **Using Library Explorer**.

**NOTE:**
The ESG G3 can have up to 12 modules, but only the first 8 can contain drives. Drives must be installed in consecutive slots in the modules.

**Cartridge Locations**

The library uses a coordinate addressing system that indicates the location of cartridges using six coordinates. The coordinates are represented by the library in a comma separated list. For example:

1,1,1,1,2,1 = aisle 1, module 1, rack 1, section 1, column 2, row 1

The following list explains each location variable:

- **Aisle** — there is only one aisle in the library. This value will always be 1.
- **Module** — there are from 1 to 12 modules (the control module, up to seven expansion modules that can contain drives, and up to 4 additional expansion modules that contain slots only). The value will be between 1 and 12.
- **Rack** — there are 2 rack designations inside each module. These will always be either 1 or 2, with 2 being the inside of the access door.

![Figure 14 Aisle, Module, and Rack Numbering Locations](image)

**Figure 14 Aisle, Module, and Rack Numbering Locations**

- **Section** — there are 10 sections in a rack, numbered from top to bottom.
- **Column** — there are 4 columns in a rack, numbered from left to right as you face the front of the rack. These are numbered from 1 to 4.
- **Row** — this is equal to one cartridge slot. The number of rows per section can vary depending on the size of the cartridge. The rows are numbered from 1 to 6 for LTO cartridges.
Figure 14 shows the section, column and row numbering for rack 1 of a library that contains LTO cartridges. See Figure 15 to review rack numbering.

Figure 15 Section, Column, and Row Numbering for Rack 1 - LTO Cartridges

1. Column 2. Row (individual slot)
3. X-axis rail counts as section 6 4. Section

NOTE:

Tape drives that are installed in rack 1 of a control module or an expansion module replace storage in columns 1 and 2. Because drives are installed from the bottom to the top, you lose the storage starting in section 10 first. You do not lose the magazine in columns 1 and 2 of section 5. Column 1 never contains storage in the control module.

Figure 16 shows the section, column, and row numbering for rack 2 of a library that contains LTO cartridges. This is shown as you face the inside of the opened module door.

NOTE:

The cartridges in the 24-slot LTO I/E station are addressed as part of column 3 and are in sections 1 through 4 (top to bottom). When you have an I/E station installed on rack 2, there are no cartridges in columns 3 and 4 of section 5. See Figure 16.
Figure 16 Section, Column, and Row Numbering for Rack 2 - LTO Cartridges

NOTE:

In Figure 16, the five magazines shown in column 4, sections 6-10 do not exist in a control module. However, these magazines exist in expansion modules.

Figure 17 shows examples of location coordinates. These examples assume that the linear storage is located in aisle 1, module 1, and rack 1. That is why the first three numbers in the comma separated list are 1,1,1. The last three numbers represent the address on the linear storage assembly.
1. Location coordinate 1, 1, 1, 3, 2, 1

2. Location coordinate 1, 1, 1, 7, 3, 2

3. Column 1 is not available in a control module, so there is no coordinate

**Figure 17 Example Location Coordinates**

The LMC uses dialog boxes, like the one shown in Figure 18, that enable you to specify cartridge locations. These coordinates are reported in parenthetical format with each element separated by commas. In parenthetical format, the location of cartridge KR5840L5, shown in the Load Drives dialog box below, is (1,1,1,2,2).
Tape Drive Locations

The location coordinates of a drive are based on the position of the drive in the module and section.

- Tape drives are always in rack 1, column 1, of a particular module.
- Columns are read from left to right as you face the rack.
- Because all drives in the library are full-height drives, each drive is in row 1 of the designated section.
- The library can accommodate 2 drive clusters per rack with each drive cluster containing up to 6 drives.
- Drive number 1 is in the lowest section of the lower drive cluster. Drives are numbered from bottom to top. Figure 19 shows the physical location of drive 9. Compare with Table 13.
2. Rack 1 (back)
3. Module 1
4. Section 1
5. Drive cluster
6. Section 6
7. Section 7
8. Drive 9 (1, 1, 1, 9, 1, 1)
9. Section 12

Figure 19 Drive-side Location Coordinates

Table 13 Drive location coordinates

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1–8</td>
<td>1</td>
<td>1–12</td>
<td>1</td>
</tr>
<tr>
<td>Aisle</td>
<td>Module</td>
<td>Rack</td>
<td>Section (drive number)</td>
<td>Column</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Viewing the Physical Library or a Partition

The View menu enables you to view details about the physical library or a specific partition in the library information panel area of the main LMC display.

NOTE:

Before you can begin many of the library operations that this guide describes, you must first set the library view to either the physical library or a partition.
Using the View Menu

From the View menu, click the name of the physical library or a partition. The physical library is listed at the top of the View menu. Individual partitions, if they exist, are listed below the physical library.

After you select a library (or partition) view, the library information panel area of the main LMC display shows status information and statistical details about the physical library or partition selected.

Using the Managed Views Region of the LMC display

The Managed Views region of the LMC display enables you to quickly select between library views (physical or individual partitions) and take the physical library or a partition online or offline. If you are using the LMC from a remote client, you can keep this dialog box in view while you use the LMC to perform other library operations.

1. In the Managed Views region of the LMC, click the button with the name of the library or a partition to view.

   The Name field in the System Information section of the LMC displays the name of the library or partition selected. The library information panel area of the main LMC display shows status information and statistical details about the physical library or partition selected.

2. See Changing the Library State to take the library offline or put it back online.

**NOTE:**
You do not need to change the current library view to change the online or offline state of the physical library or a partition.

Changing the Library State

You can take the physical library or any of its partitions online or offline. Some library functions require that the physical library or partitions be in an online or offline state. You also can shut down the physical library from the LMC.

**NOTE:**
Shutting down the library only prepares it to be powered off. You will use the shutdown procedure in some circumstances to prepare the library for remove and replace procedures.

Taking the Physical Library or a Partition Online or Offline

To take the physical library online or offline, change its mode:

1. Make sure that you are viewing the physical library or the partition that you want to take online or offline. See Viewing the Physical Library or a Partition.

2. Click Operations > Change Mode. Alternatively, in the Managed Views section of the LMC, click the mode button next to the name of the physical library or partition for which you would like to change the mode. (The button reads either Online or Offline.)

   The Change Library Mode dialog box appears with the current state of the physical library or partition shown.
• Select the **Online** radio button to take the physical library or partition to an online state, which is the normal operating condition. In this mode, the robotics are enabled and all host commands are processed.

• Select the **Offline** button to take the physical library or partition to an offline state. If only the physical library is taken offline, the library partitions will not process robotics commands, even though they are online. If only a partition is taken offline, neither the physical library nor the other partitions are affected.

3. Select either **Online** or **Offline**, and then click **OK**.

4. If you selected **Offline**, a message appears that asks you whether you want to continue. If you are sure that no backup applications are using the library, click **Yes**.

### Online and Offline Functionality

Some library functions require the physical library or partitions to be in a particular state (either online or offline) before they can be performed. If you choose a function that requires the library or partition state to be changed from its current state, you are prompted to do so.

Table 14 summarizes the library functions that require the physical library or partitions to be either online or offline.

**Table 14 Library Functions Requiring Online or Offline State**

<table>
<thead>
<tr>
<th>Function</th>
<th>Physical Library</th>
<th>Partition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operations &gt; Import</td>
<td>Online</td>
<td>Offline</td>
</tr>
<tr>
<td>Operations &gt; Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operations &gt; Drives &gt; Load</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operations &gt; Drives &gt; Unload</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operations &gt; Move Media</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operations &gt; Inventory (partition view)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Partitions (create, modify, or delete)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tools &gt; Partitions Defragmentation</td>
<td>—</td>
<td>Offline</td>
</tr>
<tr>
<td>Function</td>
<td>Physical Library</td>
<td>Partition</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Operations &gt; Inventory (physical library view)</td>
<td>Offline</td>
<td>—</td>
</tr>
<tr>
<td>Tools &gt; Save/Restore (restore, revert, or rescue)</td>
<td>Offline</td>
<td>—</td>
</tr>
<tr>
<td>Tools &gt; Library Diagnostics &gt; Teach</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Tools &gt; Library Diagnostics &gt; Verification Tests (start test)</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Tools &gt; Update Firmware &gt; Library Service &gt; Manual Diagnostics</td>
<td>—</td>
<td>—</td>
</tr>
<tr>
<td>Tools &gt; Update Firmware &gt; Drives</td>
<td>Offline—Current view (library or partition) must be offline</td>
<td>—</td>
</tr>
</tbody>
</table>

**Working With Local User Accounts**

You can set up three levels of local user accounts: guest, user, and administrator. Guests see only the main LMC display. Local Users can operate a partition, but cannot run diagnostic tools, which require access to the physical library. Administrators can access the entire physical library and all of its partitions.

Administrators are responsible for:

- Setting up and managing users
- Specifying logging and notification policies
- Updating software
- Setting the date and time
- Importing, exporting, and moving media
- Any other management associated with the physical library

For information on user accounts that reside on a Lightweight Directory Access Protocol (LDAP) server, see Using LDAP.

**Creating Local User Accounts**

To create local user accounts:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > User Configuration > Local Users.
   The Local Users dialog box appears.
4. To prevent guest login privileges on the library, click **Disable Guest Login**. You can toggle between **Disable Guest Login** and **Enable Guest Login**.

**NOTE:**
For a list of commands that are available to users logging on to the library as a guest, see **Table 10**.

5. To create a user account, click **Create**.
   The **Local Users - User Account Type** dialog box appears.

6. In the **Enter User Name** text box, type a user name.

**NOTE:**
User accounts with the names **guest**, **admin**, and **service** are reserved. You cannot use these names for user accounts.

7. In the **Enter Password** text box, type a password.

**NOTE:**
Passwords that are most secure include a combination of letters, numbers, and non-alphanumeric characters. Passwords must be eight or more characters in length. The word **password** is not available for use.

8. In the **Confirm Password** text box, type the password again.

9. For **Select Privilege**, select a privilege level (**Administrator** or **User**).
10. Perform one of the following tasks:
   • If you selected Administrator, the Finish button becomes available. To register your user account selections, click Finish, and then skip the remaining information in this procedure.
   • If you selected User, click Next.
   The Local Users - User Account Type - Assign Partitions dialog box appears.

11. On the Local Users - User Account Type - Assign Partitions dialog box, select the check boxes to the left of the libraries to which you want the user to have access, or select the Select All check box to give the user access to all listed libraries.

12. To register your user account selections, click Finish.

**NOTE:**
The Back button enables you to go back to a previous dialog box and make changes to your selections.

---

### Modifying Local User Accounts

To modify local user accounts:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > User Configuration > Local Users.
   The Local Users dialog box appears.

**NOTE:**
If you want to modify guest privileges, you can toggle between Enable Guest Login and Disable Guest Login. For a list of commands that are available to users logging on to the library as a guest, see Table 10.

4. In the table of local users, click to highlight the name of the account that you want to modify, then click Modify.
   The Modify User Account — [account name] screen of the Local Users dialog box appears.
5. If you want to change the user account password, type a new password in both the Enter Password and Confirm Password text boxes. Otherwise, proceed to the next step.
NOTE:
Passwords that are most secure include a combination of letters, numbers, and non-alphanumeric characters. Passwords must be eight or more characters in length. The word password is not available for use.
It is recommended that you change all account passwords periodically.

6. If you want to change the privilege level of this user account, select the appropriate privilege level (Administrator or User). Otherwise, proceed to the next step.

NOTE:
For a list of commands that are available to administrators and users, see Table 10.

7. Perform one of the following tasks:
   • If Select Privilege is set to Administrator, the Finish button is available. To register your user account changes, click Finish, and then skip the remaining information in this procedure.
   • If Select Privilege is set to User, click Next.

8. Select the check boxes to the left of the partitions to which you want the user to have access, or select the Select All check box to give the user access to all listed partitions.

9. To register your user account selections, click Finish.

NOTE:
The Back button enables you to go back to a previous dialog box and make changes to your selections.

Deleting Local User Accounts

To delete local user accounts:
1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > User Configuration > Local Users.
The Local Users dialog box appears.
4. In the table of names, click to highlight the name of the account that you want to delete.
5. Click Delete.
   A message appears that asks you whether you are sure that you want to delete the account.
6. Click Yes.
The library deletes the user account.
Viewing Local User Account Permissions

To view local user account permissions:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Setup > User Configuration > Local Users. The Local Users dialog box appears.
4. To view the permissions for all users, click Permissions. The Users Permissions dialog box appears.

5. Click Close to return to the Local Users dialog box.

User Privileges and Library/Partition Functions

The library allows you to interactively control operations, set options, check operating statistics, and diagnose and repair errors. Some operations pertain only to a physical library, some only to a partition, and other functions work for both the physical library and partitions. Table 15 summarizes all available commands by privilege level and library and partition environment.

> NOTE:

Only one administrator user can be logged on and performing system configuration at any one time. If another administrator attempts to log on a message appears warning that only one administrator is permitted at a time. If a service user attempts to log on while an administrator or another service user is logged on the system automatically logs off the original administrator or service user.

Table 15 Remote Client Commands, Privilege Levels, and Views

<table>
<thead>
<tr>
<th>Commands using remote client Operations menu</th>
<th>Privilege level</th>
<th>Physical library</th>
<th>Partition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operations Menu</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change Mode</td>
<td>Admin, User¹</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Import²</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Export²</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Commands using remote client Operations menu</td>
<td>Privilege level</td>
<td>Physical library</td>
<td>Partition</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>----------------</td>
<td>------------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Drives &gt; Load⁴</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Drives &gt; Unload⁴</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Move Media</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>I/E Stations</td>
<td>Admin, User¹</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Inventory</td>
<td>Admin, User¹</td>
<td>X³</td>
<td>X², 4</td>
</tr>
<tr>
<td>System Shutdown</td>
<td>Admin</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Log off</td>
<td>Admin, User, Guest</td>
<td>X³</td>
<td>X⁵</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Monitor Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
</tr>
<tr>
<td>Drives</td>
</tr>
<tr>
<td>I/E Station</td>
</tr>
<tr>
<td>Extended I/E Slots</td>
</tr>
<tr>
<td>Slots</td>
</tr>
<tr>
<td>Media</td>
</tr>
<tr>
<td>Sensors</td>
</tr>
<tr>
<td>Email Configuration Record</td>
</tr>
<tr>
<td>Users</td>
</tr>
<tr>
<td>Partitions</td>
</tr>
<tr>
<td>Key Management</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Setup Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Wizard</td>
</tr>
<tr>
<td>Partitions³</td>
</tr>
<tr>
<td>Configure</td>
</tr>
<tr>
<td>Control Path</td>
</tr>
<tr>
<td>Data Path Failover</td>
</tr>
<tr>
<td>Automated Media Pool</td>
</tr>
<tr>
<td>Secure Manager</td>
</tr>
<tr>
<td>Commands using remote client Operations menu</td>
</tr>
<tr>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>Drive Settings</td>
</tr>
<tr>
<td>Network Configuration</td>
</tr>
<tr>
<td>Network Configuration</td>
</tr>
<tr>
<td>DNS Configuration</td>
</tr>
<tr>
<td>Network Security Settings</td>
</tr>
<tr>
<td>Library Settings</td>
</tr>
<tr>
<td>Aisle Light Settings</td>
</tr>
<tr>
<td>Screen Saver</td>
</tr>
<tr>
<td>Library Behavioral Settings</td>
</tr>
<tr>
<td>Drive Cleaning</td>
</tr>
<tr>
<td>User Configuration</td>
</tr>
<tr>
<td>Local Users</td>
</tr>
<tr>
<td>LDAP</td>
</tr>
<tr>
<td>Notifications</td>
</tr>
<tr>
<td>System Setup</td>
</tr>
<tr>
<td>Media Security</td>
</tr>
<tr>
<td>SMTP Email Configuration</td>
</tr>
<tr>
<td>SNMP Trap Registration</td>
</tr>
<tr>
<td>Date and Time</td>
</tr>
<tr>
<td>Licenses</td>
</tr>
<tr>
<td>Encryption</td>
</tr>
<tr>
<td>Key Management Setup Wizard</td>
</tr>
</tbody>
</table>

**Tools Menu**

<p>| Event Viewer                               | Admin          | X                | X        |
| Drives³                                    | Admin          |                  | X        |
| Update Firmware                            | Admin          | X                | X        |
| Library                                    | Admin          | X                | X        |
| Drives                                     | Admin          | X                | X        |
| Support Events                             | Admin          |                  | X        |</p>
<table>
<thead>
<tr>
<th>Commands using remote client Operations menu</th>
<th>Privilege level</th>
<th>Physical library</th>
<th>Partition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library Diagnostics&lt;sup&gt;3&lt;/sup&gt;</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Teach</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Verification Tests</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Save/Restore&lt;sup&gt;3&lt;/sup&gt;</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Reports</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Reporting Options</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Events</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Media</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Library Configuration</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Retrieve MIBs</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Library Explorer</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Partitions Defragmentation</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Sift Sort</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Export</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Capture Report</td>
<td>Admin</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Clear Station</td>
<td>Admin</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>

**View**

| [physical library name]                     | Admin, User, Guest<sup>6</sup> | X                | X         |
| [partition name]                             | Admin, User, Guest<sup>6</sup> | X                | X         |

**Help**

| Index                                        | Admin, User        | X                | X         |
| About                                        | Admin, User, Guest | X                | X         |

**System status buttons**

<p>| Drives                                       | Admin, User&lt;sup&gt;1&lt;/sup&gt;, Guest&lt;sup&gt;1&lt;/sup&gt; | X                | X         |
| Connectivity                                 | Admin, User&lt;sup&gt;1&lt;/sup&gt;, Guest&lt;sup&gt;1&lt;/sup&gt; | X                | X         |
| Control                                      | Admin, User&lt;sup&gt;1&lt;/sup&gt;, Guest&lt;sup&gt;1&lt;/sup&gt; | X                | X         |</p>
<table>
<thead>
<tr>
<th>Commands using remote client</th>
<th>Privilege level</th>
<th>Physical library</th>
<th>Partition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operations menu</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Robotics</td>
<td>Admin, User¹,</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Guest¹</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>Admin, User¹,</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Guest¹</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cooling</td>
<td>Admin, User¹,</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td></td>
<td>Guest¹</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

¹Users can use this command only from partitions to which they have privileges.
²Physical library must be offline.
³Physical library must be online.
⁴Feature is configurable from the library OCP only, but the configuration is viewable from the OCP or remote client.
⁵Shutdown is available to administrators only.
⁶Guest can view the main LMC display, but cannot obtain more details or perform operations. Guests and users can view status information from the faces of status buttons, but they cannot click them to obtain details.

Shutting Down/Rebooting the Library

Always perform the shutdown process before you remove power from the library. **Shutdown** prepares the library operation system and firmware for when you physically turn off power to the library. **Shutdown** makes sure that the library finishes all active commands received from the host and prevents the processing of any new commands. It also shuts down all partitions. **Shutdown** can only be performed from the OCP.

**Reboot** shuts down and restarts the library operating system and firmware. When performing a reboot, the library finishes all active commands received from the host application and does not process any new commands. The library shuts down all partitions and restarts them during the reboot. In addition, if automatic inventory is enabled, the library performs an inventory of cartridges, tape drives, and slots during a reboot. **Reboot** can be performed from the OCP or a remote client LMC.

⚠️ **CAUTION:**

Before shutting down or rebooting the library, make certain there is no I/O activity on any of the partitions.

To shut down or reboot the library:

1. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
2. Select Operations > System Shutdown.
   The System Shutdown dialog box appears.
3. Select **Shutdown** to do a complete shutdown and power off of the library (from the OCP only), or select **Reboot** to do a reset of the library without powering off (from the OCP or a remote client LMC).

   A message appears that asks you whether you want to continue.

4. If you are sure that all library operations are finished, click **OK**.

   **NOTE:**

   To recover from library shutdown, you must cycle power on the library (power it off and then power it on). See **Powering Off the Library** and **Powering On the Library**.

   When the shutdown process completes, the LMC display turns dark. The library is now ready to be powered off.

### Powering Off the Library

**CAUTION:**

Always perform the shutdown procedure before powering off the library. **Shutdown** prepares the library operation system and firmware for when you physically turn off power to the library. If you do not perform library shutdown before you power off the library, loss of data could occur. See **Shutting Down/Rebooting the Library**.

To power off the library:

1. After starting the shutdown process, wait for the LMC display to turn dark.
2. To turn off power to the library, press the **Power** button on the indicator panel.
3. On the power distribution units, set the circuit breaker switch to the down (O) position.

### Powering On the Library

To power on the library:

1. Make sure that you wait 5 minutes after powering off the library before you power it on.
**CAUTION:**
Waiting 5 minutes is important because the power supply discharges for several seconds after you power off the library. If you attempt to power on the library too soon, the power supply will fault.

2. On the power distribution unit(s), set the circuit breaker switch to the up (I) position.
3. To turn on power to the library, press the **Power** button on the indicator panel.

The library begins to boot up. Within five minutes, the LMC display appears on the library OCP. A library with only a few drives usually will be fully powered on and ready for use within 10 minutes. However, if a library is large with a high number of drives, it can take more than an hour for the library to fully power on, complete its discovery process, and become ready for use. During the power-on process, the **Robotics Enabled** indicator flashes. When the library is fully up and ready to receive commands, the **Robotics Enabled** indicator turns solid green.

### Locking/Unlocking the I/E Station

The ESL G3 I/E stations have multiple open and close sensors. When you are finished accessing the I/E station, make sure the station door is fully closed.

There are three reasons the I/E station door locks:

- The library imports or exports a cartridge from the I/E station door. While the library is attempting to import or export a tape from a given I/E station slot, only the associated I/E station door is locked in the closed position. All other I/E station doors remain accessible. On a Get command from an I/E station slot, the associated I/E station door remains locked until the media has been successfully moved to its destination. This allows the media to be returned to the I/E station slot in the event of a Put error.
- A user has requested that the I/E station door be locked.
- The application software has locked the I/E station as part of the normal tape movement process.

Administrative users can lock or unlock the I/E station doors using an option from the **Operations** menu.

To lock or unlock the I/E station:

1. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
2. Click **Operations > I/E Station**.

**NOTE:**

The I/E Station # column lists the I/E station number for each door. All single door I/E stations are numbered starting with 1 at the control module. All double door I/E stations are numbered with a number and a letter, such as 2A and 2B, the module number (1-8), with A as the left I/E station and B the right I/E station.

3. To change the state of the I/E station doors, do one of the following:
   - To lock an I/E station door, in the appropriate **Action** column, click **Lock**.
   - To unlock an I/E station door, in the appropriate **Action** column, click **Unlock**.
4. To return to the main console, click **Close**.
Using the Library When Robotics Are Not Ready

When the library robotics are not yet ready to accept commands, features of the LMC are still available while others are not. This can happen during startup, reboot, or while the library is running. During run time, for example, the robotics will become unavailable if someone opens and closes an access door without pressing the **Robotics Enabled** button.

Whenever robotics become disabled, a message appears in the **Activity** area on the main LMC display that states, **Warning: The Robotics are not Enabled.** Users can log on locally or remotely while the robotics are disabled.

Table 16 lists the menu commands that are available when the robotics become disabled either before system discovery can occur or after system discovery has occurred. As the table shows, significantly fewer menu commands are available when the library is started up or rebooted and the robotics become disabled before system discovery occurs.

NOTE:

Menu commands not listed in the table are not available when the robotics become disabled, regardless of when the robotics become disabled. Unavailable menu commands are grayed out on the LMC.

### Table 16 Menu Commands when Robotics are Disabled

<table>
<thead>
<tr>
<th>Available Menu Commands When Robotics Become Disabled</th>
<th>After Discovery</th>
<th>Before Discovery</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operations &gt; Change Mode (for shutdown only)</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Operations &gt; Log Off</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Monitor &gt; Drives &gt;</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Monitor &gt; I/E Station</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Monitor &gt; Slots</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Monitor &gt; Media</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Monitor &gt; Sensor</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Monitor &gt; Users</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Setup Wizard</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Partitions</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Network Configuration (from OCP only)</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Setup &gt; Library Settings</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Users</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Notification</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Date and Time</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Setup &gt; Licenses</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Available Menu Commands When Robotics Become Disabled</td>
<td>After Discovery</td>
<td>Before Discovery</td>
</tr>
<tr>
<td>------------------------------------------------------</td>
<td>----------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Setup &gt; Secure Manager</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tools &gt; Event Viewer</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Tools &gt; Drives</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Tools &gt; Connectivity</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Tools &gt; Save/Restore</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>View &gt; [physical library name] (Physical)</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View &gt; [partition name] (Partition)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Help &gt; Content</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Help &gt; About</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
4 Monitoring the library

The library includes advanced system monitoring and alerting mechanisms that inform you of library status and issues. It provides you with status information about various library subsystems and components. It also notifies you of issues it detects and guides you through diagnosing and correcting issues before problems interfere with backups.

Using Library Explorer

You can use the Library Explorer feature to view a graphical presentation of all the drives, cartridges, and slots in the library. The Library Explorer displays all library elements according to physical location in any configuration, from 1 module to 12 modules, and 1 drive up to the maximum number of 96 drives.

You can access the Library Explorer from both the physical and partition views, but the functionality in the physical view is limited. If you are in a partition view, Library Explorer displays slots and drives pertaining to that particular partition.

The Library Explorer features are available to administrator and service users, along with non-administrative users who have limited access to library functions. Users who do not have administrative privileges can perform all Operations options available to non-administrative users directly from the Library Explorer dialog boxes.

You can use the Library Explorer to directly perform the following tasks:

• Locate an element by entering its address
• Locate a cartridge by entering the media barcode
• Load and unload drives
• Move cartridges
• Perform inventory
• Import and export
• View drive details
• Perform all drive related functions

To use Library Explorer:

1. Click Tools > Library Explorer, or click the EXPLORER button in the toolbar.
   The Library Explorer dialog box appears.
2. Display library data using either the **Select Filter** options or clicking on a particular module in the **Select Module** section of the dialog box.

- **Using Select Filter**, search for and display specific criteria according to device type and location coordinates, or by **Media ID**.
  - Select the **DeviceType** filter, then from the **Type** drop-down list click the appropriate device type: **Storage**, **I/E** (I/E Station), or **Drive**. Click **Show**.
    The **Control Module** dialog box displays a graphical view of the library elements according to the **Type** selected.
  - To search for a specific cartridge according to the barcode, select the **Media ID** filter, type the barcode in the **Media ID** field, then click **Show**.
    The **Module** dialog box displays the specific cartridge highlighted in red within the module where it is located.
  - To search for a specific cartridge according to the element address, select the **Element Address** filter, type the element address in the field, then click **Show**. You must be in partition view to filter using the **Element Address**.

- **In the Select Module area**, select a specific module in the library to view. On a multi-module library, all modules are represented.
  - **In the Select Module area**, click on the module you want to view. The **Module** dialog box displays the current configuration of Rack one and Rack two (Door - Inside view) according to the selected module.
NOTE:
The Rack two (Door - Inside view) view is a MIRROR image of the outside view, so I/E station B is on the left, and I/E station A is on the right.

If you search for an element by its address or locate a cartridge by its media barcode, the search result appears in red in the Control Module dialog box.

3. To return to the Library Explorer dialog box, click Close.
The Library Explorer dialog box appears.
Understanding the Graphical Display, frame view

You can access the Library Explorer Control Module from both the physical and partition views, but the functionality in the physical view is limited. If you are in a partition view, you can view slots and drives pertaining to that particular partition.

• The **Library Explorer Module** dialog box displays the current configuration of Rack One and Rack Two (Door - Inside view) according to the module you chose.
• The Rack Two (Door - Inside view) view is a MIRROR image of the outside view, so I/E station B is on the left, and I/E station A is on the right.
• Slots containing cartridges are blue. Empty slots are black. Your search result appears in red.
• Details concerning the particular cartridge, drive, or slot appear in the Information area.

The **Information** area displays the following details:

• Type  
• Location  
• Element  
• Partition  
• Barcode (media ID)  
• Barcode numbers appear on slots containing cartridges. If you do not want to view the barcode information, clear the **Show** check box.  
• If you click on a specific slot or drive, that slot or drive is highlighted in red, and details about the slot or drive appear in the Information area.  
• To move from one module to another, click on the arrows at the bottom of the dialog box.

Accessing Library Operations

To access available library operations for a specific drive or slot, from the Library Explorer Module, click on **Menu** or right click on the drive or slot. You can perform the following operations, depending on what library or partition is selected:

• View details of a drive  
• Conduct an Inventory of a drive or a slot  
• Load media into a drive  
• Move media  
• Import cartridges  
• Export cartridges

Monitoring System Components

The LMC provides detailed information about the status of the library and components. You also can access statistics about the library and other helpful information, such as library and component serial numbers, port numbers, World Wide Names (WWNs), IDs, and firmware versions.

Monitoring System Status

The **System Status** dialog box displays status information for various library entities (hardware or system metrics). You can view system status for a physical library or a partition.

To monitor system status:
1. Click Monitor > System. The System Status dialog box appears. Table 17 describes the elements on the System Status dialog box.

**Table 17 System Status Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>A system item for which status information is available (hardware or system metric).</td>
</tr>
<tr>
<td>Serial Number</td>
<td>If applicable or available, the serial number or other identifying number of the system item.</td>
</tr>
<tr>
<td>Status</td>
<td>Status information for the system item.</td>
</tr>
<tr>
<td>Version</td>
<td>If applicable, the firmware version currently loaded on the system item.</td>
</tr>
</tbody>
</table>

Table 18 describes the items that can appear in the status list.

**Table 18 Status List Items**

<table>
<thead>
<tr>
<th>Item</th>
<th>Serial Number</th>
<th>Status Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>The library serial number</td>
<td>The status of the library (Online or Offline).</td>
<td>Firmware version</td>
</tr>
<tr>
<td>Library Uptime</td>
<td>The library serial number</td>
<td>The amount of time that the library has been up (in days, hours, minutes, and seconds).</td>
<td>N/A</td>
</tr>
<tr>
<td>Media Moves</td>
<td>The library serial number</td>
<td>The number of media moves during the library history.</td>
<td>N/A</td>
</tr>
<tr>
<td>Recovered Gets</td>
<td>The library serial number</td>
<td>The number of recovered gets during the library history.</td>
<td>N/A</td>
</tr>
<tr>
<td>Recovered Puts</td>
<td>The library serial number</td>
<td>The number of recovered puts during the library history.</td>
<td>N/A</td>
</tr>
<tr>
<td>Recovered Scans</td>
<td>The library serial number</td>
<td>The number of recovered scans during the library history.</td>
<td>N/A</td>
</tr>
<tr>
<td>MCB</td>
<td>The MCB serial number</td>
<td>The current status of the MCB (Good, Degraded, or Failed).</td>
<td>Firmware version</td>
</tr>
<tr>
<td>CMB</td>
<td>The CMB serial number</td>
<td>For each CMB that is present, the current status of the CMB (Good, Degraded, or Failed).</td>
<td>Firmware version</td>
</tr>
<tr>
<td>RCU</td>
<td>The RCU serial number</td>
<td>The current status of the RCU (Good, Degraded, or Failed).</td>
<td>Firmware version</td>
</tr>
<tr>
<td>Vertical Motion</td>
<td>The RCU serial number</td>
<td>The number of meters vertically traveled during the library history.</td>
<td>N/A</td>
</tr>
<tr>
<td>Item</td>
<td>Serial Number</td>
<td>Status Description</td>
<td>Version</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------</td>
<td>------------------------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Horizontal Motion</td>
<td>The RCU serial number</td>
<td>The number of meters horizontally traveled during the library history.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

2. To mail, save, or print status information, use the **Send** button (see Emailing, Saving, and Printing Status Information).

3. Click **Close** to close the dialog box.

**Monitoring Drive Status**

The **Drive Status** dialog box displays status information for tape drives in the currently-selected partition. If you are working in the physical library, status information for all drives appears. You can perform this procedure while viewing either the physical library or a partition.

To monitor drive status:

1. Make sure that you are viewing the physical library or the appropriate partition. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library or partition.

2. Click **Monitor > Drives**.

The **Drive Status** dialog box appears.

**Table 19 describes the elements on the Drive Status dialog box.**

**Table 19 Drive Status Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The type of drive (for example, LTO-5 – FC).</td>
</tr>
<tr>
<td>WWN</td>
<td>For a Fibre drive only, the World Wide Name of the drive.</td>
</tr>
<tr>
<td>WWN Port 1</td>
<td>For a Fibre drive only, the World Wide Name of drive port 1.</td>
</tr>
<tr>
<td>WWN Port 2</td>
<td>For a Fibre drive only, the World Wide Name of drive port 2.</td>
</tr>
<tr>
<td>Link Status P1</td>
<td>The status of port 1 on the drive as reported by the RAS system (for example, Good or Failed).</td>
</tr>
<tr>
<td>Link Status P2</td>
<td>The status of port 2 on the drive as reported by the RAS system (for example, Good or Failed).</td>
</tr>
<tr>
<td>Health</td>
<td>Drive health as reported by the RAS system (for example, Good or Failed).</td>
</tr>
<tr>
<td>Firmware level</td>
<td>The firmware level of the drive.</td>
</tr>
<tr>
<td>Barcode</td>
<td>The barcode of the cartridge in the drive.</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the drive by means of a coordinate system. For information about location coordinates, see Understanding Location Coordinates.</td>
</tr>
<tr>
<td>Physical SN</td>
<td>The serial number of the particular drive.</td>
</tr>
<tr>
<td>Vendor</td>
<td>The name of the drive vendor.</td>
</tr>
</tbody>
</table>
### 3. From the Drive Status dialog box, you can perform the following tasks:
- Change the sorting of drives in the status list (for example, by type or location) by clicking the column heading by which you want the drives sorted. Repeatedly clicking a column heading toggles between ascending and descending order.
- Mail, save, or print status information by using the Send button (see Emailing, Saving, and Printing Status Information).

### 4. Click Close to exit the dialog box.

## Monitoring I/E Station Status

The **I/E Station Status** dialog box displays detailed information about the magazine slots in the I/E stations within the currently selected partition. If you are working in the physical library, status information appears for all magazine slots in all I/E stations. You can perform this procedure while viewing either the physical library or a partition.

**NOTE:**

Only modules 1–8 can have I/E stations. Modules 9–12, if present, do not support I/E stations.

To monitor I/E station status:

1. Click **Monitor > I/E Station** or use the I/E toolbar button.

   The **I/E Station Status** dialog box appears.

   **Table 20** describes the elements on the **I/E Station Status** dialog box.

### Table 20 I/E Station Status Dialog Box

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
</table>
| I/E Station # | All single door I/E stations are numbered starting with 1 at the control module.  
|               | All double door I/E stations are numbered with a number and a letter, for example: 2A and 2B — the frame number (1-8), with A as the left I/E station and B as the right. |
| Magazine #    | The number of the I/E station magazine (numbered from top to bottom in the I/E station).                                                |
2. From the I/E Station Status dialog box, you can perform the following tasks:
   • Change the sorting of magazine slots in the status list (for example, by I/E station number or partition name) by clicking the column heading by which you want the magazine slots sorted. Repeatedly clicking a column heading toggles between ascending and descending order.
   • Mail, save, or print status information by using the Send button (see Emailing, Saving, and Printing Status Information).

3. Click Close to exit the dialog box.

Monitoring Slots Status

The Slots Status dialog box displays detailed information about the slots in the currently-selected partition. If you are working in the physical library, you can view status information for all slots. Because the number of slots in a physical library or partition can be quite large, you can select a subset of the available slots. You can perform this procedure while viewing either the physical library or a partition.

To monitor slot and extended I/E slot status:

1. From the View menu or in the Managed Views section of the LMC, click the name of the physical library or the appropriate partition.

2. Click Monitor > Slots.
   The Slots Status dialog box appears.
Table 21 describes the elements on the Slots Status dialog box.

Table 21 Slots Status Dialog Box

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Location:</td>
<td></td>
</tr>
<tr>
<td>Aisle</td>
<td>The location of slots by aisle number</td>
</tr>
<tr>
<td>Module</td>
<td>The location of slots by module number</td>
</tr>
<tr>
<td>Rack</td>
<td>The location of slots by rack number</td>
</tr>
<tr>
<td>Section</td>
<td>The location of slots by section number</td>
</tr>
<tr>
<td>Column</td>
<td>The location of slots by column number</td>
</tr>
<tr>
<td>Row</td>
<td>The location of slots by row number</td>
</tr>
<tr>
<td>Status</td>
<td></td>
</tr>
<tr>
<td>Barcode</td>
<td>The barcode of the cartridge in the slot, or EMPTY</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the slot (see Understanding Location Coordinates).</td>
</tr>
<tr>
<td># Puts</td>
<td>The number of Put operations during the library history</td>
</tr>
<tr>
<td>Partition Name</td>
<td>The name of the partition to which the slot is assigned (column exists in library view only)</td>
</tr>
</tbody>
</table>
3. If appropriate, perform the following tasks from the Slots Status dialog box:
   • Change the sorting of slots in the status list (for example, by location or slot type) by clicking the column heading by which you want the slots sorted. Repeatedly clicking a column heading toggles between ascending and descending order.
   • Use filtering criteria to select the slots that you want to appear in the status list on the dialog box (see Filtering Slots by Location).
   • Check the status of the slots (see Checking slot status).
   • Mail, save, or print status information by using the Send button (see Emailing, Saving, and Printing Status Information).

4. Click Close to exit the dialog box.

Checking slot status

Use the Slots Status dialog box to view detailed information about the slots in the currently-selected library or partition.

To view slot status information:
1. Perform steps 1–3 of Monitoring Slots Status.
2. To see only occupied or empty slots, select OCCUPIED or EMPTY from the State drop-down box, then select Show.
3. Select Send to save, e-mail, or print the information.
4. Select Close to exit the dialog box.

Filtering Slots by Location

You can specify the slots that you want to appear in the status list by selecting the location from the Filter area of the Slots Status dialog box.

To filter slots by location:
1. Perform steps 1–3 of Monitoring Slots Status.
2. Click the appropriate option from each of the Location drop-down lists:
   • Aisle
   • Module
   • Rack
   • Section
   • Column
   • Row
   The defaults are set to All unless a drop-down list does not have more than one option. For example, the Aisle drop-down list is always set to 1 by default because only one aisle exists in the library. Therefore, the drop-down list also is grayed out and selections cannot be made from it. These selections correspond to location coordinates for the physical library. For example, to select all slots in the drive-side rack of the control module, click 1 for module, 1 for rack, All for section, All for column, and All for row. For more information about location coordinates, see Understanding Location Coordinates.
3. Click Show.
4. Click Close to exit the dialog box.
Monitoring Media Status

The Media Status dialog box displays detailed information about the media in the currently selected partition. If you are working in the physical library, you can view status information for all media. Because the number of media in a physical library or partition can be quite large, you can select a subset of the available slots. You can perform this procedure while viewing either the physical library or a partition.

To monitor media status:

1. Click Monitor > Media.
   - The Media Status dialog box appears.
   - Table 22 describes the elements on the Media Status dialog box.

<table>
<thead>
<tr>
<th>Table 22 Media Status Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>In the Filter area:</td>
</tr>
<tr>
<td>Barcode</td>
</tr>
<tr>
<td>Media Type</td>
</tr>
<tr>
<td>In the status list area:</td>
</tr>
<tr>
<td>Barcode</td>
</tr>
<tr>
<td>Media Type</td>
</tr>
<tr>
<td>Location</td>
</tr>
<tr>
<td># Mounts</td>
</tr>
<tr>
<td>Encryption</td>
</tr>
<tr>
<td>Partition Name</td>
</tr>
</tbody>
</table>

2. From the Media Status dialog box, you can perform the following tasks:
   - Change the sorting of media in the status list (for example, by location or media type) by clicking the column heading by which you want the media sorted. Repeatedly clicking a column heading toggles between ascending and descending order.
   - Use filtering criteria to select the media that you want to appear in the status list on the dialog box (see below).
   - Mail, save, or print status information by using the Send button (see Emailing, Saving, and Printing Status Information).

To specify the media that you want to appear in the status list, select media ID and media type criteria from the Filter area of the Media Status dialog box:

1. Use one or both of the following elements to specify the media that you want to appear in the status list:
   - To specify a media item by media ID, type the exact barcode that is associated with a particular cartridge in the Barcode text box. You also can use the asterisk (*) as a wildcard character to represent one or more characters in the media ID. This will list all media for IDs that...
match the designated pattern. For example, if you set the **Barcode** value to J00*, any media with IDs that start with J00 will appear in the status list.

- To specify media by media type, click **All** or a specific media type, such as LTO5, from the **Media Type** drop-down list. Only media types that are currently used in the library appear in the drop-down list. The default is set to **All**.

2. Click **Show**.

### Monitoring library configuration

View the I/E, drive, and slot partition distribution in the Library Configuration report:

1. Click **Tools > Reports > Library Configuration**.
2. To print the file, click the **Print** icon, select the desired settings in the **Print** dialog box, then click **OK**.
3. To save the file, click the **PDF** icon, type the desired settings into the **Saving Report into a PDF - File** dialog box, then click **Confirm**.
4. To exit the report, click the **Close** icon.

### Working with the media usage report

The Media Usage Report collects information on all media that have ever been in the library, including media that is no longer in the library. Lifetime media usage metrics are associated with the cartridge and are kept on the embedded chip. The report reflects what the drive reports from the media chip whenever the media is unloaded, and lists any associated errors.

When the log reaches maximum size, old information is deleted as new information is added.

To view the media usage report:

1. Log on as an administrator.
2. Select **Tools > Reports > Media > Usage**.

The **Media Usage Report** dialog box is displayed, showing the information in Table 23.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barcode</td>
<td>Media cartridge barcode label</td>
</tr>
<tr>
<td>Serial number</td>
<td>Media cartridge serial number</td>
</tr>
<tr>
<td>Manufacturer</td>
<td>Media cartridge manufacturer</td>
</tr>
<tr>
<td>Type</td>
<td>Media type (L4 or L5)</td>
</tr>
<tr>
<td>Manufacture date</td>
<td>Media cartridge manufacturing date and time (format: YYYYMMDD HH:MM:SS)</td>
</tr>
<tr>
<td>Thread count</td>
<td>Number of times the tape has been mounted and threaded on the drive</td>
</tr>
<tr>
<td>MB read</td>
<td>Cartridge lifetime MB read</td>
</tr>
<tr>
<td>MB written</td>
<td>Cartridge lifetime MB written</td>
</tr>
<tr>
<td>Recovered write errors</td>
<td>Errors in writing data where an attempt to re-write the data was successful</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Recovered read errors</td>
<td>Errors in reading data where an attempt to re-read the data was successful</td>
</tr>
<tr>
<td>Unrecovered write errors</td>
<td>Errors where all re-write attempts failed and the data could not be successfully written to the tape</td>
</tr>
<tr>
<td>Unrecovered read errors</td>
<td>Errors where all re-read attempts failed and the data could not be successfully read from the tape</td>
</tr>
<tr>
<td>Encryption</td>
<td>Cartridge Encryption Status (Unknown, Encrypted, or Not Encrypted)</td>
</tr>
</tbody>
</table>

3. To e-mail, save, or print the report, click **Send**.
   - To indicate that you want to send the information as an e-mail message to a recipient, select **Email**, and then either type an e-mail address in the **Email** text box or select an existing address from the drop-down list. If appropriate, type a comment in the **Comment** text box to send with the information.
   - To save the information, select **Save**, then either type in the **Save** text box a path and a file name to which you want the information saved, or click **Browse** to specify a location and a file name.

**NOTE:**
The **Save** option is available to remote client users only. It appears grayed out on the OCP.

- To indicate that you want to send the information to a printer, select **Print**.

**NOTE:**
The **Print** option is available to remote client users only. It appears grayed out on the OCP.

4. Click **Cancel** to exit the **Media Usage Report**.

**Monitoring Sensor Status**

The **Sensor Status** dialog box displays detailed information about the library power and cooling systems, such as operational status, temperature, voltage or wattage, and fan speed in rotations per minute (RPM). You can perform the following procedures while viewing either the physical library or a partition.

**Accessing the Sensor Status Dialog Box**

To access sensor status:

1. Click **Monitor > Sensors**.
   
The **Sensors Status** dialog box appears with the **Cooling Fan** tab displayed.
Displaying Cooling Fan Information

To display detailed information about the library cooling fans:

1. Click the **Cooling Fan** tab on the **Sensor Status** dialog box.
   
   Table 24 describes the elements on the **Cooling Fan** tab.

   **Table 24 Cooling Fan Information**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the cooling fan sensor.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the cooling fan. If the fan speed is within normal operating limits, the status is <strong>Nominal</strong>. Otherwise, a warning or alarm is indicated.</td>
</tr>
<tr>
<td>RPM</td>
<td>The current speed of the fan in rotations per minute (RPM).</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the cooling fan within the library. Locations of cooling fans for control management blades (CMBs) are indicated by means of a coordinate system. For information about location coordinates, see Understanding Location Coordinates.</td>
</tr>
</tbody>
</table>

2. To view current information, click **Refresh**.

Displaying Power Supply Information

To display detailed information about the library power supplies:

1. Click the **Power Supply** tab on the **Sensor Status** dialog box.
   
   Table 25 describes the elements on the **Power Supply** tab.

   **Table 25 Power Supply Information**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the power supply sensor.</td>
</tr>
<tr>
<td>Wattage</td>
<td>The amount of power in watts.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of power (AC or DC).</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the power supply within the library.</td>
</tr>
</tbody>
</table>

2. To view current information, click **Refresh**.

Displaying Temperature Information

To display temperature status information for various library components:

1. Click the **Temperature** tab on the **Sensor Status** dialog box.
   
   Table 26 describes the elements on the **Temperature** tab.

   **Table 26 Temperature Information on Sensor Status Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the temperature sensor.</td>
</tr>
</tbody>
</table>
2. To view current information, click **Refresh**.

### Displaying Voltage Information

To display voltage status information for various library components:

1. Click the **Voltage** tab on the **Sensor Status** dialog box.

   **Table 27** describes the elements on the **Voltage** tab.

   **Table 27 Voltage Information on the Sensor Status Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the voltage sensor.</td>
</tr>
<tr>
<td>Status</td>
<td>The voltage status at the location of the sensor. If the voltage is within normal operational limits, the status is <strong>Nominal</strong>. Otherwise, a warning or alarm is indicated.</td>
</tr>
<tr>
<td>Millivolts</td>
<td>The sensor voltage reading in millivolts.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of power at the location of the sensor (AC or DC).</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the voltage sensor within the library. Control management blade (CMB) locations are indicated by means of a coordinate system. For information about location coordinates, see <strong>Understanding Location Coordinates</strong>.</td>
</tr>
</tbody>
</table>

2. To view current information, click **Refresh**.

### Saving and Restoring Library Configuration

The library save and restore capabilities enable you to save a remote or local copy of configuration settings for the library drives and partitions, including the allocation of drives, storage magazines, and I/E station magazines to each partition. If the current library configuration becomes lost or unstable, you can use the LMC to apply the locally or remotely saved configuration image, which eliminates the need to reconfigure the entire library to bring it back to its original state.

The **Save and Restore Library Configuration** dialog box enables you to:

- Save configuration settings of a library as a remotely or locally stored image.
- Restore, revert, or rescue the library by applying a remotely or locally stored image of a library configuration settings.
CAUTION:
As a result of restore, rescue, or revert operations, the library shuts down. You must have physical access to the library to bring the library back up. If you are performing a restore, rescue, or revert operation using remote access, the library will remain shut down until the library is directly powered back on.

Types of Configuration Image Files

There are three types of configuration images that correspond to the Restore, Rescue, and Revert commands:

- The restore image is stored on a remote file system and is created any time you use the Save command. You might restore the library configuration, for example, if the locally saved library configuration is lost because the compact flash memory on the Management Control Blade (MCB) is replaced. Because of the image remote location, the Save and Restore commands are available only through the remote client.

- The rescue image is stored locally on the library file system and is created any time you use the Save Rescue command. You might rescue the library configuration, for example, if the library becomes unstable due to a configuration change and you want to roll back the library configuration settings to a previous state. The Save Rescue and Rescue commands are available from both the remote client and the library OCP. You also have the option to save the rescue image when you save the remote restore image.

- The revert image is automatically created and stored locally as the first step of any restore or rescue operation. The Revert command is available from both the remote client and the local OCP.

When to Save the Library Configuration

Even though you can choose to save the library configuration at any time, the library prompts you to save in certain situations. Specifically, the library prompts you to save whenever you change configuration settings in the following areas:

- User accounts
- Event notifications
- E-mail setup

Other configuration changes that the library detects cause the library to generate warning events for the Control subsystem. This causes a warning icon to appear on the Control system status button. Be aware that if a more serious unresolved event already exists in that status group, the warning event is generated, but no notification is sent until the more serious problem event is resolved or closed.

CAUTION:
Changes to hardware, such as removing drives, do not prompt you to save, either by means of messages or warning events. Therefore, it is important to save the configuration image after a hardware configuration change.

Saving a Remote Restore Image

Use the Save command to save a library configuration restore image on a remote file system. To make sure that the image captures all library configuration changes, save the image often.
To save a remote restore image:

1. Log on as an administrator from the remote client. The Save command is not available from the library OCP.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Save/Restore.
   The Save and Restore Library Configuration dialog box appears.
   
   ![Save and Restore Library Configuration dialog box]

   4. Click Save.
   5. Using the file chooser dialog box, specify a path to a directory on your remote file system in which to save the restore image. You only need to specify the path because the MCB determines the image file name.
   6. To proceed, click Open.
      The library prompts you to decide whether you want to write over the current rescue image that is stored locally on the library.
   7. Click Yes.
      The rescue image timestamp that appears on the Save and Restore Library Configuration dialog box will be updated to indicate that the file has changed.
      If no rescue image exists, the library prompts you to decide if you want to generate one.
      If the save operation succeeds, a message appears that indicates the name of the image file that was saved to the remote file system. If the save operation does not succeed, a message appears that describes the error that occurred.

Saving a Local Rescue Image

Use the Save Rescue command to save a library configuration rescue image locally on the library file system. To make sure that the image captures all library configuration changes, you should save the image often.

To save a local rescue image:

1. Log on as an administrator from the remote client or from the library OCP.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Save/Restore.
4. Click Save Rescue.
   The save rescue operation starts.
   If the save rescue image operation succeeds, a message appears that indicates that the rescue image file was saved to the library file system. The rescue image timestamp displayed on the Save and Restore Library Configuration dialog box will be updated to indicate that the file has changed.
If the save rescue operation does not succeed, a message appears that describes the error that occurred.

Restoring Library Configuration

Use the **Restore** command to restore a library using a configuration image that is saved on a remote file system.

If library configuration has occurred since the last time the image was saved, those changes will be lost when the older configuration is restored. The restore operation will succeed, but you will then need to reconfigure the library, including the partitions and mappings. Therefore, it is important to save the local rescue and/or remote restore image periodically, especially following hardware configuration changes.

⚠️ **CAUTION:**

Be cautious if you plan to use a saved library configuration image that is out of date. You might restore configuration information that you do not want, such as former passwords, partitions, mappings, and hardware configurations.

To restore library configuration:

1. Log on as an administrator from the remote client. The **Restore** command is not available from the library OCP.
2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Tools > Save/Restore**. The **Save and Restore Library Configuration** dialog box appears.
4. Click **Restore**.

_planes:

- If the library is not offline, you receive a message that asks you whether you want to take it offline. Click **Yes**.
5. Using the file chooser dialog box, locate the restore image file on the remote file system.
6. When you have located the file and are ready to proceed, click **Open**.
NOTE:
Because the management control blade (MCB) determines the name of the restore image file, you might not know the file name when you are searching for it on the remote file system. The file name always includes the library serial number, date stamp, and time stamp, in that order and separated by underscores.
An example file name might look like this:
213100020_2004-02-18_13.23.47.tar.gz
The serial number encoded in the image file must match the library serial number. A serial number mismatch will result in a message and the operation will not continue.

When image file compatibility has been established, the library reboots itself and continues with restoring the configuration. The reset operation could take minutes to complete. If you are near the library and can see the library OCP, normal behavior is when two working messages appear and the OCP goes dark when the LMC server restarts. From the remote client, a message appears that indicates that the LMC server is reconnecting to the client. After it reconnects, the LMC server performs a discovery.
If the restore operation succeeds, a message appears that indicates that the operation succeeded. If the restore operation fails at any point, the library generates an event that contains details about the failure. Perform a revert or rescue operation to return the library to a stable configuration.

7. After the restore operation has completed on the library, close and restart the remote client.
8. If you have not done so already, make sure that the robotics are enabled and bring the library back online so that data input and output can continue.

Rescuing Library Configuration

Use the Rescue command to restore a library using the configuration rescue image that is saved locally on the library file system.

△ CAUTION:
Be cautious if you plan to use a saved library configuration image that is out of date. You might restore configuration information that you do not want, such as former passwords, partitions, mappings, and hardware configurations.

If library configuration has occurred since the last time the image was saved, those changes will be lost when the older configuration is restored. The restore operation will succeed, but you will then need to reconfigure the library, including the partitions and mappings. Therefore, it is important to save the local rescue and/or remote restore image periodically, especially following hardware configuration changes.

To rescue library configuration:
1. Log on as an administrator from the remote client. The Restore command is not available from the library OCP.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Save/Restore.
The Save and Restore Library Configuration dialog box appears.
4. Click Rescue.

**NOTE:**
If the library is not offline, you receive a message that asks you whether you want to take it offline. Click Yes.

5. At the prompt, make sure that all data input and output has stopped. Click Yes to continue. When the system determines that it can reconfigure the library using the saved image, a message dialog box appears that informs you that the library will reboot itself. The reset could take minutes to complete. If you are near the library and can see the library OCP, normal behavior is when two working messages appear and the OCP goes dark when the LMC server restarts. From the remote client, a message appears that indicates that the LMC server is reconnecting to the client. After it reconnects, the LMC server performs a discovery. As the MCB reboots, the MCB, LMC server, and robotics control unit (RCU) change to the configuration settings stored in the rescue image. When the LMC has restarted, reconnected, and completed its discovery operation, a message appears that indicates that the library has been restored to its previous configuration. If the operation succeeds, a message appears that indicates that the operation completed successfully. If the operation fails at any point, the library generates an event that contains details about the failure. Perform a revert or rescue operation to return the library to a stable configuration.

6. If you have not already done so, make sure that the robotics are enabled and bring the library back online so that data input and output can recommence.

Reverting Library Configuration

In the event that either a restore or rescue operation fails before completion and the library becomes unstable, the Revert command provides a way to roll back any library configuration changes that might have occurred during the operation. The Revert command is unavailable if no revert image is saved. On a new library, no revert image exists until a restore or rescue operation is attempted for the first time.

**CAUTION:**
As a result of restore, rescue, or revert operations, the library shuts down. You must have physical access to the library to bring the library back up. If you are performing a restore, rescue, or revert operation using remote access, the library will remain shut down until the library is directly powered back on.
To revert library configuration:

1. Log on as an administrator from the remote client or from the library OCP.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Save/Restore.
   The Save and Restore Library Configuration dialog box appears.
4. Click Revert.

**NOTE:**
If the library is not offline, you receive a message that asks you whether you want to take it offline. Click Yes.

5. At the prompt, check whether all library data input and output has stopped. To continue, click Yes.
   When the system determines that it can reconfigure the library using the saved image, a message dialog box appears that informs you that the library will reboot itself. The reset could take minutes to complete. If you are near the library and can see the library OCP, normal behavior is when two working messages appear and the OCP goes dark when the LMC server restarts.
   As the MCB reboots, the MCB, LMC server, and robotics control unit (RCU) change to the configuration settings stored in the rescue image.
   When the LMC has restarted, reconnected, and completed its discovery operation, a message appears that indicates that the library has been restored to its previous configuration.
   If the operation succeeds, a message appears that indicates that the library has been restored to its previous configuration.
   If the operation fails at any point, the library generates an event that contains details about the failure. Perform a revert or rescue to return the library to a stable configuration.
6. If you have not already done so, make sure that the robotics are enabled and bring the library back online so that data input and output can recommence.

**Emailing or Saving the Configuration Record**

Use the Email Configuration Record dialog box to:

- Send the configuration record to a selected e-mail address. See Emailing the Configuration Record.
- Save the configuration record to a specified .txt file. See Saving the Configuration Record.

Before you can e-mail the configuration record, the library e-mail account must be configured. For information on configuring the library e-mail account, see Configuring E-mail.

**NOTE:**
Only users with administrative privileges can e-mail or save the configuration record.

**Emailing the Configuration Record**

To e-mail the configuration record:

1. Log on as an administrator.
2. From the menu bar, click **Monitor > Email Configuration Record**. The **Email Configuration Record** dialog box appears.

3. Click **Email** and select or type in the destination e-mail address.

   **NOTE:**
   You can only specify one e-mail address. If you need to send the configuration record to multiple destinations, repeat this procedure for each e-mail address.

4. Use the **Comment** box to type any additional information you want to include in the e-mail message.

5. Click **OK** to send the configuration record and your comment text to the specified e-mail address and close the **Email Configuration Record** dialog box.

The e-mail message includes both the configuration record information and your comments as embedded text, with **Library Configuration Information** as the subject.

**Saving the Configuration Record**

To save the configuration record:

1. Log on as an administrator.

2. From the menu bar, click **Monitor > Email Configuration Record**. The **Email Configuration Record** dialog box appears.

3. Click **Save**, and use the **Browse** function to specify location for the file, type in the file name, then select the file type (default is .txt).

4. Click **OK** to save the configuration record to the specified location and close the **Email Configuration Record** dialog box.

**Monitoring user status**

The Users Status dialog box displays information about users currently logged onto the library. You can monitor user status while either viewing the physical library or partition. You must log in as an admin user or service user to access the User Status information.

To view user status information:
1. Log on as an administrator.
2. From the View menu or in the Managed Views region of the LMC, click the name of the physical library or appropriate partition.
3. Click Monitor > Users.
   The Users Status dialog box appears, and displays Table 28 for each user logged onto the library.

<table>
<thead>
<tr>
<th>Table 28 User Status Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Role</td>
</tr>
<tr>
<td>Host</td>
</tr>
<tr>
<td>IP</td>
</tr>
<tr>
<td>OS</td>
</tr>
<tr>
<td>OS User</td>
</tr>
</tbody>
</table>

4. To refresh the information displayed in the dialog box, click Refresh.
5. Click Close to exit the Users Status dialog box.

Monitoring Partitions Status

If you want to see settings and information for a partition but do not need to make changes, view partition details. Unlike modifying a partition, viewing details does not require you to take a partition offline.

To monitor partitions status:
1. From the View menu or in the Managed Views section of the LMC, click the name of the physical library.
2. On the menu bar, click Monitor > Partitions.
   The Partitions Status dialog box appears with a list of all logical partitions in the library and information about each partition.
   Table 29 describes the elements on the Partitions Status dialog box.

<table>
<thead>
<tr>
<th>Table 29 Partitions Status Dialog Box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Status</td>
</tr>
<tr>
<td>Media Type</td>
</tr>
<tr>
<td>Interface</td>
</tr>
<tr>
<td># Drives</td>
</tr>
<tr>
<td># Storage Slots</td>
</tr>
<tr>
<td># I/E Slots</td>
</tr>
</tbody>
</table>
### Viewing partition status details

The **Partition Details** dialog box displays status information for partitions on your library.

To view status details about partitions:

1. From the **View** menu or in the Managed Views section of the LMC, click the name of the physical library.
2. On the menu bar, click **Monitor > Partitions**.
3. Click the partition to view in the list, and then click **Details**.
   
   General information about the partition displays, including the partition name, status, serial number, and media type; number of drives, storage slots and I/E slots in the partition; barcode restrictions, return media identifier, autolevel status, drive cleaning status, and the LCP WWPN.

4. Click **Close** to close the **Partition Details** dialog box.
5. Click **Close** to close the **Partitions Status** dialog box.

### Monitoring Key Management

If the library is enrolled with ESKM key management servers, you can view ESKM server and certificate information and e-mail, save, or print it. To do so:

1. Click **Monitor > Key Management** to display the **Enterprise Secure Key Manager Server Information** dialog box.

   The dialog box lists the following information:

   • For each ESKM server, the node address
   • For each ESKM server, the tier number
   • For each ESKM server, the node number
   • For each certificate, the type (Certificate Authority (CA) or Client)
   • For each certificate, the location
   • For each certificate, the serial number
   • For each certificate, the dates during which the certificate is valid
   • For each certificate, the status of the certificate (Valid or Invalid)
   • For each certificate, the certificate issuer and subject

2. To e-mail, save, or print the information:
   a. Click **Send** to display the **Email, Save or Print Table** dialog box.

---

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barcode Restrictions</td>
<td>The current setting for barcode restrictions (Enforce Restrictions, No Restrictions, or Full Restrictions).</td>
</tr>
<tr>
<td>Media Identifier</td>
<td>The current setting for return media identifier (Suffix, Pass Through, Prefix, or Disabled).</td>
</tr>
<tr>
<td>Drive Autolevel</td>
<td>The current setting for drive firmware autoleveling (Enabled or Disabled).</td>
</tr>
<tr>
<td>Auto Drive Clean</td>
<td>The current setting for automatic drive cleaning (Enabled or Disabled).</td>
</tr>
<tr>
<td>LCP WWPN</td>
<td>The world wide port name of the library control path.</td>
</tr>
</tbody>
</table>
b. Select the radio button next to Email, Save, or Print.

c. If you selected Email, type the e-mail address of the recipient into the Email field, or select it from the pull-down menu. Type a message in the Comment field, if appropriate.

d. If you selected Save, indicate the location and file name by one of the following methods:
   • Type the file path and name into the Save field.
   • Browse to the location to save the file, type the correct value in the File Name field, select the appropriate option in the Files of Type field from the pull-down menu, then click Open.

e. Click OK.

3. Click Close to exit the Enterprise Secure Key Manager Server Information dialog box.

Creating Support Tickets

Support tickets are generated when a hardware problem is detected. The ticket provides information that helps diagnose and resolve the problem. When a support ticket is generated, the library collects configuration information and executes a Device Analysis test on the selected device. The information is saved as a *.tgz file containing *.ltd data files for each device in the support ticket. The .tgz file can be e-mailed or saved to a disk.

To configure and save a support ticket:
1. Click Tools > Support Tickets to display the Welcome screen of the Support Ticket Wizard.
2. Click Next.
3. Select the appropriate radio button to indicate whether the report is e-mailed or saved as a file.
   • If you select Email, type in or select from the drop-down list the e-mail address of the recipient.
   • If you select File, type in or browse to the file location then specify the file name.
4. In the Component Selection section of the dialog box, clear and check the boxes to indicate which components will be included in the Support Ticket.
5. Click Next.
6. In the Components Selected area of the Confirmation dialog box, scroll through the list to ensure you have selected the correct components. If any are incorrect, use the Back button and make the appropriate changes.
7. After the component selection is verified, read the Note in the dialog box, select the Continue with Support Ticket generation box, and click Finish.
   The Support Ticket is generated and sent to the specified email address or file location.
8. Click OK in the Support Ticket complete dialog box.

Emailing, Saving, and Printing Status Information

The Send button on each status dialog box enables you to send status information to e-mail addresses. If you are accessing the LMC from a remote client, Send also enables you to save the information to a file or print it. You cannot save or print information from the library OCP. The information that is sent will be the same as what displays in the status dialog box at the time you click Send.
NOTE:
Before you perform the following procedure, make sure that e-mail is appropriately configured in the LMC so that the library can send information to the recipient. See Configuring E-mail.

To mail, save, and print status information:

1. Make sure that the status dialog box displays the status information that you want to send.
2. Click Send.
   The Email, Save or Print Table dialog box appears.

3. Perform one of the following tasks:
   - To indicate that you want to send the information as an e-mail message to a recipient, select Email, and then either type an e-mail address in the Email text box or select an existing address from the drop-down list. If appropriate, type a comment in the Comment text box to send with the information.
   - To save the information, select Save, then either type in the Save text box a path and a file name to which you want the information saved, or click Browse to specify a location and a file name.

   NOTE:
   The Save option is available to remote client users only. It appears grayed out on the OCP.

   - To indicate that you want to send the information to a printer, select Print.

   NOTE:
   The Print option is available to remote client users only. It appears grayed out on the OCP.

4. To send, click OK.
This chapter describes common library maintenance operations.

**NOTE:**
If you are experiencing system problems, check subsystems and components before looking for a service event or contacting technical support. Your service representative might ask you to check these things or, if you are an administrator, you might be asked to run a diagnostic procedure or upload new firmware.

### Configuring and Testing Drives

The **Drives** dialog box enables you to do the following:
- Set speed and connection parameters
- Reset drives
- Cycle power to drives
- Take drives online or offline
- Identify drives
- Run a pass/fail test for LTO-type drives
- Eject tape cartridges from drives
- Send drive logs by e-mail or save them
- Clean drives

### Viewing the Drive dialog box

Drive information on this dialog box is automatically refreshed whenever a drive is added or removed.

To use the **Drive** dialog box:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the **View** menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click **Tools > Drives**.
   The **Drives** dialog box appears.
Table 30 describes the elements on the Drives dialog box.

**Table 30 Drives Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In the Drives area:</td>
<td></td>
</tr>
<tr>
<td>Drive Type drop-down list</td>
<td>Enables you to select the type of drives to list on the Drives dialog box (for example, LTO4 for LTO-4 tape drives). All lists every drive in the library.</td>
</tr>
<tr>
<td>State</td>
<td>The state of the drive (Varied On or Varied Off).</td>
</tr>
<tr>
<td>Drive Type</td>
<td>The type of drive (for example, LTO-5 - FC).</td>
</tr>
<tr>
<td>Location</td>
<td>The location of the drive by means of a coordinate system. For information about location coordinates, see Understanding Location Coordinates.</td>
</tr>
<tr>
<td>Health</td>
<td>The status of the drive as reported by the event system (for example, Good or Failed).</td>
</tr>
<tr>
<td>WWN</td>
<td>Indicates the World Wide Name of the drive.</td>
</tr>
<tr>
<td>Barcode</td>
<td>If a cartridge is loaded in the specified drive, the barcode number of the cartridge.</td>
</tr>
<tr>
<td>Partition Name</td>
<td>The name of the partition to which the drive is assigned.</td>
</tr>
<tr>
<td>Serial #</td>
<td>The serial number of the drive.</td>
</tr>
<tr>
<td>Firmware Version</td>
<td>The drive firmware version.</td>
</tr>
</tbody>
</table>
In the Control area:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Cycle</td>
<td>Cycles power to the specified drive by removing the power and then restoring it. Try to reset drives before you cycle power to them.</td>
</tr>
<tr>
<td>Reset Drive</td>
<td>Resets the specified drive without cycling the power.</td>
</tr>
<tr>
<td>Vary Off or Vary On</td>
<td>Varies off or varies on the specified drive. The label of the button toggles between Vary Off and Vary On. Each use of this button updates the drive information in the Drive(s) area. Use this button to hot swap drives.</td>
</tr>
<tr>
<td>Identify</td>
<td>Causes a status LED on the back of the specified drive to blink rapidly so that you can identify it. When you click Identify, a message appears that informs you that you can now identify the drive by the rapidly blinking LED on the back of it. After you find the drive, click OK to stop the rapid blinking.</td>
</tr>
<tr>
<td>Self Test</td>
<td>Runs a pass/fail test on the specified drive.</td>
</tr>
<tr>
<td>Eject</td>
<td>Ejects any currently loaded tape from the specified drive.</td>
</tr>
<tr>
<td>Support Ticket</td>
<td>Enables you to e-mail or save a Support Ticket (see Emailing, Saving, and Printing Test Logs).</td>
</tr>
<tr>
<td>Clean</td>
<td>Enables the drive cleaning process (see Cleaning a Drive).</td>
</tr>
<tr>
<td>Details</td>
<td>Displays the Drive Details dialog box for the selected drive. See Viewing Drive Details for more information.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Closes the dialog box.</td>
</tr>
<tr>
<td>Help</td>
<td>Displays context-specific Online Help.</td>
</tr>
</tbody>
</table>

4. In the Drive(s) area, click the appropriate drive row to highlight it.
5. Perform operations in the Control area of the Drives dialog box.

Viewing Drive Details

To view drive details:

1. On the Drives dialog box in the Drive(s) area, click the appropriate drive row to highlight it.
2. Click Details.
   The Drive Details dialog box appears.
   The Drive Details region of the Drive Details dialog box displays detailed information about the selected drive.
   Table 31 describes the elements that appear in this region. For descriptions of elements in the Control area, see Configuring and Testing Drives.

Table 31 Drive Details Dialog Box

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drive Model</td>
<td>The brand name of the drive model.</td>
</tr>
<tr>
<td>Vendor</td>
<td>The drive vendor.</td>
</tr>
<tr>
<td>Firmware Level</td>
<td>The firmware version that is currently installed on the drive.</td>
</tr>
<tr>
<td><strong>Element</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Physical SN</td>
<td>The serial number of the drive.</td>
</tr>
</tbody>
</table>
| Logical SN          | The logical serial number that the library assigns to a drive in a specific location. This is not the serial number of the particular drive (see Physical SN in this table).  
If a drive is replaced by another drive in the same library location, the logical serial number remains the same. From the host's perspective, the replacement drive is the same as the original one.  
If the logical serial number addressing feature is disabled for the library, Disabled appears in this field. |
| Location            | The location of the drive by means of a coordinate system. For information about location coordinates, see Understanding Location Coordinates.                                                                         |
| Drive Type          | The type of drive (for example, LTO-4 for LTO-4 tape drives).                                                                                                                                                     |
| Interface Type      | The type of interface (FC).                                                                                                                                                                                       |
| WWN                 | The World Wide Name of the drive.                                                                                                                                                                                 |
| Assigned LUN        | The assigned logical unit number.                                                                                                                                                                                 |
| Online Status       | The status of the drive (Varied On or Varied Off).                                                                                                                                                                |
| Drive Error Code    | If the drive currently has no errors, No Error appears in this field. If the library is unable to acquire a drive error code, such as when the robotics are disabled, Unavailable appears in this field.                      |
| Health Status       | The status of the drive as reported by the event system (for example, Good or Failed).                                                                                                                               |
| Fibre Channel Loop ID | For Fibre drives only, the loop ID assigned to the drive.                                                                                                                                                           |
| Fibre Channel Loop ID Mode | For Fibre drives only, the way in which the loop ID is assigned to the drive (Hard or Soft).                                                                                                                        |
| Number of Loads     | The number of loads during the drive history in this library.                                                                                                                                                       |
| Read Errors         | The number of read errors that have occurred during the drive history in this library.                                                                                                                                |
| Write Errors        | The number of write errors that have occurred during the drive history in this library.                                                                                                                               |
| Megabytes Read      | The amount of data in megabytes that the drive has read during its history in this library.                                                                                                                         |
| Megabytes Written   | The amount of data in megabytes that the drive has written during its history in this library.                                                                                                                        |

3. To return to the Drives dialog box, click Cancel.

**Emailing and Saving Support Tickets**

To mail and save drive logs:

1. From the Drives dialog box, click Support Ticket.
The Email or Save Support Ticket dialog box appears.

2. Perform one of the following tasks:
   - To send the Support Ticket as an e-mail message to a recipient, select Email, and then either type an e-mail address in the Email text box or select an existing address from the drop-down list. Type a comment in the Comment text box to send with the log.
   - To save the Support Ticket, select Save, and then either type in the Save text box a path and a file name to which you want the information saved, or click Browse to specify a location and a file name.

NOTE:
The Save option is available to remote client users only. It appears grayed out on the OCP.

Cleaning a Drive

Use the Drives dialog box to manually initiate a drive cleaning operation. When cleaning a drive, use cleaning media inserted in the I/E station or media in an assigned cleaning magazine.

NOTE:
If the host application coordinates drive cleaning, or if automatic drive cleaning is enabled for the partition, you do not need to manually initiate a drive cleaning operation to perform routine cleaning tasks. In these cases, routine cleaning is handled by the host application or the library, and you should manually initiate a drive cleaning operation only as part of a troubleshooting procedure.

Before you manually initiate a drive cleaning operation, add cleaning media to the library.

There are two ways to add cleaning media to the library:
- Insert cleaning media into the I/E station and close the I/E station door.
- Configure drive cleaning by assigning cleaning magazines and importing cleaning media. (See Configuring Drive Cleaning.)

After adding cleaning media to the library, manually initiate a drive cleaning operation:

1. On the menu bar, click Tools > Drives to display the Drives dialog box.
2. Click a drive in the list, and then click Clean.
   The Clean Drive dialog box appears.
3. Under Cleaning Source, click an option:
   • To use cleaning media inserted in the I/E station, click Use Media in I/E Station, and then click to select a piece of cleaning media in the list.
   • To use cleaning media in an assigned cleaning magazine, click Use Media in Cleaning Slots.

4. Click OK.
   The drive cleaning operation is initiated, and the Clean Drive dialog box closes. Once the cleaning operation completes, the cleaning media is returned to the I/E station or assigned cleaning magazine.

**NOTE:**
The system does not display a message when the cleaning operation is completed.

---

**Saving a Report Template**

To generate a Drive Resource Utilization Report, a template is required. Loading the template recalls saved report criteria and lets you quickly generate a report based on the saved criteria.

1. On the menu bar, click **Tools > Reports > Events**.
   The Event Report dialog box appears.


3. Under Templates, click Save.
NOTE:
The Save button appears grayed-out until a change is made in the Specify Report Criteria region of the dialog box.

4. Type a name for the template, and then click OK.
The template appears in the list under Templates.

5. To load the saved report criteria at a later time, click the template in the list, and then click View to generate the report.

6. To close the Report Criteria dialog box, click Cancel.

Viewing the Drive Resource Utilization Reports

The Drive Resource Utilization Reporting (DRUR) feature enables you to view and manage your tape drive resources. The data provided through DRUR can help you determine the proper work load distribution between the drives in your library. DRUR provides you with up to twelve months of historical data for each SN drive installed, and includes MB read and written, mounts, and media motion time.

NOTE:
The DRUR feature requires a license key to use. For more information, see Generating the Events Report.

You can view the DRUR data in summary reports and graphs, which you can then export from the library into a PDF document. You also can export and save the data as comma delimited text files (.csv). A .csv file is a plain text file that stores basic database-style information in a simple format, with one record on each line, and each field within that record separated by a comma.

DRUR data is based on the actual drive serial number (SN), not the logical drive serial number. The data tracked and reported through the DRUR feature is data that has been accumulated while the drive SN has been installed in the library.

NOTE:
You can e-mail, save, or print reports from a remote client. However, you cannot save or print reports from the library OCP.

To create drive utilization reports:

1. Log on as administrator.

2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.

3. Ensure that the correct report template exists. See Saving a Report Template.

4. Click Tools > Reports > Events.
The Events Report dialog box appears.

5. If there is a template saved for this report, select it from the Templates field, then continue to 8 of this procedure.

6. If there is not a corresponding template saved, on the Report Criteria dialog box, use the following criteria filters to view and export specific data:
• Range
  • Historical
  • Current Month
  • Last Month
  • Last 3 Months
  • Last 6 Months
  • Last 12 months
  • Last 30 days
  • Last 7 days
• Grouping
  • Subsystem
  • FRU category (field replaceable unit)
  • FRU Id
  • Serial Number
  • Selected Drive by Physical SN (based on an individual physical drive serial number)
• Attribute
  • All
  • Total (read and write)
• Type
  • Rollup: A device X-axis for the display of attributes by drive or library.
  • Trend: A time scale X-axis for the display of the trend of the particular attribute.

7. Choose from the following charts to visually display your data:
  • Area
  • Bar
  • Bar 3D
  • Line
  • Stacked Area
  • Stacked Bar
  • Stacked Bar 3D
  • Pie
  • Pie 3D

8. To directly e-mail or save the data:
   a. Click Export.
      • To export data, in the Export Raw Data dialog box, select E-mail to send the data in .csv file format.
      • To save the data, select Save. In the Save text box, type the path and file name, or click Browse to select a save location.
   b. Click OK.

9. To view a report according to the criteria selected, click View.
   The report appears graphically according to the type of chart selected.

10. To preview the report for printing or saving as a PDF, click Preview.
11. To view all pages of the report, click the **Next** and **Back** icons on the toolbar at the top of the window.

12. Use the **Zoom In** and **Zoom Out** icons on the toolbar, if appropriate.

13. To save the report as an Adobe® Portable Document Format (PDF) file:
   a. Click the **Adobe PDF** icon on the toolbar.
   b. In the **Saving Report into a PDF-File** dialog box, enter the appropriate information.
   c. Click **Confirm** to convert the report into a PDF file.

14. To print the report:
   a. Click the **Print** icon on the toolbar.
   b. Select the printer and other settings.
   c. Click **OK** to send the report to the printer.

15. Click the **Close** icon on the toolbar to exit the Print Preview dialog box.

16. Click **Close** to exit the Report Viewer dialog box.
Teaching the Library (Configuration and Calibration)

The Teach command enables you to update the stored library configuration and calibration information. Use this command after you replace a library component or whenever you need to assess the position and alignment of library components or the physical library configuration (such as the number of modules and I/E stations, the locations of storage magazines and drives, and the types of media used in the library).

You can configure the library to automatically perform the full teach routine (configuration and calibration) whenever the library power is cycled. For more information, see Running Configuration Teach.

Running Configuration Teach

Starting the configuration teach process causes the library to assess its contents, gathering information as follows:

- Number of modules
- Types of media
- Storage magazine locations
- Number of I/E stations and magazine type
- Types of drives
- Drive locations

If you change the physical library configuration in any of these areas, you should initiate the configuration teach process (for example, when you add or remove storage or remove storage to add another component). The library will automatically perform a configuration teach, calibration teach, and inventory when an expansion module is added.

NOTE:
The library automatically performs an inventory after it completes the configuration teach process.

To run configuration teach:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Library Diagnostics > Teach.

NOTE:
If the physical library is not offline, you receive a message that asks you whether you want to take it offline. Click Yes.

The Teach dialog box appears.
Configure is already selected by default.

4. Click Start.
   During the configuration teach process, the picker moves to each storage magazine, I/E magazine, and drive in the library and stores information about them. Teach results appear in the Results text box when the process completes. If the configuration teach process completes successfully, the Teach dialog box might close automatically.

Running Calibration Teach

Starting the calibration teach process causes the library to assess the position and alignment of various library components through the use of calibration targets. Use this process to avoid cartridge-handling problems caused by rack, drive, or I/E station misalignments.

Rack alignment calibration targets are tabs that are located on two special magazines in each drive-side and door-side storage rack. I/E station targets are small square holes that are located at the top and bottom of the I/E station. Whenever you perform work on the library that could affect the position of rack, drive, or I/E station calibration targets, even slightly, you should initiate the calibration teach process.

NOTE:
When the library reaches 20,000 moves after the last calibration occurred, and if then the library is rebooted or an access door is closed, the library automatically re-calibrates itself.

To run calibration teach:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Library Diagnostics > Teach.

NOTE:
If the physical library is not offline, you receive a message that asks you whether you want to take it offline. Click Yes.

The Teach dialog box appears with Configure selected by default.
4. Select Calibrate.

5. Click Start.

During the calibration teach process, the picker moves to the home position, which is X-Y coordinate position 0,0. Then, for each rack of each module, the picker moves to a magazine at the top and one at the bottom and stores those positions in coordinates relative to the 0,0 position. Teach results appear in the Results area when the process completes. If the calibration teach process completes successfully, the Teach dialog box might close automatically.

**NOTE:**
Use the Physical Library command on the Setup menu to disable or enable automatic inventory after a calibration teach.

---

### Working with Verification Tests

A collection of verification tests are available to assist you or a customer service engineer (CSE) in determining whether the library is properly installed, configured, and operational. Running the tests is an important part of ensuring that the system is working correctly. See Verification Test Functions.

**NOTE:**
Because resolving an issue often involves complex technical procedures, such as removing and replacing FRUs, and because verification tests often require preparation and trained interpretation of results, it is recommended that a CSE perform the tests.

The following types of verification tests are available:
- Installation verification tests
- Partial system tests
- FRU operation tests
- Custom tests

The verification tests provide the following:
- Fully automated tests
- Tests to determine marginality of installation
- Detailed problem analysis
- Full system tests or individual field replaceable unit (FRU) tests
- Logs of installation and configuration tests
- Graphical reports showing passed, marginal, and failed results
To perform these tests, the picker assembly must be ready and functional, and the library must be powered on. In addition, the library must be in an offline state, and at least one scratch tape must be inserted in the I/E station.

Verification Test Descriptions

Installation Verification Test

The installation verification test enables you to verify that the library installation and configuration is complete and functioning correctly. The installation verification test runs the following individual tests:

- Library alignment test
- Picker assembly test
- I/E station assembly test
- Get/Put test
- Scanner fiducial test

A smaller library configuration will require about 1 hour. Larger configurations will require as long as 6 hours to run the installation verification test. The time to complete individual tests on an 8-frame configuration is approximately:

- Library alignment test - 30 minutes
- Picker assembly test - 1 minute
- I/E station assembly test - 5 minutes for each 24 slot I/E station
- Get/Put test - 120 minutes
- Scanner fiducial test - 75 minutes

Partial System Tests

The partial system tests perform the selected sub-tests to test an area or range of the library configuration. The selectable tests include:

- Frame test - This test includes the same individual tests as the installation verification test, but enables you to specify a range of modules rather than testing all modules.
- Configuration test - This test includes the picker assembly and scanner fiducial tests.

Both tests enable you to select a range of modules and racks to test. For example, if you have a 4-module library, you can select to test only modules 3 and 4. The frame test performs the same operations as the installation verification test, except there are frame and rack range parameters available.

FRU Operational Tests

The FRU operational tests enable you to verify the replacement of a FRU. When the FRU test is selected, you can select any of the following individual tests:

- Accessor assembly
- Picker assembly
- Drive sled assembly
- I/E assembly
- Scan barcode
When one of the sub-tests is selected, you may be prompted to enter additional information.

**Custom Library Alignment Tests**

The custom tests enable you to run a sub-test that is normally part of the larger tests that call multiple sub-tests (including Installation and Partial).

See *Verification Test Functions* for more specific information about each sub-test.

**Verification Test Functions**

Use the *Verification Tests* dialog box to run tests and view results. Figure 20 shows the parts of the *Verification Tests* dialog box. To display the dialog box, click **Tools > Library Diagnostics > Verification Tests**.

![Figure 20 Verification Tests Dialog Box](image)

**Library Alignment Test**

The library alignment test performs the following tasks:

- Performs accessor X-axis and Y-axis travel test (also calls the FRU accessor assembly test)
Calibrates library and checks calibration offsets by comparing them to the default values for the drives and I/E stations
- Checks magazine offsets
- Checks collected offset alignments for magazines, I/E stations, and drive sleds
- Checks joint alignment quality

Get/Put Test

The library alignment test performs the following tasks:
- Performs a Get/Put of a scratch tape in the top and bottom slots of each magazine that supports the scratch tape media
- Performs a Get/Put of existing media if no scratch tape is found or if the top or bottom is occupied
- Moves a scratch tape to one row in each frame to test cross-frame alignment
- Uses a scratch tape to perform a Get/Put in each compatible drive

Accessor Assembly Test

The accessor assembly test performs the following tasks:
- Checks for the module terminator (the terminator on the LBX board in the last expansion module)
- Checks the joint alignment (makes sure all the joints on the X-axis are flush)
- Performs two passes around the library to ensure that the X-axis and Y-axis encoders are reading correctly and the belts are not slipping
- Tests the calibration sensor
- Checks the alignment of the accessor to the control module

Picker Assembly Test

The picker assembly test performs the following tasks:
- Performs pivot left and right check
- Performs reach and retract five times
- If the LMC gets its side done, performs a Get/Put of the selected cell
- Scans the control module serial number to make sure the scanner is reading properly

Drive Sled Assembly Test

The drive sled assembly test performs the following tasks:
- Calibrates the drive sled
- Checks the quality of the sled fiducial
- Performs Get/Put to the drive

Scan Barcode Test

The scan barcode test performs the following tasks:
- Moves to selected cell coordinate and scans the barcode label
- Checks to ensure the label reads the same from top to bottom
- Verifies the quality of the barcode labels and checks to make sure barcode labels are in a readable position
I/E Station Assembly Test

The I/E station assembly test performs the following tasks:

• Locks and unlocks the I/E station
• Calibrates the I/E station and check offsets collected
• Checks each magazine fiducial in the I/E station
• Performs Get/Put tests on all the I/E station cells

Scanner Fiducial Test

The scanner fiducial test performs the following tasks:

• Scans and checks each magazine fiducial
• Scans and checks each drive sled fiducial
• Tests the calibration sensor
• Calibrates and checks repeatability, up to three times for marginal and failed calibration targets

Initiating Verification Tests

This section provides instructions for running the installation verification test, partial tests, FRU operational tests, and custom tests. The test results appear after the tests complete.

To stop a test, disable the robotics by pressing the Robotics Enable button on the OCP or by clicking Stop on the Verification Tests dialog box. Control will be returned to you as soon as the current command is completed.

The different reports (Library Report, Drive Report, and Blade Report) are generated and viewed in the Reports area of the Verification Tests dialog box.

If a typical user logs on while an administrator is logged on and running a verification test, testing will continue unaffected. Only one administrator can be logged on at any given time.

Running the Installation Verification Test

When the installation verification test is running, no one else can log on to the library. The message Verification Test is Running appears in the Activity area of the main LMC display.

To run the installation verification test:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
   The Verification Tests dialog box appears.
4. From the Select Test drop-down list, click Install.
5. Click Start.
6. If prompted to take the library offline, click Yes.
   The IVT Pre-Test Questionnaire appears.
7. Complete the pre-test questionnaire by clicking inside the box next to the questions. You cannot continue with the installation verification test until you have completed and verified the question requests on this questionnaire.

NOTE: Make sure you physically verify each of the questions on the questionnaire. Each of the items listed can cause the installation verification test to have unexpected behavior and unreliable results. The tests must be re-run if they fail.

8. After you complete the questionnaire, click Next.

An Attention dialog box appears, instructing you to insert a scratch cartridge in the I/E station.

9. Insert a scratch cartridge into the I/E station, then click Next.
NOTE:
Make sure that the scratch tapes are formatted and contain no data that cannot be overwritten. Scratch tapes must have barcode labels with valid volume serial numbers on them. Also, you might find it useful to write down the serial numbers so that you can identify your scratch tapes. This procedure will not damage any cartridges that are already installed in the library. If the scratch cartridge becomes lodged in a drive or magazine, it must be manually removed from the library. If not removed, the cartridge will become part of the partition the next time the accessor assembly is enabled.

The I/E station will be locked until the inventory is complete.

10. Select a scratch cartridge of each media type (for example, LTO-4 and LTO-5) in the library.

NOTE:
You can select one scratch cartridge per media type. Each test that requires a scratch cartridge will call the media types as needed.

11. After you select the cartridges, click Finish. As the tests run, the library will generate events if problems are discovered. You must close the Verification Tests dialog box to view those events. Return to the Verification Tests dialog box to view test results.

12. After the test is complete, click Reports to view the test results.

   The report window appears with the Graphical tab displayed.
   • Use the Graphical tab to view graphical reports and to quickly identify areas where marginal or failed results occurred.
   • Use the toolbar to navigate between graphical reports or to save the results in PDF format.
      For more information about how to work with graphical reports, see Verification Test Graphical Reports.

13. For more detailed test results, click the Text tab to view the test log generated by the LMC.

14. Review the test log to find marginal or failed test results, and to see troubleshooting information. For information about how to interpret test logs, see Verification Test Logs.

15. To e-mail, print, or save the test log as a text file, in the Tools region of the Text view click Send, then specify the output location. For more information, see Emailing, Saving, and Printing Test Logs.
16. To see the results for a previous test, click to select the test name in the Test Results region of the dialog box, then click Reports. The LMC saves the most recent five test results.

17. When you are finished working with the test results, click Close to close the result window.

18. If you are finished performing verification tests, click Close to close the Verification Tests dialog box.

Partial Tests

To perform partial tests:

1. Log on as an administrator.

2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.

   The Verification Tests dialog box appears.

4. From the Select Test drop-down list, click Partial.
5. From the Select Sub-test drop-down list, click either Frame or Configuration or both. A check mark indicates the test is selected.

6. Click Start.

7. If prompted to take the library offline, click Yes. An Attention dialog box appears.

8. Select either Continue With Scratch Tapes or Continue Without Scratch Tapes, and then click Next.

9. If you selected Continue With Scratch Tapes:
   a. If there is no scratch cartridge in the I/E station, insert one now, then click Next.

   NOTE:
   Make sure that scratch tapes are formatted and contain no data that cannot be overwritten. Scratch tapes must have barcode labels with valid volume serial numbers on them. Also, you might find it useful to write down the serial number so that you can identify your scratch tapes.

   This procedure will not damage any cartridges that are already installed in the library. If the scratch cartridge becomes lodged in a drive or magazine, it must be manually removed from the library. If not removed, the cartridge will become part of the partition the next time the accessor assembly is enabled.

   The I/E station will be locked until the inventory is complete.

   b. To shorten the list of cartridges in Selected Tapes in I/E Stations, use the Media Barcode Filter.

   c. Click to select a scratch cartridge of each media type listed in the Selected Tapes in I/E Stations dialog box, then click Next.

   NOTE:
   Select one scratch cartridge per media type. Each test that requires a scratch cartridge will call the media types as needed.

10. Make the appropriate selections in the Frame Text and/or Configuration Test regions of the Attention dialog box, then click Finish. (The regions appear based on what type of test you selected earlier. The following example shows both the frame and configuration tests because both were selected.)
FRU Operational Tests

There are two ways to run the FRU operational tests. You can select the FRU test from the Verification Tests dialog box, or if that FRU is supported by the verification tests you can run the test from the Events dialog box. This section explains both procedures.

The screens displayed by the FRU operational tests vary, depending on which sub-test is selected. For example, if you click Picker Assembly, I/E Assembly, or Drive Sled Assembly, then click Start, the Select Scratch Tapes dialog box appears.

To run FRU operational tests from the Verification Tests dialog box:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
   The Verification Tests dialog box appears.
   FRU tests are available for the Accessor Assembly, Picker Assembly, Drive Sled Assembly, I/E Assembly, and Scan Barcode. You can only test one FRU at a time.
   The following steps provide instructions for running the Scan Barcode test. The other tests provide similar windows and functionality for the other FRUs.
4. From the Select Test drop-down list, click FRU.
5. From the Select Sub-test drop-down list, click Scan Barcode.
6. Click Start.
7. If prompted to take the library offline, click Yes.
   The Attention Select an Element dialog box appears.
This dialog box enables you to enter any coordinate address in the library (aisle, module, rack, section, column, and row). The address does not need to be occupied by a drive or cartridge.

8. Click Finish.

Test progress is shown in the Verification Tests dialog box in the Test Results region of the screen.

9. After the test is complete, click Reports to view the test results.
For more information about how to work with graphical reports, see Verification Test Graphical Reports.

For information about how to interpret test logs, see Verification Test Logs.

For information about how to e-mail, print, or save text logs, see Emailing, Saving, and Printing Test Logs.

To run FRU operational tests from the Events dialog box:

1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Event Viewer.
4. From the Events dialog box, click the categories of the event logs you want to view in the Select State, Select Severity, and Select Sub-system regions of the dialog box.

5. Click OK to display the events, if any, in the Event List dialog box.
6. Click an event to display in the Select Event region of the dialog box, and then click Details.
7. From the Event Details dialog box, click FRU Test to display the Verification Test dialog box.
8. After the FRU test successfully verifies that the FRU has PASSED or is MARGINAL, all events associated with the failure are transitioned to the Verify state.

Running custom tests

The custom tests allow you to run a sub-test that is normally part of the larger tests that call multiple sub-tests—such as Installation or Partial.

To run custom tests:

1. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.


   The Verification Tests dialog box appears.

3. From the Select Test drop-down list, click Custom.

   The Select Sub-test field defaults to the Library Alignment sub-test and cannot be changed.

4. Click Start.

5. If prompted to take the library offline, click Yes.

   The Attention dialog box appears.

6. Select the number of the module and racks where you want to perform the tests.
7. Click **Finish**.
   
The test progress appears in the **Verification Tests** dialog box.

8. After the test is complete, the test name and results summary displays in the Test Results region of the dialog box. Click **Reports** to view detailed test results.

**Understanding the Verification Test Inventory**

The verification tests generate inventory lists that provide specific information about the library configurations. Inventory lists for the library, drives, and blades are available. On the **Verification Test** dialog box, select the type of inventory list that you want to see (**Library**, **Drive**, or **Blade**).

The results of all sub-tests are displayed on the **Verification Tests** dialog box after each individual test is completed. To understand the results, see **Test Results**.

**Library Inventory**

This inventory list provides the following statistical information:

- Library Serial Number
- Library Firmware Version
- Library WWN Base
- Power Supply Count
- IEX Count
- LSC Count
- Frame Count
- CMB Count (Control Management Blade)
- EEB Count
- MCB Count (Management Control Blade)
- LMD Count
- LGR Count
  
  For each EEB: EEB App Fwr Version, EEB Serial Number, and EEB Location
  
  For each LMD: LMD Serial Number
  
  For each Frame: Frame Serial Number and Frame Location (for example “in Module 1”)
  
  For each power supply: Power Supply Serial Number and Power Supply Location
  
  For each CMB: CMB App Fwr Version, CMB Boot Fwr Version, CMB Pip Fwr Version, CMB Serial Number, and CMB Location
  
  For each MCB: MCB App Fwr Version, MCB Boot Fwr Version, MCB Pip Fwr Version, MCB Serial Number, and MCB Location
  
  LGR Serial Number
  
  LSC Serial Number
  
  Number of Cartridges
  
  Number of I/E Stations
  
  Number of Frames
  
  Number of Drives
  
  Number of Aisles
  
  Storage Magazine Count
• IP Magazine Count
• For each type of drive: Drive Count

Drive Inventory

This inventory list provides the following information about each drive:

• Drive Type
• Interface (FIBRE)
• Physical SN
• Logical SN
• FW Version
• Sled SN
• Sled App Version
• Sled Boot FW

Test Results

The results of all sub-tests appear on the Verification Tests dialog box after each individual test is completed. See Table 32 for an explanation of test results.

Table 32 Test Results

<table>
<thead>
<tr>
<th>Test Results</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>PASSED</td>
<td>Completed the test without reported errors.</td>
</tr>
<tr>
<td>MARGINAL</td>
<td>Completed the test, but the system had to retry or had to skip part of the test. A MARGINAL result is considered PASSED, but the log should be checked to see if the marginality can be corrected.</td>
</tr>
<tr>
<td>FAILED</td>
<td>An error has been found and needs to be corrected. A fatal error, or an error that causes a part of the system to become disabled, will halt the test.</td>
</tr>
<tr>
<td>INCOMPLETE</td>
<td>This portion of a test was incomplete due to an interruption or a portion of the test was run (for example, no scratch tape was used so must only use existing tapes). An incomplete will occur when the door is opened, an abort command is issued, or when the Robotics Enable button is pressed.</td>
</tr>
<tr>
<td>SKIPPED</td>
<td>This portion of the test was skipped. The cause is that either a scratch tape was not present or the library was not configured for the test.</td>
</tr>
<tr>
<td>WARNING</td>
<td>A warning is additional information about the test that the user should know. For example, if a calibration failed, but the stored offsets are analyzed, a warning should be posted that states that the offset check might not be accurate.</td>
</tr>
<tr>
<td>STOPPED</td>
<td>The test was interrupted. The log will show the result to provide a record of test interruption.</td>
</tr>
</tbody>
</table>
NOTE:
A single problem in the library can cause failed results in multiple tests. After taking action to correct a failed result, run tests that yielded marginal or failed results again.

Verification Test Graphical Reports

Some verification tests produce graphical reports that let you easily see if the test generated PASSED, MARGINAL, or FAILED results. Each result is shown in a different color:

- P - passed (green)
- M - marginal (yellow)
- F - failed (red)

There are 8 types of graphical reports. Each individual test generates 2 or more graphical reports (except for the scan barcode test, which does not generate graphical reports). The following sections show an example of each type of graphical report and actions to take to correct a marginal or failed result.

To view the graphical reports for a test, click Reports on the Verification Tests dialog box.

Joint Alignments

The joint alignment graphical report shows the results for tests of alignment between frames. It also shows the results for tests of accessor travel to all corners of the library.

- If the graphical report shows one or more failed results for joint alignment, realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.
- If all the joints passed testing but accessor movement failed, manually move the accessor down the aisle in each direction to locate any places where motion of the accessor is not smooth or is restricted. Then realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.

Vertical Alignments

The vertical alignments graphical report shows the results for test of vertical alignment of tape magazines on the drive-side and door-side of each frame, and for vertical alignment of each I/E station.

- If the graphical report shows a failed result for the drive-side or door-side, make sure that all tape magazines are installed properly on that side and that the calibration targets are correctly snapped on to the magazines.
- If the graphical report shows a failed result for the I/E station, make sure the I/E station and front door are completely shut.
- If running the test again still generates failed results, realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.

Horizontal Alignments

The horizontal alignments graphical report shows the results for tests of horizontal alignment of tape magazines on the drive-side and door-side across frames, and for horizontal alignment of I/E stations across frames.
This graphical report is not generated for libraries with only one frame.

- If the graphical report shows a failed result for the drive-side or door-side, make sure that all tape magazines are installed properly on that side and that the calibration targets are correctly snapped on to the magazines.
- If the graphical report shows a failed result for the I/E station, make sure the I/E station and front door are completely shut.
- If running the test again still generates failed results, realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.

**Calibration Offsets**

The calibration offsets graphical report shows the results for tests of tape magazine, drive sled, and I/E station offsets compared to predefined tolerances. Reports are generated for drive-side and door-side for all frames.

- If the graphical report shows a failed result for one or more tape magazines, make sure the magazines at the location of the failure are installed properly and that the calibration targets are correctly snapped on to the magazines.
- If the graphical report shows a failed result for the I/E station, make sure the I/E station and front door are completely shut.
- If running the test again still generates failed results, realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.

**Boundary/Accessibility**

The boundary/accessibility graphical report shows the results for tests of the accessor while performing Get, Put, and Scan functions for all tape magazines and drive sleds. (This tests whether magazines and sleds are within the maximum allowable movement range of the accessor.)

- If the graphical report shows a failed result for one or more tape magazines, make sure the magazines at the location of the failure are installed properly and that the calibration targets are correctly snapped on to the magazines.
- If the graphical report shows a failed result for the I/E station, make sure the I/E station and front door are completely shut.
- If running the test again still generates failed results, realign the middle X-axis rail and check the alignment of the top and bottom X-axis rails at the location of the failure.

**Get/Put**

The Get/Put graphical report shows the results for tests of the picker assembly while performing one Get and one Put function for each tape magazine. The picker will use the selected scratch tape or the existing tape if it finds one at the target.

- If the graphical report shows a failed result for one or more tape magazines, make sure the magazines at the location of the failure are installed properly.
- If there are multiple marginal results in an area, review the area to make sure it is not prone to problems. Also run the library alignment test (part of the installation verification or partial frame test) to make sure the library is level.
- If there are a large number of issues, use rubbing alcohol to clean the picker fingers and the detents in the side of the tapes.
• If the problems persist, you may need to replace the picker assembly.

Scan Fiducials

The scan fiducials graphical report shows the results for tests of the fiducial barcode on each tape magazine and drive sled, including the width, expected Y position (shift), and the number of hits the scanner receives while traveling up and down. (Only known magazines are tested.)

• If the graphical report shows a failed result for one or more tape magazines, replace the affected magazines.
• If there are multiple marginal or failed results, run the library alignment test (part of the installation verification or partial frame test) to make sure the library is level.
• If the library is level and there are multiple marginal or failed results, the scanner should be inspected and replaced if necessary.

Picker Pivot/Reach

The picker pivot/reach graphical report shows the results for tests of the picker while performing rotation and reach/retract actions.

See Figure 21.

Figure 21 Picker Pivot/Reach Graphical Report
• If the graphical report shows one or more marginal or failed results, inspect the picker. It should rotate easily by hand, and the fingers should spring into a clamped position. Make sure both rotation axis belts are free of debris. Also make sure that the storage is correctly seated in the I/E station and that the I/E station and front door are completely shut.
• If the problems persist, you may need to replace the picker assembly.

Verification Test Logs

Each verification test produces a test log that details all information and results from the individual tests and sub-tests. In addition, the log includes information to help you understand the test results and to help resolve any problems encountered.

To view a test log:

1. Click Reports on the Verification Tests dialog box to display the report window.
2. Select the test to view in the Test Results region of the dialog box. You can view results for the five most recent tests.
3. Click Reports.
   This log file is appended with data as each test finishes. You can repeat the test if any problems are found and fixed. If the Verification Tests dialog box was not closed during the retesting, all results are contained in one log file.
4. Click the Text tab.
5. To save the information that the test generates, click Send.
   If you are using the remote LMC client, you can choose to save the log to your hard drive. If you choose to save directly to your hard drive, the report listing and test log are combined into one text file.

A test log provides the following information:

• The test output is from the library alignment test.
• The test title is always shown between rows of equal signs.
• A brief guide for understanding coordinates and offsets used in the test results is provided near the beginning of the log.
• The X-axis and Y-axis limits applied by this test are shown. MARGINAL output is placed between parentheses, and FAILED output is placed between brackets; for example, (30) and [45].
• The results of the sub-test appear between dashed lines.
• Coordinates are represented as A (aisle), F (frame), R (rack), S (section), C (column), and R (row).
• All location values are in 0.1 mm.
• All results that you should review are identified with four arrows (>>>>) in the column to the left of the detailed results.
• At the end of every test, summary results of every sub-test are given. The overall test result appears between asterisk lines, and a summary of sub-test results follows.
   Figure 22 shows an example of a test log.
To view the graphical reports and text logs:

1. In the **Verification Tests** dialog box, click **Reports**.
   The report window appears with the **Graphical** tab displayed. Use the **Graphical** tab to view graphical reports and to quickly identify areas where marginal or failed results occurred. Use the toolbar to navigate between graphical reports or to save the results in PDF format.

2. For more detailed test results, click the **Text** tab to view the test log generated by the LMC. Review the text log to find marginal or failed test results, and to see troubleshooting information. To e-mail the test log or save it as a text file, click **Send** and then specify the output location.

3. To see the results for a previous test, click **Reports**, and then click a test. The LMC saves the most recent five test results.

4. When you are finished working with the test results, click **Close** to close the result window. If you are finished running verification tests, click **Close** to return to the LMC main menu.

**Figure 22 Example Test Log Output**

To view the graphical reports and text logs:

1. In the **Verification Tests** dialog box, click **Reports**.
   The report window appears with the **Graphical** tab displayed. Use the **Graphical** tab to view graphical reports and to quickly identify areas where marginal or failed results occurred. Use the toolbar to navigate between graphical reports or to save the results in PDF format.

2. For more detailed test results, click the **Text** tab to view the test log generated by the LMC. Review the text log to find marginal or failed test results, and to see troubleshooting information. To e-mail the test log or save it as a text file, click **Send** and then specify the output location.

3. To see the results for a previous test, click **Reports**, and then click a test. The LMC saves the most recent five test results.

4. When you are finished working with the test results, click **Close** to close the result window. If you are finished running verification tests, click **Close** to return to the LMC main menu.
Emailing, Saving, and Printing Test Logs

The Send button on the Text tab on the report window enables you to send a verification test log to e-mail addresses. If you are accessing the LMC from a remote client, Send also enables you to save the log to a file or print it.

**NOTE:**

You can mail, save, or print verification test logs from a remote client. However, you cannot save or print logs from the library OCP.

The information that is sent will be the same as what the Text tab displays at the time that you click Send.

**NOTE:**

Before you perform the following procedure, you must make sure that e-mail is appropriately configured in the LMC so that the library can send logs to the recipient. See Configuring E-mail.

To mail, save, and print test logs:

1. Make sure that the Text tab on the report window displays the log that you want to send.
2. Click Send.

   The Email, Save or Print Table dialog box appears.

3. Perform one of the following tasks:
   - To indicate that you want to send the log as an e-mail message to a recipient, select Email, and then either type an e-mail address in the Email field or select an existing address from the drop-down list. Type a comment in the Comment field to send with the log.
   - To indicate that you want to save the log, select Save, and then either type in the Save field a path and a file name to which you want the log saved, or click Browse to specify a location and a file name.

**NOTE:**

The Save option is available to remote client users only. It appears grayed out on the OCP.
• To indicate that you want to send the log to a printer, select Print.

NOTE:
The Print option is available to remote client users only. It appears grayed out on the OCP.

4. To send, click OK.
5. Click Close to exit the dialog box.

Using the Partitions Defragmentation Tool

Typically, partitions in a library are physically contiguous. That is, all tape slots that belong to a partition are adjacent to one another in the library.

However, if a partition is enlarged, or if an expansion module is added to a library, it is possible that some or all partitions in the library will no longer be physically contiguous. In this case, the slots that belong to a partition are not all adjacent to one other, and the partition is fragmented. Fragmentation can make bulk loading media more difficult.

Defragmenting partitions reassigns slots in the library so that all slots in each partition are physically contiguous with one another. In addition, media is moved as needed to make sure it resides in the correct partition. In the process, tapes are first moved from their old location to the I/E station, and then are moved to their new location in the library.

NOTE:
Only partitions that contain an I/E station can be defragmented. Also, at least one magazine in the I/E station must be empty. Partitions that do not contain an I/E station cannot be defragmented and will be skipped.

Depending on the size of the library, defragmenting partitions can be a time-consuming process.

Defragmenting Partitions

After enlarging a partition or adding an expansion module to the library, check for partition fragmentation, and then defragment partitions if necessary.

To defragment partitions:
1. Log on as an administrator.
2. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
3. Click Tools > Partitions Defragmentation.
   The Partitions Defragmentation dialog box appears. This dialog box shows a graphical representation of the tape magazines in the library. Magazines are color-coded to indicate which partition they belong to.
   If the library has more than one frame, click the >> and << buttons at the bottom of the dialog box to display the next or previous frame. If one or more partitions are fragmented, you can defragment them.
4. To begin defragmenting partitions, click **Start**.
A dialog box appears notifying you that partitions that do not have a free I/E station slot cannot be defragmented and will be skipped.

5. Verify that the I/E station in each partition has at least one free slot, and then click **Yes**.
A dialog box appears notifying you that all partitions must be taken offline before defragmenting can begin.

---

**NOTE:**
If the library is not fragmented, an **Attention** dialog box displays this information. Click **OK** to exit the dialog box.

---

6. Click **Yes** to take all partitions offline.
The partitions defragmentation operation starts. A progress bar at the top of the **Partitions Defragmentation** dialog box displays the percentage complete for the operation.
When defragmenting is complete, a dialog box appears prompting you to take all partitions online.

7. Click Yes to take all partitions online.
8. Click Close to close the Partitions Defragmentation dialog box.

Canceling Defragmentation

Depending on the size of the library, defragmenting partitions can be a time-consuming process. If needed, you can click Close on the Partitions Defragmentation dialog box to cancel the defragmentation operation at any time. When prompted, click Yes to confirm the action.

After you cancel defragmentation, the library finishes moving the current magazine (and any media it contains), then defragmentation stops. If you cancel defragmentation, no tapes will be stranded, and all media will still be assigned to the correct partition. You can resume defragmentation at a later time by clicking Start on the Partitions Defragmentation dialog box.

Recovering After Defragmentation is Interrupted

If a defragmentation operation fails (for example, if a power interruption occurs or the robotics go offline), no tapes will be stranded, and all media will still be assigned to the correct partition.

However, it is possible that some media which was in the process of being moved will remain in the I/E station. In this case, simply import the media into the library. The media will automatically be moved to a magazine in the correct partition. For more information about importing media, see Importing Cartridges Into Partitions.

Cycling Library Power

If library firmware seems to be at fault, or the robot will not move, or a circuit board has gone down, try recycling power to the library. Cycling library power involves shutting down the library, powering it off, and then powering it on. For more information, see Shutting Down/Rebooting the Library.

Using Sift Sort

The Sift Sort Export functionality is to facilitate bulk movement of cartridges from their standard slot locations to either a specific storage area within the library or to the load port elements I/E station (the default setting will be the left upper storage area within the library). The default mode of operation of the SSE will be to put or relocate cartridges in sort order within the library, based on slot # or other logical grouping. This facilitates quickly locating similar cartridge IDs and easier visualization of daily/weekly/monthly tapes (if a barcode nomenclature is implemented).

- Exporting Media via Sift Sort
- Capturing Sift Sort Screen Shot

Exporting Media via Sift Sort

To export media using Sift Sort:

1. Log on as an administrator.
2. Select Tools > Sift Sort > Export.
   The Sift Sort Export dialog box appears.
3. To filter by partition, in the **SSE Source Filter** area, do the following:
   a. Select a **Partition** from the drop down list.
   b. To use an additional filter, in the **Media Filter** field, type the search string, and click **Filter**. For example, to filter all media containing the character 8, type *8*. This field is case sensitive. The appropriate media appears in the **Select SSE Media** section below.

4. Optionally, in the **Barcode File Selection** section, you can filter by using an user-supplied file (that lists barcodes):
   a. Click **Browse** to locate the appropriate file.
   b. Click **Enable File Filter** to instruct the interface to filter out barcodes contained in that file. If the barcodes in that file do not belong to the particular partition selected, those barcodes are highlighted in red in the **Select SSE Media** section and are not selectable.

5. Once you have selected media to sift sort, in the **SSE Starting Slot Destination** area, click **Explorer** to select a coordinate location graphically by clicking on a cell.
6. To relocate a cartridge to the last empty slot of the destination element selected, ensure that the Relocate Full check box is checked.

**NOTE:**
The Relocate Full box is cleared as the default condition.

- When Relocate Full is checked, any tapes in the destination area will be moved to the lowest available element address location in the partition.
- When Relocate Full is not cleared, tapes that exist in the destination area will not be moved (skipped).

7. To clear the criteria selected above, click Reset.

8. In the Select SSE Media region of the dialog box, clear or select the box or boxes to indicate the cartridges to include in the Sift Sort operation. Use the Select All Media box to clear or select all cartridges listed.

9. Click OK.

10. Click Yes in the Warning dialog box to take the partition offline.

    The Control Module screen appears.

    Based on the selections you made on the Sift Sort Export screen, the Control Module screen displays the available storage locations.

11. Click the desired storage location slot for the export function.

    The coordinates and details for that location appear in the Destination area of the SSE Starting Slot Destination region of the dialog box.

12. Click Select.

    The Sift Sort Export screen appears.

Capturing Sift Sort Screen Shot

Use the Capture Report screen to capture a picture of the last sift sort export you performed. The picture can be saved to a file on your local work station or e-mailed to a recipient.

1. Log on as an administrator.


    The Capture Sift Sort Screen Shot screen appears.

3. On the top of the screen, click the circle next to the type of capture you want to perform: BMP, GIF, PNG, or JPEG.

4. Click Capture.

    The Capture Sift Sort Export screen appears.

5. To e-mail the capture:
   a. Click the radio button to select Email.
   b. Either type the e-mail address into the Email field or select one from the drop-down list.
   c. In the Comment section, include a note to the recipient, or any comments about the capture.

6. To save the capture, click Save. Then click Browse to locate the location where you want to save the capture on your computer.

7. Click OK to e-Mail or save the record and exit the dialog box.

8. Click Close to exit the Capture Sift Sort Screen Shot dialog box.
Retrieving, Emailing, and Saving MIB Files

The **Retrieve MIBs** option on the **Tools** menu allows you to retrieve the ESL G3 MIB files, which can be compiled into your SNMP Management tools. After retrieving the MIB files, you can extract the contents for use with a third-party SNMP tool. You can also e-mail or save the MIB file.

To retrieve MIB files:

1. Log on as an administrator.
2. Select **Tools > Reports > Retrieve MIBs**.
   
   The **Retrieve MIBs zip file** dialog box appears.

   ![Retrieve MIBs zip file dialog box](image)

3. To email the MIB:
   
   a. Click the radio button to select **Email**.
   
   b. Either type the e-mail address or select one from the drop-down list.
   
   c. In the **Comment** section, type a note to the recipient or any comments about the capture.

4. To save the MIB File, click the radio button to select **Save**, then click **Browse** to navigate to the location where you want to save the MIB file on your computer.

5. Click **OK** to send or save the file and exit the dialog box.

Maintaining Air Filters

The access door of each control and expansion module has two air filters: one located at the top, and the other located at the bottom, as shown in **Figure 23**.
Figure 23 Top and Bottom Air Filters

Many factors exist that contribute to the need to regularly service the air filters. For example, the total number of tape drives and the operating environment greatly affect the rate at which debris accumulates in the air filters.

With the maximum number of tape drives operating in a normal data center environment, check the filters every two years. If you see dust and debris on the inlet side of the filters, remove the filters and use water and a mild soap to clean them. The materials in the filters should last for the life of the product. However, if abnormal contamination occurs, you should replace them. To order filters, contact your service representative.

To remove and replace either a top or bottom air filter:

1. Locate the required tools:
   - #1 Phillips screwdriver
   - Air filter

2. Take the library offline.
   For information about taking the library offline, see Changing the Library State.

3. On the operator panel, press Robotics Enabled to turn off power to the picker and return it to the home position.
   The power is on to all other components.

4. Open the access door.
   Aisle power is disabled.

5. Use the Phillips screwdriver to unscrew the two captive thumbscrews. The screws remain attached to the retaining bar.
6. Remove the air filter.
7. Use water and a mild soap to clean the air filter.
8. Allow the air filter to dry.

**NOTE:**
Make sure that the air filter is completely dry before placing it back in the access door.

9. Place the filter in the opening.
10. Place the retaining bar over the filter to hold it in place. Use the Phillips screwdriver to tighten the two captive thumbscrews.
11. Close the access door.
12. On the operator panel, press **Robotics Enabled** to enable the picker.
13. Bring the library online. See *Changing the Library State*. 
6 Working with Cartridges and Barcodes

The Library Management Console (LMC) simplifies cartridge loading and unloading, importing and exporting, and moving and inventory operations. The maximum library configuration can accommodate from 102 to 5316 LTO cartridges for the following drive types:

- FC LTO-4
- FC LTO-5

Every partition in the library must contain at least one cleaning cartridge.

Handling Cartridges Properly

To ensure the longest possible life for your cartridges, follow these guidelines:

- Select a visible location to post procedures that describe proper media handling.
- Ensure that anyone who handles cartridges has been properly trained in all procedures.
- Do not drop or strike cartridges. Excessive shock could damage the internal contents of cartridges or the casings themselves, rendering the cartridges unusable.
- Do not expose cartridges to direct sunlight or sources of heat, including portable heaters and heating ducts.
- Do not stack cartridges more than five high.
- The operating temperature range for LTO cartridges is 10º to 35ºC. The storage temperature range is 16º to 32ºC in a dust-free environment with a relative humidity range between 20% and 80% (non-condensing).
- If cartridges have been exposed to temperatures outside the ranges specified above, stabilize the cartridges at room temperature for the same amount of time they were exposed to extreme temperatures or for 24 hours, whichever is less.
- Do not place cartridges near sources of electromagnetic energy or strong magnetic fields, such as computer monitors, electric motors, speakers, or x-ray equipment. Exposure to electromagnetic energy or magnetic fields can destroy data and the embedded servo code written on the media by the cartridge manufacturer, rendering the cartridges unusable.
- Place identification labels only in the designated slots on the cartridges.
- If you ship cartridges, ship them in their original packaging or something stronger.
- Do not insert damaged cartridges into drives.
- Do not touch the tape or tape leader.
- Do not degauss cartridges that you intend to reuse.

Removing Lodged Cartridges

It is very unlikely that a cartridge will become lodged in the robot. If this happens, contact technical support. It also is very unlikely that a cartridge will become lodged in a drive. If this happens, remove it.
To remove a lodged cartridge:

1. On the operator panel, press Robotics Enabled to turn off power to the picker and return it to the home position.
   The power is on to all other components.

2. Open the access door.
   Aisle power is disabled.

3. On the drive, press Eject, and remove the cartridge.

4. Close the access door.
   The power is on to all other components.

5. On the operator panel, press Robotics Enabled to enable the picker.

**Write-Protecting Cartridges**

All cartridges have a write-protect (write-inhibit) switch to prevent accidental erasure or overwriting of data. Before loading a cartridge into the library, make sure that the write-protect switch is positioned correctly (either on or off).

For LTO cartridges, slide the red or orange write-protect switch to the right so that the padlock shows in the closed position. The switch is located on the left side of the cartridge front. See Figure 24 for the location of the switch on the cartridge.

![Figure 24 Write-protect Switch on an LTO Cartridge](image)

**Barcode Requirements**

Barcode Requirements

Cartridges must have an external barcode label that is machine-readable to identify the volume serial number. A barcode must use only uppercase letters A to Z and/or numeric values 0 to 9. The library supports Code 39 (3 of 9) type barcode labels.
For LTO media barcodes, the library dynamically supports 1 to 14 characters for volume serial number plus a two-character media type identifier. See the image below for an example of an LTO-5 barcode label.

HP-supplied barcode labels will provide the best results. Barcode labels from other sources can be used, but they must meet the following requirements:

- ANSI MH10.8M-1983 Standard
- Number of digits: 6+2
- Background reflection: greater than 25 percent
- Print contrast: greater than 75 percent
- Ratio: greater than 2.2
- Module: >= .254 mm
- Print tolerance: ± 57 mm

Additional Requirements:

- Height of the visible portion of the barcode: 10 mm ±2 mm
- Length of the rest zones: 5.25 mm ± 0.25 mm
- No black marks should be present in the intermediate spaces or rest zones
- No white areas should be present on the bars

⚠️ CAUTION:

The misuse of barcode technology can result in backup and restore failures. To ensure that your barcodes meet HP quality standards, always purchase them from an approved supplier and never print barcode labels yourself. For more information, see the order form provided with the library, as well as the Barcode Label Requirements, Compatibility and Usage white paper available from http://www.hp.com/support.

Installing Barcode Labels

Each cartridge in the library must have an external label that is operator and machine readable to identify the barcode number. Most manufacturers offer cartridges with the labels already applied or with the labels included that you can attach.

⚠️ NOTE:

Duplicate barcodes are not supported even if you have mixed media or multiple partitions in the library. If the library has cartridges with identical barcode labels, the library will issue an event notifying you of the issue. Areas in the LMC where media IDs are listed will show information for the first cartridge, but the cartridge with the duplicate barcode label will not be listed.

All barcode labels are applied to the front of a cartridge. Peel off the label and place it on the cartridge. Verify that the label is aligned so that the numbers appear above the barcode, and so that the label is not crooked on the cartridge. Figure 25 shows an example of barcode label alignment.
Do not place a barcode label on top of a cartridge. Doing so can cause inventory operations to fail.

![Image of barcode labels on cartridges]

**Figure 25 Applying Barcode Labels to Cartridges**

**Using Cleaning Cartridges**

Most tape drives require occasional cleaning. A cleaning cartridge cleans accumulated debris from the tape drive and the read/write head.

**CAUTION:**
You must use a separate cleaning cartridge for each partition in the library.

Backup applications or archive software applications use different techniques to automate the process of cleaning drives. These tools specify cleaning cycles based on cycle counts of the drive, drive requests, or regularly scheduled intervals.

The cleaning process itself requires certain considerations:

- Cleaning tapes must be labeled with a barcode. In some cases, specific labels have been established as industry standard. For instance, the prefix CLN might be used to identify a cleaning tape. The library does not require a specific content to the label and accepts conventional tape labels.
- Insert a cleaning tape just as you do any other data tape. The most common method is by means of the I/E station using host application control.
- Cleaning tapes often has limited lives that can last only as long as 20 cycles. The controlling host application manages the number of uses of a cleaning tape. Errors can occur if a tape is inserted into a drive when the tape has already been used the maximum number of times.
- Export a cleaning tape just as you would export any other data tape.
- The concepts of physical and partitions must be considered when setting up cleaning procedures and methods. In general, cleaning cartridges must be treated in the same manner as data cartridges. Any physical cartridge (cleaning or data) can exist in only one partition. There can be no sharing of cleaning cartridges between partitions.
Managing Media

The LMC provides you with commands for:

- Importing and exporting cartridges
- Moving media from one storage location to another
- Loading and unloading drives
- Taking inventory

The following sections provide instructions for performing these tasks.

NOTE:

Unless the situation requires it, use the host application to move, load, unload, import, or export cartridges instead of doing so through the LMC. Using the host to move media makes sure that the host view of the library remains in sync with the actual library configuration.

Importing Cartridges Into Partitions

When you first start using your library, open the door and manually insert, directly into storage slots, as many cartridges as you plan to use. The cartridges will not go back all the way if they are inserted incorrectly.

After your library begins operation, use the Import Media dialog box to add cartridges without interrupting library operations. Place cartridges in the I/E station. The scanner automatically reads the barcodes on the new cartridges.

To import cartridges into partitions:

1. Make sure that you are viewing the partition into which you want to import a data cartridge. From the View menu, click the name of the appropriate partition.
2. Insert a data cartridge into an appropriate I/E station. You can insert multiple cartridges up to the maximum number of slots in your I/E station.
3. To see which I/E stations are associated with a particular partition, click Monitor > I/E Station.
4. Click Operations > Import or click the Import button on the toolbar.
   If the partition is not offline, you receive a message that asks you whether you want to take it offline.
5. Click Yes.
   The Import Media dialog box displays a list of cartridges in the I/E station.
Table 33 describes the elements in the Import Media dialog box.

### Table 33 Import Media Dialog Box

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barcode</td>
<td>The volume serial number of the cartridge.</td>
</tr>
<tr>
<td>Slot</td>
<td>The slot number in the I/E station magazine. To understand the location designation, see Understanding Location Coordinates.</td>
</tr>
<tr>
<td>I/E Station</td>
<td>The module number.</td>
</tr>
<tr>
<td>Magazine</td>
<td>The magazine number (section) where the slot is located, numbered from the top down.</td>
</tr>
<tr>
<td>Results</td>
<td>“Imported” or “Failed”.</td>
</tr>
</tbody>
</table>

6. Click a cartridge to highlight it, and then click Import. The picker automatically moves the cartridge from the I/E station to the first available empty slot in that partition. You cannot manually specify the slot.

### Exporting Cartridges From Partitions

When partitions are created, specific I/E station slots are associated with that partition. When you export cartridges in a library with partitions, cartridges are exported to the partition I/E station slots. You can only export cartridges if I/E station slots for that partition are empty.

To export cartridges from partitions:

1. Make sure that you are viewing the partition from which you want to export a data cartridge. From the View menu, click the name of the appropriate partition.
2. Click Operations > Export or click the Export button on the toolbar.
**NOTE:**
The physical library must be online.
If the partition is not offline, you will receive a message that asks you whether you want to take it offline. Click Yes.

The Export Media dialog box displays a list of cartridges in the partition.

3. If you want to display one or more media IDs that match a particular pattern, type a media filter in the Media Filter text box, and then click Filter.
   Filter performs a search for media IDs that match a particular pattern. For example, the media filter might be set to capture media IDs beginning with the string J00.

4. Select the corresponding check box in the leftmost column for each cartridge that you want to export.
The maximum number of slots that are available in the I/E station partition appears at the top of the table.

5. Click OK.
   All designated cartridges are exported to the I/E station slots that are associated with the partition. After the operation completes, the library automatically refreshes information in the table.

### Loading Drives

The Load Drives dialog box enables you to load drives with cartridges from the current partition.

To load drives:

1. Make sure that you are viewing the partition from which you want to load drives. From the View menu, click the name of the appropriate partition.

2. Click Operations > Drives > Load.
The Load Drives dialog box appears.

3. If you want to display one or more media IDs that match a particular pattern, type a media filter in the Media ID text box, and then click Filter.
   Filter performs a search for media IDs that match a particular pattern. For example, the media filter might be set to capture media IDs beginning with the string J00.

4. Click the data cartridge to load into the drive to highlight it.

**NOTE:**
You can load only one cartridge at a time.

The parameters used to define a cartridge are media ID (barcode) and location. Location is defined as a series of coordinates representing the aisle, module, rack, section, column, and row where a cartridge is located. See Understanding Location Coordinates.
The Select Media area shows the full slots.

5. Click the destination drive to receive the media to highlight it. The Select Drive area is populated with empty drives.
   You can select only one drive at a time.

6. To load the data cartridge into the selected drive, click OK.
Unloading Drives

The Unload Drives dialog box enables you to rewind the cartridge in the drive, eject it, and return it to storage.

To unload drives:

1. Make sure that you are viewing the partition from which you want to unload drives. From the View menu, click the name of the appropriate partition.
2. Click Operations > Drives > Unload.
   The Unload Drives dialog box appears.
3. If you want to display media IDs by media type, click the appropriate media type from the Media Type drop-down list.
4. Click the drive you want to unload to highlight it. You can only unload one drive at a time. The parameters used to define a cartridge are media ID (volume serial number) and location. Location is defined as a series of coordinates representing the aisle, module, rack, section, column, and row where a cartridge is located. See Understanding Location Coordinates.
5. Click OK.
   The library rewinds the data cartridge, unloads it from the drive, and returns it to storage.

Moving Media

The Move Media dialog box enables you to move media from one location to another within a partition.

**NOTE:**
Only one cartridge can be moved at a time.

To move media:

1. Make sure that you are viewing the partition within which you want to move media. From the View menu, click the name of the appropriate partition.
2. Click Operations > Move Media.
   The Move Media dialog box appears.
   The table in the Select Source area lists slot locations with cartridges, and the table in the Select Target area lists slot locations without cartridges.
   You can limit the cartridges that are listed in the Select Source table in the following ways:
   • To list cartridges by location, click the arrows next to the location coordinate boxes at the top of the Select Source area, click the appropriate numbers or All, and then click Show. For information about location coordinates, see Understanding Location Coordinates.
   • To list a particular cartridge by media ID, type the volume serial number of the cartridge in the Media ID text box, and then click Show. You also can type a partial volume serial number, such as K00, to list all cartridges within the specified location coordinates that have a volume serial number containing the specified string of characters.
   • You also can limit the slot locations that are listed in the Select Target table by device type. From the Device Type drop-down list, click I/E Station, Storage, or Drive.
3. In the Select Source table, click the media ID for the cartridge that you want to move to highlight it. If necessary, you can use the scroll bar to display additional media IDs for cartridges that are in drives or I/E stations.
4. In the Select Target table, click the destination for the cartridge that you want to move to highlight it. If necessary, you can use the scroll bar to display additional slot locations.

5. Click OK.
   The media moves to the new location.

Inventory

The Inventory command causes the library to scan all storage locations, drives, and I/E stations. The library automatically performs an inventory when doors are closed or the library’s configuration information is changed in any way. You can configure inventories to automatically occur whenever the power is cycled, or you can initiate an inventory immediately by clicking Operations > Inventory.

To perform an inventory:
1. Log on as an administrator.
2. You can perform this procedure while either viewing the physical library or a partition. From the View menu, click the name of the physical library or the appropriate partition.
3. Click Operations > Inventory.

**NOTE:**

If you want to perform an inventory of the physical library, and it is not offline, you will receive a message that asks you whether you want to take it offline. Click Yes.

If you want to perform an inventory of a partition, and if the physical library is offline, you will receive a message that asks you whether you want to take the physical library online. Click Yes. Also, if the partition is online, you will receive a message that asks you whether you want to take it offline. Click Yes.

The Inventory dialog box appears.

![Inventory dialog box](image)

This dialog box shows the total number of slots and the number of occupied slots in the physical library or the partition, depending on the view you chose.

4. To perform an inventory, click OK.
   The inventory process take a few minutes to complete.

5. When the Inventory completed successfully message appears, click OK.
7 Managing library firmware and software versions

Updating Library Software

To download library software to the library and perform various update operations, you can use the Update Software option to access the Update Firmware Wizard.

**NOTE:**
This process may take 30 to 45 minutes.

Library software update files contain updates for one or more of the following library components:

- Management control blade (MCB)
- Robotics control unit (RCU)
- Control management blade (CMB)
- Ethernet Control blade (EEB)
- Power and control subsystem (PIP) for blades
- Drive sleds
- Individual drive firmware image files contain updates for specific types of drives.

Before you can update the library with a library software update file, you must use the Update Firmware Wizard to download the file to the MCB. You can use the wizard to perform the following operations:

- Install new library software (including downloading and installing software).
- Reinstall the currently installed library software package.
- Roll back library software to a previously installed package.

You can perform all update operations while viewing the physical library. However, if you are viewing a partition, the only operations that are available to you are for updating drive firmware (by using either firmware images or update tapes) for drives within the partition.

You can perform update operations from either the library OCP or a remote client on a remote host computer, with one exception. You cannot download images from the local OCP.

During the software update process, the MCB distributes the various parts of the software package to the proper library components. The MCB also keeps track of the software components it updates so that you can roll those components back to a previous version.

After the library finishes installing new library software or rolling back library software to a previously installed level, the library automatically restarts. Any necessary autoleveling of library components begins after the library powers up and discovers library components.
CAUTION:
As a result of restore, rescue, or revert operations, the library shuts down. You must have physical access to the library to bring the library back up. If you are performing a restore, rescue, or revert operation using remote access, the library will remain shut down until the library is directly powered back on.

If you choose to reinstall the currently installed software package, the robotics control unit (RCU), picker, and drive sleds are updated. Therefore, the library does not restart after the reinstallation process completes. The reinstallation procedure should be run only under specific circumstances. For more information, see Rolling Back to the Previous Build Package.

NOTE:
Rollback and reinstallation of current package options are viable recovery steps during a failed firmware upgrade. However, these features should not be used as troubleshooting tools.

Accessing the Update Firmware Wizard

The Update Firmware Wizard gives you access to all of the library software update operations.

NOTE:
Before performing a software upgrade, we recommend that you shut down and restart the library.

To access the Update Firmware Wizard:
1. Log on as admin or service.
2. You can access the Update Firmware Wizard while viewing either the physical library or a partition. From the View menu, click the name of the physical library or the appropriate partition.
3. Click Tools > Update Firmware > Library.
The Update Firmware Wizard dialog box appears.

This dialog box explains the operations you can perform by using the Update Firmware Wizard.

4. If you are ready to proceed, click Next. If you are not ready to proceed, click Cancel.
The Select Library Software Package for Installation dialog box appears.
Installing New Library Software

To update your library software, you must download a new library software package to the library management control blade (MCB) from the remote client file system, and then install the downloaded software. You can perform the library software update from either the library OCP or a remote client, but you must perform the software download to the MCB from a remote client.

NOTE:
Some upgrades will not be download upgrades but instead CF (compact flash) swap upgrades.

NOTE:
If you are accessing the LMC using the remote client application, be aware that after you update the library software and after the library restarts, you will not be able to view the LMC from the remote client application. You must update the client software to match the version of software you installed on the library.

Downloading a New Library Software Package

Before you install a new library software package, you must download the package to the library MCB from the remote client file system. You must perform the download from a remote client.
NOTE:
Before you begin the following procedure, make sure that you have obtained the new library software package from HP and placed it in an accessible location on your laptop.

To download a new library software package:

   The Software Update dialog box appears.
2. Navigate to the location of the software file (with a .frm extension) you want to download, click the file to highlight it, and then click Open.
   The Operation in Progress screen displays the progress of the download.
   The download process copies the software file from the remote file system to the library MCB.
   When the download process completes, the Library System Software Update dialog box appears again with the Install downloaded package option automatically selected.
   The version number of the software package appears at the end of the Install downloaded package option.

Installing a New Library Software Package

After you download the new library software package, you are ready to install it from either the library OCP or a remote client. This procedure assumes that you are working from a remote client.

To install a new library software package:

1. On the Library System Software Update dialog box, select Install downloaded package.

   NOTE:
   If you downloaded a software package and then began this procedure without closing the Update Firmware Wizard - Library System Software Update dialog box, Install downloaded package is already selected.

2. Click Next.
   The estimated time for the installation is displayed.
3. Click Install.
   A warning message appears asking you to take the library offline.
4. Click Yes.

   NOTE:
   The library automatically logs off other users so that they cannot perform library operations while the library software update operation is in progress.

   The Update Software Summary window asks if you want to continue.
5. Click Yes.
   The Software Update Progress screen displays the progress of the installation.
Real-time progress information appears under **Progress Summary** in the **Description** and **Status** columns.

**NOTE:**

During the update, the **Abort** button appears dimmed and is unavailable. Do not interrupt the update process before it is completed. Interrupting the update process might cause the library to become unusable until its software is restored.

After 100% success has been achieved for all components, the library is shutdown. This process could take several minutes.

6. After the update is complete, the **Software Update Progress** screen appears. Click **OK**.

   The Attention message informs you that the software update was successful, the library will be rebooting, and that you have been automatically logged off from the system.

**NOTE:**

If the software update was not successful, an event is generated. Resolve all events and begin the software update process again.

7. Click **OK**.

   The message **Library is being shutdown... appears**.

   This action may take a few minutes.

   The **Operation in Progress** screen appears.

8. Log off the remote browser and log in again after the library has completed its reboot process.

9. Click **Help > About**. Validate that the components reflect the correct firmware version.

**Reinstalling Current Library Software**

The reinstall feature enables you to re-establish the installation of the library software that is currently active on the MCB to the various remote devices, such as the RCU and the CMB. Perform this procedure if either of the following situations has occurred:

- The compact flash on the MCB has been replaced, the library software on it is now at a different level, and you want to invoke the level that is on the MCB compact flash.
- The RCU has been replaced and you want to bring it to the level that is on the MCB.

To reinstall current library software:

1. On the **Library System Software Update** dialog box, select **Reinstall current package**.

2. Click **Next**.

   The **Update Firmware Wizard** dialog box appears.

3. Click **Install**.
NOTE:
If the physical library is not offline, you receive a message that asks you whether you want to take it offline. Click Yes.

The library automatically logs off other users so that they cannot perform library operations while the library software update operation is in progress.

The Software Update Progress dialog box appears. Real-time progress information appears under Progress Summary in the Description and Status columns.

NOTE:
The components that already have the correct version loaded will quickly transition to a Success status during the reinstall process.

△ CAUTION:
During the update, the Abort button appears dimmed and is unavailable. Do not interrupt the update process before it is completed. Interrupting the update process might cause the library to become unusable until its software is restored.

4. After the update process completes, click OK.

Within approximately a minute after completing the update process, the RCU restarts.

△ CAUTION:
Do not perform any library operations until the RCU is completely restarted.

NOTE:
Before the RCU is restarted, the main menu Activity panel displays the message, WARNING: The Robotics is not Enabled. This message indicates that the RCU is not yet ready. When the RCU is ready, the message disappears.

5. Bring the physical library online.
   a. From the LMC, click Operations > Change Mode.
   b. Select Online, and then click OK.
5. Click Help > About. Validate that the components reflect the correct firmware version.

Rolling Back to the Previous Build Package
To roll back to the previous build package:
1. On the Library System Software Update dialog box, select Rollback to package.
2. Click Next.
The **Update Firmware Wizard** dialog box appears.

3. Click **Install**.

**NOTE:**

If the physical library is not offline, you receive a message that asks you whether you want to take it offline. Click **Yes**.

The library automatically logs off other users so that they cannot perform library operations while the library software update operation is in progress.

The **Software Update Progress** dialog box appears.

Real-time progress information appears under **Progress Summary** in the **Description** and **Status** columns.

**CAUTION:**

During the update, the **Abort** button appears dimmed and is unavailable. Do not interrupt the update process before it is completed. Interrupting the update process might cause the library to become unusable until its software is restored.

4. After the update process completes, click **OK**.

Within approximately a minute after completing the update process, the RCU restarts.

**CAUTION:**

Do not perform any library operations until the RCU is completely restarted.

5. Bring the physical library online.
   a. From the LMC, click **Operations > Change Mode**.
   b. Select **Online**, and then click **OK**.

6. Click **Help > About**. Validate that the components reflect the correct firmware version.

### Updating Drive Firmware

**IMPORTANT:**

You can perform drive firmware updates from either the library OCP or a remote client, but you must perform drive firmware downloads from a remote client.

It is important to make sure that the library is running the appropriate level of drive firmware, compatible with the drive type. To determine the appropriate drive firmware, see the library Release Notes or contact HP technical support. If you want to update drive firmware by using Ethernet Expansion Blades (EEB), perform the procedure in this section. Drives that are not attached to Ethernet Expansion Blades must be updated by using update tapes.
NOTE:
If you are viewing a partition, you can only set up update drive firmware for drives within the partition.

You can use the **Update Drive Firmware** command from the **Tools** menu to update drive brick firmware on one or more drives by using either update tapes or drive firmware images that you have downloaded to the library.

### Accessing the Update Drive Firmware Dialog Box

NOTE:
Before performing a firmware upgrade, we recommend that you shut down and restart the library.

To access the **Update Drive Firmware** dialog box:

1. Log on as admin or service.
2. You can access the **Update Drive Firmware** dialog box while viewing either the physical library or a partition. From the **View** menu, click the name of the physical library or the appropriate partition.

   CAUTION:
   If you are viewing a partition, drive firmware update operations affect drives that are within the partition only.

3. Click **Tools > Update Firmware > Drives**.
   If the physical library or the partition you are viewing is not offline, you receive a message that asks you whether you want to take it offline.
4. Click **Yes**.
   The **Update Drive Firmware** dialog box appears.
From the **Update Drive Firmware** dialog box, you can update drive firmware by using either update tapes or drive firmware images that you have downloaded to the library. The table lists all drives in the library or, if you are currently viewing a partition, all drives in the partition.

The **Manage Images** button enables you to download new drive firmware images to the library or delete drive firmware images that the library currently stores. Drive images that are currently stored on the library are listed in the drop-down list in the **Select Firmware File** area.

To update drive firmware by using downloaded firmware images, proceed to **Updating Drive Firmware Using Firmware Images**.

To update drive firmware by using update tapes, proceed to **Updating Drive Firmware Using Update Tapes**.

### Downloading New Drive Firmware

**IMPORTANT:**

You can perform drive firmware updates from either the library OCP or a remote client, but you must perform drive firmware downloads from a remote client.

To download new drive firmware:

1. Download the new drive firmware image to the library MCB from the remote client file system and place it in an accessible location on your laptop.
2. On the **Update Drive Firmware** dialog box, click **Manage Images**. The **Manage Drive Firmware Images** dialog box appears.

---

---
The library has enough space for 20 MB (with a maximum of 8 images) of drive firmware images. If the check box for a drive firmware image is clear, you can delete the image by clicking it to highlight it, and then clicking Delete.

3. To download a new drive firmware image, click Download. The Select firmware image file to download dialog box appears.

4. Navigate to the location of the drive firmware image file (with a .frm extension) you want to download, and then click the image file to highlight it.

5. Click Open.

The download process copies the drive firmware image from the remote file system to the MCB. After the download process finishes, the drive firmware image file is added to the list on the Manage Drive Firmware Images dialog box.

6. On the Manage Drive Firmware Images dialog box, click Close.

The Update Drive Firmware dialog box appears again.

Updating Drive Firmware Using Firmware Images

⚠️ **CAUTION:**

If you are viewing a partition, drive firmware update operations affect drives that are within the partition only.

⚠️ **CAUTION:**

Before you update drive firmware during this procedure, make sure that tapes are not mounted in any of the drives. If tapes are mounted in drives during the update process, the library loses knowledge of the cartridge home cell in storage, resulting in library and host inventory issues.

If you load a firmware image onto a drive that is the same version that is currently running on the drive, the upgrade will fail.

If host reservations exist on drives, remove them prior to initiating drive code changes.

To update drive firmware using firmware images:
1. On the Update Drive Firmware dialog box, select Firmware Image.

2. In the left-most column of the table under the Update Method area, select one or more check boxes that correspond to drives that you want to update with the same drive firmware image. Use the following rules to select drives:
   • Do not select drives that are currently loaded.
   • If you select more than one drive, make sure that they are all of the same drive type.
   • Click Select All to select all drives. (All drives must be of the same drive type.)

3. From the drop-down list in the Select Firmware File area, click the drive firmware image you want to use to update the drives you selected.

⚠️ CAUTION:
The drop-down list includes all drive firmware images that are currently stored on the library, regardless of drive type. Be careful to select a drive firmware image that is compatible with the type of drive that you want to update. See the current library release notes for compatibility information or contact HP technical support at http://www.hp.com/support.

4. Click Start.

⚠️ NOTE:
The library automatically logs off other users so that they cannot perform library operations while the drive firmware update operation is in progress.

The library updates the firmware on each selected drive.

Updating Drive Firmware Using Update Tapes

It is important to verify that the library firmware version is compatible with the new drive firmware version. To determine the appropriate drive firmware, see the library Release Notes or contact HP technical support. If you need to update drive firmware by using update tapes, perform the following procedure.

⚠️ NOTE:
If you are viewing a partition, drive firmware update operations affect drives that are within the partition only, and uses the I/E slots within the partition. If you are viewing the physical library, drive firmware update operations affect all drives.
To update drive firmware using update tapes:

1. Write down the Barcode number on the tape before inserting it into the I/E Station.
2. From the Physical Library view, insert the firmware tape(s) into any I/E station slots in the library.
3. On the Update Drive Firmware dialog box, select FMR Tape.
   The Select Firmware Tapes dialog box appears.
4. Select the tape cartridges you want to use for the firmware update by checking the check boxes in the media table, and click OK.

   **NOTE:**
   You can perform a firmware update only for drives of the same type (such as LTO-4 or LTO-5).

5. Click Start.
   A message, **Updating do not power cycle the drive**, is displayed above the drive table in red.

   **CAUTION:**
   Do not power cycle the drive.

The Status column in the drive table displays the status of the update.
This chapter describes how the library informs you of issues that it detects within its subsystems. It also provides information about working with events to resolve issues, running verifications tests to check whether the issues have been resolved, interpreting LEDs, and accessing Online Help.

Is the access door closed?

Library operations are taken offline when the access door is opened. If library operations have stopped, check whether the access door is shut and the Robotics Enabled indicator is solid green.

Is a cartridge or drive having problems?

Cartridges can become old and less dependable. If you experience problems reading, writing, or otherwise using a cartridge, try the following:

- Use the Monitor > Media command to determine the number of mounts for the cartridge, then compare that number to other cartridges in the system. If the cartridge has been used excessively, replace it with a new cartridge.
- Ask an administrator to put the cartridge in a different drive, then use the Tools > Drives command to check the error count. If the error count continues to increase, replace the old cartridge with a new cartridge.
- If you have received a message about read/write failures, copy the data from the failing cartridge and replace it with a new cartridge.

Use TapeAssure in Command View TL, version 2.8 or later, to pinpoint the problem. (Command View TL requires a per-library license.) TapeAssure provides information about cartridges and drives, including quality, performance, life, and configuration. HP’s TapeAssure Analysis Template can also be used to graph and analyze a variety of statistics over time.


How Does the Library Report Issues?

The library has advanced problem detection, reporting, and notification functionality. The library has many processors and sensors that monitor conditions and operations, such as temperatures, voltages, current, calibrations, and firmware versions.

The first indication of issues is the status indicator on the indicator panel, as shown in Figure 26.
1. Status indicator

Figure 26 Status Indicator

- If the Status indicator light is solid green, the library currently has no events in an Open state.
- If the Status indicator light is flashing amber, at least one of the six subsystems has an event in an Open state.

When the library detects an issue, it creates an event for it. A event includes the following types of information:

- Details about the issue.
- Reports that are associated with the event.
- A repair page that provides corrective actions.

In most cases, events isolate field replaceable units (FRUs) that you must service or replace.

NOTE:

Events can indicate failures or other serious problems, but they also can indicate warning conditions that you should investigate or other helpful information. For example, opening the library access door or changing the library configuration causes the library to create an event, but these situations would not indicate serious problems. However, you should investigate the events.

The library assigns a severity level to each event that it creates and notifies users of the event. Table 34 describes possible severity levels for events.

Table 34 Severity Levels Assigned to Events

<table>
<thead>
<tr>
<th>Severity Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 (Failed)</td>
<td>Indicates that a failure has occurred or a different serious condition exists within a library subsystem that requires immediate corrective action. In most cases, a hardware component is no longer functioning at an acceptable level or has failed. Typical library operations are either impossible or highly unreliable. Examples of failure situations include a FRU that is not functioning, a temperature threshold that has been reached that causes unreliable operations, or a partition that the library has automatically taken offline.</td>
</tr>
<tr>
<td>Severity Level</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>2 (Degraded)</td>
<td>Indicates that a degraded condition exists within a library subsystem that impacts system performance or redundancy. Typical library operations can continue without immediate corrective action, but an administrator should investigate the condition and correct the problem soon. An example of a degraded situation is a redundant power supply that has failed or a connectivity problem that has caused host port failover to occur.</td>
</tr>
<tr>
<td>3 (Warning)</td>
<td>Indicates that a condition exists within a library subsystem that has little effect on system operations. Typical library operations can continue without immediate corrective action, but you should investigate the condition and correct the problem when possible. Warnings also can provide helpful information, such as indicating that a door is open. Examples of warning situations include a FRU that is functioning less reliably or a temperature threshold that has been reached that does not affect reliable operations.</td>
</tr>
</tbody>
</table>

The library has two ways of notifying users that it has discovered issues and has created events for them:

- Status indicators on Library Management Console (LMC) system status buttons.
- E-mail notifications.

**Understanding Indicators on System Status Buttons**

System status buttons are located in the Overall System Status area at the bottom of the LMC display. Each button displays a status indicator for the library subsystem it represents. For more information about the buttons, see System Status Buttons. When the library creates an event, the status indicator button for the affected subsystem automatically changes from the following icon:

![Good (green)](image)

Good (green)

to one of the following icons:

![Warning or Degraded (yellow)](image)

Warning or Degraded (yellow)

![Failed (flashing red)](image)

Failed (flashing red)

The meanings of these status indicators correspond to the severity levels described in Table 34. If a system status button indicates anything other than a Good state, clicking it displays a list of open events for the subsystem. To access events by using the system status buttons, see Event Guidelines.

**Understanding E-mail Notifications**

The library collects status information on its components and, if the appropriate e-mail notifications have been set up in the LMC, the library can send notifications whenever events with severity levels 1, 2, or 3 are created. For information about severity levels, see Table 34.

The library assigns a severity level to each event it creates. If the event severity level matches one of an e-mail address severity codes (as set up in e-mail notifications), the library sends a notification to that particular e-mail address. The library also sends a notification if an event’s severity level escalates...
to a more severe level. The library does not send one when an event severity level becomes less severe.

To set up e-mail addresses to receive notifications, see Configuring E-mail and Setting Up E-mail Notifications.

The subject line of the e-mail notification indicates ESLG3, the library serial number, and the severity level of the event. The body of the message states that the library sent the message automatically. The message body also includes the following information, which provides details about the event and library conditions at the time of the event:

- Event summary
- Event details, including status information
- Firmware versions, including MCB, RCU, CMB, and drive
- Physical library configuration
- Library states, such as physical library online or offline, partitions online or offline, or robotics enabled or disabled
- Time stamps of recent activity
- Report summary
- Report details for the event

The notification also includes a repair page attachment. This page provides a problem description and corrective actions you or a customer service engineer (CSE) can perform. For more information about repair pages, see Viewing Repair Pages.

**NOTE:**

A notification e-mail contains helpful information about an event and how to resolve it. However, the notification represents a condition that existed at a certain time in the past. The notification might not reflect the current situation. The notification indicates a specific event ID, so you should find and examine that specific event in the LMC. The event reflects the real-time status of the issue. For more information about accessing events, see Event Guidelines.

---

**Working with Events**

Events are your primary troubleshooting tool when you experience problems with the library. An event provides details and reports about the issue and library conditions at the time of the event. It also provides guidance on how to resolve the issue. If you are an administrator or a service representative, you can access the events through the LMC. This section explains how to display event lists, view event and report details, view repair pages, and resolve and close events.

**Event Guidelines**

To help you quickly troubleshoot an issue by using events, read the following guidelines.

*What is the issue and its cause?*

You became aware of a library issue because either the library sent an e-mail notification; an LMC system status button indicated a subsystem status of Warning, Degraded, or Failed; or a backup/archive software application indicated a problem.

Events include details about the issue and library conditions at the time of the event. They also include reports, any history events that the library has created in the past for the same FRU, and a repair
To use an event to determine an issue and its cause, you can perform the following general steps:

1. Display a list of events. See Displaying Event Lists.
2. View the details for the appropriate event. See Viewing Event Details.
3. View the reports that are associated with this event. See Viewing Event Details Reports.
4. View the event repair page. See Viewing Repair Pages.

Where did the issue occur in the library?

The Status Group field on the Details tab of the Event Details dialog box indicates the library subsystem that caused the event. For more information about the Details tab, see Viewing Event Details.

The FRU ID field on the Report tab of the Event Details dialog box indicates the type of FRU that is affected. The FRU Instance field indicates the specific FRU by its location in the library. For more information about the Report tab, see Viewing Event Details Reports.

When did the issue first occur?

The Posted field on the Details tab of the Event Details dialog box indicates the date and time on which the library first reported the issue and created an event for it. For more information about the Details tab, see Viewing Event Details.

Has the issue occurred repeatedly?

The Duplicates field on the Details tab of the Event Details dialog box indicates how many times the library has reported the same issue while the event has been open.

In addition, you can determine whether the same issue has occurred and been resolved in the past. The FRU History List area on the Details tab lists events that have been opened for the same FRU in the past, but have been resolved and are now in the Closed or Verified state. By selecting a history event and then clicking Show, you can investigate the event history of a particular FRU. For more information about the Details tab and viewing history events, see Viewing Event Details.

Has the FRU been replaced before?

You can determine whether a specific FRU has been replaced in the past by examining the FRU SN field on the Details tab of the Event Details dialog box for the open event and the history events. Because the history events associated with an open event are for the same specific instance of a FRU, and because a FRU instance is identified by its location in the library, the FRU serial number, which is uniquely assigned to each FRU, will change if the unit has been replaced in the past. For more information about the Details tab and viewing history events, see Viewing Event Details.

How do I resolve the issue?

The repair page provides comprehensive procedures for resolving the issue. Both user and CSE procedures are provided. When the procedures require a CSE to perform them, contact technical support. For more information, see Viewing Repair Pages.

How can I know whether the issue is resolved?

Some issues require you to determine whether they are resolved and others the library will detect automatically.

- In some cases, the library can automatically detect that an issue is resolved (for example, an open door that is now shut). For these, the library automatically transitions the event to the Verified state.
- In other cases, the library cannot automatically detect that an issue is resolved (for example, a faulty tape cartridge). You must determine whether the issue is resolved by running a verification test or, if an applicable test does not exist, by following the repair page instructions.
If you run a test and the results are all good, the library automatically transitions the event to the **Verified** state.

If you cannot run a test, you should physically examine the FRU, and then manually transition the event to the **Closed** state after determining that the issue is resolved. After you close the event, the library transitions it to the **Verified** state if it is able to do so. For more information, see Running Verification Tests to Determine Issue Resolution and Closing Events.

The library reopens events that receive failed, degraded, or warning reports within 30 minutes of transitioning to the **Closed** or **Verified** state. If a **Closed** or **Verified** event remains free of failed, degraded, or warning reports for 30 minutes, the library locks them from transitioning back to the **Open** state. A failed, degraded, or warning report that is received beyond 30 minutes causes the library to open a new event.

**What do I do if I cannot resolve the issue?**
Contact technical support. See Contacting HP. Technical support personnel might ask you to send them an electronic copy of the event.

**How do I view the number of events that occurred in a certain time range?**
The Events Report lets you see how many events occurred in a particular time period. You can choose to group events by subsystem, module, or FRU. The results can be presented as a summary or as a trend, so you can see if the number of issues is increasing or decreasing over time. Also, the report results can be presented in different chart formats, such as bar graphs or pie charts. For more information, see Generating the Events Report.

### Displaying Event Lists

The LMC provides three ways to display event lists:

- **By clicking a system status button that indicates a **Warning**, **Degraded**, or **Failed** state.**
  This option displays a list of open events for the associated subsystem. See Using System Status Buttons to Display Event Lists.

- **By clicking **Tools** > **Event Viewer**.**
  This option displays the **Events** dialog box, from which you can obtain a list of all events or a partial list of events according to selection criteria. See Using the Events Command or the Events Button to Display Event Lists.

- **By clicking the **Events** button on the toolbar.**
  This option displays the same **Events** dialog box as the **Tools** > **Event Viewer** command does. See Using the Events Command or the Events Button to Display Event Lists.

From the event list, you can select an event to view event details, associated reports, and a repair page.

### Using System Status Buttons to Display Event Lists

To display a list of events by using a system status button, the button must indicate a **Warning**, **Degraded**, or **Failed** state. Clicking a system status button that indicates a **Good** state either displays a list of subsystem events that are in **Closed** or **Verified** states or informs you that no events exist for the subsystem.

To use system status buttons to display event lists:

1. Click the system status button that corresponds with the subsystem for which you want to display a list of open events.
   The **Event List** dialog box appears with a list of open events for the subsystem.
Table 35 describes the elements on the **Event List** dialog box:

**Table 35 Event List Dialog Box**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>The library-assigned identifier for the event.</td>
</tr>
<tr>
<td>Description</td>
<td>A summary description of the event. The description identifies the FRU that caused the event and includes reason text that describes the cause of the event.</td>
</tr>
<tr>
<td>State</td>
<td>The current state of the event. Possible states are:</td>
</tr>
<tr>
<td></td>
<td>• Open — indicates that an issue, whether problem or warning condition, has occurred in the library that requires attention</td>
</tr>
<tr>
<td></td>
<td>• Closed — indicates that a user has closed the issue</td>
</tr>
<tr>
<td></td>
<td>• Verified — indicates that the library has successful operational results or positive data that verifies that the problem is resolved</td>
</tr>
<tr>
<td>Severity</td>
<td>The severity level of the event. Possible levels are:</td>
</tr>
<tr>
<td></td>
<td>• 1 (Failed)</td>
</tr>
<tr>
<td></td>
<td>• 2 (Degraded)</td>
</tr>
<tr>
<td></td>
<td>• 3 (Warning)</td>
</tr>
<tr>
<td></td>
<td>• 5 (Good)</td>
</tr>
<tr>
<td>Serial #</td>
<td>The serial number that the manufacturer assigns to the particular FRU.</td>
</tr>
<tr>
<td>Sub-system</td>
<td>The subsystem that caused the event. Possible subsystems are:</td>
</tr>
<tr>
<td></td>
<td>• Connectivity</td>
</tr>
<tr>
<td></td>
<td>• Drives</td>
</tr>
<tr>
<td></td>
<td>• Control</td>
</tr>
<tr>
<td></td>
<td>• Power</td>
</tr>
<tr>
<td></td>
<td>• Cooling</td>
</tr>
<tr>
<td></td>
<td>• Robotics</td>
</tr>
<tr>
<td>Posted Date</td>
<td>The date and time on which the library created the event.</td>
</tr>
</tbody>
</table>
The Details button displays the Event Details dialog box. For more information, see Viewing Event Details.

2. By default, the event list is sorted by event ID in ascending order, with the oldest event at the top and the newest one at the bottom.
To change the sorting (for example, by state or severity), click the column heading by which you want the events sorted. Repeatedly clicking a column heading toggles between ascending and descending order.

Using the Events Command or the Events Button to Display Event Lists

To display event lists with the Events command or button:

1. Make sure that you are viewing the physical library. From the View menu or in the Managed Views region of the LMC, click the name of the physical library.
2. Click Tools > Event Viewer, or click the Events button on the toolbar.
The Events dialog box appears.

This dialog box enables you to specify the kinds of events that will appear in the event list. For example, you can do the following:

- To display all events in the library, select All for state, severity, and subsystem.
- To display all open events with a severity level 2 status for the drives and control subsystems, select Opened for state, 2 for severity, and Drives and Control for subsystem.
- To display all events that users have manually closed for the robotics subsystem, select Closed for state, All for severity, and Robotics for subsystem.
- To display all events that the library has automatically determined as having been resolved, select Verified for state, All for severity, and All for subsystem.

If you select a combination that does not produce an event list, a No Events Found message appears.

By default, this dialog box is set to Opened for state, All for severity level, and All for subsystems.

**NOTE:**

Events that the library has automatically verified and closed are in the Verified state. Events that users have manually closed are in the Closed state.

3. Select the appropriate check boxes in the Select State, Select Severity, and Select Sub-system areas, and then click OK.
For descriptions of elements on the **Event List** dialog box, see *Using System Status Buttons to Display Event Lists*.

4. By default, the event list is sorted by event ID in ascending order with the oldest event at the top and the newest one at the bottom. To change the sorting (for example, by state or severity), click the column heading by which you want the events sorted. Repeatedly clicking a column heading toggles between ascending and descending order.

**Viewing Event Details**

Events provide detailed information about the event itself, the reports that are associated with it, and a repair page that gives guidance for resolving the issue. These events provide important information about library conditions from which the issue emerged and helpful information for resolving it.

To display the detailed information for a particular event, perform the following steps:

1. On the **Event List** dialog box in the **Select Event** area, click the appropriate event row to highlight it.
2. Click **Details**.

The **Event Details** dialog box appears with the **Details** tab displayed.

---

The **Event #** area of the **Event Details** dialog box displays detailed information about the event. The **FRU History Event List** area lists all events that were ever opened in the past and that see the same specific FRU (based on the location of the FRU in the library) as the one reported by this event.
Table 36 describes the elements on the Details tab.

**Table 36 Event Details Dialog Box, Details Tab**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In the Event # area:</td>
<td></td>
</tr>
<tr>
<td><strong>State</strong></td>
<td>The current state of the event. Possible states are:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Open</strong> — indicates that an issue, whether problem or warning condition, has occurred in the library that requires attention.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Closed</strong> — indicates that a user has closed the issue.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Verified</strong> — indicates that the library has successful operational results or positive data that verifies that the problem is resolved.</td>
</tr>
<tr>
<td><strong>Posted</strong></td>
<td>The date and time on which the library created the report.</td>
</tr>
<tr>
<td><strong>Status Group</strong></td>
<td>The subsystem that caused the event. Possible subsystems are:</td>
</tr>
<tr>
<td></td>
<td>• Connectivity</td>
</tr>
<tr>
<td></td>
<td>• Drives</td>
</tr>
<tr>
<td></td>
<td>• Control</td>
</tr>
<tr>
<td></td>
<td>• Power</td>
</tr>
<tr>
<td></td>
<td>• Cooling</td>
</tr>
<tr>
<td></td>
<td>• Robotics</td>
</tr>
<tr>
<td><strong>Closed</strong></td>
<td>If the event is closed, the date and time on which it was closed.</td>
</tr>
<tr>
<td><strong>Severity</strong></td>
<td>The severity level that is associated with the status group (subsystem). Possible levels are:</td>
</tr>
<tr>
<td></td>
<td>• 1 (Failed)</td>
</tr>
<tr>
<td></td>
<td>• 2 (Degraded)</td>
</tr>
<tr>
<td></td>
<td>• 3 (Warning)</td>
</tr>
<tr>
<td></td>
<td>• 5 (Good)</td>
</tr>
<tr>
<td><strong>Duplicates</strong></td>
<td>The number of times that the library has reopened the event. If an event is in the Closed or Verified state and the identical problem occurs again within 30 minutes, the library reopens the event and increments the event’s duplicate count. If the library has not reopened the event, the value is zero (0).</td>
</tr>
<tr>
<td></td>
<td>Events that are in the Closed or Verified state for more than 30 minutes cannot be reopened. In this case, if the identical problem occurs again, the library creates a new event.</td>
</tr>
<tr>
<td><strong>FRU SN</strong></td>
<td>The serial number of the particular FRU.</td>
</tr>
<tr>
<td><strong>Repair Link</strong></td>
<td>The name of the repair page that is associated with the report.</td>
</tr>
<tr>
<td><strong>FRU Status</strong></td>
<td>The status of the FRU. Possible statuses are:</td>
</tr>
<tr>
<td></td>
<td>• Failed</td>
</tr>
<tr>
<td></td>
<td>• Degraded</td>
</tr>
<tr>
<td></td>
<td>• Warning</td>
</tr>
<tr>
<td></td>
<td>• Good</td>
</tr>
</tbody>
</table>
From the **Event Details**, you can perform the following tasks:

- Display detailed information for a history event by using the **Show** button, then re-display the original event details using the **Initial Event** button (see Viewing History Event Details).
- Connect to online service and support resources by clicking **Online Support**. Online service and support resources include free, secure access to KnowledgeBase articles and the Online Service Request tool. (If clicking **Online Support** does not connect you to the online service and support web site, try disabling your web browser pop-up blocker.)
- Mail, save, or print event information by using the **Send** button.
• Determine whether the issue is resolved by using the **FRU Test** button. **FRU Test** is available only if the FRU related to the event has an applicable verification test that you can run. (FRUs that belong to the Accessor, Picker, Drive, I/E Assembly, or Bar Code Label categories have applicable verification tests.) When you click **FRU Test**, the **Verification Tests** dialog box appears with the appropriate verification test already selected and ready to start. If you run a verification test and the results are all good, the library automatically transitions the event to the **Verified** state.

**NOTE:**

If the library does not have a verification test for the FRU, after you resolve the issue, you must manually transition the event to the **Closed** state by using the **Close Event** button. After you close the event, the library transitions it to the **Verified** state if it is able to do so.

• Display report information (see **Viewing Event Details Reports**).
• Display the repair page (see **Viewing Repair Pages**).

**Viewing History Event Details**

To display the detailed information for a particular history event, perform the following steps:

1. On the **Event List** dialog box in the **FRU History Event List** area of the **Details** tab, click the appropriate event row to highlight it.
2. Click **Show**.

The history event details appear in the **Event #** area. However, the list of events in the **FRU History Event List** remains the same as what the initial event displayed. This list does not change.

The **Report** and **Repair** tabs show information that is specific to the history event, but the **Close Event** and **FRU Test** buttons at the bottom of the **Event Details** dialog box are grayed out because the history event already is in the **Closed** or **Verified** state.
3. To return to the non-history event that appeared initially, click *Initial Event.*

**Viewing Event Details Reports**

The library creates a key report for each issue that occurs. As updates to the issue occur, the library creates subordinate reports that it associates with the key report. Typically, you should examine the key report because it represents the earliest time at which the event reached its highest severity level. It often isolates the most significant problem.

To display all report information that is associated with an event, click the **Report** tab on the **Event Details** dialog box. See **Using System Status Buttons to Display Event Lists.**

By default, the **Report #** area displays report details for either the key report or, if subordinate reports exist, the most recent subordinate report.

**Table 37** the elements on the **Report** tab:
Table 37 Event Details Dialog Box, Report Tab

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In the <strong>Reports Tree</strong> area:</td>
<td>Provides a hierarchy of report information that is associated with the event. Descriptions includes reason text that describes the cause of the report. Initially, only the highest level of the report tree appears. Clicking this level (<strong>Reports for Event #</strong>) reveals one or more second-level reports, and clicking a second-level report reveals one or more third-level reports. Second-level reports function essentially as containers of third-level reports. A event in the Open state has one or more third-level reports, including one key report. The key report represents the earliest time at which the event reached its highest severity level. It often isolates the most significant problem. A event in the Closed or Verified state does not have a key report.</td>
</tr>
<tr>
<td>Report tree area</td>
<td></td>
</tr>
<tr>
<td>Report ID</td>
<td>The library-assigned identifier for the report.</td>
</tr>
<tr>
<td>Posted</td>
<td>The date and time on which the library created the report.</td>
</tr>
<tr>
<td>Duplicates</td>
<td>For open events only, the number of times that the library created the same report. If the identical issue occurs while the event remains open, the library creates an identical report and increments the report’s duplicate count. If the library has not created duplicate reports, the value is zero (0).</td>
</tr>
<tr>
<td>Status Group</td>
<td>The subsystem that caused the event. Possible subsystems are: • Connectivity • Drives • Control • Power • Cooling • Robotics</td>
</tr>
<tr>
<td>Severity</td>
<td>The severity level that is associated with the status group (subsystem). Possible levels are: • Failed • Degraded • Warning • Good</td>
</tr>
<tr>
<td>FRU ID</td>
<td>The identifier for the FRU.</td>
</tr>
<tr>
<td>FRU Instance</td>
<td>In libraries with multiple FRUs of the same kind, the specific FRU that caused the report. This field usually identifies a particular FRU by its location in the library (for example, [1,1,1,8,1,1] for a drive sled). If the library has only one instance of the FRU, this field is blank.</td>
</tr>
<tr>
<td>FRU Category</td>
<td>The category to which the FRU belongs.</td>
</tr>
<tr>
<td>Reason</td>
<td>A brief explanation of why the FRU caused the report. Reasons describe the causes of issues.</td>
</tr>
</tbody>
</table>
A number that is associated with a particular issue that caused the event report. Because more than one issue can cause a report, an error code provides another level of detail to what the report provides. The error code maps to a portion of library firmware code, which a trained analyst can examine to determine the root cause of an issue. This information is for technical support use only.

<table>
<thead>
<tr>
<th>Modifier</th>
<th>A numerical qualifier, in hexadecimal format, that provides context for an error condition. A modifier adds another level of detail to what the error code provides. If a modifier does not exist for the error condition, this field is set to 0x0. This information is for technical support use only.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repair Link</td>
<td>The name of the repair page that is associated with the report.</td>
</tr>
<tr>
<td>Report Description</td>
<td>A summary description of the report.</td>
</tr>
</tbody>
</table>

**Viewing Repair Pages**

Repair pages provide problem descriptions and corrective actions that you or a CSE can perform. To display the repair page that is associated with an event, click **Repair** on the **Event Details** dialog box.

The repair page provides the following information:

- The title at the top of the repair page is a brief description of the issue.
- The **Problem** section describes the issue in more detail.
• The **User and Customer Service Engineer Actions** section provides corrective actions that the user or the Customer Service Engineer (CSE) can perform.

• The **Customer Service Engineer Actions** section provides additional corrective actions that the CSE can perform. If you are a user, do not perform these steps. Contact technical support for assistance.

---

**NOTE:**

If you are a CSE, see the *HP Enterprise Systems Library (ESL) G3 Tape Library Service Guide* for detailed maintenance action plans, and for removal and replacement procedures.

---

• The **Technical Support Information** section provides a comprehensive list of FRUs that could be involved.

• Text on the repair pages can include links to specific Online Help pages, which appear in place of the repair page when you click them. Navigation buttons near the top of the **Repair** tab enable you to access Online Help pages as follows:
  • The `< Back` button returns you to the previously viewed page (either a previously viewed Online Help page or the repair page).
  • The `Next >` button returns you to the page that you were viewing before you clicked the `< Back` button.
  • The **Content** button displays a table of contents for the Online Help system.

### Viewing Tape Alerts

Tape alerts are issued by a drive whenever there is a problem in the drive that relates to a tape cartridge. The problem can be with the drive or with the tape cartridge. You can generate tape alert reports from **Reports** on the menu.

You can use these reports to cross-reference tape alerts for drives and tape cartridges over a specified period of time, in order to determine if the problem belongs to the drive or to a specific tape cartridge. Typically, tape alerts point to a drive problem if a specific drive exhibits tape alerts against multiple pieces of media. Conversely, tape alerts point to a media problem if a specific piece of media exhibits tape alerts against multiple drives.

### Creating a Tape Alert History Report

To view a tape alert history report:

1. Click **Tools > Reports > Media > Tape Alert History**.
2. To use a previously-saved template (see Saving Report Criteria Templates) select it from the **Templates** drop-down menu.
3. To customize the report:
   a. To change date range, select the appropriate value from the **Range** field drop-down menu.
   b. To change the grouping, select the appropriate value from the **Grouping** field drop-down menu.
   c. To include the barcode, the physical SN of the drive, or any tape alerts, click to select the boxes next to the appropriate fields.
   d. To select the type of report, select the appropriate value from the **Type** field drop-down menu.
   e. To sort the information, select the appropriate sorting method from the **Sort By** field drop-down menu.
f. To specify the type of output, select the appropriate chart type from the Chart field drop-down menu. After you make any change to the Specify Report Criteria section, the Save button is activated in the Templates region of the dialog box.

4. To save the settings as a template for later use, click Save, type the appropriate value into the Enter Template Name dialog box, then click OK.

5. Click View to display the Tape Alert History Report.

6. To sort the data, click the heading of any column. Toggle the order by clicking the heading again.

7. Click Preview to preview the report as it will be saved or printed.

8. To save the report as a PDF file, click the PDF icon at the top of the preview window, enter the appropriate information in the Saving Report into a PDF-File dialog box, then click Confirm.

9. To print the report, click the Print icon at the top of the preview window, make the appropriate selections in the Print dialog box, then click OK.

10. Click the Close icon at the top of the preview window to exit.

11. Click Close to exit the Tape Alert History Report.

12. To e-mail or save the report:
   a. Click Export.
   b. To e-mail the report, select the radio button next to Email, then select or type in the email address, type in a comment (optional), then click OK.
   c. To save the report, select the radio button next to Save, browse to or type in the path and file name where the report is to be saved, then click OK.

13. Click Cancel to exit the Tape Alert History Report dialog box.

Emailing, Saving, and Printing Event Information

The Send button on the Event Details dialog box enables you to send detailed event information, including all report details, to e-mail addresses. If you are accessing the LMC from a remote client, Send also enables you to save the information to a file or print it.

**NOTE:**

You can mail, save, or print event information from a remote client. However, you cannot save or print the information from the library OCP.

Event information that a user sends by using the Send button is essentially the same as the information that the library automatically provides in e-mail notifications (see Understanding Email Notifications). The only differences are that the subject line states “Library Information” and the body of the message does not have a “REASON FOR AUTOMATED E-MAIL” section, but it has a “REPAIR AND TROUBLESHOOTING INSTRUCTIONS ATTACHED” section.

The message body also includes the following information, which provides details about the event and library conditions at the time of the event:

- Event summary
- Event details, including status information
- Firmware versions, including MCB, RCU, CMB, and drive bricks
- Physical library configuration
- Library states, such as physical library online or offline, partitions online or offline, or robotics enabled or disabled.
• Time stamps of recent activity
• Report summary
• Report details for the event

The repair page attachment is in HTML format.

**NOTE:**
Before you perform the following procedure, you must make sure that e-mail is appropriately configured in the LMC so that the library can send event details to the recipient. See Configuring E-mail.

To mail, save, or print information for a particular event, perform the following steps:

1. Make sure that the Event Details dialog box displays information for the event that you want to send. See Displaying Event Lists and Viewing Event Details.
2. Click **Send**. The Event Information dialog box appears.
3. Perform one of the following tasks:
   • To indicate that you want to send the information as an e-mail message to a recipient, select **Email**, and then either type an e-mail address in the **Email** text box or select an existing address from the drop-down list. You can type a comment in the **Comment** text box to send with the information.
   • To indicate that you want to save the information, select **Save**, and then either type in the **Save** text box a path and a file name to which you want the information saved, or click **Browse** to specify a location and a file name.

**NOTE:**
The **Save** option is available to remote client users only. It appears grayed out on the OCP.

• To indicate that you want to send the information to a printer, select **Print**.

**NOTE:**
The **Print** option is available to remote client users only. It appears grayed out on the OCP.

4. To send, click **OK**.

**Running Verification Tests to Determine Issue Resolution**

A event is always generated against a particular FRU when the library detects an issue. Therefore, the library provides FRU tests that you can run to determine whether the conditions that caused the event have been resolved. Running the FRU tests is an important part of ensuring that the system is working properly.

The library can detect issues under the following contexts:

• When the library polls at regular intervals, or
• When a host or user commands the library to perform an operation (such as occurs with GUI commands, host inventory, and host move media).
FRU tests are designed to help resolve issues under the second context. During FRU testing, the library creates operational scenarios to evaluate the functionality of a FRU. FRU tests attempt to evaluate as many aspects of the FRU as possible, but they might not fully recreate the conditions that caused the original event. The library cannot recreate all conditions and, therefore, the library does not provide tests for some FRUs.

The instructions on the event repair page direct you to run a FRU test if an applicable one exists. If you run the test and the results are all good, the library automatically transitions the event to the **Verified** state.

**NOTE:**

If you cannot run a test, make sure that you complete the repair page instructions and, if needed, physically examine the FRU. After you determine that the issue is resolved, manually transition the event to the **Closed** state. See Closing Events. After you close the event, the library transitions the event to the **Verified** state if it is able to do so.

You can access the tests in two ways:

- On the main LMC display, click **Tools > Verification Tests**. The **Verification Tests** dialog box appears. From this dialog box, you can choose from a variety of verification tests, including the FRU tests.
- On the **Event Details** dialog box, click **FRU Test**.

**NOTE:**

The **FRU Test** button is available only if the event FRU has an applicable verification test that you can run.

The **Verification Tests** dialog box appears with the appropriate test already selected and ready to start.

**Closing Events**

Manually close an event if all of the following conditions are true:

- You have completed the repair page instructions to resolve the issue (for example, replaced a FRU).
- The **FRU Test** button on the **Event Details** dialog box is not available. This means that an applicable verification test does not exist for the event FRU.

**NOTE:**

If the **FRU Test** button is available for an event, you should use it to access and run the verification test. You should not manually close it. The verification test determines whether the issue is resolved, and the library automatically transitions the event to the **Verified** state if the test passes without problems. See Running Verification Tests to Determine Issue Resolution.

- The issue has been resolved, but the event remains in an **Open** state (for example, when defective media has been replaced in the library).

You should manually transition an event to the **Closed** state after physically examining the FRU to make sure that the issue is resolved.
Closing Individual Events

To transition an event to the **Closed** state, perform the following steps:

1. Make sure that the **Event Details** dialog box displays information for the open event that you want to close. See Displaying Event Lists and Viewing Event Details.
2. Click **Close Event**.

   The event’s state changes to **Closed**. If the library is able to do so, it automatically transitions the closed event to the **Verified** state.

**NOTE:**

If the identical issue occurs again within 30 minutes after the event transitions to the Closed or Verified state, the library reopens the event and increments the event duplicate count.

Events that are in the Closed or Verified state for more than 30 minutes cannot be reopened. In this case, if the identical problem occurs again, the library creates a new event.

Closing Multiple Events

You can use this method when you have many events relating to the same issue, for example, when you have many drives in a library or many tape alerts.

To transition multiple events to the Closed state, do the following:

1. On the **Event List** dialog box, select each event you want to close by clicking the check box. See Displaying Event Lists and Viewing Event Details.
2. Click **Close Events**.
3. In the **Attention** message box, click **Yes** to confirm that you want to close multiple events.

   The event state changes to Closed. If the library is able to do so, it automatically transitions the closed events to the Verified state.

Generating the Events Report

The Events Report lets you see how many events occurred in a particular time period. You can choose to group events by subsystem, module, or FRU, and the results can be presented as a rollup summary or as a trend so you can see if the number of issues is increasing or decreasing over time. Also, the report results can be presented in different chart formats, such as bar graphs or pie charts.

After generating a report, you can print it or save it as a PDF file. In addition, you can save a set of report criteria as a template for reports you frequently generate.

Specifying Events Report Criteria

To generate the Events Report, first specify the report criteria, and then view the report.

1. Log on as an administrator.
2. On the menu bar, click **Tools > Reports > Events**.

   The **Report Criteria** dialog box appears.
3. Under **Specify Report Criteria**, click criteria options in the lists to customize the content and appearance of the **Events Report**.

Table 38 summarizes the available report criteria options.

**Table 38 Events Report Criteria**

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Range</strong></td>
<td>Specifies the range of time to cover in the report. Choices include:</td>
</tr>
<tr>
<td></td>
<td>• Historical</td>
</tr>
<tr>
<td></td>
<td>• Current Month</td>
</tr>
<tr>
<td></td>
<td>• Last Month</td>
</tr>
<tr>
<td></td>
<td>• Last 3 Months</td>
</tr>
<tr>
<td></td>
<td>• Last 6 Months</td>
</tr>
<tr>
<td></td>
<td>• Last 12 Months</td>
</tr>
<tr>
<td></td>
<td>• Last 30 Days (default)</td>
</tr>
<tr>
<td></td>
<td>• Last 7 Days</td>
</tr>
<tr>
<td><strong>Grouping</strong></td>
<td>Determines how events are grouped in the report. Choices include:</td>
</tr>
<tr>
<td></td>
<td>• Subsystem (default)—events are grouped according to subsystem</td>
</tr>
<tr>
<td></td>
<td>• FRU Category—events are grouped according to FRU category</td>
</tr>
<tr>
<td></td>
<td>• FRU Id—events are grouped according to FRU ID</td>
</tr>
<tr>
<td></td>
<td>• Serial Number—events are grouped according to module serial number</td>
</tr>
<tr>
<td></td>
<td>• Selected Drive by Physical SN—events are grouped according to drive</td>
</tr>
<tr>
<td></td>
<td>serial number (displays the <strong>Choose Drive</strong> dialog box)</td>
</tr>
<tr>
<td>Criteria</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| Attribute | Determines how events are identified in the report. Choices include:  
• All (default)—events are separated according to attribute (Failed, Degraded, Warning, or Other)  
• Total—events are not separated according to attribute |
| Type | Specifies the type of report. Choices include:  
• Rollup (default)—displays the values based on the selected grouping  
• Trend—shows the occurrence of events over time (grouping criteria is not used) |
| Chart | Determines the type of chart. Choices include:  
• Area  
• Bar  
• Bar 3D  
• Line  
• Stacked Area  
• Stacked Bar (default)  
• Stacked Bar 3D  
• Pie  
• Pie 3D |

4. Click **View**.  
The Report Viewer dialog box appears. The content and appearance of the report varies depending on the selected criteria.

5. When you are finished viewing the Events Report, click **Close**.

6. To close the Report Criteria dialog box, click **Cancel**.

**Printing or Exporting a Report to PDF**

After generating the Events Report, you can print it or export it to a PDF file.

To print or export a report to PDF:

1. On the Report Viewer dialog box, click **Preview**. The Print Preview dialog box appears.

2. Do one or more of the following:  
• To navigate through the pages of the report, click **Back** or **Next**.  
• To increase or decrease the magnification of the report, click **Zoom In** or **Zoom Out**.  
• To print the report, click **Print**. Specify print options, and then click **OK**.  
• To save the report as a PDF file, click **PDF**. Specify a file path and file name, and then click **Confirm**.

3. When you are finished working with the Print Preview dialog box, click **Close**.

**NOTE:**

You cannot print reports or save them to a PDF file using the OCP.
Exporting a Report to an E-mail or a Text File

Instead of viewing the report as a chart, you can e-mail the report data to an e-mail address. Or export the report data to a comma delimited text file (*.csv) for use in other programs.

1. On the menu bar, click **Tools > Reports > Events**. The **Report Criteria** dialog box appears.

2. Under **Specify Report Criteria**, click criteria options in the lists to customize the content and appearance of the Events Report.
   Table 6 summarizes the available report criteria options.

3. Click **Export**.
   The **Export Raw Data** dialog box appears.

4. Do one of the following:
   • To send the report data to an e-mail address, click **Email**. Type or select the e-mail address, type an optional comment in the Comment box, and then click **OK**.
   • To save the report data to a comma delimited text file, click **Save**. Specify a file path and file name, and then click **OK**.

5. To close the Report Criteria dialog box, click **Cancel**.

Saving a Report Template

If you frequently generate the Events Report with the same set of report criteria, save the criteria as a template. Loading the template recalls the saved report criteria and lets you quickly generate a report based on the saved criteria.

1. On the menu bar, click **Tools > Reports > Events**. The **Report Criteria** dialog box appears.

2. Under **Specify Report Criteria**, click criteria options in the lists to customize the content and appearance of the Events Report.
   Table 6 summarizes the available report criteria options.

3. Under **Templates**, click **Save**.

4. Type a name for the template, and then click **OK**.
   The template appears in the list under Templates.

5. To load the saved report criteria at a later time, click the template in the list, and then click **View** to generate the report.

6. To close the Report Criteria dialog box, click **Cancel**.

Interpreting LEDs

LEDs can help you assess the state of a library component. The primary library LEDs can be grouped as follows:

• Blade status LEDs
• Drive status LEDs
• Fibre port link LEDs
• MCB port LEDs
• LBX terminator LEDs
• Power supply status LEDs
Interpreting Blade Status LEDs

Each of the following library blades has a set of green, amber, and blue LEDs that indicate blade processor status, health status, and power control status:

- Management control blade (MCB)
- Control management blade (CMB)
- Robotics control unit (RCU)
- Library motor drive (LMD)
- Ethernet Expansion Blade

Figure 27 shows the locations and colors of the status LEDs on the five blades that can be in the library.

Blade status LEDs provide troubleshooting information that you can use in conjunction with events that the library creates. However, the LEDs might not directly correspond to events. The LEDs can indicate a firmware or hardware problem so severe that the library cannot create or display an event. For example, if the MCB firmware becomes inoperable, the amber LED flashes at 1Hz, but the library might not be able to display any related events.
For a description of each LED color and what its state might mean, see Table 39. For a description of how the blade status LEDs appear under normal conditions, see Table 40.

### Table 39 Explanations of blade status LED states

<table>
<thead>
<tr>
<th>LED Color</th>
<th>Represents</th>
<th>Possible states and explanations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Processor status</td>
<td>• Solid off — blade main processor is not operating (or blade is booting)&lt;br&gt;• Solid on — blade main processor is not operating (however, this does not apply to the LMD; solid on indicates that the LMD main processor is operating normally)&lt;br&gt;• Blinks one time every second (1 Hz) — blade main processor is operating normally&lt;br&gt;• Blinks 10 times every second (10 Hz) — identify mode&lt;br&gt;• Solid on for three seconds, then blinks twice at 1 Hz, and then repeats — blade firmware is downloading</td>
</tr>
<tr>
<td>Amber</td>
<td>Health status</td>
<td>• Solid off — blade power and control subsystem is operating normally&lt;br&gt;• Solid on — blade power and control subsystem has failed&lt;br&gt;Solid on also can mean that the blade power and control subsystem firmware is autoleveling. In conjunction with the blue amber LED blinking one time every 10 seconds, this is a normal condition. Autoleveling takes about three minutes for each blade, and blades within an I/O management unit autolevel in series. It can take as long as three minutes for the power and control subsystem to download. Never remove a blade when the amber LED is solid on unless it has been on continuously for at least 10 minutes.</td>
</tr>
<tr>
<td>Blue</td>
<td>Power control status</td>
<td>• Solid off — blade is not receiving power&lt;br&gt;• Solid on — blade is powered down; ready to be replaced (swap mode)&lt;br&gt;• Blinks one time every 10 seconds (flash) — blade is powered on; operating normally</td>
</tr>
</tbody>
</table>

### Table 40 Blade Status LED States - Normal Conditions

<table>
<thead>
<tr>
<th>LED Color</th>
<th>State and Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Blinks one time every second (1 Hz) — blade main processor is operating normally (however, this does not apply to the LMD; solid on indicates that the LMD main process is operating normally)</td>
</tr>
<tr>
<td>Amber</td>
<td>Solid off — no errors are detected; blade PIP is operating normally</td>
</tr>
<tr>
<td>Blue</td>
<td>Blinks one time every 10 seconds (flash) — blade is powered on; operating normally</td>
</tr>
</tbody>
</table>
**Actions Based on LED States**

When the system is operating properly, service actions should be based on events first and foremost. However, some situations occur when the amber LED indicates problems that are not detected by the event system. You should always act on any amber LED that is solidly on, which indicates that the component power and control subsystem has failed. In this case, replace the component.

When you replace a blade FRU or escalate a problem based on LED states, perform the following steps:

1. Observe and report the timing pattern of the blue, amber, and green LED group. Spend at least 30 seconds observing the LEDs and record the results in the service request (SR) and on any equipment failure report form that you return with the part. Proper reporting of all LED states is critical for determining the root cause of the failure.
2. Create a support ticket and send it to technical support for analysis.

**Interpreting Drive Status LEDs**

The library reports all drive issues that can affect customer operations. In addition to examining library reports, you should observe drive sled link LED and status LED activity.

*Figure 28* shows the locations of the status LEDs and the FC link LED on the rear of a drive sled.

![Figure 28 Rear View of FC Drive Sled (LTO-4 and LTO-5 Drives)](image)

1. LTO-4 drive
2. Status LEDs
3. Ethernet port
4. LTO-5 drive
5. Link LEDs (FC Port 1 — left, FC Port 2 — right)

*Figure 28 Rear View of FC Drive Sled (LTO-4 and LTO-5 Drives)*
Table 41 describes how to interpret the drive sled status LED activity that you might see on the rear of a drive sled.

**Table 41 Drive Sled Status LED States**

<table>
<thead>
<tr>
<th>LED color</th>
<th>Represents</th>
<th>Possible states and explanations</th>
</tr>
</thead>
</table>
| Green     | Processor status | • Solid off — drive sled main processor is not operating (or blade is booting)  
|           |             | • Solid on — drive sled main processor is not operating  
|           |             | • Blinks one time every second (1 Hz) — drive sled main processor is operating normally  
|           |             | • Blinks 10 times every second (10 Hz) — identify mode  
|           |             | • Solid on for three seconds, then blinks twice at 1 Hz, and then repeats — drive sled or drive brick firmware is downloading  
|           |             | • Blinks three times in three seconds (1 Hz), then pauses (solid off), and then repeats — drive brick is activating (varying on) |
| Amber     | Health status | • Solid off — drive sled controller (drive DC to DC converter [DDC]) is operating normally  
|           |             | • Solid on — drive sled DDC has failed |
| Blue      | Power control status | • Solid off — drive sled is not receiving power  
|           |             | • Solid on — drive brick is powered down; ready to be replaced (swap mode) or varied on  
|           |             | • Blinks one time every 10 seconds (flash) — drive brick is powered on; operating normally |

**Table 42 Blade Status LED States - Normal Conditions**

<table>
<thead>
<tr>
<th>LED Color</th>
<th>State and Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>Blinks one time every second (1 Hz) — drive sled main processor is operating normally. The green LEDs for all drive sleds that are operating normally blink together.</td>
</tr>
<tr>
<td>Amber</td>
<td>Solid off — no errors are detected; drive sled controller is operating normally.</td>
</tr>
<tr>
<td>Blue</td>
<td>Blinks one time every 10 seconds (flash) — drive sled is powered on; operating normally.</td>
</tr>
</tbody>
</table>

**Interpreting Fibre Port Link LED**

A fibre port link LED shows the state of the Fibre Channel link and whether the link is ready to transmit commands.
Drive Sled Fibre Channel Link LED

The Fibre Channel link LED for a drive sled is located on the rear of the drive sled. Figure 28 shows the location of the Fibre Channel link LED on the rear of the LTO drive sled.

**NOTE:**
Table 43 describes the Fibre Channel link LED activity on the rear of the LTO drive sled.

<table>
<thead>
<tr>
<th>LED color</th>
<th>Represents</th>
<th>State and explanation</th>
</tr>
</thead>
</table>
| Green     | LIP and activity | • Solid on — loop initialization protocol (LIP) has occurred (for example, Passive Mode).  
• Blinks at irregular intervals — host command/data activity is occurring. |
| Amber     | Online and light detected | • Solid on — the library has enabled the drive data bus; it can detect light through a fiber optic cable.  
• Blinks at regular intervals — the library has enabled the drive data bus, but light is not detected through the fiber optic cable. |
| No color  |            | Solid off — the library has not enabled the drive data bus or the drive brick is varied off. If the drive brick is varied off, the blue status LED will be solid on. |

Interpreting MCB Port LEDs

The MCB has LEDs for the Ethernet and Fibre Channel ports.

MCB Ethernet Port LEDs

The LEDs on the MCB Ethernet port indicate status and activity.

*Figure 29* shows the locations and colors of the MCB Ethernet port LEDs.
1. MCB Ethernet port LEDs

Figure 29 Locations - Colors of MCB Ethernet Port LEDs

Table 44 describes how to interpret the Ethernet port LED activity that you might see.

**Table 44 MCB Ethernet Port LED Activity**

<table>
<thead>
<tr>
<th>LED Color</th>
<th>Possible States and Explanations</th>
</tr>
</thead>
</table>
| Green     | • Solid on — the link is up; data can be sent or received through the Ethernet port  
           | • Solid off — the link is not up; data cannot be sent or received through the Ethernet port |
| Amber     | • Flashes at irregular intervals — data activity is occurring through the Ethernet port  
           | • Solid off — no data activity is occurring through the Ethernet port |

**MCB Fibre Channel Port LEDs**

The LEDs for the MCB Fibre Channel ports are for future use. Ignore LED behaviors that might appear.

Figure 30 shows the locations and colors of the LEDs.
Interpreting LBX Terminator LEDs

The LBX terminator has six green LEDs that indicate the presence of modules in the library.

![Figure 31 Locations of LBX Terminator LEDs](image)

**NOTE:**
See Table 45 for callout explanations of Figure 31.

### Table 45 LBX LED Version 03

<table>
<thead>
<tr>
<th>LED On/Off Combinations</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 2 3 4 5 6</td>
<td></td>
</tr>
<tr>
<td>Off Off Off Off Off Off</td>
<td>Robotics are disabled, the access door is open, or the LBX terminator is misaligned.</td>
</tr>
<tr>
<td>On Off Off Off Off Off</td>
<td>The library has one control module and no expansion modules.</td>
</tr>
<tr>
<td>On Off Off On Off Off</td>
<td>The library has one control module and one expansion module.</td>
</tr>
</tbody>
</table>
## LED On/Off Combinations

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>On</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>On</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>Off</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>Off</td>
<td></td>
</tr>
</tbody>
</table>

The library has one control module and two expansion modules.
The library has one control module and three expansion modules.
The library has one control module and four expansion modules.
The library has one control module and five expansion modules.
The library has one control module and six expansion modules.
The library has one control module and seven expansion modules.
The library has one control module and eight expansion modules.
The library has one control module and nine expansion modules.
The library has one control module and ten expansion modules.
The library has one control module and eleven expansion modules.

### Interpreting Power Supply LEDs

Power supply problems are reported in events. To physically identify a power supply, note the power supply number and module number in the event details. Modules can have up to two power supplies each. The top supply is #1 and the bottom supply is #2.

![NOTE:](image)

The library can be physically configured to include up to seven expansion modules. If any of the expansion modules include drives, those modules also will have power supplies.

*Figure 32* shows the locations and colors of the power supply LEDs.
1. Power supply LEDs

**Figure 32 Locations and Colors of Power Supply LEDs**

Table 46 describes how to interpret LED activity that you might see.

**Table 46 Explanation of Power Supply LED States**

<table>
<thead>
<tr>
<th>LED Color</th>
<th>Represents</th>
<th>Possible States and Explanations</th>
</tr>
</thead>
</table>
| Green (top LED)    | AC OK      | • Solid on — power supply AC input is above minimum requirements to operate
               |            | • Solid off — power supply AC input is below minimum requirements to operate                     |
| Green (middle LED) | DC OK      | Solid on — power supply output voltage is within specifications
               |            | • Solid off — power supply’s output voltage is outside of specifications                         |
| Blue (bottom LED)  | Fault      | • Solid on — indicates any of the following conditions:
               |            | • Power supply output is outside of specifications
               |            | • Current limit has been exceeded
               |            | • Temperature limit has been exceeded
               |            | • AC input is below minimum operating voltage
               |            | • PDU is on, but the Power button on the library’s indicator panel is off
               |            | • Fan failed while AC input is present and above minimum operating voltage
               |            | • Solid off — no faults are detected
Accessing Online Help

For further help, you can access the library Online Help system.

- To access the entire Online Help system, click Help, then Content.
- To access context-sensitive help, click Help from any dialog box.
9 Support and other resources

For more information and support, see the following:

• Contacting HP
• HP web sites
• Typographic conventions
• Rack stability
• HP product documentation survey

Contacting HP

For worldwide technical support information, see the HP support website:

http://www.hp.com/support

Before contacting HP, collect the following information:

• Product model names and numbers
• Support contract (if applicable)
• Product serial numbers
• Error messages
• Operating system type and revision level
• Detailed questions

HP websites

For additional information, see the following HP websites:

• http://www.hp.com
• http://www.hp.com/go/storage
• http://www.hp.com/service_locator
• http://www.hp.com/support/manuals
• http://www.hp.com/support/downloads
• http://www.hp.com/storage/whitepapers

Typographic conventions

Table 47 Document conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Element</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue text: Table 47</td>
<td>Cross-reference links and e-mail addresses</td>
</tr>
<tr>
<td>Blue, underlined text: <a href="http://www.hp.com">http://www.hp.com</a></td>
<td>Website addresses</td>
</tr>
<tr>
<td>Convention</td>
<td>Element</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Bold text**       | • Keys that are pressed  
                       • Text entered into a GUI element, such as a box  
                       • GUI elements that are clicked or selected, such as menu  
                       and list items, buttons, tabs, and check boxes |
| **Italic text**     | Text emphasis                                                          |
| **Monospace text**  | • File and directory names  
                       • System output  
                       • Code  
                       • Commands, their arguments, and argument values |
| **Monospace, italic text** | • Code variables  
                       • Command variables |
| **Monospace, bold text** | Emphasized monospace text |

⚠️ **WARNING!**  
Indicates that failure to follow directions could result in bodily harm or death.

⚠️ **CAUTION:**  
Indicates that failure to follow directions could result in damage to equipment or data.

⚠️ **IMPORTANT:**  
Provides clarifying information or specific instructions.

⚠️ **NOTE:**  
Provides additional information.

**Rack stability**  
Rack stability protects personnel and equipment.
WARNING!
To reduce the risk of personal injury or damage to equipment:
• Extend leveling jacks to the floor.
• Ensure that the full weight of the rack rests on the leveling jacks.
• Install stabilizing feet on the rack.
• In multiple-rack installations, fasten racks together securely.
• Extend only one rack component at a time. Racks can become unstable if more than one component is extended.

HP product documentation survey
Are you the person who installs, maintains, or uses this HP storage product? If so, we would like to know more about your experience using the product documentation. If not, please pass this notice to the person who is responsible for these activities.

Our goal is to provide you with documentation that makes our storage hardware and software products easy to install, operate, and maintain. Your feedback is invaluable in letting us know how we can improve your experience with HP documentation.
Please take 10 minutes to visit the following web site and complete our online survey. This will provide us with valuable information that we will use to improve your experience in the future.

http://www.hp.com/support/storagedocsurvey

Thank you for your time and your investment in HP storage products.
Enabling the ESKM License Key

To enable the ESKM license key:

1. From the menu bar, click **Setup > Licenses**.
   The **Licenses** dialog box appears.
   This dialog box lists the licensed features for your library, including their status, expiration date, and quantity.

2. To enable a license key, type the appropriate license key in the **Enter License Key** box.
   You do not need to highlight the feature before you enter a license key. License keys are not case sensitive and are all inclusive. For example, J2BGL-22622-52C22 can be entered as j2bgl22622-52c22.549.

3. Click **OK**.

Configuring Encryption Key Management

The HP ESL G3 Key Management Setup Wizard guides you through configuring the library and drives to enable a key management strategy using HP ESKM. Ensure all library configurations are complete, and the library is fully operational prior to configuring the encryption key management feature. Also, before using the library configuration wizard, be sure to complete all steps in the ESKM Configuration Guide for use with HP Tape Libraries.

The following sections are available to initially configure, or to modify the configuration of, the encryption key management feature:

- Using Select Key Management Type
- Using Update Key Manager Configuration
- Using Update Key Manager Certificate
- Using Verify Key Manager Connectivity

**NOTE:**

Each ESL G3 library must have a user account on the ESKM servers, and that account must exist prior to running the Key Management Setup Wizard. The steps to configure the library user account are in the document **ESKM Configuration Guide for use with HP Tape Libraries.**
NOTE:
HP strongly recommends that the ESKM servers be tested after the Setup Wizard is complete, to ensure encryption is functioning, and to ensure that the cluster failover configuration is correct. The steps to perform those validation tests are documented in *ESKM Configuration Guide for use with HP Tape Libraries*.

Using Select Key Management Type

Keys may be managed by either a Key Manager, or by your backup application software. To make the selection:

1. Log on as security.
2. Click **Setup > Encryption > Key Management Setup Wizard**.
3. Click **Next** to display the **Key Management Selection** page of the wizard, on which **HP Enterprise Secure Key Manager** is selected by default.
4. Click **Next** to display the **Certificate Authority Information** page of the wizard.
5. Read through the information, ensure you have met the prerequisites, then click **Next**.
6. Click to select the radio button next to the type of Certificate Authority to use, then click **Next**.
7. If you selected **HP Enterprise Secure Key Manager (E SKM) Local Authority**:
   
a. Follow the instructions on the **Retrieve the Local Certificate Authority Certificate**, then click **Next**.

b. Locate and copy the signed certificate from the ESKM local authority, paste the text of the certificate into the text box on the **Certificate Authority Certificate Entry** page, then click **Next**.

c. Follow the instructions on the **Library Certificates Information** screen, then click **Next**.

d. Copy the text of the certificate shown, then click **Next**.

e. Read the **Sign your Library Certificate** page, follow the instructions, then click **Next**.

f. Paste the text of the certificate into the text box on the **Signed Certificate Entry** page, then click **Next**.

g. Read the **HP Enterprise Secure Key Manager Information** page and click **Next**.

h. Type the **Library Username** and **Password** in the appropriate fields in the **HP Enterprise Secure Key Manager Configuration** page, then click **Next**.

   **IMPORTANT:**
   
   You must first configure the username and password for this library in the ESKM Management Console.

i. In the **Tier #1** region of the dialog box, type the name of an ESKM Node address into the **ESKM Node Address #1** field, add any other node addresses to the tier as appropriate.

   **NOTE:**
   
   Tiers are a way to indicate which ESKM servers a library should contact first when it needs to get an encryption key. For example, to avoid network performance issues, you might want a library to access local ESKM servers before remote ESKM servers. To specify this, you would enter the local ESKM server in tier 1 and the remote ESKM servers in tier 2. The library will try to get a key from any of the ESKM servers in tier 1 first. If none of the ESKM servers in tier 1 respond, it will move to tier 2. If you add or remove an ESKM from your network, you will need to update the tier information by running the Key Management Setup Wizard and selecting Update Key Manager Configuration on the first page of the wizard.

j. To change the SSL port number for the node in the tier from the default, click **Advanced**, enter the correct value in the **Port Number** field, then click **OK**.

k. To add another tier, select the **Add another tier** box and enter information as you did for Tier #1.

l. In the **Key Management Setup Summary** page of the wizard, review the information, correct it if necessary, then click **Finish**.

---

**HP Enterprise Systems Library (ESL) G3 Tape Library**

251
8. If you selected Third-Party Certificate Authority:
   a. Copy the signed certificate text (without extra spaces before or after the text) into the text box on the Certificate Authority Certificate Entry, then click Next.
   b. Follow the instructions on the Library Certificates Information screen, then click Next.
   c. Copy the text of the certificate shown, then click Next.
   d. Paste the text of the certificate into the text box on the Signed Certificate Entry page, then click Next.
   e. Read the HP Enterprise Secure Key Manager Information page and click Next.
   f. Type the Library Username, and Password in the appropriate fields in the HP Enterprise Secure Key Manager Configuration page, then click Next.

   **IMPORTANT:**
   You must first configure the username and password for this library in the ESKM Management Console.

   g. In the Tier #1 region of the dialog box, type the name of an ESKM Node address into the ESKM Node Address #1 field, add any other node addresses to the tier as appropriate.
   h. To change the SSL port number for the node in the tier from the default, click Advanced, enter the correct value in the Port Number field, then click OK.
   i. To add another tier, select the Add another tier box and enter information as you did for Tier #1.
   j. In the Key Management Setup Summary page of the wizard, review the information, correct it if necessary, then click Finish.

Using Update Key Manager Configuration
Select this option to modify any key manager configuration property except the Certificate Authority certificate, and the client certificate:

1. Log on as security.
2. Click Setup > Encryption > Key Management Setup Wizard.
3. Click Next to display the Key Management Selection page of the wizard.
4. Click to select the radio button for Update Key Manager Configuration, then click Next.
5. Read the information that displays, then click Next.
6. The configuration screens display the current settings. Either retain the values, or type new values into the appropriate fields, then click Next.
7. In the Key Management Setup Summary page of the wizard, review the information, correct it if necessary, then click Finish.

Using Update Key Manager Certificate
When a library client certificate expires, you must enter information for a new certificate. Use this procedure to change the Certificate Authority certificate or enter the new certificate information:

1. Log on as security.
2. Click **Setup > Encryption > Key Management Setup Wizard**.
3. Click **Next** to display the **Key Management Selection** page of the wizard.
4. Click to select the radio button for **Update Key Manager Certificate**, then click **Next**.
5. Click to select the radio button for the appropriate Certificate Selection (CA certificate, library certificate, or both), then click **Next**.
6. Read the information that displays, follow the instructions, then click **Next**.
7. The configuration screens display the current settings. Either retain the values, or type new values into the appropriate fields, then click **Next**.
8. In the **Key Management Setup Summary** page of the wizard, review the information, correct it if necessary, then click **Finish**.

**Using Verify Key Manager Connectivity**

This option may be run at any time. The library will login to the key management servers using SSL/TLS, authenticate using the username and password, and retrieve the key generation policies for each partition. To verify key manager connectivity:

1. Click **Setup > Encryption > Key Management Setup Wizard**.
2. Click **Next** to display the **Key Management Selection** page of the wizard.
3. Click to select the radio button for **Verify Key Manager Connectivity**, then click **Next**.
4. In the **Key Management Setup Summary** page of the wizard, review the information, correct it if necessary, then click **Finish**.
5. A dialog box displays the connectivity status. Click **OK** to exit the dialog box.

**Changing library partitions after initial ESKM setup**

When you add or remove partitions in a library that is enrolled with the ESKM, you must also add or remove the key generation policy for that partition using the ESKM Management Console software. (For instructions, see the **ESKM User Guide for use with HP Tape Libraries**.) Until the library configuration and the ESKM policies match, the library will report an Invalid Encryption Configuration error.
Frequently Asked Questions

Where do I find installation instructions? The library requires that a trained HP Support Engineer perform the installation.

Where are error messages described? When the library detects issues, it sends you e-mail notifications and creates events that provide you with detailed information about the issues and corrective actions you can perform. A event can direct you to obtain further help from technical support. For more information about troubleshooting, see Chapter 8.

How do I clean a drive? Use your backup software to clean the drives. For detailed instructions, see Using Cleaning Cartridges.

How do I know when the drives need cleaning? The host application informs you when drives need to be cleaned. See Using Cleaning Cartridges.

What is a partition? A partition is an abstraction of a single underlying physical library that presents the appearance of multiple, separate libraries for purposes of file management, access by multiple users, or dedication to one or more host applications. It is a collection of real physical elements, combined to create a grouping that is different from the physical library, and is often dedicated to a single host application. For example, you can choose to run one software application in one partition and a different software application in a second partition. For more information, see Working With Partitions. To learn how to create a partition, see Creating Partitions.

Where can I find the library serial number? The serial number appears in the ID column for the first line of output on the System Status dialog box (select Monitor > System). Use the serial number when contacting technical support for assistance.

How many characters can be in the barcodes? For LTO media barcodes, the library dynamically supports 1 to 14 characters for volume serial number plus a two-character media type identifier. The image below is an example of a supported LTO barcode label.

What barcode formats are supported? Cartridges must have an external barcode label that is machine-readable to identify the volume serial number. A barcode must use only uppercase letters A to Z and/or numeric values 0 to 9. The library currently supports Code 39 (3 of 9) type barcode labels.

What do I do if I lose my password? Contact technical support, and they will tell you how to reset the password. See Contacting HP.

What do I do if I lose power during a backup? If your library contains a redundant power supply, it is unlikely that power will ever be completely unavailable to the library.

The library should recover even if power goes out completely during a backup. If power remains off, press the Power button, and leave it in the off position until you can obtain a reliable power source. When the power to the library is turned back on, the library will recover. You must re-run the backup using your application software.
If the library does not automatically come back up after a power outage, cycle library power. Cycling library power involves shutting down the library, powering it off, and then powering it on. For more information, see Shutting Down/Rebooting the Library, Powering Off the Library, and Powering On the Library. The blue LED on the power supply will be on and not blinking.
C Product Safety Statements

This product is designed for data storage and retrieval using magnetic tape. Any other application is not considered the intended use. HP will not be held liable for damage arising from unauthorized use of the product. The user assumes all risk in this aspect.

This unit is engineered and manufactured to meet all safety and regulatory requirements. Be aware that improper use may result in bodily injury, damage to the equipment, or interference with other equipment.

⚠️ CAUTION:
Read all operating instructions in this manual before operating this product.

⚠️ WARNING!
Read all operating instructions in this manual before powering on or using this equipment.

‼️ NOTE:
When drive sled positions are empty, drive cover plates must be installed and in place at all times to prevent access into the empty drive sled positions, and promote proper air flow and cooling.

Mechanical Locks

The access and service doors can be locked with a key. The key should be kept by an authorized person at your company. Access to the interior of the library is both a data-integrity and a safety issue.

Power Button on the Library Indicator Panel

Switching off the Power button on the indicator panel, located on the front of the library, removes power from the electronics, which causes the picker to stop immediately. This button also removes power from the drives.

⚠️ WARNING!
This power button functions as a power interrupt only. To completely remove all power before servicing or in an emergency, turn off the circuit breaker on the power distribution unit, and then disconnect the power cord from the electrical source.
Federal Communications Commission notice

Part 15 of the Federal Communications Commission (FCC) Rules and Regulations has established Radio Frequency (RF) emission limits to provide an interference-free radio frequency spectrum. Many electronic devices, including computers, generate RF energy incidental to their intended function and are, therefore, covered by these rules. These rules place computers and related peripheral devices into two classes, A and B, depending upon their intended installation. Class A devices are those that may reasonably be expected to be installed in a business or commercial environment. Class B devices are those that may reasonably be expected to be installed in a residential environment (for example, personal computers). The FCC requires devices in both classes to bear a label indicating the interference potential of the device as well as additional operating instructions for the user.

FCC rating label

The FCC rating label on the device shows the classification (A or B) of the equipment. Class B devices have an FCC logo or ID on the label. Class A devices do not have an FCC logo or ID on the label. After you determine the class of the device, refer to the corresponding statement.

Class A equipment

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference to radio communications. Operation of this equipment in a residential area is likely to cause harmful interference, in which case the user will be required to correct the interference at personal expense.

Class B equipment

This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of the following measures:

- Reposition or relocate the receiving antenna.
- Increase the separation between the equipment and receiver.
- Connect the equipment into an outlet on a circuit that is different from that to which the receiver is connected.
- Consult the dealer or an experienced radio or television technician for help.
Declaration of Conformity for products marked with the FCC logo, United States only

This device complies with Part 15 of the FCC Rules. Operation is subject to the following two conditions: (1) this device may not cause harmful interference, and (2) this device must accept any interference received, including interference that may cause inappropriate operation.

For questions regarding this FCC declaration, contact us by mail or telephone:

- Hewlett-Packard Company P.O. Box 692000, Mail Stop 510101 Houston, Texas 77269-2000
- Or call 1-281-514-3333

Modification

The FCC requires the user to be notified that any changes or modifications made to this device that are not expressly approved by Hewlett-Packard Company may void the user's authority to operate the equipment.

Cables

When provided, connections to this device must be made with shielded cables with metallic RFI/EMI connector hoods in order to maintain compliance with FCC Rules and Regulations.

Mercury Statement

Required information

Hg

Projectors, LCD displays, and some multifunction printers may use lamp(s) that contain a small amount of mercury for energy-efficient lighting purposes. Mercury lamps in these products are labeled accordingly. Please manage the lamp according to local, state, or federal laws. For more information, contact the Electronic Industries Alliance at www.eiae.org. For lamp-specific disposal information check www.lamprecycle.org.

Canadian notice (Avis Canadien)

Class A equipment

This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.

Cet appareil numérique de la class A respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.
Class B equipment

This Class B digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.

Cet appareil numérique de la class B respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

European Union notice

This product complies with the following EU directives:

• Low Voltage Directive 2006/95/EC
• EMC Directive 2004/108/EC

Compliance with these directives implies conformity to applicable harmonized European standards (European Norms) which are listed on the EU Declaration of Conformity issued by Hewlett-Packard for this product or product family.

This compliance is indicated by the following conformity marking placed on the product:

![CE mark](image)

This marking is valid for non-Telecom products and EU harmonized Telecom products (e.g., Bluetooth).

Certificates can be obtained from [http://www.hp.com/go/certificates](http://www.hp.com/go/certificates).

Hewlett-Packard GmbH, HQ-TRE, Herrenberger Strasse 140, 71034 Boeblingen, Germany

Japanese notices

Japanese VCCI-A notice

この装置は、クラスA情報技術装置です。この装置を家庭環境で使用すると電波妨害を引き起こすことがあります。この場合には使用者が適切な対策を講ずるよう要求されることがあります。 VCCI-A

Japanese VCCI-B notice

この装置は、クラスB情報技術装置です。この装置は、家庭環境で使用することを目的としていますが、この装置がラジオやテレビジョン受信機に近接して使用されること、受信障害を引き起こすことがあります。

取扱説明書に従って正しい取り扱いをして下さい。 VCCI-B
Japanese power cord statement

製品には、同梱された電源コードをお使い下さい。
同梱された電源コードは、他の製品では使用出来ません。

Please use the attached power cord.
The attached power cord is not allowed to use with other product.

Korean notices

Class A equipment

A급 기기 (업무용 정보통신기기)
이 기기는 업무용으로 전자파적합등록을 한 기기이오니
판매자 또는 사용자는 이 점을 주의하시기 바라며, 만약
음성화폐 또는 무선하우징을 때에는 가정용으로 교환하시기
바랍니다.

Class B equipment

B급 기기 (가정용 정보통신기기)
이 기기는 가정용으로 전자파적합등록을 한 기기로서
주거지역에서는 물론 모든 지역에서 사용할 수 있습니다.

Taiwanese notices

BSMI Class A notice

警告使用者:
這是甲類的資訊產品，在居住的
環境中使用時，可能會造成射頻
干擾；在這種情況下，使用者會
被要求採取某些適當的對策。
Taiwan battery recycle statement

Türkiye Cumhuriyeti: EEE Yönetmeliğine Uygundur

Türkçe Cumhuriyeti: EEE Yönetmeliğine Uygundur
Laser compliance notices

English laser notice

This device may contain a laser that is classified as a Class 1 Laser Product in accordance with U.S. FDA regulations and the IEC 60825-1. The product does not emit hazardous laser radiation.

⚠️ WARNING!

Use of controls or adjustments or performance of procedures other than those specified herein or in the laser product's installation guide may result in hazardous radiation exposure. To reduce the risk of exposure to hazardous radiation:

- Do not try to open the module enclosure. There are no user-serviceable components inside.
- Do not operate controls, make adjustments, or perform procedures to the laser device other than those specified herein.
- Allow only HP Authorized Service technicians to repair the unit.

The Center for Devices and Radiological Health (CDRH) of the U.S. Food and Drug Administration implemented regulations for laser products on August 2, 1976. These regulations apply to laser products manufactured from August 1, 1976. Compliance is mandatory for products marketed in the United States.

Dutch laser notice

⚠️ WAARSCHUWING: dit apparaat bevat mogelijk een laser die is geclassificeerd als een laserproduct van Klasse 1 overeenkomstig de bepalingen van de Amerikaanse FDA en de richtlijn IEC 60825-1. Dit product geeft geen gevaarlijke laserstraling af.

Als u bedieningselementen gebruikt, instellingen aanpast of procedures uitvoert op een andere manier dan in deze publicatie of in de installatiehandleiding van het laserproduct wordt aangegeven, loopt u het risico te worden blootgesteld aan gevaarlijke straling. Het risico van blootstelling aan gevaarlijke straling beperkt u als volgt:

- Probeer de behuizing van de module niet te openen. U mag zelf geen onderdelen repareren.
- Gebruik voor de laserapparatuur geen andere knoppen of instellingen en voor geen andere aanpassingen of procedures uit dan die in deze handleiding worden beschreven.
- Alleen door HP gecertificeerde technici mogen het apparaat repareren.
French laser notice

⚠️ AVERTISSEMENT : cet appareil peut être équipé d’un laser classé en tant que Produit laser de classe 1 et conforme à la réglementation de la FDA américaine et à la norme 60825-1 de l’IEC. Ce produit n’émite pas de rayonnements dangereux.

L’utilisation de commandes, de réglages ou de procédures autres que ceux qui sont indiqués ici ou dans le manuel d’installation du produit laser peut exposer l’utilisateur à des rayonnements dangereux. Pour réduire le risque d’exposition à des rayonnements dangereux :

- Ne tentez pas d’ouvrir le boîtier renfermant l’appareil laser. Il ne contient aucune pièce dont la maintenance puisse être effectuée par l’utilisateur.
- Tout contrôle, réglage ou procédure autre que ceux décrits dans ce chapitre ne doivent pas être effectués par l’utilisateur.
- Seuls les Mainteneurs Agréés HP sont habilités à réparer l’appareil laser.

German laser notice


Die Anleitungen in diesem Dokument müssen befolgt werden. Bei Einstellungen oder Durchführung sonstiger Verfahren, die über die Anleitungen in diesem Dokument bzw. im Installationshandbuch des Lasergeräts hinausgehen, kann es zum Austritt gefährlicher Strahlung kommen. Zur Vermeidung der Freisetzung gefährlicher Strahlungen sind die folgenden Punkte zu beachten:

- Versuchen Sie nicht, die Abdeckung des Lasermodule zu öffnen. Im Inneren befinden sich keine Komponenten, die vom Benutzer gewartet werden können.
- Benutzen Sie das Lasergerät ausschließlich gemäß den Anleitungen und Hinweisen in diesem Dokument.
- Lassen Sie das Gerät nur von einem HP Servicepartner reparieren.

Italian laser notice

⚠️ AVVERTENZA: AVVERTENZA Questo dispositivo può contenere un laser classificato come prodotto laser di Classe 1 in conformità alle normative US FDA e IEC 60825-1. Questo prodotto non emette radiazioni laser pericolose.

L’eventuale esecuzione di comandi, regolazioni o procedure differenti a quanto specificato nella presente documentazione o nella guida di installazione del prodotto può causare l’esposizione a radiazioni nocive. Per ridurre i rischi di esposizione a radiazioni pericolose, attenersi alle seguenti precauzioni:

- Non cercare di aprire il contenitore del modulo. All’interno non vi sono componenti soggetti a manutenzione da parte dell’utente.
- Non eseguire operazioni di controllo, regolazione o di altro genere su un dispositivo laser ad eccezione di quelle specificate da queste istruzioni.
- Affidare gli interventi di riparazione dell’unità esclusivamente ai tecnici dell’Assistenza autorizzata HP.
Disposal of waste equipment by users in private household in the European Union

This symbol means do not dispose of your product with your other household waste. Instead, you should protect human health and the environment by handing over your waste equipment to a designated collection point for the recycling of waste electrical and electronic equipment.

For more information, please contact your household waste disposal service.
Bulgarian recycling notice

Изхвърляне на отпадъчно оборудване от потребители в частни домакинства в Европейския съюз

Този символ върху продукта или опаковката му показва, че продуктът не трябва да се изхвърля заедно с другите битови отпадъци. Вместо това, трябва да предадете отпадъчното оборудване в предназначен за събирането му пункт за рециклиране на неколпазаено електрическо и електронно борудване. За допълнителна информация се свържете с фирмата по чистота, чиито услуги използвате.

Czech recycling notice

Likvidace zařízení v domácnostech v Evropské unii

Tento symbol znamená, že nesmíte tento produkt likvidovat spolu s jiným domovním odpadem. Místo toho měli chránit lidské zdraví a životní prostředí tím, že jej předáváte na k tomu určené sběrné pracoviště, kde se zabývají recyklaci elektrického a elektronického vybavení. Pro více informací kontaktujte společnost zabývající se sběrem a svozem domovního odpadu.

Danish recycling notice

Bortskaffelse af brugt udstyr hos brugere i private hjem i EU

Dette symbol betyder, at produktet ikke må bortskaffes sammen med andet husholdningsaffald. Du skal i stedet den menneskelige sundhed og miljøet ved at aflævere dit brugte udstyr på et dertil beregnet inddsamlingssted for af brugt, elektrisk og elektronisk udstyr. Kontakt nærmeste renovationsafdeling for yderligere oplysninger.

Dutch recycling notice

Inzameling van afgedankte apparatuur van particuliere huishoudens in de Europese Unie

Dit symbool betekent dat het product niet mag worden gedeponeerd bij het overige huishoudelijke afval. Bescherm de gezondheid en het milieu door afgedankte apparatuur in te leveren bij een hiervoor bestemd inzamelpunt voor recycling van afgedankte elektrische en elektronische apparatuur. Neem voor meer informatie contact op met uw gemeentereinigingsdienst.
Estonian recycling notice

Äravisatatate seadmete likvideerimine Euroopa Liidu eramajapidamistes


Finnish recycling notice

Kotitalousjätteiden hävittäminen Euroopan unionin alueella

Tämä symboli merkitsee, että laitetta ei saa hävittää muiden kotitalousjätteiden mukana. Sen sijaan sinun on suojattava ihmisten terveyttä ja ympäristöä toimittamalla käytöstä poistettu laite sähkö- tai elektroniikkajätteen kierrätyspisteeseen. Lisätietoja saat jätehuoltoyhtiölta.

French recycling notice

Mise au rebut d’équipement par les utilisateurs privés dans l’Union Européenne

Ce symbole indique que vous ne devez pas jeter votre produit avec les ordures ménagères. Il est de votre responsabilité de protéger la santé et l’environnement et de vous débarrasser de votre équipement en le remettant à une déchetterie effectuant le recyclage des équipements électriques et électroniques. Pour de plus amples informations, prenez contact avec votre service d’élimination des ordures ménagères.

German recycling notice

Entsorgung von Altgeräten von Benutzern in privaten Haushalten in der EU

Greek recycling notice

Απόρριψη άχρηστου εξοπλισμού από ιδιώτες χρήστες στην Ευρωπαϊκή Ένωση

Αυτό το σύμβολο σημαίνει ότι δεν πρέπει να απορρίψετε το προϊόν με τα λοιπά οικιακά απορρίμματα. Αντίθετα, πρέπει να προστατέψετε την ανθρώπινη υγεία και το περιβάλλον παραδίδοντας τον άχρηστο εξοπλισμό σας σε εξουσιοδοτημένο σημείο συλλογής για την ανακύκλωση άχρηστου ηλεκτρικού και ηλεκτρονικού εξοπλισμού. Για περισσότερες πληροφορίες, επικοινωνήστε με την υπηρεσία απόρριψης απορριμμάτων της περιοχής σας.

Hungarian recycling notice

A hulladék anyagok megsemmisítése az Európai Unió háztartásaiban

Ez a szimbólum azt jelzi, hogy a készüléket nem szabad a háztartási hulladékkal együtt kidobni. Ehelyett a leselejtezett berendezéseknek az elektromos vagy elektronikus hulladék átvételére kijelölt helyen történő beszolgáltatásával megóvja az emberi egészséget és a környezetet. További információt a helyi közügyi vállalattól kaphat.

Italian recycling notice

Smaltimento di apparecchiature usate da parte di utenti privati nell’Unione Europea

Questo simbolo avvisa di non smaltire il prodotto con i normali rifiuti domestici. Rispettare la salute umana e l’ambiente conferendo l’apparecchiatura dismessa a un centro di raccolta designato per il riciclo di apparecchiature elettroniche ed elettriche. Per ulteriori informazioni, rivolgersi al servizio per lo smaltimento dei rifiuti domestici.

Latvian recycling notice

Europos Sąjungos namų ūkio vartotojų įrangos atliekų šalinimas

Šis simbols nurodo, kad gaminio negalima išmesti kartu su kitomis buitinėmis atliekomis. Kad apsaugotumėte žmonių sveikatą ir aplinką, pasenusių nenaudojamą įrangą turite nuvežti į elektrinių ir elektroninių atliekų surinkimo punktą. Daugiau informacijos teiraukitės buitinės atliekų surinkimo tarnybos.
Lithuanian recycling notice

Nolietotu iekārtu iznicināšanas noteikumi lietotājiem Eiropas Savienības privātajās mājsaimniecībās

Šis simbols norāda, ka ierīci nedrīkst utilizēt kopā ar citiem mājsaimniecības atkritumiem. Jums jārūpējas par cilvēku veselības un vides aizsardzību, nododot lietotu aprikojumu atreizējai pārstrādi īpašā lietotu elektrisko un elektronisko ierīču savākšanas punktā. Lai iegūtu plašāku informāciju, lūdzu, sazinieties ar savu mājsaimniecības atkritumu likvidēšanas dienestu.

Polish recycling notice

Utylizacja zużytego sprzętu przez użytkowników w prywatnych gospodarstwach domowych w krajach Unii Europejskiej

Ten symbol oznacza, że nie wolno wyrzucać produktu wraz z innymi domowymi odpadkami. Obowiązkiem użytkownika jest ochrona zdrowia ludzkiego i środowiska przez przekazanie zużytego sprzętu do wyznaczonego punktu zajmującego się recyklingiem odpadów powstałych ze sprzętu elektrycznego i elektronicznego. Więcej informacji można uzyskać od lokalnej firmy zajmującej wywozem nieczystości.

Portuguese recycling notice

Descarte de equipamentos usados por utilizadores domésticos na União Europeia

Este símbolo indica que não deve descartar o seu produto juntamente com os outros lixos domiciliares. Ao invés disso, deve proteger a saúde humana e o meio ambiente levando o seu equipamento para descarte em um ponto de recolha destinado à reciclagem de resíduos de equipamentos eléctricos e electrónicos. Para obter mais informações, contacte o seu serviço de tratamento de resíduos domésticos.

Romanian recycling notice

Casarea echipamentului uzat de către utilizatorii casnici din Uniunea Europeană

Acest simbol înseamnă să nu se arunce produsul cu alte deșeuri menajere. În schimb, trebuie să protejeți sănătatea umezii și mediul predând echipamentul uzat la un punct de colectare desemnat pentru reciclarea echipamentelor electrice și electronice uzate. Pentru informații suplimentare, vă rugăm să contactați serviciul de eliminare a deșeurilor menajere local.
Verklaring betreffende de batterij

WAARSCHUWING: dit apparaat bevat mogelijk een batterij.

- Probeer de batterijen na het verwijderen niet op te laden.
- Stel de batterijen niet bloot aan water of temperaturen boven 60° C.
- De batterijen mogen niet worden beschadigd, gedemonteerd, geplet of doorboord.
- Zorg dat u geen kortsluiting veroorzaakt tussen de externe contactpunten en laat de batterijen niet in aanraking komen met water of vuur.
- Gebruik ter vervanging alleen door HP goedgekeurde batterijen.

Batterijen, accu's en accumulators mogen niet worden gedeponeerd bij het normale huishoudelijke afval. Als u de batterijen/accu's wilt inleveren voor hergebruik of op de juiste manier wilt vernietigen, kunt u gebruik maken van het openbare inzamelingsysteem voor klein chemisch afval of ze terugsturen naar HP of een geautoriseerde HP Business of Service Partner.

Neem contact op met een geautoriseerde leverancier of een Business of Service Partner voor meer informatie over het vervangen of op de juiste manier vernietigen van accu's.
French battery notice

Avis relatif aux piles

⚠️ AVERTISSEMENT : cet appareil peut contenir des piles.

- N’essayez pas de recharger les piles après les avoir retirées.
- Évitez de les mettre en contact avec de l’eau ou de les soumettre à des températures supérieures à 60°C.
- N’essayez pas de démonter, d’écumer ou de percer les piles.
- N’essayez pas de court-circuiter les bornes de la pile ou de jeter cette dernière dans le feu ou l’eau.
- Remplacez les piles exclusivement par des pièces de rechange HP prévues pour ce produit.

Les piles, modules de batteries et accumulateurs ne doivent pas être jetés avec les déchets ménagers. Pour permettre leur recyclage ou leur élimination, veuillez utiliser les systèmes de collecte publique ou renvoyez-les à HP, à votre Partenaire Agréé HP ou aux agents agréés.

Contactez un Revendeur Agréé ou Mainteneur Agréé pour savoir comment remplacer et jeter vos piles.

German battery notice

Hinweise zu Batterien und Akkus

⚠️ VORSICHT: Dieses Produkt enthält unter Umständen eine Batterie oder einen Akku.

- Versuchen Sie nicht, Batterien und Akkus außerhalb des Gerätes wieder aufzuladen.
- Schützen Sie Batterien und Akkus vor Feuchtigkeit und Temperaturen über 60°.
- Verwenden Sie Batterien und Akkus nicht missbräuchlich, nehmen Sie sie nicht auseinander und vermeiden Sie mechanische Beschädigungen jeglicher Art.
- Vermeiden Sie Kurzschlüsse, und setzen Sie Batterien und Akkus weder Wasser noch Feuer aus.
- Ersetzen Sie Batterien und Akkus nur durch die von HP vorgesehenen Ersatzteile.

Batterien und Akkus dürfen nicht über den normalen Hausmüll entsorgt werden. Um sie der Wiederverwertung oder dem Sondernmüll zuzuweisen, nutzen Sie die öffentlichen Sammelstellen, oder setzen Sie sich bezüglich der Entsorgung mit einem HP Partner in Verbindung.

Weitere Informationen zum Austausch von Batterien und Akkus oder zur sachgemäßen Entsorgung erhalten Sie bei Ihrem HP Partner oder Servicepartner.
Italian battery notice

Istruzioni per la batteria

⚠️ AVVERTENZA: Questo dispositivo può contenere una batteria.

- Non tentare di ricaricare le batterie se rimosse.
- Evitare che la batteria entri in contatto con l’acqua o siano esposte a temperature superiori a 60°C.
- Non smontare, schiacciare, forare o utilizzare in modo improprio la batteria.
- Non accostare i contatti esterni o gettare in acqua o sul fuoco la batteria.
- Sostituire la batteria solo con i ricambi HP previsti a questo scopo.

Le batterie e gli accumulatori non devono essere smaltiti insieme ai rifiuti domestici. Per procedere al riciclaggio o al corretto smaltimento, utilizzare il sistema di raccolta pubblico dei rifiuti o restituirli a HP, ai Partner Ufficiali HP o ai relativi rappresentanti.

Per ulteriori informazioni sulla sostituzione e sullo smaltimento delle batterie, contattare un Partner Ufficiale o un Centro di assistenza autorizzato.

Japanese battery notice

バッテリに関する注意

⚠️ 警告: 本製品はバッテリを内蔵している場合があります。

- バッテリを取り外している場合は、充電しないでください。
- バッテリを水にさらしたり、60℃（140°F）以上の温度にさらさないでください。
- バッテリを誤用、分解、破壊したり、穴をあけたりしないでください。
- 外部極を短絡させたり、火や水に投棄しないでください。
- バッテリを交換する際は、HP指定の製品と交換してください。

バッテリ、バッテリ、パック、蓄電池は一般の家庭廃棄物と一緒に廃棄しないでください。リサイクルまたは適切に廃棄するため、公共の収集システム、HP、HPパートナー、またはHPパートナーの代理店にお送りください。

バッテリ交換および適切な廃棄方法についての情報は、HPのサポート窓口にお問い合わせください。
Declaración sobre las baterías

⚠️ ADVERTENCIA: Este dispositivo podría contener una batería.
- No intente recargar las baterías si las extrae.
- Evite el contacto de las baterías con agua y no las exponga a temperaturas superiores a los 60 ºC (140 ºF).
- No utilice incorrectamente, ni desmonte, aplaste o pinche las baterías.
- No cortocircuite los contactos externos ni la arroje al fuego o al agua.
- Sustituya las baterías sólo por el repuesto designado por HP.

Las baterías, los paquetes de baterías y los acumuladores no se deben eliminar junto con los desperdicios generales de la casa. Con el fin de tirarlos al contenedor de reciclaje adecuado, utilice los sistemas públicos de recogida o devuélvalas a HP, un distribuidor autorizado de HP o sus agentes.

Para obtener más información sobre la sustitución de la batería o su eliminación correcta, consulte con su distribuidor o servicio técnico autorizado.
This glossary consists of terms unique to the library along with some storage industry terminology.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Access door</strong></td>
<td>Refers to the doors on either the control module or expansion module from which you can access the magazines and accessor assembly.</td>
</tr>
<tr>
<td><strong>Capacity on demand (COD)</strong></td>
<td>A library feature that enables users to have a large physical library, but users pay only for what capacity they are currently using. License upgrades enable more capacity to be added without a system interruption.</td>
</tr>
<tr>
<td><strong>Control management blade (CMB)</strong></td>
<td>A version of the MCB that has no I/O ports for Ethernet, SCSI, serial, or Fibre Channel. It is the controller board for the I/O management unit in expansion modules.</td>
</tr>
<tr>
<td><strong>Control module</strong></td>
<td>The first component of the library. It consists of an library management module, cartridges, drives, power, and an I/E station.</td>
</tr>
<tr>
<td><strong>Data path</strong></td>
<td>One of the many possible paths that data can move over in the storage area network environment, potentially involving many components or connections between initiators and targets that have been set since the initial configuration occurred.</td>
</tr>
<tr>
<td><strong>Drive pooling</strong></td>
<td>Drives to be held in a pool (or pools) of drives. You can specify policy settings for the drive pools to configure how each pool will react to a drive failure and load balancing.</td>
</tr>
<tr>
<td><strong>Drive sled position</strong></td>
<td>A slot where a Fibre Channel or SCSI drives reside in the control module or expansion module in one of the two drive clusters. There are six drive sled positions in each of the two drive clusters.</td>
</tr>
<tr>
<td><strong>Encryption Key Management (EKM)</strong></td>
<td>A generic term used to encompass any encryption key management solution.</td>
</tr>
<tr>
<td><strong>Ethernet Expansion Blade (EEB)</strong></td>
<td>Provides Ethernet connectivity to 6 Ethernet drives. This connectivity is to the library internal Ethernet and should not be connected to an external Ethernet source.</td>
</tr>
<tr>
<td><strong>Expansion module</strong></td>
<td>Expansion modules enlarge the library configuration by adding modules for additional media storage. You can add up eleven expansion modules to a library configuration. The first seven expansion modules may contain optional hardware, such as additional drives and I/E stations.</td>
</tr>
</tbody>
</table>
| **I/E station**                           | A door on the access door of the control module (or expansion modules) that contains magazines into which cartridges can be imported into or exported out of the library. All single door I/E stations are numbered starting with 1 at the control module. All double door I/E stations are numbered with a number and a letter—for example
2A and 2B—the module number (1-8), with A as the left I/E station and B the right.

**I/O management unit**
A management and connectivity interface for the library. The control module and first seven expansion modules can have I/O management units installed. The I/O management unit may contain a Control Management Blade (CMB) and Ethernet Expansion Blades (EEB).

**Latchhook**
The latches used to lock the printed circuit blades into place when they are inserted into the I/O management unit or library management module.

**Library management console (LMC)**
Library Management Console (LMC) The management software client for the library. You can use the LMC either locally from the OCP operator panel on the control module or remotely through a web browser running a Java applet.

**Library management module (LMM)**
The connectivity interface for the three blades that provide intelligence and connectivity to the library through the control module. The management control blade (MCB), robotics control unit (RCU), and library motor drive (LMD) blades are installed in the LMM.

**Library Managed (AMP) partition**
A partition in the ESL G3 that is like any other partition, except it is not visible to any backup applications or hosts. Allows the library to be able to manage the partition, rather than the backup application managing the partition. A virtual partition that can be dynamically allocated to other, previously-created standard partitions, all without disrupting host or application operation. AMP magazines are presented to host applications as part of a standard partition, but AMP magazines appear as “inaccessible” until they are assigned to a normal partition. AMP may be thought of as “thin provisioning” for a tape library. Both the Partition license and the AMP license are required to enable AMP. Both licenses are sold on a per-library basis.

**Linear Tape-Open (LTO)**
A media technology that is open format. LTO comes in two formats, Accelis and Ultrium. Accelis is the fast access implementation, while Ultrium is the high capacity implementation.

**Management control blade (MCB)**
The library controller board, which resides in the LMM. The MCB has I/O ports for Fibre Channel, Ethernet, serial, and SCSI.

**Partition**
A partition is a logical portion of the physical library that is viewed by the host as if it is a complete library. Partitions present the appearance of multiple, separate libraries for purposes of file management, access by multiple users, or dedication to one or more host applications.

**Picker**
The robotic hand portion of the accessor assembly that handles cartridges.

**HP Enterprise Secure Key Manager (ESKM)**
The HP encryption key management solutions that supports HP LTO-4 and LTO-5 FC tape drives.

**Service door**
The door on a control module or expansion module that provides access to the I/O management unit, LMM, power supplies, drive sleds and other components.

**Storage area network (SAN)**
A dedicated, high-performance network whose primary purpose is the transfer of data along FC or high-speed Ethernet connections between servers, interconnect devices, and storage peripherals.
**WORM** The library supports write once, read many technology in LTO-4 and greater tape drives. WORM allows non-erasable data to be written once and provides extra data security by prohibiting accidental data erasure.

**X-axis** The horizontal position of the accessor assembly.

**Y-axis** The vertical position of the accessor assembly.
Index

A
access door, 211
advanced reporting, 65
air filters, 186
aisle lights, 84
automated media pool
  media, 48

B
barcode, 255
  label, 191
    requirements, 190
barcodes, 189
battery replacement notices, 272
blade status, 234

C
calibration
  teaching the library, 158, 159
  teaching the library, 158, 159
Canadian notice, 260
capacity on demand, 17
cartridge, 211
  proper handling, 189
  removing, 189
  write-protect, 190
cartridges, 23, 27, 189
cleaning, 192
density, 16
exporting, 194
importing, 193
loading, 54
locations, 102
magazines, 24
change mode, 108
cleaning magazine
  unassigning, 72
cleaning magazines, 70
cleaning media
  exporting, 72
cleaning a drive, 153
cleaning media, 70
CMB, 22

components
  subsystems,
  configuration
    modifying, 31
    image file, 138
    library, 138
    rescuing, 141
    restore, 137, 140
    reverting, 142
    save, 137, 138
    teaching the library, 158
    teaching the library, 158
    type, 138
configuration record
  Email, 143
  save, 144
contacting HP, 245
control management blade, 22
control module, 17
control path, 36
  configuration, 47
conventions
  document, 245
    text symbols, 246
cooling fan information, 136

data path failover, 45
date
  set, 53, 54
Declaration of Conformity, 260
defragmentation, 181
demonstration mode
  pause, 30
demonstration mode, 29
  start, 30
  stop, 30
Disposal of waste equipment, European Union, 266
DNS
  configuring, 57
document
  conventions, 245
documentation
  providing feedback, 247
download
  library software, 201
drive
  clean, 255
  firmware, 206, 207
  loading, 195
  setting up, 58
  status, 236
  unloading, 196
  updating firmware, 205
drive cleaning, 69
drive cluster
  defined, 28
Drive Resource Utilization Reports
  viewing, 155
drives, 27, 28
  clean, 153
  Drive Resource Utilization Reports, 155
  locations, 106
  monitor status, 128
  view, 149
  view details, 151
E
e-mail, 59
  configuration, 59, 60
  notifications, 60, 213
EEB, 22
Email
  configuration record, 143
  MIB files, 186
  status information, 148
  support tickets, 147, 152
  test logs, 180
encryption
  key management, 249
  configuring partitions, 253
encryption key management, 249
error messages, 255
ESKM
  license key, 249
  management solutions, 249
Ethernet explosion blade, 22
European Union notice, 261
event
  reports, 223
  event detail reports, 223
  event lists, 216
  events, 214, 216
    close, 229
    command, 218
    details, 101, 222
    guidelines, 214
    history, 222
    viewing, 219
events
  details, 101, 222
  events list, 218
  events report, 230
  expansion module, 15
  expansion modules, 18
  explorer
    frame view, 126
    library view, 123
  exporting
    cartridges, 194
F
FAQ, 255
features
  offline, 109
  online, 109
Federal Communications Commission notice, 259
firmware
  downloading, 207
  drive, 209
  images, 208
  library, 199
  update tapes, 209
  updating, 205, 206, 208, 209
H
help
  obtaining, 245
hosts, 17
HP
  technical support, 245
I
I/E station, 22
  extended, 23
  locking/unlocking, 120
  monitor status, 129
importing
  cartridges, 193
indicator panel, 90, 91
information panel
  description, 98
install
library software, 201
installation instructions, 255
inventory, 197

J
Japanese notices, 261
job
deleting, 69
editing, 69
scheduling, 66

K
Korean notices, 262

L
laser compliance notices, 264
LBX terminator, 240
LDAP, 78
  configuring, 79
guidelines, 78
LED, 233
  blade status, 234
drive status, 236
fibre port link, 237
LBX terminator, 240
MCB port, 238
power supply, 241
library
control module, 17
cycle power, 183
demonstration mode, 29
  See also demonstration mode
density, 16
expansion module, 15
management module (LMM), 20
offline, 108
online, 108
overview, 15
power off, 119
power on, 119
reboot, 118
report, 211
robotics not ready, 121
shutdown, 118
software, 202, 203
teaching, 158
troubleshooting, 211
library firmware, 199
Library Management Console
  See LMC
library configuration, 31
library explorer
  frame view, 126
  library view, 123
library motor driver, 21
library software, 199
  updating, 199
license key, 32
LMC, 16
  access, 92
  access the applet, 88
  managed views region, 108
  menus, 94
  remote client, 17
  software requirements, 88
LMD, 21
LMM, 20
loading drives, 195
local user, 110
  create account, 110
  delete account, 113
  modify account, 112
  view account permissions, 114
location coordinates, 102
location coordinates
cartridges, 102
drives, 106
log off
OCP, 88
remote client LMC, 89
logon
  multiple libraries, 90
  OCP, 87
  remote client LMC, 88
M
magazines
cartridges, 24
mailing
  event information, 227
managed views, 108
management control blade, 21
managing media, 193
MCB, 21
MCB port, 238
media, 34
  moving, 196
media status information, 133
media usage report, 134
menus, 94
  privileges and environments, MIB files
  Retrieve, Email, and Save, 186
mode, 108
monitor, 123
  key management, 146
cooling fan, 136
drive status, 128
events, 101
I/E station, 129
media, 133
partition status details, 146
partitions status, 145
power supply, 136
sensor, 135
sensor status, 135
slots, 130
system status, 126
temperature, 136
voltage, 137

network configuration, 53, 55
network configuration, 53, 55
notifications, 64
e-mail, 60, 213

OCP, 28, 90
Overall System Status, 100

partition, 255
  media, 34
  control path, 47
  exporting cartridges, 194
  importing cartridges, 193
  offline, 108
  online, 108
partition status, 145
partition status details, 146
partitions, 34
  creating, 36
  modifying, 42
  data path failover, 45
  deleting, 46
partitions defragmentation
canceling, 183
partitions defragmentation, 181
  interrupted, 183
  recovering, 183
  running, 181
password, 255
picker, 22

power, 29
  backup, 255
  cycle, 183
power off, 119
power on, 119
power supply
  LED, 241
  power supply information, 136
print
  event information, 227
  status information, 148

R
rack stability
  warning, 246
RCU, 21
reboot, 118
recycling notices, 266
regulatory compliance
  Canadian notice, 260
  European Union notice, 261
  Japanese notices, 261
  Korean notices, 262
  recycling notices, 266
  Taiwanese notices, 262
regulatory compliance
  laser, 264
repair pages, 225
report
  library, 211
  MIB files, 186
report criteria
  templates, 66
report template
  save, 154
reports
  Tape Alert History Report, 226
requirements
  software for running LMC, 88
restore
  library configuration, 137, 140
Retrieve
  MIB files, 186
robotics
  not ready, 121
  robotics control unit, 21

Save
  MIB files, 186
save
  configuration record, 144
  event information, 227
library configuration, 137, 138
local restore image, 139
remote restore image, 138
report template, 154
status information, 148
support tickets, 147, 152

saving
  templates, 66
screen saver, 82
Secure Manager
  create an Access Group, 76
  delete a host, 75
  modify a host, 75
Secure Manager
  Access Group Configuration, 75
  add a host to an Access Group, 77
  change Access Group name, 76
  create a host, 75
  delete an Access Group, 76
  enable/disable, 74
Host Access Configuration, 77
Host Configuration, 74
remove a host from an access group, 77
security, 64
Send
  test logs, 180
sensor status, 135
serial number, 255
setup wizard, 31, 53
shutdown, 118
Sift Sort
  using, 183
Sift Sort
  capture, 185
  export media, 183
slots
  check status, 132
  filter, 132
  monitor status, 130
SNMP
  traps, 73
software
  downloading, 201
  installing, 201, 202
library, 199, 202, 203
reinstalling, 203
rollback, 204
update, 199
status indicator, 211, 213
status indicator, 211, 213
status information
  mail, save, and print, 148
storage density, 16
subsystem
  power, 29
subsystems
  components,
support tickets
  create, 147
  Email, 147
  Email and Save, 152
  save, 147
symbols in text, 246
system status
  monitor, 126

T
Taiwanese notices, 262
tape alerts, 226
technical support
  HP, 245
technical support
  service locator website, 245
temperature information, 136
templates
  report criteria, 66
test logs
  Email or Send, 180
text symbols, 246
time
  set, 53, 54
toolbar, 98
troubleshooting
  library, 211
typographic conventions, 245

U
unloading drives, 196
update
  library software, 199
  software wizard, 200
user
  library/partition, 114
  privileges, 114
  status, 144
users
  local, 110
V
Verification Tests
  boundary/accessibility graphical report, 176
  Custom, 162, 172
  drive inventory, 174
  Install, 161, 164
  library inventory, 173
  Partial, 161, 167
  picker pivot/reach graphical report, 177
  results, 174
  vertical alignments graphical report, 175
verification tests, 228
Verification Tests
  Accessor Assembly, 163
  calibration offsets graphical report, 176
  Custom, 162, 172
  Drive Sled Assembly, 163
  FRU, 161, 169
  functions, 162
  Get/Put, 163
  Get/Put graphical report, 176
  graphical reports, 175
  horizontal alignments graphical report, 175
  I/E Station Assembly, 164
  initiating, 164
  Install, 161, 164
  inventory, 173
  joint alignments graphical report, 175
  Library Alignment, 162
  logs, 178
  overview, 160
  Partial, 161, 167
  Picker Assembly, 163
  Scan Barcode, 163
  scan fiducials graphical report, 177
  Scanner Fiducial, 164
view, 108
voltage information, 137

W
warning
  rack stability, 246
websites
  HP, 245
WORM, 27